Sunteți pe pagina 1din 31

Suport de curs ECDL modul 4 Office 2007

1 LA INCEPUT
1.1 Despre modulul 4
Modulul Calcul Tabelar este al patrulea modul din lista de 7 module necesare pentru a fi promovate in vederea obtinerii Permisului European de Conducere a Calculatorului (cunoscut si ca diploma ECDL). Prezentul suport de curs este bazat pe versiunea 5.0 a Programei ECDL Romania, pe care o respecta si o extinde cu informatii aditionale. In orice situatie, Programa ECDL (a carei ultima varianta poate fi consultata online pe siteul ECDL Romania la adresa http://www.ecdl.org.ro/certificari_ecdl.php?id=55 ) are prioritate in termeni de informatie care trebuie cunoscuta de catre candidat. Certificarea ECDL este independenta de aplicatia pe care s-a sustinut examenul, dar acest suport de curs este realizat pentru aplicatia Excel din Pachetul Microsoft Office 2007 versiunea in limba engleza.

1.2 Despre Examen


Examenul propriu-zis consta in accesarea unei aplicatii online si rezolvarea a 36 de intrebari (de obicei practice, dar sunt si intrebari grila, cu o varianta si doar o varianta de raspuns). Durata examenului este de 45 de minute, iar punctajul necesar pentru a promova este 75. La sfarsitul celor 45 de minute (sau cand candidatul apasa Finalizare in aplicatie) se da nota pe loc. In general, programul folosit (Excel 2007) are mai multe posibilitati de a realiza o actiune (de exemplu, sunt cel putin trei metode pentru a face Copy-Paste). De obicei nu conteaza modul in care este rezolvata o problema, atata vreme cat rezultatul final este cel corect. Insa trebuie remarcata existenta unor intrebari de genul Unde dati click pentru..., sau Combinatia de taste face..., motiv pentru care vom prezenta mai multe variante de rezolvare a aceluiasi subiect.

1.3 Cateva clarificari legale


Acest suport de curs este oferit ca atare, cu buna credinta ca respecta programa ECDL, dar nu se ofera nici o garantie in termeni legali, de orice natura. Prezentul suport de curs este protejat de legile copyright-ului si este autorizat a fi folosit si distribuit doar de catre, si in randul, candidatilor inscrisi pentru a sustine examene ECDL la Centrul Autorizat de Examinare ECDL 38 UAIC Iasi (care este si titularul dreptului de proprietate intelectuala asupra continutului).

1.4 Terminologie
Recomandam parcurgerea celorlalte doua module ECDL inainte de a parcurge acest suport de curs. Dar deoarece, cel putin la nivel teoretic, ECDL-ul permite inceperea examinarilor in ce ordine doreste candidatul, consideram necesar amintirea catorva termeni care vor fi folositi frecvent in acest suport de curs: -Formularea Click de mouse se traduce prin apasarea butonului stang al mouse-ului -Formularea Dublu-Click (de mouse) se traduce prin apasarea de doua ori, in succesiune rapida, a butonului stang al mouse-ului. -Formularea Click Dreapta (de Mouse) se traduce prin apasarea butonului din dreapta al mouse-ului. -A da/executa click (de mouse) presupune apasarea unuia din cele doua butoane ale mouse-ului. -Cand nu se specifica daca este click stanga sau click dreapta, se subintelege Click Stanga. Apasarea unor butoane din interfata se executa tot cu butonul stang al mouse-ului. -Formularea (combinatia de taste) Ctrl+A inseamna apasarea simultana a celor doua taste mentionate (in context, taxta Control si tasta a; alte taste care mai pot apare in loc de, sau impreuna cu, Control, sunt Alt si Shift). -Meniul contextual este meniul care apare atunci cand se executa click dreapta (pe un text selectat, pe o figura, etc). Meniul contextual grupeaza majoritatea operatiunilor care pot fi executate asupra selectiei pe care s-a dat Click Dreapta. -A selecta un element dintr-un meniu inseamna a da click (stanga) pe acel element din meniu.

ECDL 38 UAIC Iasi

2. LUCRU CU APLICATIA EXCEL


2.1 Elementele ferestrei Excel 2007
Fereastra principala a aplicatiei are urmatoarele elemente:
Butonul Office Bara de acces rapid Butoane pentru minimalizarea ferestrei, maximizarea ferestrei, si inchiderea aplicatiei Bara de titlul, cu numele fisierului si al aplicatiei

Banda de meniuri, cu elementele grupate in Tab-uri (Home, Insert, Page Layout)

Butonul de activare a sistemul de asistenta (Help-ul)

Zona principala de scriere si afisare

Butoanele pentru selectarea foii de lucru curente

Butoane pentru schimbarea rapida a modului de vizualizare a textului Scala pentru modificarea dimensiunii de afisare (Zoom-ul)

Ca majoritatea aplicatiilor, fereastra Excel are o bara de titlu si cele trei butoane de minimalizare, maximizare/redimensionare si inchidere. Sub acestea se gaseste butonul de asistenta (Help), si trei butoane similare celor trei mentionate, pentru minimalizarea foi de lucru, pentru redimensionarea acesteia si pentru inchiderea foii de lucru )in toate aceste cazuri, fereastra Excel ramane neschimbata). Principala modificare, comparativ cu variantele anterioare de Excel este aparitia benzii de meniuri (in engleza, Ribbon), in locul meniurilor clasice consacrate de Windows ca parte a paradigmei WIMP. Benzile de meniuri grupeaza la indemana cele mai des folosite optiuni, care altfel ar fi trebuit cautate prin ferestre de optiuni. Meniurilor prezentate mai sus li se adauga altele, atunci cand sunt inserate anumite obiecte (de exemplu, inserarea unei imagini face ca, atunci cand a fost dat click pe aceasta, sa apara un alt meniu, Picture Tools). In coltul din dreapta sus a ferestrei gasim butonul de Office, care grupeaza elemente ce tin de fisier, de la creare si salvare pana la listare (acesta va fi detaliat in subcapitolul urmator). Cateva optiuni de particularizare a aplicatiei Excel se gasesc accesand acest buton Office, sau utilizand Bara de Acces Rapid de langa acesta. In general, pe aceasta bara avem trei butoane (Save, Undo si Redo), impreuna cu o sageata in jos de 3

Suport de curs ECDL modul 4 Office 2007 unde putem particulariza cateva aspecte ce tin de interfata (detalii in capitolul 2.3). Nu putem aminti cele doua seturi de scurtaturi din partea dreapta-jos a ferestrei, care modifica modalitatea de afisare a informatiilor, respectiv dimensiunea de afisare. Aceste butoane si functionalitati sunt detaliate in capitolul 3.2 Partea principala a ferestrei Excel este ocupata de foaia de lucru, a carei elemente sunt detaliate in figura urmatoare:
Coloana curenta Randul curent Caseta de nume Bara de formule Indicatorii coloanelor Celula curenta Indicatorii randurilor

Bare de derulare Butoane de navigare in foile de lucru

Asa cum se vede, toata suprafata de lucru este un tabel. El aste alcatuit din celule, fiecare celula avand ca indicativ coloana si randul pe care se gaseste. Coloanele sunt definite prin litere (A, B, C...) iar randurile prin numele (1,2...). Celula din imaginea noastra are indicativul B2 (coloana B, randul 2), vizibil in partea stanga sus a figurii, in caseta de nume a celulei. Daca am fi selectat un grup de celule, indicativul respective selectii (detalii in capitolul urmator) este vizibil in aceasta caseta. Exista posibilitatea avansata de a da un nume unei anume celule (de exemplu, celula care contine procentul de TVA); de fiecare data cand am da click pe acea celula, numele ei ar apare in caseta de nume. Continutul celulei apare scris pe bara de formule. Pe exemplul nostru, bara de formule contine textul Modul 4-calcul tabelar. Daca in celula B2 am avea o formula (de exemplu, A1+A2) care ar da, sa zicem, 10, atunci in celula B2 ar scrie 10, dar pe bara de formula ar fi scris formula A1+A2. Mai multe despre cum sunt referite celulele in capitolul 8.2

ECDL 38 UAIC Iasi

2.2 Butonul Office


Tot ce tine de lucrul cu fisiere (creare, salvare, etc) se realizeaza din butonul de Office, accesibil din orice parte a ferestrei principale . Acesta inlocuieste prima parte a meniului File din Excel 2003 si cuprinde urmatoarele elemente: New>crearea unui nou document Excel (combinatie de taste: Ctrl+N). In fereastra care apare vi se da posibilitatea sa creati un document Excel gol, sau sa folositi formatele predefintie (template-uri) pe care Excel-ul vi le pune la dispozitie. In general sunt formate predefinite documente financiare.

Sus: Fereastra care apare la apasarea butonului Office. Evidentierea optiunii Print duce la activarea submeniului Preview and Print the Document Stanga: Fereastra New, cu optiunea implicita de creare a documentelor Jos: Aceeasi fereastra New, dar cu vizualizarea template-urilor (sabloanelor) instalate.

Open > aveti posibilitatea de a deschide un fisier gata creat (combinatie de taste> Ctrl+O). In fereastra care se deschide puteti naviga folosind structura arborescenta din partea stanga pentru a ajunge la directorul care contine fisierul in cauza (structura similara ferestrei Computer utilizata la Modulul 2). O data selectat un director din stanga, continutul acestuia (subdirectoare si fisiere) apare in partea dreapta a ferestrei..

Pentru a deschide fisierul dorit se face dublu click pe acesta, sau se selecteaza cu un click si se apasa butonul Open

Stanga: Fereastra Open.

Suport de curs ECDL modul 4 Office 2007 Save i Save As > permit salvarea documentului deschis. Daca fisierul a fost creat si este prima data cand se doreste salvarea lui, atunci apasarea Save (combinatie de taste: Ctrl+S), respectiv apasarea Save As (combinatie de taste: F12) va aduc in prim plan aceeasi fereastra, similara ferestre Open, atat ca in loc de un buton care sa deschida fisierele avem unul care sa salveze. Avem zona File Name, in care introducem denumirea dorita pentru fisier, si zona Save File Type, in care putem modifica tipul fisierului. De obicei, cu Excel 2007 cream fisiere Excel Workbook (extensia .xlsx, amintiti-va discutia despre tipuri de fisiere de la Modulul 2). Este insa, posibil, sa avem nevoie sa salvam documentul nostru in alt format decat cel predefinit pentru Excel 2007 (vezi figura). Daca fisierul nostru are nume (fie avea nume cand l-am deschis, fie i l-am dat noi mai devreme folosind instructiunile din acest paragraf), atunci vom constata ca apasand Save, fisierul este salvat cu denumirea pe care o are deja (nu ne mai apare fereastra in care sa fim intrebati ce denumire vrem sa aiba fisierul). Daca vrem sa salvam fisierul deschis cu alta denumire, atunci alegem optiunea Save As, si ne apare fereastra corespunzatoare. Reformuland, se poate spune ca Save salveaza fisierul cu numele curent, Save As salveaza fisierul cu alt nume. Close> apasand acest buton inchidem documentul deschis, dar nu inchidem si Excel-ul. Putem, ulterior, sa deschidem alt fisier, fara sa trebuiasca sa asteptam sa se incarce aplicatia. Convert> daca am deschis un fisier creat cu o varianta anterioara de Excel (de exemplu Excel 2003), o parte dintre functionalitatile aduse de Excel 2007 vor fi dezactivate. Pentru a beneficia de toate avantajele transformarii unui fisier din tipul .xls specific Excel 2003 in tipul .xlsx specific Excel 2007, vom converti fisierul la noul format, folosind aceasta optiune din meniu. De remarcat ca optiunea Convert nu apare in meniu decat daca a fost deschis un fisier creat cu Excel 2003. Print> daca este tinut mouse-ul deasupra, activeaza in partea dreapta a meniului cateva optiuni, intre care si cea de previzualizare (prima figura din acest subcapitol). Daca se executa direct Click de mouse, activeaza fereastra de Imprimare. Vom gestiona informatiile despre listare intr-un capitol special.

ECDL 38 UAIC Iasi

2.3 Configurarea Excel-ului


Principala modalitate de configurare a aplicatiei Excel 2007 consta in accesarea butonul Excel Options din meniul Office. Urmatoarele ferestre va arata cateva din configurari (fiti atenti la care dintre capitolele de setari sunt evidentiate cu galben in partea din stanga a ferestrelor, pentru a sti cum sa ajungeti la aceste optiuni). Activati optiunile apasand butonul OK.

Schimbarea numelui de utilizator

Schimbarea directorul predefinit pentru salvarea fisierelor

Schimbarea indicatorului zecimal din punct in virgula

Schimbarea unitatii de afisare la benzi derulante (inchi, centimetri, pixeli)

Suport de curs ECDL modul 4 Office 2007

Aflarea versiunii de Excel folosite... sau a altor informatii despre versiunea curenta.

Mentionam ca Excel Options nu are posibilitatea de a schimba unitatile de masura predefinite. Acest lucru tine de setarile regionale ale calculatorului si au fost acoperite la modulul 2. De exemplu, daca statia de lucru este configurata ca fiind localizata in Statele Unite ale Americii, automat Excel-ul foloseste formatul de data luna-zi-an, punctul (.) ca separator zecimal (nu virgula, ca in Romania) si inch ca unitati de masura. Asa cum aminteam la inceput, cateva optiuni de configurare mai avem si apasand sageata de langa Bara de acces rapid. Se bifeaza ce optiuni se doresc a exista pe aceasta bara (bifate in imaginea din dreapta sunt Save, Undo si Redo), sau se poate accesa optiunea More Commands pentru a aduce si alte setari pe aceasta bara de scurtaturi. Tot de aici avem posibilitatea de a muta Bara sub banda de meniuri (Show Below the Ribbon). O ultima posibilitatea oferita de acest meniu este de a ascunde cu totul Banda de Meniuri (Minimize the Ribbon)

2.4 Help
Sistemul de asistenta a Word-ului poate fi accesat dand click pe iconita dedicata, aflata in dreapta benzii de meniuri, in rand cu tab-urile (sau apasand tasta F1). Se deschide o fereastra in care suntem invitati sa navigam in structura ierarfica, sau sa introducem un cuvant de cautat. Accesarea solutiei se face dand click pe link-urile furnizate ca raspuns:

ECDL 38 UAIC Iasi

2.5 Anularea operatiunilor


Daca am facut ceva gresit, avem posibilitatea sa anulam ultimele operatiuni, apasand butonul Undo (combinatie de taste Ctrl+Z). Butonul Undo se gaseste doar ca parte a barei de acces rapid, si vine impreuna cu o lista derulanta din care putem anula, in bloc, mai multe operatiuni gresite. O astfel de situatie este prezentata in dreapta (operatiunile de anulat sunt marcate cu galben) Daca ne razgandim, avem butonul invers, Redo, pe aceeasi bara de acces rapid.

2.6 Navigarea intre ferestre


Va amintim de la modulul 2 ca pentru a naviga intre doua documente deschise, in Windows Vista, se apasa combinatia de taste Alt+Tab, sau se da click pe iconita Word de pe bara de stare si se alege fisierul dorit; daca se tine 3 secunde cursorul mouse-ului peste una din ferestre, pe ecran apare o previzualizare a continutului acelei ferestre, ajutandu-ne sa ne decidem asupra carui document vrem sa lucram.

2.7 Cautarea/ in fisiere


Daca vrem sa cautam un anumit text, putem folosi butonul Find aflat pe banda Home, in partea dreapta, in grupul Find&Select (combinatie de taste: Ctrl+F). In fereastra care apare introducem textul de cautat (zona Find What) si apasam Find Setari avansate de cautare sunt accesibile apasand butonul Oprtions. Excel-ul ne permite sa si inlocuim automat termenii pe care ii cautam. Acest lucru se realizeaza din fereastra Replace (accesibil fie ca Tab al ferestrei Find, fie direct din grupul Find&Select, in partea dreapta a benzii Home. In noua fereastra ii dam textul de cautat, si textul cu care acesta am vrea sa fie inlocuit. Butoanele de jos ne permit sa inlocuim instanta curenta descoperita (replace), sa inlocuim toate instantele in care cuvantul cautat apare (Replace all), sa ne limitam la a cauta urmatoarea aparitie a cuvantului in cauza (Find Next), respectiv sa ni se afiseze lista tuturor aparitiilor (Find All)

Suport de curs ECDL modul 4 Office 2007

3. MEDIUL DE LUCRU
3.1 Meniuri
Asa cum am spus, benzile de meniuri grupeaza la indemana cele mai des folosite optiuni, care altfel ar fi trebuit cautate prin ferestre de optiuni. In capitolele urmatoare vom porni de la functie, spre a gasi modalitati de efectuare, si astfel vom ajunge si la meniuri. Dar acum, la inceput, consideram utila o trecere in revista a acestora. Marea majoritate a elementelor care tin de lucrul cu celule si datele dinauntru se gasesc in Tabul Home. Spre deosebire de Word, nu grupeaza doar elemente de estetioca, ci si de sortare si filtrare a datelor.
Alinierea textului in celula Font Scris inclinat Formatari ale celulelor de tip Tipul celulei numeric

Dimensiune caracter

Paste

Cut Aldin Margini celula Copy Cursiv Maturica Subliniere Culoare umplere Culoare text

Aliniat stanga , centrat , dreapta

Butonul de infasurare a textului Butonul de unire a doua celule si centrare a textului din acestea

Formatare conditionata
Elemente predefinite pentru estetica tabelului si a celulei

Introdus, sters si formatat celule

Cautare, inlocuire, selectie Sortare si filtrare

Meniul Page Layout grupeaza formatarile de pagini. Tot aici se gasesc optiunile pentru afisarea textului pe coloana si pentru despartire in silabe. Setarile avasate (fereastra Page Setup) este tratata in capitolul 6.

Margini

Orientarea Dimen- Selectapaginii siunea rea (portret sau hartiei suprafepeisaj) tei listate

Configurarea imprimarii anumitor randuri/coloane pe toate paginile Intreruperi de pagina

Scalarea tabelului in vederea imprimarii

Vizualizarea, respective listarea grilei si a antetelor

Meniul Insert este tratat in capitolul 7.

10

ECDL 38 UAIC Iasi

3.2 Modificarea afisajului


Meniul Views ne permite sa particularizam modalitatea de afisare. Punctam ca se modifica modul de afisare (zoom=panoramare) nu si textul propriu-zis. Motivul pentru care putem face asta este ca ne serveste diferitelor scopuri. De exemplu, putem sa vedem pagina noastra ca foaie de imprimanta (Page Layout), sa nu vedem grilajul, antetele de randuri si coloane (A, B, C..., respectiv 1,2,3), etc. De pe mijlocul benzii putem modifica dimensiunea de afisare (Zoom-ul). Consideram ca este foarte util sa aveti activata rigla, lucru care se poate face si din acest meniu. Cateva din optiuni se gasesc si in partea din dreapta jos a ferestrei Excel

Vizualizare normala, respectiv in aspect de pagina

Vizualizarea doar a sectiunilor tiparibile Vizualizari particularizate Vizualizare pe tot ecranul

Optiuni de afisare Rigla Bara de formule Grila Antete de rand si coloana

Diferite variante de Zoom/Panoramare

Meniul de inghetare a randurilor si coloanelor

11

Suport de curs ECDL modul 4 Office 2007

4. PROPRIETATI ALE CELULEI 4.1 Denumire si selectie


La baza oricarui tabel este celula. Aceasta are drept coordonate litera coloanei si numarul randului pe care se afla (aceasta fiind si denumirea celulei). De exemplu, B2 este denumirea celulei aflata la intersectia coloanei B cu randul 2. Numele celulei apare figurata si in caseta de text. Continutul celulei apare scris si pe bara de functii. Pentru a selecta un grup de celule avem mai multe variante. Se considera ca dand click pe o celula am selectat-o. Daca vrem sa selectam un grup de celule adiacente tragem cu mouse-ul peste ele (nu uitati, cursorul sa arate asa , nu asaS Selectia pe care am realizat-o poate fi asemanata unui dreptunghi (eventual, un patrat). Pentru a defini aceasta selectie ne uitam la celula din stanga sus si la cea din dreapta jos. Celulele in cauza, separate prin semnul de doua puncte (:) vor defini selectia noastra. In imaginea alaturata, selectia este definita ca B2:C5. Alte exemple de selectii includ A2:A5 (celulele A2,A3,A4 si A5), respectiv B1:C1 (pentru o selectie realizata din celulele B1 si C1) Daca vrem sa selectam un rand intreg, dam click pe cifra randului respectiv (cursorul devine o sageata neagra, orientata spre dreapta). Denumirea selectiei va avea forma 2:2. Daca vrem sa selectam o coloana intreaga, dam click pe litera coloanei respective (cursorul devine o sageata neagra, orientata in jos). Denumirea selectiei va avea forma B:B. Putem selecta si anumite celule tinand apasata tasta Control si dand click de mouse pe ele. In general aceasta selectie (referita prin enumerarea coordonatelor celulelor) nu se preteaza la operatiuni de genul Copy/Paste.

12

ECDL 38 UAIC Iasi

4.2 Tipuri de date


Formatarea celulelor se poatre realiza folosind instrumentele din bara Home, sau fereastra Format Cell din meniul contextual. Deoarece aceasta fereastra grupeaza majoritatea particularizarilor care pot fi facute asupra unei celule, va fi discutata in amanuntime, urmand ca figurile sa faca corespondenta intre setarile din fereastra si iconitele de pe banda de meniuri. Spre deosebire de tabelele realizate in alte programe (de exemplu, Word), Excel-ul este foarte strict legat de tipul de date dintr-o celula. Intre altele, acest lucru este necesar datorita unor restrictii care apar la utilizarea formulelor. Ceea ce pentru noi este clar (cifrele sunt numere, 12.02.2010 este o data), pentru Excel trebuie specificat in clar. E adevarat, uneori incearca singur sa ghiceasca, folosind niste setari prestabilite. Daca am vrea sa configuram tipul de date dintr-o celula (si trebuie punctat ca intr-o celula putem avea date de un singur tip de date), putem folosi tab-ul Number din fereastra Format Cells. -Formatul General: s-ar putea considera ca acesta este modul Excel-ului de a spune ca nu conteaza ce format sunt datele. De obicei Excel-ul in acest format introduce datele, pana cand apare o situatie (de exemplu, o formula) care necesita clarificare. -Formatul Numeric (number) clasifica datele ca fiind numere, si seteaza numarul de zecimale. Trebuie punctat faptul ca, daca introducem un numar de 2 zecimale (de exemplu, 4,56), iar apoi setam din propprietatile formatului numeric sa se afiseze doar o zecimala, valoarea din celula este rotunjita in plus daca este mai mare sau egala cu jumatate de fractiune, si in minus, in restul situatiilor (pe exemplul nostru, 4,56 este rotunjit la 4,6, 4,54 ar fi rotunjit la 4,5 ar fi fost rotunjit la 4,4). Mai trebuie remarcat ca rotunjirea este doar pentru afisare; daca ne uitam pe bara de formule, valoarea din celula este cea originala; s-a schimbat doar valoarea pe care o afiseaza. Excel-ul. La acest format numeric mai trebuie atrasa atentia asupra diferentelor de notare din sistemul romanesc fata de sistemul anglo-saxon. In sistemul romanesc 3,000 este egal cu trei. In sistemul anglosaxon, separatorul zecimal nu este virgula, este punctul, iar virgula este separatorul de mii; 3,000 inseamna trei mii in acest sistem. Similar, 3.000 inseamna trei mii in Romania si doar trei in Statele Unite. Excelul preia setarile legate de punctul zecimal citind setarile legate de locatie si preferinte asa cum sunt ele configurate din Windows. -Formatul monetar (curency) ne permite sa setam automat aparitia unei monezi langa valoarea din celula. Unitatea monetara se selecteaza din lista derulanta. Exista si aici posibilitatea de a configura numarul de zecimale (ca si la formatul numeric, valoarea afisata se rotunjeste). Trebuie remarcat 13

Suport de curs ECDL modul 4 Office 2007 faptul ca unitatea monetara este doar afisata, nu inclusa in valoarea celulei. De asemenea, Excel-ul nu restrictioneaza in nici un fel aplicarea formulelor asupra celulelor de tip monetar astfel incat puteti aduna fara probleme dolari cu lire. -Formatul contabil (Accounting) difera prin cel monetar prin simplul fapt ca aliniaza toate valorile dintr-o coloana cu date de acest fel astfel incat intregii sa fie pe o coloana iar zecimalele pe alta, cu separatoarii zecimali aranjati pentru a delimita cele doua coloane) -Formatul Data Calendaristica (Date) permite setarea valorii unei celule pentru a fi de tipul data. Fereastra ne permite sa setam limba in care va fi afisata data (lista derulanta Location) si modul de afisare. Trebuie mentionat ca si acest tip de date este dependent de locatia selectata. De exemplu, daca Windows-ul este configurat pentru Romania, data poate fi introdusa in celule in formatul zz.ll.aaaa, sau zz/ll/aaaa (20.12.2010 sau 20/12/2010). In sistemul anglo-saxon, data se introduce strict in formatul ll/zz/aaaa (12/20/2010). -Formatul Procent (percent) transforma valoarea numerica din celula in procent. Valoarea din celula trebuie sa reprezinte o parte din intreg (altfel spus, valoarea 0,2 din celula este tranformata in 20%, dar valoarea 20 din celula devine 2000%). Si aici avem posibilitatea de setare a zecimalelor (cu rotunjire). Formatul Text converteste valoarea (chiar si numerica) in text, si o aliniaza la stanga. Trebuie mentionat ca Excelul converteste automat celulele care contin doar cifre in tip numeric. Daca, totusi, vrem sa introducem valori numerice ca sir de caractere (adica text), le introducem precedate de un apostrof (`) Mentionam faptul ca tipul de date din celule pot fi configurate si folosind optiunile de pe centrul benzii de meniuri Home (imaginea din stanga). Meniul din lista de rulanta ne permite sa selectam cu un click tipul de date, sau optiuni de genul cresterea/scaderea numarului de zecimale afisate (cu rotunjirea afisarii), asa cum am mentionat la discutia despre formaul numeric. In partea dreapta aveti continutul listei derulante care permite selectarea tipului de date din celula.

14

ECDL 38 UAIC Iasi

4.3 Estetica textului


Al doilea Tab al ferestrei Format Cells (Alignment) ne permite sa particularizam modul in care textul este aliniat in celula (in imaginea de mai jos aveti si iconitele echivalente de pe banda de meniuri Home). Se intampla, uneori, sa avem celule mult mai late si/sau mai inalte decat este nevoie, iar textul sa nu ocupe tot spatiul celulei. Zona Text Alignment ne permite sa aliniem textul pe orizontala si/sau pe verticala. Putem chiar seta o margine in celula (indent). Uneori textul este, dimpotriva, mai mare decat decat celula, si atunci avem trei optiuni: fie redimensionam celula, fie configuram celula astfel incat textul sa fie scris pe mai multe randuri in cadrul aceleiasi celule (Wrap text) fie configuram Excelul astfel incat textul din celula sa fie redimenionat automat spre a incape (Shrink to fit) In partea dreapta, zona Orientation ne permite sa scriem inclinat in celula. Am lasat la urma optiunea Merge cells. Daca selectam doua/mai multe celule, avem posibilitatea de a le uni intr-una mai mare (de exemplu, cand scriem titlul tabelului, sau avem in capul de tabel elemente de grupare). O optiune similara era prezenta si in Word. Spre deosebire de programul de procesare al textelor, in Excel nu avem posibilitatea sa spargem aceasta uniune in cate randuri si coloane vrem. Aici putem doar anula uniunea (prin debifare), si celulele se intorc la situatia anterioara unirii. Tab-ul urmator al Ferestrei Format Cells ne permite sa particularizam aspectul textului. Setarile sunt mai sarace ca in fereastra omonima din Word, dar sunt suficiente pentru introdus text. Cateva din optiuni se gasesc si pe banda Home, in zona Fonts

15

Suport de curs ECDL modul 4 Office 2007 Ajungand la discutia despre marginile celulei (Tab-ul Border) trebuie sa mentionam ca grilajul care se vede pe celulele din Excel nu apare la imprimanta (decat in anumite conditii). Ca urmare, pana cand nu-i particularizam marginile, tabelul la imprimare va iesi fara linii de demarcare. Ca si la Word, trebuie intelesi pasii de urmat: se incepe cu alegerea tipului de linie (1), apoi a culorii (2) si, in final, a tipului de margine dorit (3, margini predefinite, sau 4-margini particularizate selectand locatia prin apasarea 3 butoanelor). Asa cum se vede in imagine, se 1 pot trasa inclusiv linii pe diagonale. O alta metoda de a trasa borduri este utilizarea butonului Borders din zona Fonts a benzii de meniuri Home. 2 4

Ultimul Tab, Fill, se ocupa de culoarea de umplere a celulei. Se poate alege o culoare, sau diferite efecte (Pattern). Exista si butonul care permite alegerea unei culori de umplere direct din banda de meniuri Home. Nu putem incheia discutia despre estetica unei celule fara sa amintim doua facilitati de formatare automata, prezente pe banda de meniuri Home: Format as a Table si Cell Styles. Consideram ca imaginile din josul acestei pagini sunt elocvente pentru ce fac. Si, ca si la Word, o data stabilit aspectul estetic al unei celule, putem folosi Copiatorul de formate (sau maturica ) pentru a aplica respectivele setari si altor celule: se da click pe celula sursa, se apasa maturica pe banda Home, se selecteaza celulele destinatie.

16

ECDL 38 UAIC Iasi

4.4 Inserare, stergere, comentare


Aparent o problema simpla: in mijlocul unui tabel noi vrem sa introducem o noua celula (nu un nou rand, nu o noua coloana, ci o noua celula). Intrebarea este ce se va intampla cu restul celulelor in acest moment. Pentru a introduce o noua celula putem apela la meniul contextula, sau la lista derulanta de langa butonul Insert de pe banda de meniuri Home. Feareastra care apare (imaginea din stanga) ne ofera niste posibilitati: celulele pot fie culisa spre dreapta, fie culisa in jos (avand ca punct de reper celula selectata in momentul respectiv). Alternativ, ni se propune sa introducem un nou rand respectiv o noua coloana. O problema similara apare cand vrem sa stergem o celula. In acest moment trebuie sa nuantam diferenta intre a terge continutul unei celule (tasta Delete este foarte eficienta) si a sterge celula cu totul. In acest din urma caz, tabelul nu poate ramane cu un loc gol in mijlocul lui, astfel incat ne este prezentata aceeasi fereastra cu optiuni de culisare a inregistrarilor (spre stanga sau in sus).

In imaginile de mai jos, din tabelul din stanga am sters celula cu litera f, alegand ca celulele sa culiseze spre stanga (Shift Cells Left). Astfel, celulele cu g si h au ajuns sub b si c.

Uneori, insa, avem nevoie de informatii suplimentare despre o celula. O posibilitate de a adauga notite gasim in meniul contextual, Insert Comments. Textul va fi afisat doar atunci cand mouse-ul este deasupra celulei, altfel singurul element care da de golexistenta unui comentariu fiind un triunghi rosu in coltul din dreapta sus al celulei. Un comentariu poate fi editat din meniul contextual al celulei (Edit Comment) sau sters cu totul (Delete Comment).

17

Suport de curs ECDL modul 4 Office 2007

5. RANDURI, COLOANE, FOI 5.1 Operatiuni comune si redimensionari


Selectand un rand sau o coloana (click pe litera coloanei, respectiv click pe numarul randului accesam urmatorul meniu contextual: -Cut -Copy -Paste -Paste Special (folosit atunci cand, de exemplu, nu vrei sa copii dintr-o parte in alta formula dintr-o celula, ci doar rezultatul) -Insert (introduce un nou rand/o noua coloana) -Detele (Sterge randul/coloana curenta) -Clear Contents (echivalentul tastei Delete, sterge inregistrarile din selectia respectiva) -Format Cells (activeaza fereastra respectiva pe celulele selectate) -Row Height (inaltimea randului), respectiv Column Width (latimea coloanei). Intr-un tabel Excel nu avem celule care sa aiba alta dimensiunea fata de o alta celula de pe acelasi rand/de pe aceeasi coloana. Ca urmare redimensionarea uneia inseamna redimensionarea tuturor celulelor de pe randul sau coloana in cauza. Fereastra care apare permite aceasta redimensionare. O alta posibilitate de a redimensiona randul; sau coloana se realizeaza prin tragere de mouse de marginea randului/coloanei (dar aceasta tragere trebuie realizata pe indicatorii de rand sau coloana, adica daca vrem sa redimensionam coloana A, vom trage de marginea dintre A si B). Se remarca si modificarea cursorului, in . pentru redimensionat coloane, respectiv in pentru redimensionat randuri. De remarcat ca, daca in momentul in care cursorul ajunge intr-una din pozitiile mentionate, dam dubluclick, Excel-ul redimensioneaza respectivul rand/respectiva coloana astfel incat sa incapa tot textul din celulele pe care le cuprinde. -Hide si Unhide, ascunderea, respectiv afisarea randului/coloanei. Dupa ascundere, se selecteaza vecinii randului/coloanei ascunse si din meniul contextual se alege Unhide). O a doua metoda de a afisa un rand/o coloana ascuns(a) porneste tot cu selectarea vecinilor acestuia/acesteia, si apoi se foloseste banda de meniuri Home>Format>Hide&Unhide>Unhide

5.2 Inghetarea randurilor si coloanelor


Sa presupunem ca avem un tabel mare, si pe lungime si pe latime. Al derula prin scroll de mouse inseamna a nu mai avea afisat capul de tabel. Analog, daca folosim bara de derulare spre a merge in dreapta tabelului, riscam sa nu mai stim ce scria pe primele celule ala randului (cui ii apartin informatiile pe care le vedem). Solutia tine de inghetarea randului si/sau a coloanelor. Pentru a ingheta un rand, selectam randul imediat urmator, si din banda de meniuri View alegem Freeze Panes. In acest moment, deruland in jos tabelul, capul de tabel ramane permanent sus afisat. Analog, pentru a selecta o coloana pe care vrem s-o avem permanent la indemana, selectam coloana imediat la dreapta acestea si alegem Freeze Panes. 18

ECDL 38 UAIC Iasi Pentru a a ingheta un rand si o coloana (in cazul tabelelor si foarte lungi si foarte late, selectam celula de la intersectia randului urmator celui dorit cu coloana din dreapta celei dorite.Pe exemplul de mai jos, pentru a ingheta randul 1 si coloana A, am dat click in celula B2. Apoi Apasam Freeze Panes

Pentru a dezgheta, se merge in acelasi meniu, care acum afiseaza Unfreeze panes

5.3 Foi de lucru


Un fisier Excel poate avea mai multe foi de lucru (in engleza Spreadsheet, sau simplu Sheet) care pot sa nu aiba nici o legatura unele cu altele (sau, dimpotriva, pot fi legate prin formule). Navigarea intre foile de lucru se face folosind butoanele din stanga-jos in fereastra Excel. Butonul cel mai din dreapta permite ne creaza o noua foaie de lucru.

Meniul contextual al foii de lucru permitrea realizarea urmatoarelor operatiuni asupra foii de lucru curente: -Inserare -Stergere -Redenumire (de mentionat ca functioneaza si dubluclick-ul pe numele foii de lucru) -Mutare sau copiere (diferenta este facuta de bifa Copy, in fereastra de mai jos; de mentionat ca functioneaza si tragerea cu mouse-ul a foii de lucru in pozitia dorita) -Colorarea tab-ului foii curente -Ascunderea foii.

Imprimarea foilor de calcul este tratata in capitolul 10.

19

Suport de curs ECDL modul 4 Office 2007

6. OPERATIUNI ASUPRA DATELOR 6.1 Serii de date


Sa presupunem ca avem un tabel caruia vrem sa-i adaugam o coloana Nr. Crt. O optiune ar fi sa competam de mana toate nr.crt.-urile, pentru toate randurile. Alta ar fi sa folosim serii de date. Scriem primele doua elemente ale seriei (in cazul nostru, 1 si 2), selectam cele doua celule si apoi dam click pe patratelul negru care apare in coltul din dreapta jos al selectiei (mouse-ul isi schimba cursorul). Si tragem in jos, sau la dreapta, dupa nevoie. Excel-ul a inteles ca noi vrem sa continuam numararea, si a generat el numerele in continuare. Serii de date pot incepe si cu alte valori, pot fi din 2 in 2 (in functie de versiunea de Office instalata). Lista lunilor din exemplul din stanga a fost generata tot folosind serii de date.

6.2 Sortari
Cea mai simpla sortare se poate face din meniul contextual al unei celule. Primele doua sunt analoagele sortarii crescatoare/descrescatoare. Urmatoarele 3 permit relocarea celulelor cu culoare, font sau iconita identice cu cea selectata in varful sortarii. Ultima optiune, Custom sort, lanseaza o fereastra dedicata, de unde purtem configura sortarea din lista derulante.

Remarcati bifa din dreapta sus, My Data Has Headers, daca am creat un tabel fara cap (pur si simplu am introdus valorile) aceasta trebuie debifata. Cateva optiuni de sortare se gasesc si pe banda Home, in stanga, butonul Sort&Filter.

6.3 Filtrari
Daca sortarile rearanjau elementele dintr-un tabel, filtrarile ascund elementele care nu corespund unor criterii. Cel mai simplu filtru se pune automat pe capul de tabel apasand butonul Filter din meniul vizibil in imaginea din dreapta. In acest moment celulele din capul de tabel au capatat sagetele de liste derulante:

20

ECDL 38 UAIC Iasi Meniul care apare grupeaza inregistrarile egale si permite selectia prin bifare (pe exemplul de pe pagina anterioara, bifand 100 ni se afiseaza doar lunile Ianuarie, Noiembrie si Decembrie)

Pe langa Optiunile de sortare, este evident ca acest meniu vine si cu alte posibilitati de filtrare (meniul Number Filters, care, daca celulele ar fi avut date de tip text, ar fi fost inlocuit cu Text Filters). Fiecare din optiunile submeniului ne duc la o fereastra cu liste derulante, de unde putem alege potentialele conditii.

21

Suport de curs ECDL modul 4 Office 2007

7. INTRODUCETI UN....
Acest capitol reuneste elementele care pot fi introduse intr-un fisier, pe langa text propriuzis. Toate obiectele de inserat prevazute in programa ECDL (cu exceptia functiilor si a intreruperilor de pagina) se gasesc in Meniul Insert.

Imagine de pe calculator Imagine din biblioteca de imagini Scheme Forme geometrice

Grafice

Caseta text

Simboluri Antete si subsoluri

7.1Simboluri
Uneori este necesar sa introducem simboluri care nu se regasesc pe tastatura: Lira Sterlina, Euro, copyright, marca inregistrata, caractere latine, semne matematice (, , , , , , ). Inainte de implementarea in Windows a tastaturii romanesti, diacriticile aveau acelasi statut de semne care nu erau pe tastatura, dar care puteau fi generate folosind optiunea de inserare a simbolurilor (pe banda Insert, in extrema dreapta). Fereastra de Simboluri cuprinde o lista derulanta cu fonturi, si o lista cu simbolurile posibile; dubluclick pe un simbol, si acesta este inserat in text. De obicei, dintre fonturi se folosesc (normal text), Windings si Webdings (acestea din urma fiind fonturi special create pentru simboluri. Figura de mai jos arata o astfel de fereastra, cu fontul Windings, si simbolul unui telefon selectat spre inserare.

22

ECDL 38 UAIC Iasi Amintim ca daca se doreste introducerea unui simbol monetar intr-o celula, NU se folosesc acest tip de simboluri. De exemplu, daca intr-o celula in care avem valoarea 20 vrem sa se afiseze 20$, nu vom introduce semnul $ de la tastatura (adica nu vom scrie in celula 20$). Facand asta, Excel-ul transforma toata celula in camp de tip text. Daca vrom sa apara scris 20$, vom marca celula ca avand valori de tip Monetar (Currency), si vom alege unitatea monetara $ (conform capitolului 4.2). In exemplul alaturat, valoarea din celula este 20, dar afisat este 20.00$, conform setarilor tipului Currency.

7.2 Antete si subsoluri


Antetele si subsolurile sunt portiuni de text (dar nu numai) care se repeta pe fiecare pagina. Numele autorilor unui manual, de exemplu, titlul unei carti care apare pe fiecare pagina, sau numerotarea paginilor. Antetele difera de subsoluri doar prin localizare (antetele sunt in susul paginii, subsolurile sunt in josul acestora). Excel-ul vine cu doua posibilitati de a introduce antete si subsoluri. Una este ca parte a meniului Page Setup si va fi discutata in capitolul 10. Cealalta porneste cu apasarea butonului Header (respectiv Footer) din meniul Insert. Modul de vizualizare a paginii se schimba din Normal in Page Layout.
Schimbat intre antet si subsol

Data si ora Introdus imagine Nr.paginii Aginia(structu nume fisier, nume sheet Aginia(stru pagini Calea, Nr. total de
Aginia(structura) Aginia(structura) functiei apare in

Antete diferite pt prima pagina, respectiv pagini pare/impare


Aginia(structura) functiei apare in

Cele trei zone de antet

Pentru a introduce un antet se da click intr-una din cele trei zone special marcate pe foaie, apoi se alege din meniul Header&Footer Tools elementul dorit. Se poate merge pe particularizare, inclusiv cu text introdus de la tastatura, si elementele se pot combina (de exemplu, se poate introduce de la tastatura pagina , apoi din bara se introduce numarul paginii, apoi iar de la tastatura din , din nou, din meniu se introduce numarul de pagina, iar in final, din tastatura, se scrie pagini). Alternativ, se poate introduce un antet predefinit, apasand pe sageata de sub butonul Header. Analog se procedeaza si pentru subsoluri.

23

Suport de curs ECDL modul 4 Office 2007

7.3 Imagini
Wordul permite introducerea de imagini in text. Aceste imagini pot fi introduse de pe calculator, din biblioteca de imagini, pot fi desenate din forme geometrice sau pot fi scheme. Imaginile de pe calculator (Pictures) se introduc folosind o fereastra asemenatoare celei Open. Se merge in directorul dorit, se gaseste imaginea si se deschide cu dublu-click. Clipart-urile sunt imagini care au fost instalate o data cu Word-ul, sau sunt accesibile automat dintr-o baza de date online. La apasarea butonului Clipart in partea dreapta a paginii apare o fereastra prin intermediul careia cautam clipart-ul care ne trebuie. Se introduce textul de cautat in zona Search For si apoi se apasa Go; din cliparturile gasite se da click pe cel care ne intereseaza. In exemplul din dreapta, am cautat imagini de calatorie (travel). Dupa ca am introdus o imagine de pe calculator sau din cliparturi, ne apare pe banda un meniu special atunci cand selectam, cu un click, imaginea. Ne sunt puse la dispozitie o multime de efecte predefinite (mare parte dintre ele accesabile in zona Picture Styles. Imaginea poate fi redimensionata folosind partea din dreapta a meniului, dar exista si o alta posibilitate: Selectarea imaginii se face printr- un click stnga pe aceasta. Imaginea va aprea ncadrat ntr-un ptrat cu 8 puncte. Acum putei modifica dimensiunea obiectului plasnd cursorul mouse-ului deasupra unui din cele 8 puncte. Cursorul poate avea diferite forme n funcie de punctul de deasupra cruia l plasai. Dup apariia cursorului apsai i tragei spre interior sau exterior (micorare sau mrire). Din coluri modificare se face proporionat (fr a se distorsiona imaginea iniial).

Imaginile pot fi copiate cu Copy-Paste (utilizand oricare din cele trei metode descrise in capitolul 4.3), pot fi sterse apasand tastele Delete sau Backspace. Formele geometrice sunt imagini care trebuiesc desenate: se alege forma dorita, si apoi se schiteaza conturul cu mouse-ul. Banda de meniuri care apare este similara celei de la celelalte tipuri de imagini. Schemele (SmartArt) reunesc si combina diferite tipuri de structuri care pot fi utile in documente gandite pentru prezentare. Se alege tipul de SmartArt dorit, si se completeaza in casutele de text cu elementele dorite (de exemplu, intr-o schema ierarhica, cu denumiri de directori). In general adaugarea de elemente se face executand click dreapta pe elementul de legatura (de exemplu, pentru a introduce o secretara, se da click dreapta pe directorul care o va primi si i se adauga o subordonata. SmartArturile apar incadrate intr-un dreptunghi, care serveste pe post de container pentru figuri: daca se doreste copierea/mutarea/stergerea smartartului, se executa operatiile in cauza pe acest dreptunghi.

24

ECDL 38 UAIC Iasi

7.4 Intreruperi de pagina


Uneori, apar situatii in care dorim expres ca o anumita parte a tabelului sa inceapa pe o pagina noua. La prima vedere tentatia este sa accesam modul de vizualizare a paginii de imprimare si/sau sa aproximam ochiometric unde ar trebui sa inceapa noua pagina. Dar ce se intampla daca modificam celulele din paginile anterioare? Solutia consta in introducerea unei intreruperi de pagina (Page Brake). In acelasi mod in care s-a procedat la inghetarea randurilor/coloanelor (capitolul 5.2) se selecteaza randul sau coloana cu care va incepe noua pagina si, din meniul Page Layout>Breaks>Insert Page Break. Conturul paginilor de imprimat este marcat cu linii punctate direct pe tabel. Daca vrem sa stergem o intrerupere de pagina, nu putem proceda ca in Word, sa apasam Backspace. Selectam randul sau coloana cu care a inceput noua pagina si din acelasi meniu (Page Layout>Breaks) alegem Remove Page Break.

25

Suport de curs ECDL modul 4 Office 2007

8. FUNCTII 8.1 Formule


Cea mai simpla formula este cea care ii spune unei celule sa ia valoarea unei alte celule. Pe exemplul din dreapta, ii spunem celulei B2 ca vrem sa ia valoarea din celula B1. Pentru a realiza acest lucru scriem in celula B2: =B1 (fara ghilimele). Alternativ, dupa egal, in loc sa scriem B1 de la tastatura, putem da click pe celula B1; Excel a introdus automat referinta in formula. In ambele cazuri, apasam Enter pentru a iesi din modul de introducere a formulei. Ce am realizat: -semnul egal, introdus ca prim element in celula, ii spune Excelului ca noi vrem sa introducem o formula sau o functie; Excel nu va trata textul de dupa egal ca orice text, ci il va procesa corespunzator; orice formula sau functie vrem sa introducem este prefixata de semnul egal. Ca informatie tangentiala, orice celula care incepe cu un operator matematic este tratata ca o formula sau o functie. -B1 este referinta la celula care ne trebuie. In acest moment, Excelul stie ca in celula B2 va apare valoarea care este in celula B1, indiferent de modul cum aceasta valoare a ajuns acolo (de exemplu, daca valoarea din celula B1 este obtinuta, la randul ei, printr-o formula sau functie, in B2 ne va fi afisata valoarea finala, indiferent de cum a ajuns ea acolo); -Enter-ul ne scoate din modul de introducere a formulelor in celula. E ca si cum i-am spune ca am terminat cu introducerea acesteia. De remarcat ca, daca am da click in alta parte pe ecran pentru a iesi din modul de editare, Excel-ul considera ca noi vrem intentionat sa dam click pe respectiva celula (modul 2 de lucru, prezentat mai sus) si nu ne lasa sa iesim pana nu dam Enter. Candidatii au tendinta, mai ales ajunsi in acest punct, sa dea click in alta parte pentru a iesi dintr-o celula; trebuie avut grija ca nu cumva celula respectiva sa contina o functie. In figura din stanga am introdus in celula C3 o formula care sa ne calculeze suma celulelor C1 si C2. Ca optiuni de introducere avem: -scriem de la tastatura in C3 =C1+C2 (fara ghilimele), urmat de Enter; -scriem semnul egal in celula C3, dam click de mouse in celula C1, apasam de la tastatura semnul +, dam click de mouse in celula C2, apasam Enter. In ambele cazuri, rezultatul este acelasi, vizibil in imaginea din dreapta. De remarcat ca, desi in celula C3 ne este afisat valoarea sumei, pe bara de formule ne este afisata formula prin care am ajuns la acel rezultat. Daca dam click pe bara de formule, sau dublu-click pe celula (pentru a intra in modul de editare), celulele folosite in formula sunt reprezentate cu culori diferite, pentru a putea fi mai bine localizate in tabel. Absolut similar se lucreaza cu alti operatori matematici (+,-,* pentru inmultire, / pentru impartire, ^ pentru ridicare la putere). In subcapitolul 8.3 vom prezenta un alt mod in care se face adunarea.

26

ECDL 38 UAIC Iasi

8.2 Referinte
Vom incepe din nou cu un exemplu: in imaginea din dreapta, pe coloana D vrem sa calculam suma celulelor corespunzatoare din coloanele B si C. De exemplu, in D1 vrem sa apara suma B1 + C1. Introducem formula, apasam Enter, obtinem un rezultat si ar trebui sa repetam operatia pentru toate celulele. Putem aplica modalitatea de lucru cu serii de date, descrisa in capitolul 6.1: selectam D1, dam click pe coltul din dreapta jos al acestei celule si tragem in jos; Excel-ul ne introduce automat, in toate celulele, aceeasi formula, adaptata: in celula D2 avem suma dintre B2 si C2, in celula D3 avem suma dintre B3 si C3, etc. Aceeasi operatie se poate realiza, daca ni se cere acest lucru, si prin tragere pe orizontala (dupa modelul descris in capitolul 6.1). Asa cum aratam la inceput, B1 si C1 se numesc Referinte Relative la celulele respective. Sa presupunem insa, ca in celula G1, avem cursul euro-ului, iar noi trebuie sa inmultim fiecare rezultat de pe coloana D cu aceasta valoare, pentru a obtine rezultatul final, pe coloana E. Formula din celula E1 este simpla, produsul dintre D1 si G1. La randul ei, valoarea din E2 se obtine inmultind D2 cu acelasi G1, E3 este D3*G1, etc. Dupa ce scriem valoarea in celula E1, insa, daca aplicam modelul folosit mai sus prin tragere de coltul dreapta-jos al celulei, remarcam ca E2 devine D2*G2, in loc de D2*G1, cum am dori; este normal sa fie asa: D1 a crescut cu un rand si a devenit D2, G1 trebuie sa creasca si el cu un rand, devenind G2. Pentru a preveni, insa acest lucru, punem semnul $ in fata partii care nu trebuie sa creasca: -vrem ca G1 sa nu devina H1? Punem semnul $ in fata lui G, iar atunci referinta la celula noastra este $G1 - vrem ca G1 sa nu devina G2 (cazul nostru)? Punem semnul $ in fata lui 1, iar atunci referinta la celula noastra este G$1 -vrem ca, orice am face, sa nu creasca nici G nici 1? Punem dolar si in fata lui G si in fata lui 1, iar referinta la celula noastra va fi $G$1. Pe exemplul nostru, noi nu vrem ca G1 sa creasca in G2, si atunci, in celula E1, in loc de =D1*G1 scriem =D1*G$1. Astfel, atunci cand copiem formula in celulele celelalte, D1 devine D2, apoi D3 si tot asa, dar G$1 ramane tot timpul G$1. De remarcat ca daca in loc de G$1 am fi scris $G$1 nu era gresit, pentru ca obiectivul nostru era atins: 1 nu trebuia sa devina G2. Pentru a ne usura introducerea semnului $, Excel-ul ne da posibilitatea ca daca dam click pe bara de formule pe textul G1, sa apasam tasta F4 si sa trecem automat prin toate posibilitatile de plasare ale semnului $. G1 se numea referinta relativa. $G$1 se numeste referinta absoluta, iar G$1 si $G1 se numesc referinte mixte. Celulele pot fi referite si dupa Foaia de lucru in care se afla; de exemplu, celula G1 din foaia de lucru Sheet1 este referita ca Sheet1!G1

27

Suport de curs ECDL modul 4 Office 2007

8.3 Formule
Am vazut deja ca daca intr-o celula, sa zicem, C6 scriem =C1+C2+C3+C4+C5 obtinem suma tuturor acestor celule. Excel-ul vine cu o serie de functii, care au ca scop usurarea lucrului (va dati seama ce ar insemna sa faceti din click-uri si plusuri suma unei intregi coloane). Sunt doua modalitati de a introduce o functie intr-o celula: fie din meniul Formulas butonul Insert Functions, fie apasand butonul Insert Functions de pe bara de formule. In ambele cazuri ni se deschide o fereastra ca in figura de mai jos.
Introducem cuvantul de cautare (numele functiei), apasam GO, si ne sunt returnate toate functiile care contin respectivul termen. Selectam functia dorita, si apasam OK

Fiecare functie are structura generala DENUMIRE(lista de argumente).

Argumentele sunt parametrii pe care ii introducem noi. De exemplu, pe functia de suma, argumentele sunt Categorii de functii celulele din care vom face suma. De obicei, parametrii sunt separati prin Lista functiilor din virgule. O functie poate contine ca categoria aleasa parametru alta functie sau alte functii (se numesc functii imbricate sau Informatii despre incapsulate). functia selectata Revenind la exemplul nostru, in zona de cautare introducem textul SUM, si, dupa ce apasam GO, o sa ni se returneze mai multe functii care contin SUM. Noi o cautam pe cea mai simpla, cea cu acelasi nume. In fereastra care apare ni sa da posibilitatea de a introduce argumentele functiei. Putem face acest lucru fie scriind Codul (structura) functiei apare in timp real pe bara de formule de la tastatura C1,C2,C3,C4,C5 (fara ghilimele), si atunci Excelul stie sa calculeze Suma de (C1,C2,C3,C4,C5). Acelasi lucru il obtinem daca in loc Previzualizarea valorii Zona argumentelor de enumerarea celulelor argumentelor scriem selectia lor, C1:C5 (vezi capitolul 4.1), si atunci Excel-ul stie sa Previzualizarea explicatii calculeze Suma celulelor rezultatului functiei (de la C1 la C5). Pentru a treia varianta, si cea mai comoda, vom folosi iconita care semnifica faptul ca putem da click pe celulele in cauza: Click pe iconita, restul ferestrei SUM dispare (pentru a nu ne incurca), selectam celulele din care vrem sa facem Suma (de la C1 la C5), si . Ne-am apoi apasam intors la fereastra SUM. Apasam OK, iar acum in celula C6 ne-a aparut suma. Sus, pe bara de functii, ne este prezentata structura functiei. Daca o stim, am putea-o introduce de aici, fara sa apelam la fereastra SUM. 28

ECDL 38 UAIC Iasi Celelalte functii care trebuie cunoscute la acest modul si care respecta exact structura functiei SUM (se procedeaza exact la fel) sunt: -AVERAGE: returneaza media aritmetica a valorilor din celulelor selectate -MIN: returneaza minimul valorilor din celulelor selectate -MAX: returneaza maximul valorilor din celulelor selectate -COUNT: numara cate din celulele selectate sunt de tip numeric. Functia ROUND ne permite sa rotunjim valoarea din celula sursa, la un numar de zecimale stabilit tot de noi. De exemplu, daca rotunjim 2,15 la 1 zecimala obtinem 2,2. Analog, 2,1499999 rotunjit la o zecimala este 2,1. Structura functiei este ROUND (numar,zecimale).

Introducem celula sursa Cate zecimale vrem

Revenind la exemplul anterior, cel cu functia SUM (calculata in celula C6 din celulele C1:C5, ca in imaginea din stanga), sa presupunem ca ni se cere ca daca valoarea finala este, de exemplu, mai mare decat 150 sa afisam in celula C7 Da, altfel trebuie sa afisam in aceeasi celula Nu. Solutia este sa folosim functia IF (daca), a carei structura in romana este (totul scris pe un singur rand, remarcati virgulile si parantezele): IF(conditie, valoarea_pe_care_o_ia_celula_daca_este_adevarata_conditia, valoarea_pe_care_o_ia_celula_daca_este_falsa_conditia) Conditia este ca valoarea din C6 sa fie mai mare decat 150. Daca este adevarata conditia, sa se afiseze Da, daca este falsa conditia, sa se afiseze Nu. In zona conditiei putem scrie noi, de la tastatura C6>150, sau putem apasa iconita , da click pe C6, intors in fereastra functiei apasand iconita (ca mai sus la SUM), si apoi scriem in continuare >150. Faptul ca avem iconite pentru selectat celulele si la ultimele doua argumente ne arata ca, la nevoie, in celula C7, putem afisa valori din alte celule, nu doar textul Da sau Nu. De asemenea trebuie remarcat ca pe exemplul nostru raspunsul este Nu; valoarea din celula C6 este 150 care nu este strict mai mare decat conditia pusa de noi; semnul pentru mai mare sau egal este >= (fara ghilimele) . In O mica observatie legata de utilizarea ferestrei care apare dupa apasarea iconitei anumite situatii, cand vrem sa dam click intr-o celula folosind aceasta fereastra, Excel-ul nu sterge referinta la celula care era inainte, ci pastreaza ambele referinte selectate. De aceea recomandam ca atunci cand am ajuns in aceasta fereastra sa stergem (apasand Backspace) orice informatie exista deja acolo. Un exemplu (creat in scop didactic) de astfel de situatii este in dreapta. 29

Suport de curs ECDL modul 4 Office 2007

9. GRAFICE
Excel-ul permite realizarea de representari grafice ale datelor din tabele, folosind o mare varietate de modele. Graficele se introduc din meniul Insert. In primul pas se alege tipul de grafic dorit. Pentru pasul al doilea, trebuie sa-i spunem pe baza caror date construim graficul. In general, Excel-ul incearca sa ghiceasca ce date vrem sa folosim.Problema este ca el nu are de unde sa stie ca pe ultimul rand, de exemplu, noi avem suma elementelor de mai sus (in exemplul din dreapta, graficul nu ar trebui sa includa si Total-ul). Ca urmare, recomandam prudenta in utilizarea graficelor create automat. Pentru a selecta datele care vor fi utilizate accesam fereastra Select Data Source, fie dand click dreapta in zona alba a graficului, fie accesand butonul corespunzator din meniu Chart Tools>Design (acest meniu este prezentat pe pagina urmatoare). Graficele in Excel se construiesc pe baza seriilor de date; de exemplu, un grafic pentru un tabel cu doua coloane contine 2 serii de date, aferente celor doua coloane. Ca urmare, in aceasta fereastra Select Data Source, noi ii spunem Excel-ului ce serii de date sa foloseasca pentru crearea , graficului (remarcati permanent iconitele care permit sa dam click direct pe tabel spre a selecta ce ne intereseaza). Pentru a selecta Zona de date a tabelului seriile date avem doua optiuni: fie selectam zona de date a tabelului (marcata cu contur punctat pe imaginea din dreapta), si lasam Excel-ul sa inteleaga care sunt seriile de date. A doua posibilitate consta in apasarea butonului Add si adaugarea manuala a fiecarei serii, folosind fereastra care apare. Pe exemplul din Butoane pt Adaugarea, Informatii stanga, am Editarea, Stergerea sau despre Axa rearanjarea seriei de date adaugat o a Ox a Serii de date selectate treia serie, graficului continand ca titlul textul din celula D1, iar ca valori grupul de celule D2:D4. Fereastra din dreapta sus va contine, astfel, 3 serii de date (dreapta jos). Remarcam insa, in zona dedicata axei Ox, faptul ca seriile nu sunt referite corespunzator (pe axa Ox ar fi trebui sa apara cele trei nume, Ion Maria si Ana). Pentru a rezolva acest lucru apasam butonul Edit din zona Horizontal Axis si selectam cele trei celule in cauza. Dam OK-uri pentru a iesi din ferestre si a ajunge la graficul nostru.

30

ECDL 38 UAIC Iasi

Orice element al graficului poate fi modificat dand click dreapta pe el si alegand din meniul contextual optiunea care incepe cu Format.... Mare parte din elemente pot fi redimensionate sau mutate selectandu-le si apoi modificandu-le cu ajutorul mouse-ul. Cateva optiuni sunt prezente si pe bara de meniuri Chart Tools>Design.

Schimbam tipul de grafic (pastrand datele)

Schimbam intre ele candurile cu coloanele

Selectam datele pentru care construim graficul

Schimbam aspectul graficului (cu sau fara legenda/titlu/ tabel inclus/valori,etc

Schimbam paleta coloristica a graficului

Mutam graficul in alta locatie

Din acest meniu putem schimba tipul graficului si dupa ce l-am creat (Excel-ul va incerca sa pastreze seriile de date). Putem adauga noi serii de date sau schimba locul randurilor cu coloanele. In partea dreapta avem posibilitatea de a schimba paleta coloristica. In extrema dreapta, butonul Move Chart ne permite sa mutam automat graficul in alta foaie de lucru (Object In de mentionat ca putem face asta si cu Copy-Paste) sau intro foaie de lucru proprie (New Sheet). Pe mijlocul meniului Chart Tools>Design avem cateva optiuni predefinite legate de aspect (cu sau fara legenda/cap de tabel, etc). Adevaratele optiuni de particularizare a acestor elemente sunt in meniul Chart Tools>Layout. In general fiecare element deschide un submeniu (apasand pe sagetica in jos de sub buton) care contine acelasi lucru: posibilitatea de a nu apare de loc, cateva optiuni de localizare predefinita, si un More ... Options care duce in fereastra Format... a respectivului element.

Titl Axe Legend u Daca vremasa apara valorile trecute pe coloanele graficului

Avalorile Grila de pe axe de Daca vrem sa apara tabelul de date sub grafic

Fundalul graficului Ultimul meniu din bara Chart Tools Format, se ocupa de partea estetica.

In acest subcapitol am folosit exemplul unui grafic de tip Coloana (Column). Analog se procedeaza si in cazul celorlalte tipuri de grafice: linie (Line), diagrama de structura/ disc/cerc (Pie), bara (Bar). Singura diferenta este la graficul de tip Pie, care, prin natura lui, nu poate avea decat o singura serie de date.

31

S-ar putea să vă placă și