Sunteți pe pagina 1din 13

ALGORITMOS Y DIAGRAMAS DE FLUJO

P-01.-HALLAR LA SUMA DE LOS 7 PRIMEROS NUMEROS NATURALES. SOLUCIN ALGORITMO Proceso SOL_PROB_01_MIENTRAS n=0; suma=0; Mientras n<=6 Hacer suma=suma+n; n=n+1; FinMientras Escribir "la suma es: ",suma; FinProceso

ALGORITMO

Proceso SOL_PROB_01_REPETIDOR n=0; suma=0; Repetir suma =suma+n; n=n+1; Hasta Que n>6 Escribir "la suma es: ", suma; FinProceso

SOL. DE ALGUNOS PROBLEMAS WAIRA

ALGORITMOS Y DIAGRAMAS DE FLUJO

P-02.-HALLAR LA SUMA DE LOS PRIMEROS 20 NMEROS DIVISIBLES POR 4. SOLUCIN ALGORITMO Proceso SOL_PROB_02_MIENTRAS N<-0; p<-0; suma<-0; Mientras N<=19 Hacer P<-N*4; suma<-suma+P; N<-N+1; FinMientras Escribir 'la suma es: ',suma; FinProceso

ALGORITMO Proceso SOL_PROB_02_REPETIDOR n=0; p=0; suma=0; Repetir p=n*4; suma=suma+p; n=n+1; Hasta Que n>19 Escribir "la suma es: ",suma; FinProceso

SOL. DE ALGUNOS PROBLEMAS WAIRA

ALGORITMOS Y DIAGRAMAS DE FLUJO

P-03.-CALCULAR LA SUMA DE 1-200. SOLUCIN ALGORITMO Proceso SOL_PROB_03_MIENTRAS n=1; suma=0; Mientras n<=200 Hacer suma=suma+n; n=n+1; FinMientras Escribir "la suma de 1-200 es: ",suma; FinProceso

ALGORITMO Proceso SOL_PROB_03_REPETIDOR n=1; suma=0; Repetir suma=suma+n; n=n+1; Hasta Que n>200 Escribir "la suma de 1-200 es: ",suma; FinProceso

SOL. DE ALGUNOS PROBLEMAS WAIRA

ALGORITMOS Y DIAGRAMAS DE FLUJO

P-04.-CALCULAR LA SUMA DE LOS CUADRADOS DE LOS PRIMEROS 100 NUMEROS


NATURALES. (TENER PRESENTE FORMULA: = = = (+)(+) )

SOLUCIN ALGORITMO Proceso SOL_PROB_04 n=99; suma=0; suma=(n*(n+1)*(2*n+1))/6; Escribir "el resultado es: ",suma; FinProceso

P-05.- DADO EL VALOR DE COMPRA DE UN PRODUCTO, HALLAR EL IGV (18%) Y EL PRECIO DE VENTA DEL PRODUCTO. SOLUCIN

ALGORITMO Proceso SOL_PROB_05 Definir pc,i,pv Como Real; Escribir 'ingrese el precio de compra'; Leer pc; i=(18*pc)/100; pv=pc+i; Escribir 'el igv es: ',i; Escribir 'el precio de venta es: ',pv; FinProceso

SOL. DE ALGUNOS PROBLEMAS WAIRA

ALGORITMOS Y DIAGRAMAS DE FLUJO

P-06.-EN UNA PLAYA DE ESTACIONAMIENTO COBRAN S/.2.5 x POR HORA O FRACCON, DISEAR UN ALGORITMO QUE DETERMINE CUANTO HABRA QUE PAGAR UN CLIENTE POR EL ESTACIONAMIENTO DE VEHICULO, CONOCIENDO EL TIEMPO DE ESTACIONAMIENTO EN HORAS Y MINUTOS. NOTA: SI SE DE 15 min SE CONSIDERA PAGO POR UNA HORA. SOLUCIN ALGORITMO Proceso SOL_PROB_06 Definir hr,min,pe Como Real; Escribir "ingrese numero de hora(s) de estacionamiento"; Leer hr; Escribir "ingrese el tiempo restante de min"; Leer min; Si min>15 Entonces pe=((hr+1)*2.5); Sino pe=(hr*2.5); FinSi Escribir "el pago por estacionamiento es: ",pe ; FinProceso

P-07.-EN UN SALON DE CLASE SE DESEA SABER: A.- Cuntos hombres y mujeres estn matriculados? B.- Cuntos solteros mayores de 18 aos tienen hijos. C.- Cuntos casados menores de 30 aos no tienen hijos? D.- Cuntas casadas tienen hijos? SOLUCIN

SOL. DE ALGUNOS PROBLEMAS WAIRA

ALGORITMOS Y DIAGRAMAS DE FLUJO

Tener presente lo siguiente: NH=Nmero de Hombres. NM=Nmero de Mujeres. SMECH=Solteros Mayores de Edad (>18) Con Hijos. CMCH=Casadas Mujeres Con Hijos. CMTSH=Casados Menores de Treinta aos (<30) Sin Hijos. EC=Estado Civil (admite Casados C y Solteros S) NHI=Nmero de Hijos ALGORITMO Proceso SOL_PROB_07 NH=0,NM=0,CMCH=0,SMECH=0,CMTSH=0; Leer SEXO,EC,NHI,EDAD; Repetir Si SEXO='H' Entonces NH<-(NH+1); Si EC='S' Entonces Si EDAD>18 Entonces Si NHI>0 Entonces SMECH<-(SMECH+1); FinSi FinSi Sino Si EDAD>30 Entonces Si NHI=0 Entonces CMTSH<-(CMTSH+1); FinSi FinSi FinSi Sino NM<-(NM+1); Si EC='C' Entonces Si NHI>0 Entonces
SOL. DE ALGUNOS PROBLEMAS WAIRA 6

ALGORITMOS Y DIAGRAMAS DE FLUJO

CMCH<-(CMCH+1); FinSi FinSi FinSi Hasta Que /* Escribir 'imprimir las respuestas', NH,NM,CMCH,CMTSH,SMECH; FinProceso

P-08.-EN UNA ENCUESTA SE OBTUVO INFORMACION POR EL GUSTO DE FUMAR A.- Cuntas mujeres mayores de 18 aos fuman Premier? B.- Cuntos hombres menores de 20 fuman Hamilton y Premier? C.- Cuntos hombres y mujeres No fumas ningn tipo de cigarrillo? SOLUCIN Tener presente lo siguiente: PNF=Personas que No Fuman
SOL. DE ALGUNOS PROBLEMAS WAIRA 7

ALGORITMOS Y DIAGRAMAS DE FLUJO HFC=Hombres Fuman Cigarro (Hamilton H y Premier P) MFC=Mujeres Fuman Cigarro CI=Cigarro (1 opcin) CI1=Cigarro (2 opcin) ALGORITMO Proceso SOL_PROB_08 PNF=0, HFC=0, MFC=0; Repetir Leer FUMAR,EDAD,SEXO,CI,CI1; Si FUMAR='S" Entonces Si SEXO='M' Entonces Si EDAD<20 Entonces Si CI='H' Entonces Si CI1='P' Entonces HFC=HFC+1; FinSi FinSi FinSi Sino Si EDAD>18 Entonces Si CI='P' Entonces MFC=MFC+1; FinSi FinSi FinSi Sino PNF=PNF+1; FinSi Hasta Que /* Escribir 'MOSTRAR:', PNF,MFC,HFC; FinProceso
SOL. DE ALGUNOS PROBLEMAS WAIRA 8

ALGORITMOS Y DIAGRAMAS DE FLUJO

SOL. DE ALGUNOS PROBLEMAS WAIRA

ALGORITMOS Y DIAGRAMAS DE FLUJO

P-01.suma de los 7 nmeros naturales

P-02.suma de los 20 primeros nmeros naturales divisibles por 4.

SOL. DE ALGUNOS PROBLEMAS WAIRA

10

ALGORITMOS Y DIAGRAMAS DE FLUJO

P-03.hallar la suma de 1 al 200.

P-04.hallar la suma de los cuadrados de los 100 primeros nmeros naturales.

SOL. DE ALGUNOS PROBLEMAS WAIRA

11

ALGORITMOS Y DIAGRAMAS DE FLUJO

P-05. Dado el valor de compra de un producto, hallar el IGV (18%) y el precio de venta.

SOL. DE ALGUNOS PROBLEMAS WAIRA

12

ALGORITMOS Y DIAGRAMAS DE FLUJO

P-06.-EN UNA PLAYA DE ESTACIONAMIENTO COBRAN S/.2.5 x POR HORA O FRACCON, DISEAR UN ALGORITMO QUE DETERMINE CUANTO HABRA QUE PAGAR UN CLIENTE POR EL ESTACIONAMIENTO DE VEHICULO, CONOCIENDO EL TIEMPO DE ESTACIONAMIENTO EN HORAS Y MINUTOS. NOTA: SI SE pasa DE 15 min SE CONSIDERA PAGO POR UNA HORA.

SOL. DE ALGUNOS PROBLEMAS WAIRA

13