Sunteți pe pagina 1din 34

es

gi
CCNA

lo
Cisco Certified no
Network Associate
ch
Lab Guide
Te
M

Name: ______________________
O

Faculty:_____________________
Batch: ______________________
ZO

Branch:_____________________

Zoom Technologies® 1
Lab completion report
Name:_________________________
Batch:_________________________
LAB DATE Student Sig Lab Coordinator Sig Remarks

Initial

es
WAN Int

Static

gi
RIP

lo
EIGRP

OSPF
no
Access
ch
List
NAT
Te

Frame
Relay
VLAN
M

VTP
Inter-
O

VLAN
Port
ZO

Security

Sign Of the Faculty _________________________


Imp Note: After completing the lab on every session take the sign
of the lab coordinator, course completion certificate will not be
issued otherwise.

Zoom Technologies® 2
es
gi
lo
no
ch
Te
M
O
ZO

Zoom Technologies® 3
Lab 1 - INITIAL ROUTER CONFIGURATION

es
User mode:
Router >
Router > enable

gi
Show commands:
Router # show running-config
Router # show startup-config

lo
Router # show version
Router # show flash
Moving to Global configuration mode:
Router # configure terminal
Router(config) #
no
Assigning Hostname to Router
ch
Rotuer(config)#Hostname Hyderabad
Assigning ip address to Ethernet interface:
Hyderabad (config) # interface Ethernet 0
Hyderabad (config-if) # ip address 192.168.1.1 255.255.255.0
Te

Hyderabad (config-if) # no shut

Assigning Telnet password:


Hyderabad (config) # line vty 0 4
Hyderabad (config-line) #login
Hyderabad (config-line) #password zoom
M

Hyderabad (config-line) #exit


Hyderabad (config) #exit

Assigning console password:


O

Hyderabad (config) # line con 0


Hyderabad (config-line) # login
Hyderabad (config-line) # password ccna
ZO

Hyderabad (config-line) # exit


Hyderabad (config) # exit

Assigning Auxiliary password:


Hyderabad (config) # line aux 0
Hyderabad (config-line) # login
Hyderabad (config-line) # password cisco
Hyderabad (config-line) # exit
Hyderabad (config) # exit

Assigning enable password:


Hyderabad (config) # enable password cisco

Zoom Technologies® 4
Hyderabad (config) # enable secret zoom

Checking the Changes in running-config


Hyderabad # show running-config
Hyderabad # show startup-config

Commands to save the configuration:

Hyderabad # copy running-config startup-config


( OR )
Hyderabad # write memory

es
( OR )
Hyderabad # wr

Checking the startup-config:

gi
Hyderabad # show startup-config

Check the following if you have completed in the labs

lo
1. Establish Telnet session to the Router

2. Configure hostname to router.


no
3. Configuring Ethernet interface of the Router
ch
4. Password protection to the Telnet session

5. Password protection to the Console session


Te

6. Password protection to the Auxiliary session

7. Setting up privilege mode Password.

8. Context sensitive help


M

9. Display the contents of Running-Configuration


O

10.Display the contents of Startup-configuration

11.Saving the Configuration


ZO

12.Establishing a console session to the Router

Important Note
Please don’t forget to fill in the Lab Completion Report after the lab and take the signature of the lab
coordinator as Course completion certificate will not be issued otherwise.

Zoom Technologies® 5
Lab 2 - WAN INTERFACE CONFIGURATION:

s
172.16.0.1/16 172.17.0.1/16
S0 S0

e
HYD S1
CHE S1
172.16.0.2/16 BAN

gi
E0 172.17.0.2/16
E0 E0
10.0.0.1/8 BAN
192.168.1.1/24 192.168.2.1/24
N

lo
no
LAN - 192.168.1.0/24 LAN – 10.0.0.0/8

ch
LAN - 192.168.2.0/24

ON CHE: ON HYD: ON BAN:

CHE# configure terminal HYD # configure terminal BAN# configure terminal

Te
CHE(config)# interface serial 0 HYD (config) # interface serial 1 BAN(config)#interface serial 1
CHE(config-if)# ip address 172.16.0.1 255.255.0.0 HYD(config-if)#ip address 172.16.0.2 255.255.0.0 BAN(config-if)#ip address 172.17.0.2 255.255.0.0
CHE(config-if)# no shutdown HYD(config-if)#no shutdown BAN(config-if)#no shutdown
CHE(config-if)# encapsulation hdlc HYD(config-if)#clock rate 64000 BAN(config-if)#encapsulation hdlc
CHE(config-if)# exit HYD(config-if)#encapsulation hdlc BAN(config-if)#^z
CHE(config)# exit HYD(config-if)#^z
M
HYD# configure terminal
HYD(config) #interface serial 0
HYD(config-if)#ip address 172.17.0.1 255.255.0.0
O
HYD(config-if)#no shutdown
HYD(config-if)#encapsulation hdlc
HYD(config-if)#clock rate 64000
ZO

HYD(config-if)#^z

Zoom Technologies® 6
Fill the Blanks before Starting your configuration

e s
gi
lo
no
Router Name:_________________

ROUTER # configure terminal

ch
ROUTER (config) # interface serial _____
ROUTER (config-if) # ip address ___________________ ___________________
ROUTER (config-if) # no shutdown

Te
ROUTER (config-if) # clock rate 64000
ROUTER (config-if) # encapsulation hdlc
ROUTER (config-if) # exit
M
ROUTER (config) # interface serial _____
ROUTER (config-if) # ip address ___________________ ___________________
O
ROUTER (config-if) # no shutdown
ROUTER (config-if) # encapsulation hdlc
ZO

ROUTER (config-if) # clock rate 64000


ROUTER (config-if) # exit

Zoom Technologies® 7
s
Show commands:

e
Serial interface troubleshooting

gi
Router # show interfaces s 0

lo
1. Serial 0 is up , line protocol is up (connectivity is fine)

2. Serial 0 is administratively down, line protocol is down

no
(No Shutdown has to be given on the local router serial interface)

3. Serial 0 is up, line protocol is down


(Encapsulation mismatch or clock rate has to be given on DCE)

ch
4. Serial 0 is down, line protocol is down
(Serial interface on the remote router has to be configure)

Te
Router # show controllers s 0

(To know whether the cable connected to the serial interface is DCE or DTE)
M
O
ZO

Zoom Technologies® 8
Lab 3.1 - STATIC ROUTING

e s
172.16.0.1/16 172.17.0.1/16
S0 S0

gi
HYD S1
CHE S1
172.16.0.2/16
E0 172.17.0.2/16 BAN
E0 E0
BAN

lo
192.168.1.1/24 10.0.0.1/8
192.168.2.1/24
N

no
ch
LAN - 192.168.1.0/24 LAN – 10.0.0.0/8 LAN - 192.168.2.0/24

ON CHE :
AREA 0
CHE # config terminal
CHE(config) # ip routing
CHE(config) # ip route 10.0.0.0 255.0.0.0 172.16.0.2
Te
ON HYD :

HYD # config terminal


HYD(config) # ip routing
HYD(config) # ip route 192.168.1.0 255.255.255.0
172.16.0.1
ON BAN:

BAN # config terminal


BAN(config) # ip routing
BAN(config) # ip route 10.0.0.0 255.0.0.0 172.17.0.1
M
HYD(config) # ip route 192.168.2.0 255.255.255.0
172.17.0.2
O

Show commands: Debug commands:


ZO

ROUTER # show ip route ROUTER # debug ip routing


ROUTER # debug ip packet

Zoom Technologies® 9
s
Fill the Blanks before Starting your configuration

e
gi
Router Name:_________________

lo
ROUTER # configure terminal
ROUTER(config) # interface serial 0

no
ROUTER(config-if) # ip address ___________ _____________
ROUTER(config-if) # no shutdown

ch
ROUTER(config-if) # clock rate 64000
ROUTER(config-if) # encapsulation hdlc
ROUTER(config-if) # exit
ROUTER(config) # interface serial 1

Te
ROUTER(config-if) # ip address ___________ _____________
ROUTER(config-if) # no shutdown
M
ROUTER(config-if) # encapsulation hdlc
ROUTER(config-if) # clock rate 64000
ROUTER(config-if) # exit
O

ROUTER(config) #
ZO

ROUTER(config) # ip routing
ROUTER(config) # ip route _________________ ___________________ _________
ROUTER(config) # ip route _________________ ___________________ _________

Zoom Technologies® 10
Lab 3.2 - STATIC ROUTING

e s
172.16.0.1/16 172.17.0.1/16
S0 S0

gi
HYD S1
CHE S1
172.16.0.2/16
E0 172.17.0.2/16 BAN
E0

lo
E0
BAN
192.168.1.1/24 10.0.0.1/8
192.168.2.1/24
N

no
ch
LAN - 192.168.1.0/24 LAN – 10.0.0.0/8 LAN - 192.168.2.0/24

ON CHE :
AREA 0
CHE # config terminal
CHE(config) # ip routing
CHE(config) # ip route 10.0.0.0 255.0.0.0 172.16.0.2
CHE(config) # ip route 192.168.2.0 255.255.255.0
Te
ON HYD :

HYD # config terminal


HYD(config) # ip routing
HYD(config) # ip route 192.168.1.0 255.255.255.0
172.16.0.1
ON BAN:

BAN # config terminal


BAN(config) # ip routing
BAN(config) # ip route 10.0.0.0 255.0.0.0 172.17.0.1
BAN(config) # ip route 192.168.1.0 255.255.255.0
M
172.16.0.2 HYD(config) # ip route 192.168.2.0 255.255.255.0 172.17.0.1
CHE(config) # ip route 172.17.0.0 255.255.0.0 172.17.0.2 BAN(config) # ip route 172.16.0.0 255.255.0.0
172.16.0.2 172.17.0.1
O
ZO

Show commands:

ROUTER # show ip route

Zoom Technologies® 11
Lab 3.3: Default Routing

172.16.0.1
S0

CHE
E0

es
192.168.1.1

gi
ON CHE :

lo
CHE # config terminal
CHE(config) # ip routing

no
CHE(config) # ip route 0.0.0.0 0.0.0.0 s0

Show commands:
ch
ROUTER # show ip route
Te

Router Name:_________________
ROUTER # configure terminal
ROUTER(config) # interface serial 0
M

ROUTER(config-if) # ip address _________________________


ROUTER(config-if) # no shutdown
O

ROUTER(config-if) # clock rate 64000


ROUTER(config-if) # encapsulation hdlc
ZO

ROUTER(config-if) # exit
ROUTER(config) #
ROUTER(config) # ip routing
ROUTER(config) # ip route 0.0.0.0 0.0.0.0 _____ ____

Zoom Technologies® 12
1. Assign the IP address and make the serial interface

administratively up.

2. Understanding the importance of extended ping command.

3. Understanding the importance of debug IP packet command.

4. Understanding the routing table.

es
5. Adding a static route by defining the next hop address.

6. Adding a static route by defining the exit interface.

gi
7. Adding a default route.

lo
no
ch
Te
M
O
ZO

Zoom Technologies® 13
Lab 4 - RIP:

s
172.16.0.1/16 172.17.0.1/16
S0

e
S0

HYD S1
CHE S1
BAN

gi
172.16.0.2/16
E0 172.17.0.2/16
E0 E0
10.0.0.1/8 BAN
192.168.1.1/24 192.168.2.1/24
N

lo
no
ch
LAN - 192.168.1.0/24 LAN – 10.0.0.0/8 LAN - 192.168.2.0/24

ON CHE: ON HYD : ON BAN:

CHE#config terminal
CHE(config)#ip routing
CHE(config)#router rip
Te
CHE(config-router)# network 192.168.1.0
CHE(config-router) # network 172.16.0.0
AREA 0
CHE(config-router)
CHE#
#^z
HYD # config terminal
HYD(config) # ip routing
HYD(config) # router rip
HYD(config-router) # network 10.0.0.0 0
HYD(config-router) # network 172.16.0.0
HYD(config-router) # network 172.17.0.0
HYD(config-router) # ^z
BAN # config terminal
BAN(config) # ip routing
BAN(config) # router rip
BAN(config-router) # network 192.168.2.0
BAN(config-router) # network 172.17.0.0
BAN(config-router) # ^z
BAN#
M
HYD#

Show commands: Debug commands:


O

HYD # show ip route HYD # debug ip rip


HYD # show ip protocols HYD# terminal monitor
ZO

Zoom Technologies® 14
Fill the Blanks before Starting your configuration

e s
gi
lo
Router Name:_________________

no
ROUTER # configure terminal
ROUTER (config) # interface serial 0 ROUTER(config) #

ch
ROUTER (config-if) # ip address ____________ ___________ ROUTER(config) # ip routing
ROUTER (config-if) # no shutdown ROUTER(config) # router rip
ROUTER (config-if) # clock rate 64000 ROUTER(config-router) # network ________________
ROUTER (config-if) # encapsulation hdlc
ROUTER (config-if) # exit
ROUTER (config) # interface serial 1
Te
ROUTER (config-if) # ip address ____________ ___________
ROUTER(config-router) # network ________________
ROUTER(config-router) # network________________
ROUTER(config-router) # ^z
ROUTER#
M
ROUTER (config-if) # no shutdown
ROUTER (config-if) # encapsulation hdlc
O

ROUTER (config-if) # clock rate 64000


ROUTER (config-if) # exit
ZO

Zoom Technologies® 15
1. Enabling RIP Protocol process on the respective networks

2. Understanding the RIP protocol routes in the routing table

3. Understanding the RIP updates using debug IP RIP command

4. Check the A.D usage with RIP and Static

es
gi
lo
no
ch
Te
M
O
ZO

Zoom Technologies® 16
s
Lab 5 - EIGRP

e
172.16.0.1/16 172.17.0.1/16
S0 S0

gi
HYD S1
CHE S1
172.16.0.2/16
E0 172.17.0.2/16 BAN
E0 E0
10.0.0.1/8 BAN

lo
192.168.1.1/24 192.168.2.1/24
N

no
ch
LAN - 192.168.1.0/24 LAN – 10.0.0.0/8 LAN - 192.168.2.0/24

ON CHE:

CHE # config terminal


CHE(config) # ip routing
Te ON HYD:

HYD # config terminal


HYD(config) # ip routing
ON BAN:

BAN # config terminal


BAN(config) # ip routing
CHE(config) # router eigrp 10 HYD(config) # router eigrp 10 BAN(config) # router eigrp 10
CHE(config-router)# network 192.168.1.0 HYD(config-router)#network 10.0.0.0 BAN(config-router)#network 192.168.2.0
CHE(config-router)# network 172.16.0.0 HYD(config-router)#network 172.16.0.0 BAN(config-router)#network 172.17.0.0
M
CHE(config-router)# exit HYD(config-router)#network 172.17.0.0 BAN(config-router)#exit
CHE(config) AREA
# exit 0 HYD(config-router)#exit BAN(config)#exit
HYD(config) # exit
O

Show commands: Show commands:


ZO

HYD # show ip route HYD # show ip eigrp topology [all]


HYD # show ip protocols HYD # show ip eigrp neighbor
HYD # show ip eigrp neighbor details

Zoom Technologies® 17
s
Fill the Blanks before Starting your configuration

e
gi
lo
Router Name:_________________

no
ROUTER # configure terminal ROUTER(config) #

ch
ROUTER (config) # interface serial 0 ROUTER(config) # ip routing
ROUTER (config-if) # ip address ___________ ____________ ROUTER(config) # router eigrp _______
ROUTER (config-if) # no shutdown ROUTER(config-router) # network ________________
ROUTER (config-if) # clock rate 64000
ROUTER (config-if) # encapsulation hdlc
Te ROUTER(config-router) # network ________________
ROUTER(config-router) # network________________
ROUTER (config-if) # exit ROUTER(config-router) # ^z
ROUTER (config) # interface serial 1 ROUTER#
M

ROUTER (config-if) # ip address ___________ ____________


ROUTER (config-if) # no shutdown
O

ROUTER (config-if) # encapsulation hdlc


ROUTER (config-if) # clock rate 64000
ZO

ROUTER (config-if) # exit

Zoom Technologies® 18
1. Configuration of EIGRP

2. Verify Neighbor table

3. Verify topology table (FD/AD)

4. Verify the routing table

es
gi
lo
no
ch
Te
M
O
ZO

Zoom Technologies® 19
Lab 6 - OSPF

s
AREA 0

e
172.16.0.1/16 172.17.0.1/16
S0 S0

gi
HYD S1
CHE BAN
172.16.0.2/16 CHE S1
BAN
E0 172.17.0.2/16 BAN
E0 E0

lo
10.0.0.1/8 BAN
192.168.1.1/24
N
192.168.2.1/24
N

no
ch
LAN - 192.168.1.0/24 LAN – 10.0.0.0/8 LAN - 192.168.2.0/24

ON CHE:

CHE # config terminal


CHE(config) # ip routing
CHE(config) # router ospf 5
CHE(config-router)#network 192.168.1.0 0.0.0.255 area 0
CHE(config-router)#network 172.16.0.0 0.0.255.255 area 0
Te
ON HYD:

HYD # config terminal


HYD(config) # ip routing
HYD(config) # router ospf 3
HYD(config-router)# network 10.0.0.0 0.255.255.255 area 0
HYD(config-router)# network 172.16.0.0 0.0.255.255 area 0
ON BAN:

BAN # config terminal


BAN(config) # ip routing
BAN(config) # router ospf 3
BAN(config-router)#network 192.168.2.0 0.0.0.255 area 0
BAN(config-router)#network 172.17.0.0 0.0.255.255 area 0
M
CHE(config-router) #^z HYD(config-router)# network 172.17.0.0 0.0.255.255 area 0 BAN(config-router)#^z
CHE# HYD(config-router)# ^z BAN#
AREA 0 HYD #
O

Show commands: Debug commands:


ZO

Router # debug ip ospf adj


Router # show ip route Router # debug ip ospf hello
Router # show ip ospf database Router # debug ip ospf packets
Router # show ip ospf neighbors Router # debug ip ospf events

Zoom Technologies® 20
Fill in the Blanks before starting your configuration

e s
gi
lo
Router Name:_________________

no
ROUTER # configure terminal
ROUTER (config) # interface serial 0 ROUTER(config) # router OSPF ____

ch
ROUTER (config-if) # ip address ______________ _________ ROUTER(config-router) # network _________ _______ area _____
ROUTER (config-if) # no shutdown ROUTER(config-router) # network _________ _______ area _____

Te
ROUTER (config-if) # clock rate 64000 ROUTER(config-router) # network _________ _______ area _____
ROUTER (config-if) # encapsulation hdlc ROUTER(config-router) # ^z
ROUTER (config-if) # exit ROUTER#
ROUTER (config) # interface serial 1
M
ROUTER (config-if) # ip address ______________ _________
ROUTER (config-if) # no shutdown
O

ROUTER (config-if) # encapsulation hdlc


ROUTER (config-if) # clock rate 64000
ZO

ROUTER (config-if) # exit


ROUTER(config) #
ROUTER(config) # ip routing
Zoom Technologies® 21
1. Configuration of OSPF

2. Automatic selection process of router-id

3. Debugging and understanding the functioning of hello packet

4. Debugging and understanding the adjacency formation

5. Verification of OSPF database

es
6. Verification of OSPF Neighbor table

7. Election of DR/BDR

gi
lo
no
ch
Te
M
O
ZO

Zoom Technologies® 22
Lab 7 - STANDARD ACCESS-LIST:
172.16.0.1/16 172.17.0.1/16

s
S0 S0

HYD

e
S1
172.16.0.2/16 CHE S1
BAN
E0 172.17.0.2/16
E0 E0
BAN

gi
192.168.1.1/24 10.0.0.1/8
192.168.2.1/24
N

lo
no
LAN - 192.168.1.0/24 LAN – 10.0.0.0/8 LAN - 192.168.2.0/24

ch
SCENARIO 1: SCENARIO 2: SCENARIO 3:

Only 192.168.2.0 should communicate with Configuration of an access-list on HYD that Configuration of an standard access-list on
192.168.1.0 administrative access through Telnet is Bangalore Ethernet 0 in the outbound

ON CHE:

CHE #config terminal


CHE (config) # access-list 1 permit
192.168.2.0 0.0.0.255
CHE (config) # int e0
Te
possible only from 10.0.0.10

ON HYD:

HYD #config terminal


HYD (config) # access-list 1 permit
direction denying 10.0.0.10

ON BAN:

BAN #config terminal


BAN (config) # access-list 1 deny 10.0.0.10
M
10.0.0.10 0.0.0.0 0.0.0.0
CHE (config-if) # ip access-group 1 out
HYD (config) # line vty 0 4 BAN (config)#access-list 1 permit any
CHE (config-if) # exit
HYD (config-line) # ip access-class in BAN (config)#interface Ethernet 0
CHE (config) # exit
HYD (config-line) # exit BAN (config-if) # ip access-group 1 out
O

HYD (config) # exit BAN (config-if) # exit


CHE # show ip access-list
BAN (config) # exit
HYD # show ip access-list
ZO

Note: Use the command prompt of a PC try


to ping the filtered ip address

Zoom Technologies® 23
Lab 8 - EXTENDED ACCESS-LIST:

s
172.16.0.1/16 172.17.0.1/16

e
S0 S0

HYD S1
CHE

gi
S1
172.16.0.2/16
E0 172.17.0.2/16 BAN
E0 E0
10.0.0.1/8 BAN
192.168.1.1/24 192.168.2.1/24
N

lo
no
ch
LAN - 192.168.1.0/24 LAN – 10.0.0.0/8 LAN - 192.168.2.0/24
`
SCENARIO :2 SCENARIO :1 SCENARIO :3
Configuration of an extended access-list Configuration of an extended access-list Configuration of an extended access-list
CHESerial 0 in inbound direction
deny PING (Echo) from Bang LAN to Chen LAN
permit all other services.

On CHE:
Te
HYD Ethernet 0 in outbound direction.
Allow only FTP service to be access from Bang
LAN

On HYD:
BAN serial 1 in inbound direction.
Deny HTTP from Chen LAN to Bang LAN.
Permit all other service from any network.
On BAN:
M
BAN#configure terminal
CHE#configure terminal HYD#configure terminal BAN (config)#access-list 111 deny tcp 192.168.1.0
CHE (config)#access-list 110 deny icmp HYD (config)#access-list 101 permit tcp 192.168.2.0 0.0.0.255 192.168.2.0 0.0.0.255 eq 80
192.168.2.0 0.0.0.255 192.168.1.0 0.0.0.255 0.0.0.255 10.0.0.10 0.0.0.0 eq ftp BAN (config)#access-list 111 permit ip any any
HYD (config)#interface ethernet 0
O

echo BAN (config)#interface serial 1


CHE (config)#access-list 110 permit ip any any HYD (config-if)#ip access-group 101 out BAN (config-if)#ip access-group 111 in
CHE (config)#interface serial 0 HYD (config-if)#exit BAN (config-if)^z
CHE (config-if)#ip access-group 110 in HYD (config)#
ZO

CHE (config-if)^z BAN # sh ip access-list


HYD # sh ip access-list
CHE # sh ip access-list

Zoom Technologies® 24
1. Configure any routing protocol (e.g. RIP) & check the
communication

2. Configure Standard access-list on CHE Ethernet 0 in the out


bound direction, permitting only 192.168.2.0

3. Configure an access-list on HYD that administrative access


through Telnet is possible only from 10.0.0.10

es
4. Configure an access-list on BAN Ethernet 0 in the outbound
direction, denying 10.0.0.10 host only

5. Configuration an access-list on CHE serial 0 in the inbound

gi
direction, deny ping request from 192.168.2.0 to
192.168.1.0 and permitting any other services.

lo
6. Configuration of an extended access-list on HYD Ethernet 0
in the outbound direction permitting only FTP service from
the network 192.168.2.0 to 10.0.0.10
no
7. Configuration of an extended access-list on BAN serial 1 in
inbound direction denying HTTP from 192.168.1.0 to
192.168.2.0 and permitting other traffic from any network
ch
to 192.168.2.0 network.
Te
M
O
ZO

Zoom Technologies® 25
s
LAB 9: FRAME RELAY

e
AREA 0
GOA

gi
S0.1 S0.2
172.17.0.2/16 172.18.0.1/16

DLCI DLCI

lo
400 500

no
172.17.0.1/16 DLCI DLCI 172.18.0.2/16
S1.2 300 600 S1.2

ch
BAN BOM
S1.1 DLCI
<
DLCI S1.1
172.16.0.2/16 100 172.19.0.2/16
800

Te DLCI
200

S0.1
DLCI
700

S0.2
M
172.16.0.1/16 172.19.0.1/16
O

CHE
ZO

Zoom Technologies® 26
CONFIGURATION ON CHE: CONFIGURATION ON BAN: CONFIGURATION ON GOA:

s
CHE# BAN# GOA#
CHE# config terminal BAN # config terminal GOA # config terminal
CHE(config)# interface serial 0 BAN (config)# interface serial 1

e
GOA(config)# interface serial 0
CHE(config-if)# no ip address BAN (config-if)# no ip address GOA(config-if)# no ip address
CHE(config-if)# no shut BAN (config-if)# no shut GOA(config-if)# no shut

gi
CHE(config-if)# encapsulation frame-relay BAN (config-if)# encapsulation frame-relay GOA(config-if)# encapsulation frame-relay
CHE(config-if)#frame-relay lmi-type cisco BAN (config-if)#frame-relay lmi-type cisco GOA(config-if)#frame-relay lmi-type cisco
CHE(config-if)# exit BAN (config-if)# exit GOA(config-if)# exit
CHE(config)# interface serial 0.1 point-to-point BAN (config)# interface serial 1.1 point-to-point GOA(config)# interface serial 0.1 point-to-point

lo
CHE(config-if)#ip address 172.16.0.1 255.255.0.0 BAN (config-if)#ip address 172.16.0.2 255.255.0.0 GOA(config-if)#ip address 172.17.0.2 255.255.0.0
CHE(config-if)#frame-relay interface-dlci 200 BAN (config-if)#frame-relay interface-dlci 100 GOA(config-if)#frame-relay interface-dlci 400
CHE(config-if-dlci)#exit BAN (config-if-dlci)#exit GOA(config-if-dlci)#exit

no
CHE(config-if)#exit BAN (config-if)#exit GOA(config-if)#exit
CHE(config)# interface serial 0.2 point-to-point BAN (config)# interface serial 1.2 point-to-point GOA(config)# interface serial 0.2 point-to-point
CHE(config-if)#ip address 172.19.0.1 255.255.0.0 BAN (config-if)#ip address 172.17.0.1 255.255.0.0 GOA(config-if)#ip address 172.18.0.1 255.255.0.0
CHE(config-if)#frame-relay interface-dlci 700 BAN (config-if)#frame-relay interface-dlci 300 GOA(config-if)#frame-relay interface-dlci 500
CHE(config-if-dlci)#exit BAN (config-if-dlci)#exit GOA(config-if-dlci)#exit
CHE(config-if)#exit BAN (config-if)#exit

ch
GOA(config-if)#exit
CHE(config)#^z BAN (config)#^z GOA(config)#^z
CHE# BAN # GOA#

CONFIGURATION ON BOM: Show commands:

Te
BOM#
BOM # config terminal
BOM(config)# interface serial 1
BOM(config-if)# no ip address
BOM(config-if)# no shut
BOM(config-if)# encapsulation frame-relay
BOM(config-if)#frame-relay lmi-type cisco
ROUTER# show frame-relay pvc
ROUTER# show frame-relay map
ROUTER # show ip route
M
BOM(config-if)# exit
BOM(config)# interface serial 1.1 point-to-point
BOM(config-if)#ip address 172.19.0.2 255.255.0.0
BOM(config-if)#frame-relay interface-dlci 800
O

BOM(config-if-dlci)#exit
BOM(config-if)#exit
BOM(config)# interface serial 1.2 point-to-point
ZO

BOM(config-if)#ip address 172.18.0.2 255.255.0.0


BOM(config-if)#frame-relay interface-dlci 600
BOM(config-if-dlci)#exit
BOM(config-if)#exit
BOM(config)#^z
BOM#
Zoom Technologies® 27
1. Configuration of the frame-relay encapsulations

2. Observation of the status of PVCs

3. Verification of the frame relay map

4. Configure static routing on Frame relay and check communication

5. Verification of the routing tables

es
ROUTER#

gi
ROUTER# config terminal
ROUTER(config)# interface serial ____

lo
ROUTER(config-if)# no ip address
ROUTER(config-if)# no shut
ROUTER(config-if)# encapsulation frame-relay
ROUTER(config-if)#frame-relay lmi-type cisco
no
ROUTER(config-if)# exit
ch
ROUTER(config)# interface serial ____.___ point-to-point
ROUTER(config-if)#ip address ____________ ____________
Te

ROUTER(config-if)#frame-relay interface-dlci _____


ROUTER(config-if-dlci)#exit
ROUTER(config-if)#exit
ROUTER(config)# interface serial ___.____ point-to-point
M

ROUTER(config-if)#ip address ____________ ____________


ROUTER(config-if)#frame-relay interface-dlci _____
O

ROUTER(config-if-dlci)#exit
ROUTER(config-if)#exit
ZO

ROUTER(config)#^z
ROUTER#

Zoom Technologies® 28
Lab 10 - VLAN

es
gi
lo
no
ch

ON 192.168.20.50 ON 192.168.20.51
Te

VLAN CREATION: VLAN CREATION:

2950 # config terminal 2950 # config terminal


2950(config) # vlan 10 2950(config) # vlan 10
2950(config-vlan) # name sales 2950(config-vlan) # name sales
M

2950(config) # vlan 20 2950(config) # vlan 20


2950(config-vlan) # name mkt 2950(config-vlan) # name mkt
O

ASSIGNING MEMBERSHIP TO THE PORTS: ASSIGNING MEMBERSHIP TO THE PORTS:

2950(config) # interface range fa0/1 -2 2950(config) # interface range fa0/13 - 14


ZO

2950(config-if) # switchport mode access 2950(config-if) # switchport mode access


2950(config-if) # switchport access vlan 10 2950(config-if) # switchport access vlan 10
2950(config-if) # exit 2950(config-if) # exit
2950(config)#interface range fa0/4 - 5 2950(config)#interface range fa0/16 - 17
2950(config)# switchport access vlan 20 2950(config)# switchport access vlan 20

TRUNKING: TRUNKING:
2950 # config terminal 2950 # config terminal
2950(config) #interface fa0/24 2950(config) #interface fa0/24
2950(config-if) # switchport mode trunk 2950(config-if) # switchport mode trunk
2950(config-if) # switchport trunk allowed vlan all 2950(config-if) # switchport trunk allowed vlan all
2950(config-if) # exit 2950(config-if) # exit
2950(config) # exit 2950(config) # exit

Zoom Technologies® 29
Lab 11 - Inter-VLAN

es
gi
lo
no
ch
Te

switch# configure terminal router#configure terminal


switch(config)#vlan 10 router(config)# interface ethernet 0
switch(config-vlan)# name Sales router(config-if)# no ip address
switch(config-vlan)# exit router(config-if)# no shutdown
switch(config)# vlan 20 router(config-if)# exit
switch(config-vlan)# name Marketting router(config)# interface ethernet 0.1
switch(config-vlan)# exit router(config-if)# encapsulation dot1q 10
M

switch(config)# interface range fa0/1 - 2 router(config-if)# ip address 192.168.1.1


switch(config-if-range)# switchport mode access 255.255.255.0
switch(config-if-range)# switchport access vlan 10 router(config-if)# exit
O

switch(config-if-range)# exit router(config)# interface ethernet 0.2


switch(config)# interface range fa0/5 - 6 router(config-if)# encapsulation dot1q 20
switch(config-if-range)# switchport mode access router(config-if)# ip address 192.168.2.1
switch(config-if-range)# switchport access vlan 20 255.255.255.0
ZO

switch(config-if-range)# exit router(config-if)# exit


switch(config)# interface fa0/10 router(config)# no ip routing
switch(config-if)# switchport mode trunk router(config)# ip routing
switch(config-if)# switchport trunk allowed vlan all
switch(config-if)# exit

Zoom Technologies® 30
1. Verification of MAC address table

2. Creation of VLAN

3. Assigning the hosts to a VLAN

4. Configure Trunking between switches

es
5. Created Sub-interfaces on Router

6. Changed sub-interface encapsulation to dot1q

gi
7. Configuration of encapsulation for the trunk link

8. Inter-VLAN communication through an external router.

lo
9. Understanding the concepts of VTP modes

Server mode

Client mode
no
ch
Transparent mode
Te
M
O
ZO

Zoom Technologies® 31
Lab 12 - Port Security

es
gi
lo
no
ch
Switch(config-if)#Switchport port-security
Switch(config-if)#Switchport port-security maximum <value>
Switch(config-if)#Switcport port-security mac-address <mac-address>
Te

Switch(config-if)#Switchport port-security violation{protect|restrict|shutdown}


M
O
ZO

Zoom Technologies® 32
Lab 13 – NAT Configuration

es
gi
lo
no
ch
Configuration of PAT Configuration of Static NAT
Te

CHE# configure terminal CHE# configure terminal


CHE(config)# interface s0 CHE(config)# interface s0
CHE(config-if)#ip address 202.1.0.18 CHE(config-if)#ip address 202.1.0.18
255.255.255.248 255.255.255.248
CHE(config-if)#no shutdown CHE(config-if)#no shutdown
CHE(config-if)#encapsulation ppp CHE(config-if)#encapsulation ppp
M

CHE(config-if)#ip nat outside CHE(config-if)#ip nat outside


CHE(config-if)#exit CHE(config-if)#exit
CHE(config)#interface Ethernet 0 CHE(config)#interface Ethernet 0
CHE(config-if)#ip nat inside CHE(config-if)#ip nat inside
O

CHE(config-if)#exit CHE(config-if)#exit
CHE(config)#access-list 10 permit 192.168.1.0 CHE(config)#ip nat inside source static
0.0.0.255 192.168.1.10 202.1.0.19
CHE(config)#ip nat inside source list 10
ZO

interface serial 0 overload


CHE(config)#exit
CHE#

Show Commands
CHE# show ip nat translation

CHE# debug ip nat

Zoom Technologies® 33
Check the following if you have completed the lab

1. Configure and verify Static Nat

2. Configure and verify Port Address Translation

es
3. Check the Nat table

gi
lo
4. Configure and verify PAT

5. Debugging of NAT no
ch
Te
M
O
ZO

Zoom Technologies® 34