Sunteți pe pagina 1din 7

1

Redactarea textelor

Definirea stilului de text

Comanda Format→ Text Style şi apare căsuţa de dialog Style Name

Din această căsuţă de dialog se selectează opţiunile pentru alegerea tipului de fonturi precum şi
datele necesare pentru a defini modul de scriere ( înălţime, unghi, efecte, etc. ).

Scrierea textelor
Textele pot fi scrise:
- într-un singur rând. În acest caz comanda este Draw→ Text→Single Line Text ;
în cazul în care se alege opţiunea aliniere ( justify ) şi se comandă desenarea unui text aliniat
cu o linie desenată prin două puncte, comenzile executabile sunt:

dtext
Current text style: "Standard" Text height: 20.0000
Specify start point of text or [Justify/Style]: j
Enter an option [Align/Fit/Center/Middle/Right/TL/TC/TR/ML/MC/MR/BL/BC/BR]: a
Specify first endpoint of text baseline:
Specify second endpoint of text baseline:
Enter text: dadgad
Enter text:

în cazul în care se alege opţiunea de stil ( style ) se prezinte lista de stiluri de text.
Comenzile executabile sunt:

_dtext
Current text style: "Standard" Text height: 44.4401
Specify start point of text or [Justify/Style]: s
Enter style name or [?] <Standard>: ?
Enter text style(s) to list <*>:
Text styles:
Style name: "Standard" Font files: txt
Height: 0.0000 Width factor: 1.0000 Obliquing angle: 0
Generation: Normal
Current text style: "Standard"

- textele pot cuprinde mai multe rânduri. În acest caz comanda este Draw→ Text→
Multiline Τext ;
Se stabileşte în primul rând zona în care se scrie textul,cu ajutorul deschiderii unei ferestre.
Comenzile executabile sunt:

_mtext Current text style: "Standard" Text height: 2.5


Specify first corner:
Specify opposite corner or [Height/Justify/Line spacing/Rotation/Style/Width]:
În loc de al doilea colţ al ferestrei de scriere se pot preciza o serie de alte opţiuni,
înălţime, aliniere, spaţierea, rotaţia, stilul, lăţimea.
2
După alegerea celui de al doilea colţ al ferestrei de scriere se deschide automat căsuţa de dialog
Multiline Text Editor . În această căsuţă de dialog există următoarele opţiuni:
- caracter, prin care se aleg tipul de font, înălţimea, atribute ale textului, culoarea şi
simboluri dintr-o bibliotecă de simboluri;
- proprietăţile, prin care se aleg stilul, alinierea, lungimea textului, unghiul;
- spaţierea textului;
- operaţii de găsire/căutare;
Căsuţa de dialog Multiline Text Editor se poate utiliza şi la importul unor texte de dimensiuni
relativ mici.

Căsuţa de dialog Multiline Text Editor se poate lansa şi prin comanda Modify→ Text ;

Utilizarea Blocurilor

Block-ul este un obiect de sine stătător, compus la rândul său din mai multe obiecte.
Avantajele utilizării blocurilor:
- posibilitatea de a folosi blocurile în comun, o copie a blocurilor putând fi stocată pe disk
pentru a putea fi utilizată la alte desene. Se pot realiza biblioteci de simboluri
standardizate;
- reducerea dimensiunilor fişierului. Copierea unor obiecte crează noi obiecte care trebuie
memorate în fişier;
- realizarea unui bloc din mai multe obiecte crează un singur obiect. Înserarea acestui nou
obiect nu conduce decât la memorarea punctelor de inserare a acestui bloc şi a numelui
blocului;
- modificare uşoară a blocului. Dacă un block este actualizat şi/sau modificat într-un desen,
programul actualizează toate simbolurile bazate pe acel bloc;
- capacitatea de a ataşa informaţii. Unui bloc creat i se pot ataşa diferite informaţii, care pot
fi extrase şi utilizate în alte programe. Aceste informaţii se numesc atribute.

Crearea unor biblioteci de simboluri

Pentru crearea unei biblioteci de simboluri se foloseşte următoarea procedură:


- se desenează construcţia geometrică necesară utilizând comenzile din AutoCAD;
- se determină poziţia optimă de pe simbol ce urmează a fi folosită ca punct de înserare (atunci
când este înserat în desen, simbolul este plasat cu punctul de înserare deasupra cursorului-
cruce de pe ecran);
- se lansează comanda Block→Make;
- din căsuţa de dialog Block Definition se selectează:
- numele blocului se înscrie în căsuţa cu denumirea Name ;
- în zona Base point a căsuţei de dialog se alege:
- punctul de înserare cu ajutorul cursorului ( pick Point );
- poziţia punctului de înserare cu ajutorul coordonatelor;
- în zona Objects
- se alege Select objects şi se selectează obiectele care formează blocul;
- se selectează opţiunea Convert to block ;
3
Se vor alege unităţile de măsură identice cu cele ale desenului din care este desenat blocul. Se
pot face comentarii, în căsuţa Description care să facă mai uşoară utilizarea blocului din cadrul
bibliotecii.
După parcurgerea întregii proceduri, obiectele iniţiale care definesc blocul sunt eliminate din
desen. Blocul definit este acum parte integrantă din desenul respectiv.

Observaţii privitoare la crearea unui bloc

- Strat, culoare, tip linie: Pentru ca blocul să preia caracteristicile stratului pe care a fost
înserat, toate obiectele acestuia trebuie să se găsească pe stratul 0, iar culoarea şi tipul de
linie trebuie stabilite la valoarea Bylayer ;
- Desenarea blocului la scară: Atunci când se crează un bloc se desenează toate obliectele care
îl compun la dimensiuni unitate;
- Definirea punctului de înserare: Punctul de înserare trebuie să fie ale în mod adecvat, pentru
o înserare corectă.

Înserarea blocurilor deja definite într-un desen

Bilblioteca de blocuri se poate utiliza astfel:

- se lansează comanda Insert→Block ;


- se alege din căsuţa Name numele blocului. Acesta care se caută ( dacă nu este în directorul
implicit ) cu comanda Browse ;
- în zona Insertion point se defineşte punctul de înserare astfel:
- dacă se activează opţiunea Specify On-screen , punctul de inserţie se stabileşte pe desenul
în care vrem să introducem blocul;
- dacă se dezactivează opţiunea Specify On-screen , punctul de inserţie se va defini prin
coordonatele acestuia.
- opţiunea Explode , dacă este setată, ne permite să inserăm obiectele din care a fost format
blocul. În caz contrar blocul este înserat ca un singur obiect.
- în zona Scale se defineşte scala la care se face înserarea blocului astfel:
- dacă se activează opţiunea Specify On-screen , scala de inserţie se stabileşte pe desenul în
care vrem să introducem blocul;
- dacă nu se activează opţiunea Specify On-screen , scala de inserţie se stabileşte prin
valorile introduse , pentru fiecare direcţie în parte;
- dacă este activată opţiunea Uniform Scale , scara este în acest caz uniformă pe cele trei
direcţii şi trebuie specificată numai în zona care defineşte direcţia X ;
- în zona Rotaţion se stabileşte unghiul cu care se roteşte blocul faţă de poziţia în care a fost
definit, astfel:
- dacă se activează opţiunea Specify On-screen , unghiul de inserţie se stabileşte pe
desenul în care vrem să introducem blocul;
- dacă nu se activează opţiunea Specify On-screen , unghiul de inserţie se stabileşte prin
valoarea unghiului înscrisă în căsuţa de dialog;

Actualizarea unui simbol


4
Pentru a modifica un bloc, el trebuie spart cu comanda Explode în obiecte iniţiale. Procedura de
lucru este următoarea:
- se inserează blocul care trebuie modificat/redefinit, oriune în desen;
- se lansează comanda Explode după introducere sau se lansează inserarea blocului cu această
opţiune, din căsuţa de dialog;
- se modifică blocul cu comenzile de editare din AutoCAD;
- se redefineşte blodul utilizând comanda Block→Make ;
- se procedează în continuare ca la definirea unui bloc nou;
- Toate blocurile înserate anterior sunt actualizate atunci când comanda Block este finalizată.

Utilizarea referinţelor externe

Comanda este Insert→External Reference

Dacă este necesar să se utilizeze informaţii existente în alte desene se poate utliliza comanda
Insert→External Reference

Exemple de utilizare a referinţelor externe:

- cartuşul desenului- un desen-referinţă externă poate servi drept cartuş al unui desen. Prin
ataşarea cartuşului ca desen de referinţă externă, acesta va fi afişat împreună cu desenul, fără
a mări dimensiunea acestuia;
- desenul de ansamblu- referinţele externe permit generarea unui desen de ansamblu pe baza
unui set de desene parţiale, care pot face obiectul unor modificări ulterioare. Deoarece
desenele referinţă externe sunt reîncărcate, ele vor reflecta întotdeuna ultima revizie;
- proiecte realizate în echipă- un grup de proiectanţi lucrează la un proiect comun. Deoarece
orice modificare a unui desen poate fi automat actualizată în celelalte desene, dacă intervine
o modificare, prin utilizarea acestei metode, fiecare proiectant va fi pus la curent cu ea.

Procedura de lucru:
- se lansează comanda Insert→External Reference ;
- se alege din căsuţa de dialog Select reference file desenul care îl utilizăm ca referinţă externă;
- se lucrează cu opţiunile ca şi în cazul blocurilor.

Detaşarea unui desen referinţă externă

Comanda Explode nu are efect la desenele referinţă externe inserate.

Pentru a modifica un desen care conţine un desen referinţă externă se lansează comanda Insert→
Xref Manager prin care se pot face următoarele operaţii:
- ataşarea desenului ( Attach );
- detaşarea desenului ( Detach );
- reîncărcarea desenului ( Reload );
- descărcarea desenului ( Unload );
- legarea desenului ( Bind ).
5
Legarea unor simboluri din desenul referinţă externă

Dacă desenul referinţă externă are un bloc, un stil de cotare, strat, tip de linie sau stil-text care se
va utiliza în desenul de ansamblu, trebuie să se lege permanent respectivul simbol în desenul de
ansamblu.

Se lansează comanda Modify → Object→ External Reference → Bind

În căsuţa de dialog există opţiunea de a se lega :


- blocurile ( Block );
- stilul de dimensionare ( Dimstyle );
- straturile ( layer );
- tipul de linie ( Linetype );
- stilul de text ( Textstyle ).

Se selectează din zona Xrefs simbolul care dorim să-l legăm permanent şi prin comanda Add
acesta va fi inserat în Definition to Bind

Atribute ataşate blocurilor

Comanda este :Draw→Block→Define Attributes

Atributele care se ataşează sunt obiecte. Atributele permit să se ataşeze blocurilor informaţii sub
formă de text, informaţii care pot extrase şi analizate în programe de baze de date şi de calcul
numeric.
Atributele sunt de asemenea utile pentru introducerea unui text care se schimbă la fiecare
introducere a unui bloc dat. De exemplu la blocul cartuş putem defini atributele care să ceară
introducerea datelor care se modifică ( nume persoane, nume desen, material,dată, etc. ).

In caseta de dialog Attribute Definition sunt definite două categorii de parametrii:


- parametrii care controlează modul de afişare a atributului;
- punctul de înserare;
- alinierea;
- stilul textului;
- înălţimea;
- unghiului de rotaţie.
Aceste date se înscriu în zonele Insertion Point şi Text Option din partea inferioară a casetei de
dialog.
- parametrii care conţin informaţia utilă a atributului;
Aceşti parametrii se înscriu în zonele Attribute şi Mode .
În zona Attribute se înscriu:
- eticheta ( Tag );eticheta clasifică atributul pe categorii, de exemplu COST, NUME,
PRODUCĂTOR, etc. Practic eticheta reprezintă numele atributului şi este utilizată la
sortarea atributelor atunci când se efectuează o extragere a acestora.
- invitaţia ( Prompt );invitaţia este utilizată de a se introduce valoarea atributului atunci când
este introdus în desen şi este reprezentat de o întrebare.
- valoarea ( Value ). reprezintă valoarea atributului.
6
Parametrii de mod ai atributului

Aceste opţiuni se pot selecta din zona Mode a casetei de dialog Attribute Definition şi se pot
prezenta sub orice combinaţie a modurilor de bază:
- invizibil ( Invisibile ) – atunci când va fi înserat acest atribut este invizibil;
- constant – atributele constante primesc întotdeauna aceeaşi valoare cînd sunt înserate;
- verificare ( Verify ) – atunci când se înserează un atribut cu verificare, programul invită de
două ori să se introducă valoarea, astfel încât să se poată schimba răspunsul înainte ca să se
insereze atributul;
- prestabilit ( Preset ) – ca şi atributele constante atributele prestabilite au aceeaşi valoare la
înserare, însă spre deosebire de atributele constante, valoarea atributelor prestabilite se poate
modifica ulterior.

Procedura de definire şi inserarea unui atribut

- se desenează un bloc;
- se selectează caseta de dialog Attribute Definition ;
- se înscrie în rubrica Tag , de ex. FABRICANT;
- se înscrie în rubrica Promt , Cine a fabricat acest obiect? ;
- se înscrie în rubrica Value , o anumită valoare a atributului, de ex. SC XXX Srl;
- se selectează opţiunile din zona Text Option , şi anume Alinierea ( Justification ), stilul de
text ( Text Style ), înălţimea ( Height ) şi rotaţia ( Rotation ) ;
- Se activează butonul Pick Point şi se alege poziţia de înserare;

Modificarea atributelor se face:

- cu comanda DDEDIT , de la bara de comandă. Se tastează cu mausul pe eticheta ( Tag )


blocului şi apare caseta de dialog Edit Attribute Definition, prin care se pot modifica
atributele blocului;
- prin selectarea blocului şi lansarea comenzii Modify→Properties . Din căsuţa de dialog
pentru modificarea proprietăţilor, la rubrica Text se pot modifica valorile atributelor iar la
rubrica Misc se pot modifica modurile de setare a atributelor.

Tehnici de editare

Ştergerea obiectelor ( Erase )

Comanda de ştergere este Modify→Erase

Această comandă se execută prin selectarea obiectelor ce trebuie şterse din planul de desenare.
Comenzile executabile sunt:
_erase
Select objects: 1 found
Select objects: 1 found, 2 total
Select objects:

Mutarea obiectelor ( Move )


7

Comanda este: Modify→Move

Prin această comandă un obiect este mutat de la o locaţie la alta în planul desenului.

Comenzile executabile sunt:

_move
Select objects: 1 found
Select objects:
Specify base point or displacement: Specify second point of displacement or
<use first point as displacement>:

Mutarea unui obiect sau a mai multor obiecte se face prin selectarea acestor obiecte, specificarea
punctului de bază care indică de unde vor fi mutate obiectele şi ulterior prin selectarea punctului
care indică unde vor fi mutate obiectele. Cele două puncte pot fi indicate prin utilizarea
cursorului sau prin indicarea cotelor ( coordonate absolute sau relative ).

Copierea obiectelor ( Copy )

Comanda este: Modify→Copy

Comanda execută copierea unui obiect sau grup de obiecte. Comanda adaugă la numărul de
obiecte existente un numărul de obiecte care au fost copiate şi deci creşte volumul desenului
foarte mult. Trebuie analizată eficienţa utilizării acestei comenzi în raport cu comenzile de
utilizare a blocurilor sau a desenelor referinţă externă.

Comenzile executabile sunt:

_copy
Select objects: 1 found
Select objects:
Specify base point or displacement, or [Multiple]: Specify second point of
displacement or <use first point as displacement>:

Comanda are acţiune similară cu comanda Move .


Obiectele selectate pot fi copiate de la o locaţia la alta. Prin selectarea opţiunii Multiple se repetă
invitaţia de copiere până când se anulează comanda.