Sunteți pe pagina 1din 8

Pseudocod

Pseudocod. Secvene repetitive


1. Se consider urmtorul algoritm, reprezentat n pseudocod: Citete n c=2 repeta cat timp rest[n/c]=0 executa scrie c n=[n/c] sfarsit cat timp c=c+1 pana cand n=1 stop Precizai ce valori numerice se afieaz dac n=9. S se scrie programul Pascal corespunztor. 2. Se consider urmtorul algoritm, reprezentat n algoritm: Citeste n S=0 Pentru i=1,n executa s=s+i i=i+1 sfarsit pentru scrie s stop Ce rezultat se va afia pentru n=6? S se scrie programul Pascal corespunztor. Rescriei folosind o structura repetitiv cu test final. 3. Se consider urmtoarea secven de instruciuni, reprezentat n pseudocod: a=1 Citeste a p=0 pentru i=1,3 executa p=p+a*i a=a+i sfarsit pentru scrie p stop Precizai care este valoarea lui p dac a=3. S se scrie programul Pascal corespunztor algoritmului dat. Rescrieti folosind o structura repetitiv cu test iniial. 4. Se consider algoritmul urmtor, reprezentat n pseudocod: Citeste n S=0 repeta c=rest[n/10] s=s+c n=[n/10] pana cand n<=99 scrie s stop
Clasa a XII a A. Probleme prof. Florin MOLDOVANU

Pseudocod

Dac n=29157, care este valoarea afiat pentru s ? S se scrie programul Pascal corespunztor algoritmului dat. Rescriei folosind structura repetitiv cu test final. 5. Se consider urmtoarea secven de instruciuni, reprezentat in pseudocod: Cat timp m<>n executa Daca m>n atunci m=m-n altfel n=n-m sfarsit daca sfarsit cat timp scrie m stop Ce valoare se va afia pentru m=60 i n=72? 6. Precizai care sunt valorile afiate, dac se vor citi n ordinea indicat valorile numerice 5 2 3. Program test Var a, b : Integer; Begin Realdn(a,b,a); Write(a, ); Writeln(b); Write(a+b); End. 7. Care sunt valorile tiprite de urmtorul program? Program suma; Var a, b : Integer; Begin A:=5; B:=13; Writeln(a,+,b:2,=,a+b:2); End. 8. Care din urmtoarele secvene sunt corecte? a. for i:=1 to do begin writeln(i); writeln(i+1); end; b. for i:=1 to do begin writeln(i); writeln(i+1); c. for i:=1 to n do begin writeln(i); writeln(i+1); end; 9. Care din urmtoarele secvene repeat until sunt corecte?
Clasa a XII a A. Probleme prof. Florin MOLDOVANU

Pseudocod

a. i:=1; repeat; writeln(i); i:=i+1; until i<10; b. i:=1; repeat writeln(i); i:=i+1; until i<10; c. i:=1; repeat writeln(i); until i<10; i:=i+1; until i<10; 10. Care din urmtoarele secvene sunt corecte? a. a:=b; a:=c; c:=a; b. a:=b; a=c; c:=a; c. a=b; a=c; c=a; 11. Care din urmtoarele secvene bucleaz la infinit? a. a:=5; b:=3; while (true) begin a:=5; b:=3; break; end; b. a:=5; b:=3;
Clasa a XII a A. Probleme prof. Florin MOLDOVANU

Pseudocod

while (a>=b) do begin a:=b; c:=a; b:=c; end; c. a:=5; b:=3; while (a>b) do begin c:=a; a:=b; a:=c; end; 12. Care secven care schimb a,b,c in b,c,a este corect? a. b. a:=b; temp:=a; b:=c; a:=b; c:=a; a:=c; c:=temp; c. temp:=a; a:=b; b:=c; c:=temp;

13. Ce afieaz urmtoarea secven de pseudocod pentru n=5729? Citeste n M=n P=0 Repeta C=rest[m/10] P=p*10+c M=[m/10] Pana cand m=0 Daca p=n atunci scrie n Altfel scrie p Sfarsit daca 14. Ce se afiseaz dup execuia urmtoarei secvente de pseudocod dac se citesc urmatoarele numere: -5 -1,2,0,7,-4 citeste n citeste a max=a;i=2 repeta cat timp i<=n citeste a daca a>max atunci max=a sfarsit daca i=i+1 sfarsit repeta aux=a;a=max;max=aux scrie max Scriei programul Pascal corespunztor.
Clasa a XII a A. Probleme prof. Florin MOLDOVANU

Pseudocod

Rescriei folosind o structura repetitiva cu test final. 15. Determinai valoarea variabilei S dup execuia urmtoarelor secvene: a. S:=0;i:=0; While i<5 do i:=i+1;s:=s+1; b. s:=1;n:=1; for i:=2 to n do s:=s+2; 16. Se consider un program n care exist urmtoarele declaraii de variabile: Var a, b, c: integer; D,e, : real; F,g : char; H,i : boolean; Care din urmtoarele atribuiri sunt corecte? a. f:=g+pred(c); b. e:=a mod ord(g); c. h:=i and odd(d); d. c:=ord(f) or round(d); e. g:=succ(ord(f)); 17. Ce se afieaz dup execuia urmtoarei secvene de pseudocod? Produs=1; contor=2; Repeat Produs=produs*contor Pana cand contor>5 Scrie produs Scrieti un program Pascal echivalent. 18. Ce se afieaz dup execuia urmtoarei secvene de pseudocod dac se citesc urmtoarele numere: 1979, 8 2000, 3 citeste an_n, luna_n citeste an_c, luna_c aux=2 daca luna_c<luna_n atunci varsta_luni=luna_c+12-luna_n aux varsta_ani=an_c-1-an_n altfel varsta_luni=luna_c-luna_n varsta_ani=an_c-an_n sfarsit daca scrie varsta_luni, varsta_ani, aux Scriei programul Pascal corespunztor. 19. Fie urmtorul algoritm: Citete n S=1 Pentru i=0,n-1 executa S=s*i Afiseaza s a. Ce afieaz programul?
Clasa a XII a A. Probleme prof. Florin MOLDOVANU

Pseudocod

b. Rescriei folosind repet pn cnd. 20. Care din urmtoarele noiuni nu fac parte din obiectele cu care lucreaz algoritmii? a. Variabile; b. Operaii; c. Limbaje de programare; d. Expresii. 21. Ce putei spune despre urmtorii algoritmi? sum=0 I=0 Ct timp i<>3 execut sum=sum+i i=i+1 sum=0 i=0 repet sum=sum+i i=i+1 pn cnd i<>3

22. Care din urmtoarele structuri nu sunt caracteristice programrii structurate? a. liniar; b. salt condiionat; c. alterntiv; d. ciclic. 23.Care din urmtoarele cuvinte nu reprezint un identificator? a_x, a1b2c3, 1abc, _ABC., xzy_, _xyz, xzy8, 8xzy 23. Scriei o instruciune care adun dou variabile ntregi digit i value i pstreaz rezultatul n variabila total. 24. Care instruciune citete un caracter i l memoreaz n variabila liter? a. readln(litera); b. readln(litera); c. readln litera; d. readln(litera); 25.. Care din urmtorii operatori este invalid n Pascal? a. == b. <> c. < d. > 26. Care din urmtoarele declaraii definete o constant numit MAXSIYE cu valoarea 80? a. constant MAXSIZE=80; b. const MAXSIZE=80; c. const MAXSIZE 80; d. constant MAXSIZE=80 27. Fie urmtorul program: program test; var i : integer; begin i:=1; for i:=1 to 65535 do begin
Clasa a XII a A. Probleme prof. Florin MOLDOVANU

Pseudocod

end; writeln(i); end. a. Valoarea afiat este 65535; b. Valoarea afiat este 65534; c. Valoarea afiat este 32766; d. Programul nu este corect deoarece se depete domeniul de valori. 28. Teorema Bohm Jacopini afirm c: a. structuri de date + algoritm = program. b. orice problem poate fi descris folosind numai structura liniar, alternativ cu dou ramuri i ciclic cu test anterior. c. orice problem poate fi descris folosind numai structura repetitiv i aceea alternativ. d. orice problem poate fi descris folosind numai structura liniar i aceea repetitiv. 29. Constituie identificator: a. orice ir de caractere; b. orice ir de caractere alfanumerice din care primul este obligatoriu liter sau _ . c. orice ir de maxim 8 caractere, primul fiind obligatoriu liter. d. orice ir de maxim 8 caractere. 30. n limbajul Pascal instruciunile se delimiteaz: a. folosind caracterul . b. folosind caracterul ; c. folosind caracterul , d. prin trecerea la linie noua. 31. Care din urmtoarele variante definete corect o constant: a. const C:=A; b. const C=A; c. #const C:=A; d. C=A; 32. Care afirmaie este corect pentru codul urmtor? Const a=8; Begin A:=9; Writeln(a); End. a. este corect i se va afia 9. b. este greit; c. este corect i se va afia 8. d. este corect i se va afia litera a. 33. Care din urmtoarele cuvinte nu aparine limbajului Pascal? a. else b. break c. goto d. list 34. Care din urmtoarele variante sunt corecte? For i:=1 to n do a. exist erori de sintax;
Clasa a XII a A. Probleme prof. Florin MOLDOVANU

Pseudocod

b. exist erori de semantic; c. este corect; d. nici una din variantele a-c. 35. Precizai care este valoarea lui s dup execuia secvenei de instruciuni: s:=0; for i:=1 to 6 do s:=s+i; a. valoarea calculat pentru s nu poate fi precizat; b. 21; c. exist erori de sintax; d. 7. 36. Fie expresia de mai jos: (x>-1) and not (x>1) or (x>=5) Intervalul selectat este: a. (-1,1] U [5,) b. (-,-1)U[1, ) c. (-,-1)U(1,5) d. [-1,1]U[5, ).

Clasa a XII a A. Probleme

prof. Florin MOLDOVANU

S-ar putea să vă placă și