Sunteți pe pagina 1din 4

BENEMRITA UNIVERSIDAD AUTNOMA DE PUEBLA

PREPARATORIA 2 DE OCTUBRE DE 1968

MATERIA: INFORMTICA III PROFESORA: MINERVA GMEZ MARCOS

-ALGORITMOSALUMNA: LORENA CUAYA CYOTL


GRUPO: 3DM

CICLO ESCOLAR: 2013 - 2014

PROBLEMAS: RESOLUCIN DE ALGORITMOS


Mara trabaja en un caf, le pagan por comisin dependiendo cuntas bebidas sirve en su turno de 8 horas., cada bebida se la pagan a $3.00 y necesita saber cunto le van a pagar si el administrador le dijo que va a recibir un pago extra del 15% sobre el total del pago, el da de la fiesta de disfraces. Elabora un algoritmo que determine cul sera su pago total ese da de fiesta, en base a las bebidas que sirva. Datos de entrada: El nmero de bebidas Constante: Precio: $3.00 Incremento: 15% (pago extra) Datos de Salida: Pagofinal

Proceso Pagofinaldelsueldo Escribir 'Dame el nmero de Bebidas' ; Leer bebidas ; Pagofinal<-[(bebidas*3)+(bebidas*3)*.15]; Escribir 'El pago final de la fiesta de disfraces es: ',Pagofinal FinProceso

En un restaurante se van a cambiar los manteles de las mesas, para ello slo se solicita la medida de los dimetros de los manteles requeridos, los cuales son redondos. Crear un programa que pueda calcular cuntos metros cuadrados se necesitan para un determinado nmero de mesas. Crea un programa que pueda calcular cuntos metros se necesitan para un determinado nmero de mesas. Datos de entrada: Dimetros de los manteles y nmero de mesas. Datos de salida: Total de metros cuadrados.

Proceso Totalmetros Escribir 'Dame el nmero de mesas' Leer mesas Escribir 'Dame el diametro de cada mesa' Leer diametro Totalmetros<-mesas*(3.1416*((diametro/2)^2)) Escribir 'El total de tela en metros cuadrados ser: ',Totalmetros FinProceso

EJERCICIOS ELABORADOS EN CLASE


Elabora los algoritmos para resolver las siguientes situaciones problemticas, determina cules son los datos de entrada, proceso y datos de salida, as como indicarlo en los algoritmos. Escribir un programa que pregunte el ao actual y la edad de una persona y calcule la edad de esa persona en el ao 2015 Datos de entrada: Edad, A_actual Constante: 2015 Datos de saluda: Edadfinal

Proceso EdadNueva Escribir 'Dame tu edad' ; Leer edad ; Escribir 'Dame el ao actual' ; Leer A_actual ; Edadfinal<-(2015-A_actual)+edad ; Escribir 'Tu edad en el 2015 ser: ' ,edadfinal FinProceso

El seor Snchez tiene una tienda de autoservicio y requiere de un programa que tras preguntar el nmero de almacn asociado a un determinado tipo de pieza, la cantidad de esa pieza pedida y el precio por unidad, efecte el clculo total de las piezas pedidas. El programa deber escribir toda la informacin de la pieza en la pantalla, adems del importe total de pedido. Datos de entrada: Clave de amlacn, nombre de la pieza, cantidad de piezas pedidas y precio unitario. Datos de salida: Toda la informacin de la pieza y el precio total.

Proceso sin_titulo Escribir 'Dame la clave de la pieza' ; Leer Clave ; Escribir 'Dame el nombre de la pieza' ; Leer Nombrepieza ; Escribir 'Dame la cantidad de piezas requeridas' ;

Leer Cantidadpiezas ; Escribir 'Dame el precio de la pieza' ; Leer Precio ; Preciototal<-(precio*cantidadpiezas) Escribir 'La clave es: ',clave, ' El nombre de la pieza es: ',nombrepieza, ' La cantidad de piezas es: ',cantidadpiezas, ' El precio unitario es: ',precio, ' El precio total es: ',preciototal FinProceso