Sunteți pe pagina 1din 3

BENEMRITA UNIVERSIDAD AUTNOMA DE PUEBLA

PREPARATORIA 2 DE OCTUBRE DE 1968

INFORMTICA III

-ALGORITMOS: FUNCIONES QUE REALIZA UN CAJERO AUTOMTICO-

ALUMNA: LORENA CUAYA CYOTL

PROFESORA: MINERVA GMEZ MARCOS

GRADO: 3DM SALUD

CICLO ESCOLAR: 2013-2014

Proceso Cajero
Escribir "Muestra las operaciones al realizar" Escribir "Deposito.. (1)" Escribir "Retiro... (2)" Escribir "Saldo... (3)" Escribir "Elegir la operacin a realizar" Leer opcin saldo <- 30000 Si opcin=1 Entonces Escribir "Darla cantidad a depositar" Leer cantidad saldo<- saldo+ cantidad Escribir "Tu saldo ahora es: ", saldo FinSi Si opcin=2 Entonces Escribir "Dar la cantidad que deseas retirar" Leer cantidad Si cantidad > saldo Entonces Escribir "La accin es invlida" Sino saldo <- saldo-cantidad FinSi Escribir "Tu saldo ahora es: ",saldo FinSi Si opcin=3 Entonces

saldo<- saldo Escribir "Tu saldo ahora es: ", saldo FinSi FinProceso

Preguntas
Qu pasa con el saldo cuando primero se elige retirar? El saldo disminuye, pero ya que el algoritmo del libro no trae saldo, entonces el salgo es negativo. Qu pasa cuando la cantidad a retirar es mayor que el saldo? Sale como resultado un saldo negativo y como sabemos eso no sucede en los cajeros, entonces para resolver esto usamos una funcin si que seala que si la cantidad que deseas retirar es mayor a la del saldo, te indique que es una operacin invlida. Cul es el saldo de inicio? En el libro no tiene un saldo al inicio, pero nosotros utilizamos uno de 30000 pesos. Qu propuesta usaras para resolver esta situacin? Plantatela en el algoritmo. Asignar un saldo