Sunteți pe pagina 1din 786

das

PSS/E™ 30.2

USERS MANUAL

November 2005

das PSS/E™ 30.2 U SERS M ANUAL November 2005 Siemens Power Transmission & Distribution, Inc. Power

Siemens Power Transmission & Distribution, Inc. Power Technologies International 1482 Erie Boulevard • P.O. Box 1058 Schenectady, NY 12301-1058 US Phone 518-395-5000 www.pti-us.com

International 1482 Erie Boulevard • P.O. Box 1058 Schenectady, NY 12301-1058 US Phone 518-395-5000 www.pti-us.com

© Copyright 1990-2005 Siemens Power Transmission & Distribution, Inc., Power Technologies International Information in this manual and any software described herein is confidential and subject to change without notice and does not represent a commitment on the part of Siemens Power Transmission & Distribution, Inc., Power Technologies International. The software described in this manual is furnished under a license agreement or non- disclosure agreement and may be used or copied only in accordance with the terms of the agreement. No part of this manual may be reproduced or transmitted in any form or by any means, electronic or mechanical, including photocopying, for any purpose other than the purchaser’s personal use, without the express written permission of Siemens Power Transmission & Distribution, Inc., Power Technologies International.

Microsoft Windows 2000, Windows XP, and Visual C++ are registered trademarks of Microsoft Corporation.

International. Microsoft Windows 2000, Windows XP, and Visual C++ ar e registered trademarks of Microsoft Corporation.

Table of Contents

Chapter 1 - PSS/E Overview

1.1 Introduction to the Users Manual

1.1.1 About the Users Manual and Other Manuals

1.1.2 Other Related Manuals

1.1.3 Obsolete Manuals

1.1.4 Document

1.1.5 Accessing Documentation Help

1.1.6 Contacting Siemens PTI for Support

1.1.7 Submitting Bug Reports and Feature Requests

Conventions

1.2 Overview: PSS/E Functionality

1.3 Overview: The PSS/E User Interface

1.3.1 Spreadsheet View

1.3.2

Tree View

1.3.3 Diagram View

1.3.3.1 Automatically Building a New One-line Diagram

1.3.4 Output Bar

1.3.5 Status Bar

1.4 Using the PSS/E User Interface

1.4.1 Using the Command Line Input Processor

1.4.2 Program Automation

1.5 Overview: Dynamic Simulation User Interface

1.6 Co-existence of Multiple PSS/E Versions

1.7 Starting the PSS/E Application

1.7.1 PSS/E Startup Command Options

1.7.2 Defining the Program Size

1.7.3 Establishing the Working Directory

1.7.4 Setting Program Options

1.8 Overview: Files Used by PSS/E

1.8.1 Input Data Files 1.8.2 Saved Case Files 1.8.3 Output Listing Files Response Files PSEB Command Files IPLAN Program Files

1.8.4

1.8.5

1.8.6

PSEB Command File s IPLAN Program Files 1.8.4 1.8.5 1.8.6 1.8.7 1.8.8 Binary Results Files 1.8.9

1.8.7

1.8.8 Binary Results Files

1.8.9 PSS/E Options File

1.8.10 Working Files

Python Program Files

1.9 Data In Non-PSS/E Formats

1.10 Using PSS/E Files

1-1

1-2

1-2

1-3

1-4

1-4

1-4

1-5

1-5

1-6

1-7

1-7

1-8

1-9

1-9

1-9

1-9

1-10

1-11

1-11

1-11

1-11

1-12

1-13

1-15

1-16

1-19

1-20

1-22

1-22

1-23

1-23

1-23

1-23

1-23

1-23

1-24

1-24

1-25

PSS/E-30.2

Table of Contents

Users Manual

1.11 Deleting PSS/E Files

1-26

1.12 Specifying PSS/E Filenames

1-26

1.13 Summary: PSS/E Files

1-26

1.14 Other Auxiliary Programs

1-28

Chapter 2 - The User Interface

2.1 Components of the User Interface

2-1

2.2 Managing Views

2-4

2.2.1 Views at Program Startup

2-4

2.2.2 Opening and Hiding Views

2-4

2.2.3 Docking and Undocking Views

2-5

2.3 The Tree View

2-6

2.3.1 The Tree View Pop-Up Menus

2-7

2.3.1.1 Right-Click on a Tree View Data Category

2-7

2.3.1.2 Right-Click on an Expanded Data Category Header

2-8

2.3.1.3 Right-Click on a Data Element within an Expanded Data Category

2-9

2.3.2 Double-Clicking

2-10

2.4 The Spreadsheet View

2-11

2.4.1 Zoom Toolbar

2-11

2.4.2 Reducing Data Volume in the Spreadsheet View

2-12

2.4.2.1 Defining a subsystem through the Subsystem Menu

2-12

2.4.2.2 Creating a Bus Subsystem from the Spreadsheet

2-14

2.4.3 The Spreadsheet View Right-click Menus

2-15

2.4.3.1 Right-clicking in a Column

2-15

2.4.3.2 Right-clicking in a Cell

2-17

2.4.3.3 Right-clicking on a Row

2-18

2.4.4 Sorting Columns

2-19

2.4.5 Copying and Pasting between Applications

2-19

2.4.6 Exporting Spreadsheet Data to a Text File

2-19

2.4.7 Editing Data in a Cell

2-19

2.4.8 Freezing and Unfreezing Columns

2-20

2.5 The Diagram View

2-21

2.5.1 Opening a New Diagram

2-22

2.5.2 Opening a Diagram File

2-22

2.5.2.1 Importing a DRAW File

2-23

2.5.2.2 Opening a Slider Diagram File

2-23

2.5.3 Specifying Bus Locations

2-24

2.5.3.1

The Bus Location Data File

2-24

2.5.4 Zooming and Panning

2.5.4 Zooming and Panning 2.5.5 Creating a Diagram for an Existing Po wer Flow Case 2.5.6

2.5.5 Creating a Diagram for an Existing Power Flow Case

2.5.6 Moving Diagram Elements

2-25

2-26

2-28

2.5.7 Copying and Pasting Diagram Elements

2-30

2.5.8 Diagram View Right-click Menus

2-32

2.5.9 Double-Clicking in the Diagram View

2-40

2.5.10 Managing Diagram

Layers

2-40

2.5.11 Viewing Results on the Diagram

2-44

2.5.11.1

Power Flow Results

2-45

PSS/E-30.2

Users Manual

Table of Contents

2.5.11.2 Showing Impedance Data on the Diagram

2-48

2.5.11.3 Displaying Power Flow Solution Differences on the Diagram

2-48

2.5.11.4 Reporting Unbalance Fault Conditions on the Diagram

2-50

2.5.11.5 Additional Diagram Display Capabilities

2-50

2.6 The File Menu

2-52

2.6.1 Creating a New File or Diagram

2-53

2.6.2 Opening

a

File

2-54

2.6.3 Saving or Showing a File (Spreadsheet View Only)

2-54

2.6.4 Closing a Diagram File

2-56

2.6.5 Saving a Diagram File

2-56

2.6.6 Comparing Files

2-57

2.6.6.1 Comparing Case Totals

2-57

2.6.6.2 Comparing Power Flow Cases

2-58

2.6.6.3 Comparing

Tie Lines

2-60

2.6.7 Displaying File Information

2-61

2.6.7.1 Listing System Components

2-62

2.6.7.2 Listing Saved Case and Snapshot Files

2-62

2.6.7.3 Listing Unused Bus Numbers

2-62

2.6.8 Displaying Case Titles, Short and Long

2-63

2.6.9 Importing Files into the Spreadsheet View

2-63

2.6.10 Importing Files into the Diagram View

2-63

2.6.11 Exporting a Diagram Image (Diagram View Only)

2-64

2.6.12 Exporting a Bus Location file (Diagram View Only)

2-64

2.6.13 Exporting a Spreadsheet Tab (Spreadsheet View Only)

2-64

2.6.14 Renumbering Buses in Auxiliary Files

2-65

2.6.15 Renumbering Buses in the Diagram

2-65

2.6.16 Converting Grow Mode

2-65

2.6.17 Setting Up the Spreadsheet Header/Footer

2-66

2.6.18 Setting Up the Spreadsheet Page

2-67

2.6.19 Setting Print Options

2-67

2.6.20 Exiting

PSS/E

2-68

2.7 The Edit Menu

2-69

2.7.1 Undoing an Edit Action

2-69

2.7.2 Copying and Pasting in the Spreadsheet View

2-69

2.7.3 Finding Items in the Spreadsheet

2-70

2.7.4 Replacing Items in the Spreadsheet

2-70

2.7.5 Freezing and Unfreezing Columns

2-70

2.7.6 Setting Program Preferences

2-70

2.8 The View Menu

2-72

2.9 The Diagram Menu

2-73

2.9.1

2.9.2

Configuring Diagram View Properties Annotating the Diagram

Checking the Diagram for Errors/Missing Items 2.9.3.1 Check All Elements
Checking the Diagram for Errors/Missing Items
2.9.3.1 Check
All
Elements

2.9.3

2-73

2-76

2-78

2-78

2.9.3.2 Check

by

Subsystem

2-78

2.9.4 Viewing Results on the Diagram

2-78

2.9.5 Binding Items in the Diagram

2-78

2.9.6 Displaying ISO

Symbols

2-79

2.9.7 Using the Auto Draw Style Option

2-79

2.9.8 Customizing Tooltips

2-79

 

PSS/E-30.2

Table of Contents

Users Manual

2.9.9 Set Active Layer and Manage Layers Diagram Menu Option

2-80

2.9.10 Manage Views Diagram Menu Option

2-80

2.9.11 Viewing the Contents of the Diagram

2-81

2.9.12 Updating Bus Locations

2-81

2.9.13 Select All Items with Property Overrides

2-82

2.9.14 Removing Property Overrides

2-82

2.9.15 Cleaning the Diagram

2-82

2.10 The Power Flow Menu

2-82

2.11 The

Fault Menu

2-83

2.12 The OPF Menu

2-84

2.13 The Transmission Access (Trans Access) Menu

2-84

2.14 The Subsystem Menu

2-85

2.15 The

Miscellaneous (Misc) Menu

2-86

2.15.1 Display and Resetting Timing Statistics

2-86

2.15.2 Inserting Text into the Progress Output

2-86

2.15.3 Selecting Extended Bus Name Input Format

2-87

2.16 The I/O Control Menu

2-87

2.16.1 Selecting Direct Report Output (OPEN)

2-88

2.16.2 Selecting Direct Progress Output (PDEV)

2-89

2.16.3 Selecting Direct Alert and Prompt Output

2-89

2.16.4 Setting the Path for Use with "&" Filenames (PATH)

2-90

2.16.5 Using Command Line and Program Automation Options

2-90

2.17 The Tools Menu

2-91

2.17.1 Customizing Toolbars

2-91

2.17.2 User Definable Buttons

2-92

2.17.3 Creating Custom Toolbars

2-93

2.18 The

Window Menu

2-94

2.19 The

Toolbars

2-94

2.19.1 The File Toolbar

2-94

2.19.2 The Zoom Toolbar

2-95

2.19.3 The Diagram Toolbar

2-95

2.19.4 The General Toolbar

2-95

2.19.5 The Automation Toolbar

2-96

2.19.6 The

Topology Toolbar

2-96

2.19.7 The

Reporting Toolbar

2-96

2.19.8 The

Results Toolbar

2-97

2.19.9 The Diagram Toolbar

2-97

 

2.19.9.1

2.19.9.2

The Diagram Manipulation Toolbar Buttons Diagram Toolbar Buttons for Network Creation

Diagram Toolbar Buttons for Adding Annotation to the Diagram View
Diagram Toolbar Buttons for Adding Annotation
to the Diagram View

2.19.9.3

2-97

2-98

2-99

 

2.19.9.4

Adding a Summation Record to the Diagram View

2-100

 

2.19.9.4.1

The Summation Block Structure

2-100

2.20 The Status Bar

 

2-103

2.21 Program Automation

 

2-103

2.21.1

Running a Program Automation File

2-104

PSS/E-30.2

Users Manual

Table of Contents

2.21.2 Constructing a Response File

2-105

2.21.3 Constructing Python and IPLAN Files

2-106

2.22

Running Command Line Interactive Sessions

2-107

Chapter 3 - Managing Power Flow Data

3.1 Overview: Managing Power Flow Data

3-1

3.2 Power Flow Data Categories

3-1

3.2.1 Case Identification Data

3-3

3.2.2 Bus Data

3-3

3.2.2.1

Extended Bus Names

3-5

3.2.2.2

Using Defaults to Minimize Bus Data

3-5

3.2.3 Load Data

3-6

3.2.3.1

Load Characteristics

3-7

3.2.4 Generator Data

3-8

3.2.4.1

Modeling of Generator Step-Up Transformers (GSU)

3-10

3.2.5 Nontransformer Branch Data

3-12

3.2.5.1

Zero Impedance Lines

3-14

3.2.6 Transformer Data

3-15

3.2.6.1

Example Transformer Data Records

3-24

3.2.7 Areas and Zones

3-25

3.2.8 Area Interchange Data

3-26

3.2.9 Two-terminal dc Line Data

3-27

3.2.10 Voltage Source Converter dc Line Data

3-30

3.2.11 Switched Shunt Data

3-33

3.2.11.1

Example Combination Switched Shunts

3-36

3.2.12 Transformer Impedance Correction Tables

3-36

3.2.13 Multi-Terminal dc Line Data

3-38

3.2.14 Multisection Line Grouping

3-42

3.2.15 Zone Data

3-44

3.2.16 Interarea Transfer Data

3-45

3.2.17 Owner Data

3-45

3.2.18 FACTS Device Data

3-46

3.3 Importing Power Flow Data

3-49

3.3.1 How PSS/E Manages Sequence Numbers

3-51

3.3.2 Adding Data to an Existing Case

3-51

3.3.3 Adding a Subsystem to an Existing Case

3-52

3.3.4 Changing Data in an Existing Case

3-52

3.3.5 Adding Machine Impedance Data

3-53

3.3.6 Importing a Saved Case

3-55

3.3.7 Adding a Long Title to the Existing Case

3-57

3.4 Viewing Power Flow Data

Selecting an Output Device Listing Bus Names
Selecting an Output Device
Listing Bus Names

3.4.1

3.4.2

3.4.3

Listing Power Flow/Sequence Data

3-59

3-60

3-62

3-62

3.4.4

Power Flow Details

3-62

3.4.4.1 Case Summary

3-63

3.4.4.2 Area Interchange Data

3-65

3.4.4.3 Bus Data

3-65

3.4.4.4 Branch Data

3-65

3.4.4.5 Dc Line Data

3-65

PSS/E-30.2

Table of Contents

Users Manual

3.4.4.6 FACTS Device Data

3-66

3.4.4.7 Transformer Impedance Correction Tables

3-66

3.4.4.8 Interarea Transfer Data

3-66

3.4.4.9 Line Connected Shunt Data

3-66

3.4.4.10 Load Data

3-66

3.4.4.11 Generator Unit Data

3-67

3.4.4.12 Multisection Line Groupings

3-67

3.4.4.13 Owner Data

3-67

3.4.4.14 Plant Data

3-67

3.4.4.15 Switched Shunt Data

3-67

3.4.4.16 Two-Winding Transformer Data

3-67

3.4.4.17 Three-Winding Transformer Data

3-68

3.4.4.18 Zone Data

3-68

3.4.5 Outaged Equipment

3-68

3.4.6 Listing Bus Shunts

3-69

3.5 Validating Power Flow Data

3-70

3.5.1 Checking

Branch Parameters

3-70

3.5.2 Checking Controlled Bus Scheduled Voltage Checks

3-72

3.5.3 Checking/Changing Transformer Adjustment Data

3-74

3.5.4 Checking Bus Not in Swing Bus Tree

3-76

3.6 Editing Data

3-77

3.6.1 Moving Data Between the Diagram and Spreadsheet Views

3-77

3.6.2 Copying Data

3-79

3.6.3 Importing Changes Via a File

3-80

3.6.4 Deleting Data

3-80

3.7 Creating a New Power Flow Case

3-81

3.8 Creating a Power Flow Case using the Diagram View

3-82

3.9 Exporting and Merging Power Flow Data

3-85

3.9.1 Exporting Power Flow Data

3-85

3.9.2 Merging Power Flow Data

3-87

Chapter 4 - Power Flow

4.1 Overview: Power Flow

4-1

4.1.1 Importing the Power Flow Case

4-1

4.1.2 Obtaining a Power Flow Solution

4-3

4.1.3 Examining Tabular Power Flow Results

4-5

4.1.4 Examining Power Flow Results Graphically

4-6

4.1.5 Running a Contingency Case

4-7

4.2 About Power Flow Calculations

4-8

4.2.1 About the Power Flow Network Admittance Matrix

4-9

4.2.2 Exporting the Power Flow Network Ad mittance Matrix 4.2.3 About Power Flow Iterative Solution

4.2.2 Exporting the Power Flow Network Admittance Matrix

4.2.3 About Power Flow Iterative Solution Algorithms

4.2.4 About Power Flow Boundary Conditions

4-11

4-12

4-13

4.2.4.1 Boundary Conditions of Constant MVA Loads

4-13

4.2.4.2 Boundary Conditions of Constant Current Loads

4-16

4.2.4.3 Boundary Conditions of Constant Impedance Loads

4-17

4.2.4.4 Boundary Conditions of Composite Loads

4-17

4.2.4.5 Boundary Conditions of the Swing Bus

4-17

PSS/E-30.2

Users Manual

Table of Contents

 

4.2.4.6 Boundary Conditions of Standard Generators

4-19

4.2.4.7 Boundary Conditions of Multiple Identical Generators

4-20

4.2.4.8 Boundary Conditions of Multiple Non-Identical Generators

4-21

4.3

About Power Flow Solution Methods

4-21

4.3.1 Defining Power Flow Solution Interrupt Control Codes

4-26

4.3.2 Power Flow Handling of Generation Equipment

4-27

4.3.3 Power Flow Handling of Switched Shunt Devices

4-27

4.3.4 Power Flow Handling of FACTS Devices

4-28

4.3.4.1 Normal Mode

4-29

4.3.4.2 Bypassed Mode

4-30

4.3.4.3 Constant

Series

Impedance Mode

4-30

4.3.4.4 Constant Series Voltage Mode

4-30

4.3.4.5 IPFC Master and Slave Modes

4-30

4.3.4.6 All Modes

4-31

4.3.5 Power Flow Handling of DC Lines

4-31

4.3.5.1 Capacitor Commutated DC Lines

4-31

4.3.5.2 VSC DC Lines

4-31

4.3.6 AC Voltage Control

4-33

4.3.6.1 Swing Buses

4-33

4.3.6.2 Setpoint Voltage Control

4-33

4.3.6.3 Band Mode Voltage Control

4-34

4.3.7 Gauss-Seidel Power Flow Iteration Methods

4-36

4.3.7.1 Gauss-Seidel

Controls

4-37

4.3.7.2 Gauss-Seidel Rules and Convergence Characteristics

4-39

4.3.8 Modified Gauss-Seidel Power Flow Solution Methods

4-40

4.3.8.1 Modified Gauss-Seidel Solution Controls

4-40

4.3.8.2 Difference Between Gauss-Seidel and Modified Gauss-Seidel

4-40

4.3.8.3 Modified Gauss-Seidel Rules and Convergence Characteristics .4-40

4-41

4-43

4-44

4.3.9 Newton-Raphson Power Flow Solution Methods

4.3.9.1 Imposition of VAR Limits to Newton-Raphson Power Flow

4.3.9.2 Newton-Raphson Solution Controls

4.3.9.3 Fully Coupled Newton Raphson Method Rules and Characteristics

4.3.9.4 Decoupled Newton Raphson Solution Rules and Characteristics

4.3.9.5 Fixed-Slope Decoupled Newton-Raphson Rules and Characteristics

4.3.9.6 Non-Divergent Newton-Raphson Solution Option

4.3.9.7 Monitoring Non-Divergent Newton-Raphson Solution

4-45

4-46

4-47

4-48

4-50

4-51

4-51

4-52

4-53

4-53

4-54

4-56

4-57

4-57

4-57

4-58

4.3.10 Combining Power Flow Solution Methods

4.3.11 Using Acceleration Factors and Solution Tolerances

4.3.11.1

4.3.11.2

Using Acceleration Factors and Tolerances in Gauss-Seidel Using Acceleration Factors and Tolerances in Modified Gauss-Seidel Using Acceleration Factors and Tolerances in Newton Raphson

4.3.11.3
4.3.11.3

4.3.12 Automatic Power Flow Solution Adjustments

Transformer Mvar

4.3.12.1 Adjusting Transformer Off-Nominal Tap Ratio

4.3.12.2 Adjusting Transformer Voltage Control

4.3.12.3 Adjusting

4.3.12.4 Adjusting Transformer Phase Shift Angle

4.3.12.5 Adjusting Transformer Direct Current (DC) Converter Taps

 

PSS/E-30.2

Table of Contents

Users Manual

4.3.12.6 Adjusting

Net Interchange

4-58

4.3.12.7 Adjusting Switched Shunt Admittance

4-58

4.4 Analyzing Power Flow Solution Results

 

4-59

4.4.1 Obtaining Tabular Power Flow Reports

4-60

4.4.1.1 Listing Bus Quantities in Power Flow Reports

4-61

4.4.1.2 Listing Shunt Elements in Power Flow Reports

4-62

4.4.1.3 Listing FACTS Devices in Power Flow Reports

4-62

4.4.1.4 Listing DC Lines in Power Flow Reports

4-63

4.4.1.5 Listing Branch Quantities in Power Flow Reports

4-65

4.4.2 Obtaining Wide Format Power Flow Reports

4-67

4.4.3 Obtaining Graphical Power Flow Reports

4-69

4.4.3.1 Showing Results Information on the Diagram

4-70

4.4.3.2 Color Coding Results on the Diagram

4-72

4.4.3.3 Animating Flows on the Diagram

4-74

4.4.3.4 Viewing Current Loadings on the Diagram

4-75

4.4.3.5 Exporting the Diagram to the Clipboard

4-75

4.4.4 Power Flow System Summary Reports

4-75

4.4.4.1 Reporting Totals by Area/Owner/Zone

4-76

 

4.4.4.1.1 Viewing

Area Totals

4-77

4.4.4.1.2 Viewing

Zone Totals

4-77

4.4.4.1.3 Viewing Owner Totals

4-78

4.4.4.2 Reporting Interchange by Area/Owner/Zone

4-79

 

4.4.4.2.1 Reporting Inter-Area/Inter-Zone Flow

4-80

4.4.4.2.2 Reporting Tie Line Flows

4-80

4.4.5 Viewing Network Limit Violations

 

4-82

4.4.5.1 Viewing Branch Limits

4-83

 

4.4.5.1.1 Branch Overloads

Viewing

4-84

4.4.5.1.2 Transformer Overloads

Viewing

4-85

4.4.5.1.3 Viewing Transmission Line Overloads

4-87

4.4.5.1.4 Viewing All Branch Current Ratings

4-89

4.4.5.2 Viewing Out-of-limit Bus Voltages

4-91

4.4.5.3 Reactive Capability

Viewing

4-93

 

4.4.5.3.1

Machine Capability Curve Data File

4-93

4.4.5.4 Viewing Generator Bus Limits

4-96

4.4.5.5 Viewing Machine Terminal Limits

4-99

 

4.4.5.5.1

Calculating Machine Overloads

4-99

4.4.5.6 Viewing Voltage Controlled Buses

4-103

4.4.5.7 Viewing Adjustable Transformers

4-106

4.5 Modifying Load Characteristics

 

4-109

4.5.1 Basic Load Characteristics

4-109

4.5.2 Converting Load Characteristics

4-110

4.5.3 Reconverting Load Characteristics

4-113

4.5.4 Scaling Loads and Generators

Characteristics 4-113 4.5.4 Scaling Loads and Generators 4-116 4.6 Modifying the Network 4-120 4.6.1 Disconnecting

4-116

4.6 Modifying the Network

4-120

4.6.1 Disconnecting Buses

4-121

4.6.1.1 Using the Filter

4-122

4.6.1.2 Disconnecting a Bus using the Diagram View

4-122

4.6.2 Reconnecting Buses

4-124

4.6.3 Removing Network Elements

4-125

4.6.3.1 Removing

Buses

4-126

4.6.3.2 Removing Outaged Equipment

4-127

PSS/E-30.2

Users Manual

Table of Contents

4.6.4 Joining Buses

 

4-128

4.6.5 Splitting

Buses

4-133

4.6.6 Tapping a Line

 

4-137

4.6.7 Moving Equipment

4-140

 

4.6.7.1 Moving Branches and Transformers

4-141

4.6.7.2 Moving Switched Shunts

4-141

4.6.7.3 Moving Plants and Machines

4-141

4.6.7.4 Moving

Loads

4-142

4.6.7.5 Notes and Example

4-142

4.6.8 Modifying the Network Using the Diagram View

4-145

 

4.6.8.1 Using the Data (GEXM) and Load Flow (GOUT) Views

4-147

4.6.8.2 Disconnecting Buses in the Diagram View

4-148

4.6.8.3 Changing Network Equipment Data Using the Diagram View

4-148

4.6.8.4 Navigating the Network Using the GEXM/GOUT Diagram View

4-149

4.7 Renumbering Buses

 

4-150

4.7.1 Renumbering Buses by Name or Number

4-151

4.7.2 Renumbering Buses by Packing

4-153

4.7.3 Renumbering Buses By Subsystem

4-155

4.7.4 Renumbering Buses in Auxiliary Data Files

4-157

4.7.5 Renumbering Subsystem Groups (Area/Owner/Zone)

4-159

 

4.7.5.1 Renumbering Areas and Zones

4-160

4.7.5.2 Renumbering

Owners

4-162

4.8 Economic Dispatch

 

4-164

4.8.1 Creating the Economic Dispatch Data File

4-164

 

4.8.1.1 Standard Record Format

4-164

4.8.1.2 Supplementary Unit Dispatch Groups

4-165

4.8.2 Application Notes

 

4-166

4.8.3 Performing an Economic Dispatch

4-168

4.8.4 Viewing Economic Dispatch Results

4-172

Chapter 5 - Contingency Analysis

 

5.1 Overview: Contingency Analysis

 

5-1

5.1.1 Reliability Testing Criteria for Contingency Analysis

5-1

5.1.2 Applying Deterministic Criteria

5-3

 

5.1.2.1 Applying Transmission Transfer Limit Analysis

5-3

5.1.2.2 Applying Voltage Stability Analysis

5-3

5.2 Performing AC Contingency Analysis

 

5-4

5.2.1

Setting Up for AC Contingency Analysis

5-4

5.2.1.1 Setting AC contingency analysis options

5-4

5.2.1.2 About Generation Dispatch

5-5

Input Data Files for AC Contingency Analysis 5.2.2.1 About the Distribution Factor File 5.2.2.2 Data
Input Data Files for AC Contingency Analysis
5.2.2.1 About the Distribution Factor File
5.2.2.2 Data File Conventions

5.2.2

5-7

5-7

5-7

 

5.2.2.3 About the Subsystem Description Data file

5-8

5.2.2.4 About the Monitored Element Data File

5-11

5.2.2.5 About the Contingency Description Data File

5-15

5.2.2.6 Building the AC Contingency Analysis Distribution Factor File

5-19

5.2.3

Ranking AC Contingencies by Severity

5-22

5.2.3.1

About the AC Contingency Ranking Process

5-22

PSS/E-30.2

Table of Contents

Users Manual

5.2.3.2 Launching the AC Contingency Ranking Process

5-23

5.2.3.3 Setting AC Contingency Analysis Solution and Control Parameters

5-23

5.2.3.4 Terminating Rules of the AC Ranking Process

5-25

5.2.3.5 Constructing the a AC Contingency List by Subsystem

5-25

5.2.3.6 Analyzing AC Contingency Ranking Results

5-26

5.2.3.7 Application Notes on AC Contingency Ranking Process

5-27

5.2.4 Running AC Contingency Analysis

5-30

5.2.5 Viewing AC Contingency Analysis Reports

5-32

5.2.5.1 Contingency Single Run Report

AC

5-32

5.2.5.2 Contingency Multiple Run Report

AC

5-35

5.2.5.3 Contingency

AC

Post Processor

5-36

5.2.6 Analyzing AC Contingency Analysis Results

5-36

5.2.6.1

AC

Contingency Analysis Report Conventions

5-37

5.2.6.2

Viewing the AC Contingency Analysis Overload Report

5-37

5.2.6.3

Viewing the AC Contingency Analysis Loading Report

5-40

5.2.6.4

Viewing the AC Contingency Analysis Available Capacity Report

5-42

5.2.6.5

Viewing the AC Contingency Analysis Non-Converged

Network Report

5-44

5.2.7 Appending to the AC Contingency Solution Output File

5-44

5.2.8 Application Notes for AC Contingency Analysis

5-45

5.3 Performing Multiple Level AC Contingency Analysis

5-47

5.3.1 Setting-Up for Multiple Level AC Contingency Analysis

5-48

5.3.1.1 Setting AC Power Flow Options

5-48

5.3.1.2 Input Data Files

5-49

5.3.1.3 Setting Multiple Level Contingency Options

5-49

5.3.2 Terms Used in Multiple-Level Contingency Analysis

5-51

5.3.3 Classification of Contingency Analysis Results

5-52

5.3.4 About Contingency List

5-53

5.3.5 Wind Chime Algorithm for Multiple Level Contingency Analysis

5-55

5.3.6 About Tripping Sequence

5-57

5.3.7 Setting-Up for Tripping Simulation

5-58

5.3.7.1 Setting Tripping Simulation Options

5-58

5.3.7.2 About Input Tripping Element Data File

5-60

5.3.7.3 Monitored Equipment

5-60

5.3.7.4 Trip Equipment

5-61

5.3.8 Running Multiple Contingency Analysis

5-63

5.3.9 View the Contingency Analysis Results

5-63

5.3.10 Application Notes on Multiple Contingency Analysis

5-64

5.4 DC Linearized Network Solutions

5-64

5.4.1 Performing a DC Linearized Network Solution

5-65

Application Notes for the DC Linearized Network Solution
Application Notes for the DC Linearized Network Solution

5.4.1.1

5.4.1.2

5.4.1.3

Viewing the DC Linearized Network Solution Report Application Notes on the DC Linearized Network Solution Report

5-67

5-68

5-69

5.4.2 Checking Linear Network DC Contingencies

5-71

5.4.2.1 Setting Initial Condition Mismatch for the Linear Network

DC

Contingency Checking

5-71

5.4.2.2 Setting Solution Options for the Linear Network DC Contingency

Checking

5-72

PSS/E-30.2

Users Manual

Table of Contents

PSS/E-30.2 Users Manual Table of Contents 5.4.2.3 Setting Linear Network DC Che cking Output Options 5.4.2.4
PSS/E-30.2 Users Manual Table of Contents 5.4.2.3 Setting Linear Network DC Che cking Output Options 5.4.2.4

5.4.2.3 Setting Linear Network DC Checking Output Options

5.4.2.4 Using the Distribution Factor Data File in Linear Network

DC

Solutions

5.4.2.5 Estimating DC Linear Network Contingency Checking Case Flows

5.4.2.6 Viewing the Linear Network DC Overload Report

5.4.2.7 Viewing the Linear Network DC Loading Report

5.5 Generator Contingency Analysis

5.5.1 Creating the Generator Inertia and Governor Response Data File

5.5.2 About the Generator Inertial Power Flow

5.5.3 About the Governor Response Solution

5.5.4 Launching the Inertial/Governor Response Solution

5.5.5 Example of a Generator Contingency Analysis Solution

5.5.5.1 Application Notes on Generator Inertial and Governor Redispatch

5.6 Calculating Distribution Factors

5.6.1 Uses of Distribution Factors

5.6.2 Performing the Distribution Factor Calculation

5.6.3 Viewing the Distribution Factor Report

5-72

5-72

5-73

5-74

5-77

5-79

5-79

5-80

5-81

5-82

5-83

5-85

5-86

5-86

5-87

5-88

Chapter 6 - Transmission Transfer Limit Analysis

6.1 Overview: Transmission Transfer Limit Analysis

6.2 Calculating Transmission Transfer Limits

6.2.1 Specifying Transfer Limit Analysis Options

6.2.1.1 Setting the Transfer Limit Initial Condition Mismatch

6.2.1.2 Setting the Transfer Limit Solution Options

6.2.1.3 Setting the Transfer Limit Subsystem Selection

6.2.1.4 Setting the Transfer Limit Summary Table Output Options

6.2.1.5 Setting the Transfer Limit General Output Options

6.2.1.6 Setting Transfer Limit Optional Interface Output

6.2.2 Performing Transfer Limit Analysis

6.2.3 Analyzing Transfer Limit Results

6.2.3.1 Viewing the Transfer Limit Analysis Base Case Conditions Report

6.2.3.2 Viewing Transfer Limit Analysis Flows For Contingency Cases

6.2.3.3 Application Notes for Transfer Limit Analysis

6.3 Factoring Generation Participation in Transfer Limit Analysis

6.3.1 Creating the Subsystem Participation Data File

6.3.2 Calculating Interchange Limits

6.3.2.1 6.3.2.2 6.3.2.3 Setting Interchange Limit Initial Condition Setting Interchange Limit Solution Options
6.3.2.1
6.3.2.2
6.3.2.3
Setting Interchange Limit Initial Condition
Setting Interchange Limit Solution Options
Setting Interchange Limit Subsystem Selection
6.3.2.4
Setting Interchange Limit Summary Table Output Options
6.3.2.5
Setting Interchange Limit General Output Options

6.3.2.6 Setting Interchange Limit Interface Output Option

6.3.3 Running Interchange Limit Analysis

6.3.4 Analyzing Interchange Limit Results

6.3.4.1 Viewing the Interchange Limit Base Case Conditions Report

6.3.4.2 Viewing Interchange Limit Contingency Cases

6-1

6-2

6-3

6-3

6-4

6-4

6-4

6-5

6-5

6-5

6-6

6-7

6-9

6-10

6-12

6-13

6-15

6-15

6-15

6-17

6-17

6-17

6-18

6-18

6-19

6-19

6-21

 

PSS/E-30.2

Table of Contents

Users Manual

 

6.3.4.3

Application Notes for Interchange Limit Analysis

6-22

6.4

Calculating Transfer Limits with Three Participating Areas

6-23

6.4.1 Performing Interchange Limit Analysis (Two Opposing Systems)

6-24

6.4.1.1 Setting the Interchange Limit (Two-Opposing Systems) Initial Condition Mismatch Option

6-25

6.4.1.2 Setting Interchange Limit (Two-Opposing Systems) Solution Options

6-25

6.4.1.3 Setting Interchange Limit (Two-Opposing Systems) Subsystem Selection

6-25

6.4.1.4 Setting Interchange Limit (Two-Opposing Systems) Output Options

6-26

6.4.1.5 Setting Interchange Limit (Two-Opposing Systems) Graphical Output Options

6-26

6.4.2 Calculating the Interchange Limit (Two-Opposing Systems)

6-26

6.4.3 Analyzing Interchange Limit (Two-Opposing Systems) Results

6-27

6.4.3.1 Viewing the Interchange Limit (Two-Opposing Systems) Tabular Report

6-27

6.4.3.2 Viewing the Interchange Limit (Two-Opposing Systems) Graphical Output

6-30

Chapter 7 - Short-Circuit Fault Analysis

7.1 Overview: Short-Circuit Fault Analysis

7-1

7.2 Preparing Short Circuit Sequence Data

7-3

 

7.2.1 Setting the Short Circuit Change Code

7-4

7.2.2 Specifying Positive Sequence Generator Impedance Data

7-4

7.2.3 Specifying Negative Sequence Generator Impedance Data

7-5

7.2.4 Specifying Zero Sequence Generator Impedance Data

7-5

7.2.5 Specifying Negative Sequence Shunt Load Data

7-6

7.2.6 Specifying Zero Sequence Shunt Load Data

7-6

7.2.7 Specifying Zero Sequence Branch Data

7-7

7.2.8 Specifying Zero Sequence Mutual Impedance Data

7-8

7.2.9 Specifying Zero Sequence Transformer Data

7-10

7.2.9.1 Analyzing the Impact of Transformer Phase Shift

7-17

7.2.9.2 Analyzing Sequence Impedance Adjustment as a Function of Tap Position

7-20

7.2.9.3 Analyzing Generators and Step-Up Transformers

7-20

7.2.10 Specifying Zero Sequence Switched Shunt Data

7-22

7.3 Appending Sequence Data to the Power Flow Case

7-23

 

7.3.1

Viewing the Sequence Data in the Power Flow Case

7-25

7.4 Fault Calculation Modeling Assumptions

7-27

 

7.4.1 Using a Detailed Fault Calculation Model

7.4.2 Using a Simplified Fault Calculation Model

Detailed Fault Calculation Models for DC Lines and FACTS Devices
Detailed Fault Calculation Models for DC Lines
and FACTS Devices

7.4.1.1

7-27

7-27

7-28

7.4.3 Using Special Conditions for Fault Calculations

7-28

7.4.3.1 Setting the Special Fault Voltage Option

7-29

7.4.3.2 Setting

Classical Short-Circuit Assumptions

7-29

7.4.3.3 Setting up for IEC909 Fault Calculations

7-30

7.5 About Detailed Unbalanced Fault Types

7-31

PSS/E-30.2

Users Manual

Table of Contents

7.5.1 Bus Faults

7-31

7.5.2 Phase Closed Unbalances

7-32

7.5.3 Line Faults

7-32

7.6 Performing Fault Analysis in PSS/E

7-33

7.6.1 Selecting Faults

7-33

7.6.1.1 Selecting

Bus Faults

7-35

7.6.1.2 Selecting In-Line Slider Faults

7-35

7.6.1.3 Selecting a Branch with One Open End

7-37

7.6.1.4 Selecting One and Two-Phase Closed Unbalance

7-38

7.6.2 Setting Up the Pre-Calc Sequence Network

7-39

7.6.3 Analyzing the Unbalance Fault Calculation Summary

7-41

7.6.3.1 Viewing Detailed Output of Unbalanced Fault Analysis

7-45

7.6.3.2 Viewing Graphical Output of Unbalance Conditions

7-46

7.6.4 Application Notes for Fault Analysis

7-48

7.6.4.1 General Fault Analysis Application Notes

7-48

7.6.4.2 Observation of Transformer Currents

7-50

7.7 Working with a Two-Wire System

7-53

7.7.1 Transmission Lines

7-54

7.7.2 Transformers

7-54

7.7.3 Secondary Circuits

7-56

7.7.4 Faults on a Two-Phase System

7-58

7.7.5 Examples of Two-Wire Systems

7-58

7.8 Performing Automatic Sequencing Fault Analysis

7-68

7.8.1 Setting the Automatic Sequencing Fault Selection Options

7-69

7.8.2 Setting Automatic Sequencing Output Options

7-71

7.8.3 Preparing for the Automatic Sequence Fault Calculation

7-72

7.8.3.1 Creating the Fault Control Input File

7-74

7.8.3.2 Creating the Relay File

7-76

7.8.4 Performing the Automatic Sequence Fault Calculation

7-77

7.8.5 Analyzing Automatic Fault Sequencing Results

7-77

7.8.5.1 Automatic Sequencing Example: 3-Phase Faults

7-79

7.8.5.2 Automatic Sequencing Example: 3-Phase & Single L-G Faults

7-82

7.8.6 Application Notes for Automatic Sequencing Fault Calculations

7-82

7.9 Calculating Circuit Breaker Interrupting Duty

7-84

7.9.1 How PSS/E Calculates Circuit Breaker Duty

7-88

7.9.2 Creating the Breaker Duty Data File

7-90

7.9.3 Creating the Fault Specification Data Input File

7-91

7.9.4 Running the Breaker Duty Calculation

7-91

7.9.4.1 Setting Breaker Duty Calculation Options

7-91

7.9.5 Launching the Breaker Duty Calculation

7-92

7.9.6 Analyzing the Breaker Duty Results

7-94

7.9.6.1 Example of Breaker Duty Results Analysis
7.9.6.1 Example of Breaker Duty Results Analysis

7.10.1

Creating the Fault Specification Data file

7.10 Calculating Fault Currents to ANSI Standards

7-95

7-97

7-97

7.10.2 Setting ANSI Fault Calculation Options

7-97

7.10.3 Performing ANSI Fault Calculations

7-100

7.10.4 Viewing ANSI Fault Calculation Output

7-100

7.11 Calculating PI Equivalent for Unbalanced Switching

7-103

7.11.1 Setting Up for the Calculation of PI Equivalents

7-104

PSS/E-30.2

Table of Contents

Users Manual

7.11.2 Running Calculations Prior to PI Equivalents

7-105

7.11.3 Analyzing PI-Equivalent Results

7-105

Chapter 8 - Balanced Switching

8.1 Overview: Balanced Switching

8-1

8.2 Objectives of a Balanced Switching Study

8-4

8.3 Preparing a Powerflow Case for Balanced Switching

8-4

8.3.1 Establishing the Powerflow Base Case for Balanced Switching

8-4

8.3.2 Converting the Generators for Balanced Switching

8-5

8.3.2.1

Ordering the Network Buses

8-6

8.3.3 Converting Loads for Balanced Switching

8-7

8.3.4 Performing a Balanced Switching Study

8-7

8.3.4.1 Factorizing the Network Admittance Matrix

8-8

8.3.4.2 Executing a Triangulaized Y Matrix Solution

8-9

8.4 Examples of Balanced Switching Studies

8-11

8.4.1 Voltage Rise on Open Line End

8-11

8.4.1.1

Viewing Open End Line Results

8-14

8.4.2 Motor Starting

8-14

8.4.3 Fault Current

8-15

Chapter 9 - Equivalent (Reduced) Networks

9.1 Overview: Equivalent (Reduced) Networks

9-1

9.1.1

Nomenclature of Equivalents

9-1

9.2 Methodology of the Electrical Equivalent

9-2

9.3 Defining Boundaries and Boundary Buses

9-2

9.4 Handling DC Lines

9-4

9.5 Approaching the Network Equivalent Process

9-4

9.5.1 Netting Generation with Load

9-5

9.5.2 Equivalencing Radial and Two-Point Type Buses

9-8

9.6 Creating a Network Equivalent

9-11

9.6.1 Selecting Network Equivalent Options

9-11

9.6.2 Constructing the Network Equivalent

9-13

9.6.3 Equivalencing a Power Flow Case

9-15

9.6.4 Application Notes for Network Equivalents

9-18

9.7 Working with Boundary Bus Mismatches

9-19

9.8 Creating Short Circuit Equivalents

9-20

9.8.1 Preparing for the Short Circuit Equivalent

9-24

9.8.2 Constructing a Short Circuit Equivalent

9.8.2 Constructing a Short Circuit Equivalent 9.9 Analyzing the Results of a Short Circuit Eq uivalent

9.9 Analyzing the Results of a Short Circuit Equivalent

9-25

9-26

9.10 Short Circuit Equivalencing of a Power Flow Case

9-27

Chapter 10 - Open Access and Pricing

10.1 Overview: Open Access and Pricing

10-1

10.2 Managing

Transaction Data

10-2

PSS/E-30.2

Users Manual

Table of Contents

Users Manual Table of Contents 10.3 Overview of Transm ission Allocation Repo rts 10-4 10.4 Available

10.3 Overview of Transmission Allocation Reports

10-4

10.4 Available Calculators

10-5

10.4.1 Transaction Impact Calculator

10-6

10.4.1.1 Selecting the Transaction Impact Calculator

10-6

10.4.1.2 Viewing the Transaction Impact Calculator Results

10-7

10.4.2 Line Loading Relief Calculator

10-8

10.4.2.1 Selecting the Line Loading Relief Calculator

10-9

10.4.2.2 Curtailing and Restoring Transactions

10-9

10.4.2.3 Working with Distribution Factor Matrix

10-11

10.4.2.4 Viewing Line Loading Relief Calculator Results

10-11

10.5 Making Allocations

10-12

10.5.1 Selecting Allocations

10-12

10.5.2 Analyzing Allocation Results

10-13

10.5.3 Viewing Branch Mileage by Owner

10-13

Chapter 11 - Performing PV/QV Analyses

11.1 Overview

11-1

11.2 How to Perform PV and QV Analysis in PSS/E

11-1

11.2.1 Performing

PV Analysis

11-1

11.2.2 Performing QV Analysis

11-8

11.3 Basic Engineering Guide to PV and QV Curves Applications

11-13

11.3.1 Objective

11-13

11.3.2 PV Analysis (PV Curves) Applications

11-13

11.3.3 QV Analysis (QV Curves) Applications

11-18

11.4 How to Implement a Specific PV Transfer

11-24

Chapter 12 - Program Automation

12.1 Overview: Program Automation

12-1

12.2 Controlling PSS/E Execution Using an API

12-1

12.3 Automation Methods in PSS/E

12-1

12.3.1 Python Programs

12-2

12.3.1.1 What is Python?

12-2

12.3.1.2 Using Python in PSS/E

12-3

12.3.1.3 The Embedded Interpreter Environment

12-4

12.3.2 Response Files

12-4

12.3.2.1 Passing Arguments to a Response File

12-5

12.3.2.2 Using "@" Commands

12-5

12.3.3 The Application Program Interface (BAT_) Commands Line Mode Commands (Four Letter Activity Names) PSS/E Macro Languages (PSEB)

12.3.4

12.3.6

IPLAN Programs
IPLAN
Programs

12.3.5

12-5

12-6

12-7

12-8

12.4 Interactively Recording PSS/E APIs

12-8

12.5 Interactively

Using Automation Files

12-10

12.6 Unattended Execution of PSS/E

12-10

12.7 Using the Command Line Interface

12-11

 

PSS/E-30.2

Table of Contents

Users Manual

Appendix A - Activity Map

 

A.1

Load Flow Input

A-1

A.2

Load Flow Data Changes

A-2

A.3

Load Flow Solution Activities

A-3

A.4

Database Interaction

A-3

A.5

Load Flow Case Documentation

A-3

A.6

Matrix Handling Activities

A-4

A.7

Switching Studies

A-5

A.8

Load/Generator Conversion

A-5

A.9

Equivalent Construction and Data Handling

A-5

A.10 Unbalanced Fault Analysis (Short Circuit)

A-5

A.11

External Interfaces

A-6

A.12 Graphical Output Activities

A-6

A.13

Digitizing Activities

A-7

A.14 Linearized Network Analysis Activities

A-7

A.15 Load Flow User-Tailored Execution

A-7

A.16 Transmission Pricing and Open Access Activities

A-7

A.17 Optimal Power Flow Activities

A-8

A.18

I/O Control

A-8

Appendix B - Compatibility Issues

B.1

PSS/E-30.0

B-1

B.1.1

General

B-1

B.1.2

B.1.3

B.1.4

Power Flow Raw Data File and Other Input Files Co-Existance with Previous Versions Simulation Model Library

B-4

B-5

B-5

B.1.4.1

Table Driven Models

B-5

B.1.4.2

B.1.4.3

User-Written Two-Machine Models Optimal Power Flow

B-8

B-8

B.1.5

B.1.6

New Features Program Corrections

B-9

B-11

Appendix C - Start-up Commands

Appendix D - Line Mode Interpreter

Appendix D - Line Mode Interpreter

D.1

Differences in Behavior

D-1

D.1.1

General

D-1

D.1.2

By Activity

D-2

Appendix E - Sample Data Files

E.1

SAVNW Case Data Input Files

E-1

E.2

SAMPLE Case Data Input Files

E-8

Chapter 1

PSS/E Overview

Chapter 1 PSS/E Overview 1.1 Introduction to the Users Manual Welcome to the Power System Simulator
Chapter 1 PSS/E Overview 1.1 Introduction to the Users Manual Welcome to the Power System Simulator

1.1 Introduction to the Users Manual

Welcome to the Power System Simulator for Engineering (PSS/E) Users Manual. The complete PSS/E package is comprised of a comprehensive suite of programs for studies of power system transmission network and generation performance in both steady-state and dynamic conditions. At present two primary simulators, one for steady-state analysis and one for dynamic simulation, facil- itate calculations for a variety of analyses, including:

• Power flow and related network functions

• Optimal power flow

• Balanced and unbalanced faults

• Network equivalent construction

• Dynamic simulation

The steady-state analysis program (traditionally the Load flow Activity Selector) has a completely revamped graphical user interface (GUI), one that’s intuitive and compliant with the many other standard GUI applications. The new interface comprises all the functionality for steady state anal- ysis, including load flow, fault analysis, optimal power flow, equivalencing, switching studies and open access. The time-tested and robust engine of PSS/E hasn’t changed, we’ve just provided a powerful and efficient interface upon which to drive the engine.

The dynamic simulation program includes all the functionality for transient, dynamic and long term stability analysis. It currently has the traditional graphical user interface, but will see a transforma- tion to the new graphical user interface in the near future.

In addition to steady-state and dynamic analysis, the PSS/E package also provides the user with a wide range of auxiliary programs for installation, data input, output, manipulation and preparation.

This manual comprehensively covers the operation and application of only the new PSS/E Inter- face, which currently focuses on power flow analysis. For a comprehensive guide to the dynamic analysis simulator, refer to the PSS/E Program Operation Manual (POM), Volumes I and II.

PSS/E Program Operation Manual (POM) , Volumes I and II . Throughout the rest of this

Throughout the rest of this manual the user will become familiar with following:

• How to use the PSS/E interface

• How to introduce and manage PSS/E model data, and data files.

• How to perform basic power system planning and operating studies.

PSS/E Overview

PSS/E-30.2

Introduction to the Users Manual

Users Manual

Introduction to the Users Manual Users Manual The PSS/E user does not need to be a
Introduction to the Users Manual Users Manual The PSS/E user does not need to be a

The PSS/E user does not need to be a Microsoft ® Windows ® Operating System expert, but a basic understanding of Windows and file management is essential. Knowledge in how to use a standard text editor and familiarity with word processing and spreadsheet type software will also prove ben- eficial, particularly when editing and managing data files and program output.

1.1.1 About the Users Manual and Other Manuals

This manual is structured to provide the user with the capability to:

• Understand and operate the PSS/E user interface (Chapter 2)

• Manage PSS/E model data and prepare data files (Chapter 3)

• Perform load flow studies (Chapter 4)

• Perform contingency analysis (Chapter 5)

• Perform transfer limit analysis (Chapter 6)

• Performing fault analysis (Chapter 7)

• Performing balanced switching studies (Chapter 8)

• Equivalence and reduce networks (Chapter 9)

• Perform open access studies (Chapter 10)

• Perform PV/QV analysis (Chapter 11)

• Use program automation (Chapter 12)

The manual also includes:

• A mapping of activity names to interface functions (Appendix A)

• Release compatibility issues (Appendix B)

• Start-up commands (Appendix C)

• Line mode differences (Appendix D)

• Sample data files (Appendix E)

Other manuals recommended for reading and reference include the PSS/E Program Operation Manual (POM) and PSS/E Program Application Guide (PAG) which discuss operational and engi- neering aspects of formulating problems for PSS/E and interpreting results. These guides are particularly apropos for the PSS/E dynamics program, and the load flow entry point (Activity LOFL) from within dynamics.

To help in the transition from the older user interface to the new one, a map between the activity names and the corresponding menu items is provided in Appendix A, Functional Summaries of PSS/E Activities. Most of the traditional activity names are also included in the menu functions of the new interface.

also included in the menu functions of the new interface. 1.1.2 Other Related Manuals The PSS/E

1.1.2 Other Related Manuals

The PSS/E Program Application Guide, Volume I and II, discusses the engineering aspects of for- mulating problems for PSS/E and interpreting its results. The two part guide can be considered an engineering textbook specifically related to system modelling and techniques within PSS/E for engi- neers responsible for planning and operations studies.

PSS/E-30.2

PSS/E Overview

Users Manual

Introduction to the Users Manual

Users Manual Introduction to the Users Manual The PSS/E OPF Manual comprehensively describes the
Users Manual Introduction to the Users Manual The PSS/E OPF Manual comprehensively describes the

The PSS/E OPF Manual comprehensively describes the operational and engineering aspects of formulating optimal power flow problems, solving them and interpreting the results. It pertains to the optional OPF module made available from a menu within PSS/E.

Computer platform specific user procedures, as well as PSS/E installation instructions and docu- mentation on several PSS/E utility programs, are contained in a set of computer dependent installation manuals (i.e., PSS/E for Windows).

The Guide to Printing and Plotting manual describes the graphics and tabular output devices sup- ported by the traditional PSS/E interface (i.e., PSS/E dynamics, PSSPLT, etc.). It includes both program user information as well as system-related instructions required by those responsible for PSS/E installation.

The PSSPLT Program Manual describes the use of the simulation channel output file processing program used for plotting dynamics study results.

The IPLAN Program Manual describes the Siemens PTI IPLAN programming language and use of the IPLAN compiler.

The PSS/E WECC Data Conversion Manual describes the auxiliary programs WECCLF, WECCDS, and RAWECC. These auxiliary programs convert data between the Western Electricity Coordi- nating Council (WECC) power flow and stability program data formats and PSS/E input data file formats.

The Saved Case Data Extraction Subroutines manual describes the programming interface func- tions whereby users may develop programs that access power flow data directly from PSS/E Saved Case Files.

The PSAS User’s Ready Reference and PSEB User’s Ready Reference describe the Command File structures that allow the PSS/E user to specify many routine power flow and dynamic simulation runs, respectively, in English sentence form. These command files are created by the user with a text editor before starting up PSS/E. The PSAS and PSEB commands are translated into a PSS/E Response File for immediate execution or for subsequent processing as a standard PSS/E Response File.

The PSS/E Application Program Interface (API) manual describes the Psspy Python procedures, PSS/E Batch Commands ("BAT_") used in the PSS/E automation facility.

The Transmission Line Characteristics (TMLC) Program Manual and the PSS/E Line Properties Calculator Manual document the two auxiliary programs available to calculate line impedances from a transmission corridor definition.

1.1.3 Obsolete Manuals

The following manuals are obsolete and no longer available:

are obsolete and no longer available: • • • • The PSS/E Grid Editor Users Guide

The PSS/E Grid Editor Users Guide has been replaced by this PSS/E Users Manual.

The Programming Manual for Device Independent Plotting (INDEPLOT) is obsolete.

The Graphic Report Generator GRPG User’s Ready Reference is obsolete.

The B-Matrix Program Manual is obsolete.

is obsolete. The B-Matrix Program Manual is obsolete. What was titled Guide to PSS/E Batch Commands

What was titled Guide to PSS/E Batch Commands has been renamed the PSS/E Application Program Interface (API) manual.

PSS/E Overview

PSS/E-30.2

Introduction to the Users Manual

Users Manual

Introduction to the Users Manual Users Manual 1.1.4 Document Conventions The following conventions are
Introduction to the Users Manual Users Manual 1.1.4 Document Conventions The following conventions are

1.1.4 Document Conventions

The following conventions are used throughout this manual:

Bold italic text denotes a menu option that the user must select, or a button the user must click. For example:

Choose File>Open from the main menu, or click the Open button on the File toolbar

Italic text is used to emphasize a word or phrase.

Indicates additional information of interest.

"Click" is a user instruction to click the left mouse button.

"Double-click" is a user instruction to click the left mouse button twice.

"Right-click" is a user instruction to click the right mouse button.

<Enter> is a user instruction to press the indicated keyboard key.

Accessing Documentation Help

All PSS/E manuals and reference guides (e.g. POM Vol. I and II, PAG Vol. I and II, etc.) are in PDF format and readily available and viewable with the Adobe Acrobat Reader (freely downloadable from the Adobe web site).

The PSS/E manuals and reference guides are located on the installation CD in the "DOCS" folder. If the option to install documentation with PSS/E is selected during the PSS/E installation, a shortcut to the PSS/E documentation will be placed on the PSS/E Start menu.

Online Help is anticipated to be available in an upcoming release. When functional, pressing the F1 key or selecting the Help button from within the PSS/E interface will take you directly to the corre- sponding section within this manual.

Contacting Siemens PTI for Support

If after consulting the documentation and online help you find that additional assistance with PSS/E is needed, you may contact Siemens PTI via any of the following methods (please send a thorough description of the problem or question, including files):

Send an email to technical support at pti-psse-support.ptd@siemens.com.

Send a fax to (518) 346-2777, attention PSS/E Support.

Call the telephone support number between the hours of 8:00 a.m. and 5:00 p.m. Eastern Time, Monday through Friday. Dial (518) 395-5075 and select option "1" for PSS/E support.

and 5:00 p.m. Eastern Time, Monday through Friday. Dial (518) 395-5075 and select option "1" for

Visit the Siemens PTI Web Site at http://www.pti-us.com and the PSS/E User Support Web Page.

Please note that access to the PSS/E User Support Web Page and to technical PSS/E sup- port is only available to those users whose companies have purchased or renewed their PSS/E maintenance and support agreement for the current calendar year.

PSS/E-30.2

PSS/E Overview

Users Manual

Overview: PSS/E Functionality

Overview Users Manual Overview: PSS/E Functionality 1.1.7 Submitting Bug Reports and Feature Requests Bug
Overview Users Manual Overview: PSS/E Functionality 1.1.7 Submitting Bug Reports and Feature Requests Bug

1.1.7 Submitting Bug Reports and Feature Requests

Bug reports and feature requests should be submitted directly to PSS/E support at pti-psse-sup- port.ptd@siemens.com. Please provide as much detail as possible. If submitting a report for a potential bug please include the steps taken, along with pertinent data files and scripts so that we may accurately reproduce the problem. If an issue does turn out to be a program bug, one of the following priorities will be assigned to it:

• High priority is given to issues that cause the program to crash or produce incorrect results with no published work around.

• Medium priority is given to issues that cause incorrect functionality, however the problem can be remedied by a published work around.

• Low priority is given to those issues that do not fall into the above categories, or are purely cosmetic in nature.

Every effort is made to address high and medium issues in a PSS/E point release. Some low priority items may also be include in a point release although this cannot be guaranteed.

Feature requests are evaluated on the basis of whether it benefits a wide majority of PSS/E users. If it does, it will likely be considered for implementation in a point release or major release of PSS/E. If several users have the same feature request, the feature may sit higher in the queue than others for implementation in PSS/E.

1.2 Overview: PSS/E Functionality

PSS/E is not set up to solve any specific problem, rather, it is set of computational tools that are directed by the user in an interactive manner. By applying these tools in the appropriate sequence, the engineer can handle a wide range of investigations for the planning and operation of electric power systems. This manual is specifically structured to help the user become familiar with the available tools and the manner in which they can be used for such investigations, most specifically steady-state analysis.

Through the PSS/E (Power Flow) interface the following functions and analyses are available:

• Power flow and related network functions

• Optimal power flow

• Open access

• Fault analysis

• Network equivalencing

• One-line diagrams

• Program automation

equivalencing • One-line diagrams • Program automation Additionally, one of the most basic premises of PSS/E

Additionally, one of the most basic premises of PSS/E is that the engineer can derive the greatest benefit from computational tools by retaining intimate control over their application. PSS/E users accustomed to such control by use of the IPLAN program language now have available the addi- tional capability to run Python programs within PSS/E for batch control and automation of the simulation processes.

PSS/E Overview

PSS/E-30.2

Overview: The PSS/E User Interface

Users Manual

Overview: The PSS/E User Interface Users Manual 1.3 Overview: The PSS/E User Interface The PSS/E (Power
Overview: The PSS/E User Interface Users Manual 1.3 Overview: The PSS/E User Interface The PSS/E (Power

1.3 Overview: The PSS/E User Interface

The PSS/E (Power Flow) interface supports a variety of interactive facilities including:

• Introduction, modification and deletion of network data using a spreadsheet.

• Creation of networks and one-line diagrams.

• Steady-state analyses (load flow, fault analysis, optimal power flow, etc.).

• Presentation of steady-state analysis results.

Initiation of the PSS/E (Power Flow) application is covered in Section 1.7. Once opened, the key elements of the user interface are the Tree View, Spreadsheet View, Diagram View and the Output Bar, as pointed out in Figure 1-1.

Tree View Main Menu Toolbars Spreadsheet View Output Bar Diagram View Status Bar Figure 1-1.
Tree View
Main Menu
Toolbars
Spreadsheet View
Output Bar
Diagram View
Status Bar
Figure 1-1. Key Elements of the Interface

PSS/E-30.2

PSS/E Overview

Users Manual

Overview: The PSS/E User Interface

Users Manual Overview: The PSS/E User Interface 1.3.1 Spreadsheet View All network data components (e.g.,
Users Manual Overview: The PSS/E User Interface 1.3.1 Spreadsheet View All network data components (e.g.,

1.3.1 Spreadsheet View

All network data components (e.g., buses, lines, loads) are represented within worksheet style tabs on the spreadsheet. The spreadsheet, or workbook, is synchronized with the bus subsystem selector so that only a subset of the data may be viewed at any time. New network elements may be entered or modified directly in the appropriate worksheet, or existing ones deleted. In the Spreadsheet View, standard Windows commands such as copy and paste actions are supported. Sorting and filtering capabilities are provided to increase usability, especially with large systems.

At program startup the Spreadsheet View is not shown. It will appear when a raw data or saved case file is opened. The Spreadsheet View is the default view for the interface and remains open once it is populated. It can be minimized, but if closed will remove the current network from PSS/E.

In Figure 1-2, the Bus tab has been selected and the spreadsheet reflects the bus data records within the working case. Other data items may be viewed by clicking on the other tabs located at the bottom of the spreadsheet view.

other tabs located at the bottom of the spreadsheet view. Figure 1-2. Overview of the Spreadsheet

Figure 1-2. Overview of the Spreadsheet View

1.3.2 Tree View

The Tree View, as shown in Figure 1-3, provides a hierarchical, expandable and collapsible list view of the network data in the system. It is synchronized with the bus subsystem selector to enable the user to reduce the amount of data presented at any one time. The Tree View is also synchronized with the Spreadsheet and Diagram Views, reflecting their current content.

and Diagram Views, reflecting their current content. Siemens Power Transmission & Distribution, Inc., Power

PSS/E Overview

PSS/E-30.2

Overview: The PSS/E User Interface

Users Manual

Overview: The PSS/E User Interface Users Manual Figure 1-3. Tree View 1.3.3 Diagram View The Diagram
Overview: The PSS/E User Interface Users Manual Figure 1-3. Tree View 1.3.3 Diagram View The Diagram
Overview: The PSS/E User Interface Users Manual Figure 1-3. Tree View 1.3.3 Diagram View The Diagram

Figure 1-3. Tree View

1.3.3 Diagram View

The Diagram View, as shown in Figure 1-4, is used to create, expand and display one-line diagrams of the electrical system. As new elements are added to the diagram, the Spreadsheet and Tree Views are automatically updated to reflect the addition. Additional diagram capabilities include the ability to view power flow and short-circuit analysis results.

The Diagram View is not automatically opened. It is initiated by opening an existing one-line drawing file, or by starting a new diagram window.

The Diagram View can directly import old PSS/E DRAW files, which can then be saved to the new diagram Slider (SLD) format. Note, one-line diagrams from the new interface are not backward compatible with the DRAW/DRED activities of previous versions of PSS/E.

the DRAW/ DRED activities of previous versions of PSS/E. Figure 1-4. Overview of Diagram View 1-8

Figure 1-4. Overview of Diagram View