Sunteți pe pagina 1din 2

Turnurile din Hanoi

-animaie flash-

Pentru crearea animaiei flash am folosit programul Adobe Professional CS6.
Unul din avantajele folosirii flash este Independena de platform care apare
din cauz c acest program a fost construit pentru o gam larg de hardware i
sisteme de operare: Astfel dac vom vizualiza obiectul Flash n Windows se va
folosi automat Playerul de Flash versiunea Windows.
Modul de realizare a animaiei este urmtorul;
1.Deschidem programul Adobe Flash Professional CS6
2. File->New->General Type->Animation->ActionScript 3.0 ->OK
3. Alegem instrumentul de desenat (Tools->Rectangle tool)
4. Desenam turnurile (fundalul) , apoi desenam discurile de mrimi diferite.
Pentru miscarea discurilor vom folosi funcia Motion Tween.
Primul pas in crearea unei animatii cu Motion Tween este convertirea
elementului asupra caruia se face animatia in Symbol.
5. Selectam discul->Click dreapta si selectam Create Motion Tween->Programul
ne va ntreba daca dorim convertirea elementului in Symbol->OK
6. Dupa ce am convertit elementul, programul va crea automat un layer. Flash
va crea in Timeline cadrele de animatie Tween pentru desen .
7.Pozitionam mouseul pe linia de margine a ultimului cadru Tween (cand acesta
capata aspectul unei sageti duble) si tragem linia pana la o celula oarecare.
Astfel se mareste numarul de cadre (si timpul) din animatie.
8. La acest pas va trebui sa adaugam cate un keyframe nainte si dupa miscare.
Prin adaugarea unui Keyframe se creaza in interiorul animatiei un cadru (un
punct de control) de la care obiectul sau traictoria pot fi modificae in Scena.
Se da click pe pozitia acelui Frame in Timeline (dreptunghiul rosu sa apara
deasupra lui) ->Cu obiectul selectat in Scena, se fac modificarile dorite, sau o
mica schimbare a pozitiei lui, dupa care se poate reveni la loc (keyframe-ul fiind
creat).

9.Alegem instrumentul pentru selectare (Selection Tool) si cu acesta mutam/
tragem discul in pozitia dorita.
Observam linia punctata care apare intre pozitia initiala si cea in care se afla
acum discul. Aceasta arata traictoria de miscare.
10.Vom face acelai lucru si cu celelalte discuri (layere) adaugnd keyframe-uri
la fiecare miscare.
11.Pentru publicarea (exportarea) animaiei intrm n File->Publish settings ,
aici selectam formatul fisierului (.swf) si locaia unde se va salva animaia.
12.n final publicm animaia File->Publish.