Sunteți pe pagina 1din 5

HQ# tclsh

foreach address {
192.168.1.1
FEC0::11:1
192.168.110.1
192.168.111.1
192.168.112.1
192.168.113.1
192.168.12.1
192.168.12.2
192.168.120.1
192.168.121.1
192.168.122.1
192.168.123.1
192.168.23.2
192.168.23.3
192.168.3.1
FEC0::31:1
FEC0::13:3
FEC0::13:1
172.16.34.3
172.16.43.3
172.16.34.4
172.16.43.4
198.133.219.1
209.165.200.225
} {
ping $address }
R1(config-rtr)#do show run
Building configuration...
## ipv6 router eigrp 101
## no shut
hostname R1
!
!
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback0
ip address 192.168.1.1 255.255.255.0
!
!
interface Loopback1
no ip address
ipv6 address FEC0::11:1/112
ipv6 eigrp 101
!
!
interface Loopback110
ip address 192.168.110.1 255.255.255.0
!
!

interface Loopback111
ip address 192.168.111.1 255.255.255.0
!
!
interface Loopback112
ip address 192.168.112.1 255.255.255.0
!
!
interface Loopback113
ip address 192.168.113.1 255.255.255.0
!
!
interface Tunnel0
no ip address
ipv6 address FEC0::13:1/112
ipv6 eigrp 101
tunnel source Serial4/0
tunnel mode ipv6ip
tunnel destination 192.168.23.3
!
!
interface Serial4/0
bandwidth 64
ip address 192.168.12.1 255.255.255.252
ip summary-address eigrp 101 192.168.0.0 255.255.128.0
no fair-queue
serial restart-delay 0
clock rate 64000
!
!
!
router eigrp 101
network 192.168.0.0 0.0.127.255
!
ip route 192.168.0.0 255.255.128.0 192.168.12.2
!
####################################
####################################
####################################
!
hostname R2
!
!
!
interface Loopback120
ip address 192.168.120.1 255.255.255.0
!
!
interface Loopback121
ip address 192.168.121.1 255.255.255.0
!
!
interface Loopback122
ip address 192.168.122.1 255.255.255.0
!
!
interface Loopback123

ip address 192.168.123.1 255.255.255.0


!
!
interface Serial4/0
bandwidth 64
ip address 192.168.12.2 255.255.255.252
ip summary-address eigrp 101 192.168.0.0 255.255.128.0
no fair-queue
serial restart-delay 0
!
!
interface Serial4/1
bandwidth 64
ip address 192.168.23.2 255.255.255.248
serial restart-delay 0
clock rate 64000
!
!
router eigrp 101
network 192.168.0.0 0.0.127.255
redistribute ospf 1 metric 10000 100 255 1 1500
!
router ospf 1
log-adjacency-changes
area 1 range 192.168.120.0 255.255.252.0
redistribute eigrp 1 subnets
network 192.168.23.0 0.0.0.7 area 0
network 192.168.120.0 0.0.3.255 area 1
!
ip route 192.168.0.0 255.255.128.0 192.168.12.1 #talvez 0.0.0.0 0.0.0.0 and inte
rf both int in s4/0#
!
#############################################
#############################################
#############################################
## ipv6 router eigrp 101
## no shut
hostname R3
!
ipv6 unicast-routing
ipv6 cef
!
!
!
!
interface Loopback0
ip address 192.168.3.1 255.255.255.0
!
!
interface Loopback3
no ip address
ipv6 address FEC0::31:1/112
ipv6 eigrp 101
!
!
interface Tunnel0
no ip address

ipv6 address FEC0::13:3/112


ipv6 eigrp 101
tunnel source Serial4/1
tunnel mode ipv6ip
tunnel destination 192.168.12.1
!
!
!
interface Serial4/1
bandwidth 64
ip address 192.168.23.3 255.255.255.248
serial restart-delay 0
!
!
interface Serial5/0
bandwidth 64
ip address 172.16.34.3 255.255.255.248
serial restart-delay 0
clock rate 64000
!
!
interface Serial5/1
bandwidth 64
ip address 172.16.43.3 255.255.255.248
serial restart-delay 0
clock rate 64000
!
!
!
router ospf 1
log-adjacency-changes
network 192.168.3.0 0.0.0.255 area 0
network 192.168.23.0 0.0.0.7 area 0
default-information originate #always <-make it type 5 LSA
!
router bgp 65101
no synchronization
bgp log-neighbor-changes
network 192.168.3.0 #maybe erase
network 192.168.23.0 mask 255.255.255.248 #maybe erase
redistribute ospf 1
neighbor 172.16.34.4 remote-as 65401
neighbor 172.16.43.4 remote-as 65401
no auto-summary
!
ip route 0.0.0.0 0.0.0.0 Serial4/1
!
############################################
############################################
hostname R4
!
interface Loopback198
ip address 198.133.219.1 255.255.255.224
!
!
interface Loopback209
ip address 209.165.200.225 255.255.255.224

!
!
!
interface Serial5/0
bandwidth 64
ip address 172.16.34.4 255.255.255.248
serial restart-delay 0
!
!
interface Serial5/1
bandwidth 64
ip address 172.16.43.4 255.255.255.248
serial restart-delay 0
!
!
router bgp 65401
no synchronization
bgp log-neighbor-changes
network 198.133.219.0 mask 255.255.255.224
network 209.165.200.224 mask 255.255.255.224
neighbor 172.16.34.3 remote-as 65101
neighbor 172.16.43.3 remote-as 65101
no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 0.0.0.0 0.0.0.0 Serial5/0
ip route 0.0.0.0 0.0.0.0 Serial5/1
!

S-ar putea să vă placă și