Sunteți pe pagina 1din 3

Probleme info

1. Se citesc 3 numere intregi. Sa se afiseze suma lor.


citeste x,y,z
S <- x+y+z
scrie S
2. Sa se calculeze suma a n numere naturale citite pe rand de la tastatur.
citete n
S<-0
i<-1
cat timp (i>=n) executa
citeste x
S <- S+x
i <- i+1
sfarsit cat timp
scrie S
3. Cititi valoarea lui n de la tastatura. Calculati produsul intr-un ciclu cu test initial, folosind o variabila i, ale carei
valori sunt pe rand termenii sumei 1,3,5...
citeste n
P<-1
i<-1
cat timp (i<=n) executa
P <- P*i
i <- i+2
sfarsit cat timp
scrie P
4. Se citesc de la tastatura n numere naturale. Sa se calculeze cate dintre ele sunt < 0.
citeste n
nr <-0
pentru i <- 1,n executa
citeste a
daca a<0 atunci
nr <- nr+1
sfarsit daca
sfarsit pentru
scrie nr
5. Se citesc de la tastatura n numere intregi. Sa se calculeze media aritmetica a numerelor pare.
citeste n
S <- 0
nr <- 0
pentru i <- 1,n executa
citeste a
daca a mod 2=0 atunci
S <- S+a
nr <- nr+1
sfarsit daca
sfarsit pentru
scrie S/nr

1|3

6. Se citesc mai multe numere intregi pana cand ultimul este 0. Sa se calculeze media aritmetica a numerelor
impare.
citeste n
S <- 0
nr <- 0
cat timp n<>0 executa
daca n mod 2 = 1 atunci
S <- S + n
nr <- nr + 1
sfirsit daca
citeste n
sfarsit cat timp
scrie S/nr
7. Se citeste un sir de numere pana la intalnirea cu 0. Sa se afiseze un mesaj DA sau NU in cazul in
care suma numerelor divizibile la 5 existente in sirul dat este divizibila la 3.
n: 22,105,72,104,57,100,25,13,0;
citeste n;
S<-0;
cat timp n<>0 executa // citeste sirul pana cand intalneste cifra zero
cat timp n<>0 executa //calculeaza suma numerelor divizibile cu 5
daca n mod 10 mod 5 = 0 atunci
S <- S + n mod 10
sfirsit daca.
n <- n div 10
sfirsit cat timp
citeste n
sfarsit cat timp
daca S mod 3 = 0 atunci
scrie DA
altfel
scrie NU
sfarsit daca
8. Se citesc numere de la tastatura pana la intilnirea cu 0. Sa se afle cate dintre ele sunt pozitive si
cate negative.
citeste n
np <- 0
nn <- 0
cat timp n<>0 executa
daca n>0 atunci
np <- np+1
altfel
nn <- nn+1
sfarsit daca
citeste n
sfirsit cat timp
scrie np, nn
9. Se da un sir de numere pe rand de la tastatura, atata timp cat nu s-a introdus valoarea 0( care nu face parte
din sir). Sa se afiseze cate numere pozitive sunt in sir.
citeste x
nr <- 0
2|3

cat timp (x<>0) executa


daca (x>0) atunci
nr <- nr+1
sfarsit daca
citeste x
sfarsit cat timp
scrie nr
10. Se da un sir de numere care se citesc de la tastatura, atata timp cat nu va fi introdus valoarea 0 . Sa se
afiseze maximul dintre elementele sirului.
citeste x
max <- x
cat timp (x<>0) executa
daca (x>max) atunci
max <- x
sfarsit daca
citeste x
scrie max

3|3