Sunteți pe pagina 1din 5

1.

VTP, Trunking si VLAN-uri


a. Configurati toate switchurile Core, Distribution si Access cu VTP.
i. Core Switch este VTP server (Nume de domeniu: CISCO / Parola:
Examen)
vtp domain CISCO
vtp password Examen
ii. Atat switch-urile Distribution, cat si cele Access sunt clienti
VTP din acelasi domeniu.
vtp domain CISCO
vtp password Examen
vtp mode client
b. Configurati interfetele corespunzatoare in mod trunk si asignati VLAN 39
ca VLAN nativ.
i. Folositi 802.1q pentru !!! toate porturile trunk !!!.
Core:
--------------------int range fa0/1-5
sw m tr
sw tr native vlan 39
Distribution:
---------------------int range fa0/1-4, fa0/20-24
sw m tr
sw tr native vlan 39
Access:
--------------------int range fa0/23-24
sw m tr
sw tr native vlan 39
ii. Configurati interfetele VLAN de management si default gateway-ul
pentru fiecare switch.
Core:
---------------------int vlan 39
ip address 192.168.10.162 255.255.255.224
ip default-gateway 192.168.10.161
D1:
----------------------int vlan 39
ip address 192.168.10.163 255.255.255.224
ip default-gateway 192.168.10.161
D2:
int vlan 39
ip address 192.168.10.164 255.255.255.224
ip default-gateway 192.168.10.161
A1:
int vlan 39
ip address 192.168.10.165 255.255.255.224
ip default-gateway 192.168.10.161
A2:
int vlan 39

ip address 192.168.10.166 255.255.255.224


ip default-gateway 192.168.10.161
A3:
int vlan 39
ip address 192.168.10.167 255.255.255.224
ip default-gateway 192.168.10.161
A4:
int vlan 39
ip address 192.168.10.168 255.255.255.224
ip default-gateway 192.168.10.161
c. Creati si denumiti vlan-urile listate in al doilea tabel de mai sus.
i. Creati vlanurile numai pe Core Switch.
Core:
---------------------vlan 10
name ENGINEERING
vlan 20
name MARKETING
vlan 30
name FACTORY
vlan 40
name VOIP
vlan 39
name MANAGEMENT
ii. Asigurati-va ca informatiile despre VLAN-uri se propaga pana la
switch-urile de acces.
do show vlan
2. VLAN-uri de acces si port security
a. Configurati switchurile cu porturi in mod de acces pentru VLAN-urile
indicate in tabel-ul al doilea.
i. Configurati manual interfetele tuturor switchurilor de access
astfel incat sa fie porturi de acces pentru vlan-urile 10, 20, 30.
TOATE ACCESS:
---------------------interface range fa0/1-5
sw m access
sw access vlan 10
interface range fa0/6-10
sw m access
sw access vlan 20
interface range fa0/11-15
sw m access
sw access vlan 30

ii. Configurati manual interfetele tuturor switchurilor de acces


astfel incat sa fie porturi voice pentru vlan-ul 40.
TOATE ACCESS:
----------------------

interface range fa0/16-20


sw m access
sw voice vlan 40
mls qos trust dscp
iii. Asigurati-va ca toate interfetele au vlan asignat.
do show vlan (21,22 ?)
TOATE ACCESS:
---------------------int range fa0/21-22
sw m access
sw access vlan 39
b. Folositi urmatoarele politici pentru port security pe porturile de
acces:
i. Pentru interfetele Fa0/1-5, Fa0/6-10, Fa0/11-15 pentru Access
Switch 1-4:
- permiteti o singura adresa MAC
- configurati salvarea in running-config a primei adrese
MAC invatate pe fiecare port de acces
- setati inchiderea porturilor (shutdown) la violarea
politicii de securitate
TOATE ACCESS:
---------------------int range fa0/1-5, fa0/6-10, fa0/11-15
sw port-security
sw port-security max 1
sw port-security mac-address sticky
sw port-security violation shutdown
3. Inter-VLAN Routing
a. VLAN-ul 39 este vlan-ul nativ si de management.
b. Prima adresa utilizabila din spatiul de adresa (subnet) al
fiecarui vlan este adresa de default gateway pentru subnetul respectiv.
c. Incapsularea este 802.1q.
VBRouter (Voice Building Router):
---------------------interface fa0/1.10
encaps dot1q 10
ip address 192.168.10.33 255.255.255.224
interface fa0/1.20
encaps dot1q 20
ip address 192.168.10.65 255.255.255.224
interface fa0/1.30
encaps dot1q 30
ip address 192.168.10.97 255.255.255.224
interface fa0/1.40
encaps dot1q 40
ip address 192.168.10.129 255.255.255.224
interface fa0/1.39
encaps dot1q 39 native
ip address 192.168.10.161 255.255.255.224
int fa0/1
no shut

4. STP pentru switchurile din Voice Building (Core, Distribution, Access)


Traficul de date si cel de voce vor fi separate si prioritizate
astfel:
a. Distribution Switch 1 trebuie sa fie Root pentru VLAN-urile
10,20,30, 39 prin configurarea unui nivel de prioritate de 4096.
spann vlan 10 priority 4096
spann vlan 20 priority 4096
spann vlan 30 priority 4096
spann vlan 39 priority 4096
b. Distribution Switch 2 va fi Backup Root pentru VLAN-urile 10,
20, 30, 39 prin configurarea unui nivel de prioritate de 8192.
spann vlan 10 priority 8192
spann vlan 20 priority 8192
spann vlan 30 priority 8192
spann vlan 39 priority 8192
c. Distribution Switch 2 va fi Root pentru vlan-ul 40 prin
configurarea prioritatii de 8192.
spann vlan 40 prio 8192
d. Distribution Switch 1 va fi Backup Root pentru vlan-ul 40 prin
configurarea prioritatii de 12288.
spann vlan 40 prio 12288
e. Configurati porturile Fa0/1-20 ale switchurilor de access astfel
incat convergenta STP sa se realizeze fara tranzitia
prin starea de listening.
TOATE ACCESS:
---------------------int range fa0/1-20
spann portfast
5. DHCP

Pe Voice Building Router configurati pooluri DHCP separate pentru


fiecare din cele 4 vlanuri de acces.
a. VLAN 10:
i. pool name ENGINEERING
ii. spatiu de adresa 192.168.10.32/27
iii. adrese excluse: primele 2 adrese utilizabile
iv. DNS Server: adresa serverului DNS
ip dhcp pool ENGINEERING
network 192.168.10.32 255.255.255.224
default 192.168.10.33
dns 192.168.20.101
ip dhcp excluded-address 192.168.10.33 192.168.10.34
b. VLAN 20:
i. pool name MARKETING
ii. spatiu de adresa 192.168.10.64/27
iii. adrese excluse: primele 3 adrese utilizabile
iv. DNS Server: adresa serverului DNS
ip dhcp pool MARKETING
net 192.168.10.64 255.255.255.224
default 192.168.10.65
dns 192.168.20.101
ip dhcp excluded-address 192.168.10.65 192.168.10.67

c. VLAN 30:
i. pool name FACTORY
ii. spatiu de adresa 192.168.10.96/27
iii. adrese excluse: primele 4 adrese utilizabile
iv. DNS Server: adresa serverului DNS
ip dhcp pool FACTORY
net 192.168.10.96 255.255.255.224
default 192.168.10.97
dns 192.168.20.101
ip dhcp excluded-address 192.168.10.97
192.168.10.100
d. VLAN 40:
i. pool name VOIP
ii. spatiu de adresa 192.168.10.128/27
iii. adrese excluse: primele 5 adrese utilizabile
iv. DNS Server: adresa serverului DNS

192.168.10.133
6. PC si IP-Phone-uri

ip dhcp pool VOIP


net 192.168.10.128 255.255.255.224
default 192.168.10.129
dns 192.168.20.101
ip dhcp excluded-address 192.168.10.129

DHCP
POWER

7. Server SSH
Configurati Voice Building Router ca server ssh cu username-ul:
cisco si parola cisco.
Testati de pe fiecare PC conexiunea prin SSH.
ip domain-name ccna.ro
crypto key generate rsa
key zeroize rsa

--pentru a elimina crypto

1024
ip ssh version 2
line vty 0 4
transport input ssh
username cisco secret 0 cisco
line vty 0 4
login local

8. Conectivitate Wireless
interfata grafica
9. Descoperiti adresa MAC a dispozitivului la care este conectat Voice
Building Router in 2 moduri.
show mac-address-table
show cdp neighbors
show cdp neighbors detail