Sunteți pe pagina 1din 4

C++

Lectia 2-Descrierea algoritmilor,limbaj algoritmic

Pseudocod=limbaj de baza ce permite utilizarea unor


instructiuni care contin structurile de baza
Program in limbaj algoritmic=succesiune de instructiuni
Instructiunile efective:
1.

Instructiuni de citire/scriere:
citeste v1,v2,...,vn

---------- cin>>v1>>v2>>...>>vn;

scrie v1,v2,...,vn

---------- cout<<v1<<v2<<...<<vn;

2.Instructiunea

STOP ---------- break;

3.Instructiunea

de atribuire

variabila <- expresie --------- variabila=expresie;


4.Instructiunea

de ramificare (structura alternativa)

daca E atunci S1
altfel S2
sf daca

---------- if (E) S1;


else S2;

5.

Instructiunea repetitiva cat timp (structura repetitiva cu test initial)


cat timp E executa

--------

while (E)

{S;}

sf cat timp
6.

Instructiunea de selectie multipla


alege E dintre

......... switch (E)

C1:S1

{case1:S1;break;

C2:S2

case2:S2;break;

.......

...................

Cn:Sn

case n:Sn;break;

rest:Sn+1

default:Sn+1;break;}

7.

Instructiune repetitiva repeta-pana cand (structura repetitiva cu test final)


repeta

-----------

{ S;}

pana cand E
8.

do
while (E);

Instructiunea repetitiva pentru (structura repetitiva cu un numar cunoscut de


pasi)
pentru contor <- val.initiala,val.finala,executa
S
sf pentru
------------------------------------------for(contor=val.initiala;contor=val.finala;pas)
S;