Sunteți pe pagina 1din 6

MICROSOFT ACCESS

O baza de date reprezinta un ansamblu de fisiere de date organizate in principal ca tabele, formulare, rapoarte, interogari etc. O tabela este denumita si entitate si este formata din atribute(campuri) care reprezinta de fapt coloanele tabelei si din instante(inregistrari) care reprezinta de fapt liniile tabelei. Orice tabela trebuie sa aiba un atribut denumit cheie primara care va identifica in mod unic fiecare instanta a unui entitati. De exemplu fie entitate(tabela) ELEV cu atributele Nr. matricol, Nume, Clasa, Data nasterii, instantele acestei tabele sunt elevii introdusi in tabela iar atributul Nr. matricol este cheie primara pentru aceasta tabela deoarece identifica in mod unic fiecare instanta(elev) a entitatii (nu pot exista 2 elevi cu aceasi numar matricol). Atribute Nr. matricol 123 344 4332 Nume Popescu Ion Ionescu Maria Popa Calin Clasa a XI-a F a X-a MI a IX-a S Data nasterii 12.03.1993 21.11.1995 04.06.1996

instante

1. 2.

Deschiderea aplicaiei ACCESS: Start->All Programs->Microsoft Office-> Microsoft Office Access 2003 Deschiderea, modificarea, salvarea i nchiderea unei baze de date existente: Meniul File->Open->Se selecteaz baza de date care se

dorete a fi deschis ->Open, File-Save, clic pe butonul , sau File-Exit. 3. Folosirea funciei ajutor: Meniul Help->Microsoft Office Access Help F1.

4. Moduri de vizualizare: din meniul View putem selecta preferinta pentru modul de vizualizare si anume: Database Objects- Afisarea in fereastra bazei de date a obiectelor de un anumit tip, pe care l-am selectat Large icons- Afisarea obiectelor sub forma unor pictograme marite. Small icons- Afisarea obiectelor sub forma unor pictograme micsorate. List - Afisarea obiectelor sub forma unei liste. Details- Afisarea obiectelor sub forma detaliata (descriere, data modificarii, data crearii, tipul). 5. Proiectarea unei baze de date: Baza de date pe care o realizm cu Microsoft Access este un fiier ce are extensia .mdb i conine urmtoarele obiecte: tabele (Tables), interogri (Query), formulare (Forms), rapoarte (Reports) i macroinstruciuni (Macros). Pentru a creea o baz de date cu Microsoft Access: File->New->se alege din caseta din dreapta ecranului opiunea Blank database -> se alege locaia unde se va memora baza de date (n seciunea Save in)->se tasteaz numele bazei de date n seciunea File name a casetei care se deschide->clic pe butonul Create (sau se apas tasta Enter).

6.

7.

8.

9. 10. Crearea unui formular simplu:Forms-Create form in design view-clic dreapta pe formular-Properties-eticheta Data-Alegem

Crearea unei tabele: crearea unei tabele nseamna doua operatii: definirea structurii si introducerea nregistrarilor. Definirea structurii presupune stabilirea cmpurilor tabelei: denumirea, tipul si proprietatile acestuia. Pentru aceasta procedam astfel: din fereastra atasata bazei de date alegem optiunea Tables-Create table in design view, in fereastra aparuta vom trece campurile tabelei, tipul acestora(text, number, date etc) si alegem atributul ce va deveni cheie primara facand clic dreapta pe acesta si alegand optiunea Primary Key. Dupa ce au fost introduse toate campurile tabelei si s-a stabilit cheia primara tabela se salveaza (File-Save). Odata salvata aceasta va aparea alaturi de celelalte obiecte in fereastra bazei de date. Pentru a adauga date in tabela creata, a vizualiza sau modifica datele introduse se apasa dublu clic pe aceasta, iar pentru a modifica structura tabelei se apasa clic dreapta pe numele acesteia si se alege optiunea Design View. Stabilirea unui index: Indexarea unei tabele reprezinta operatia prin care se ordoneaza logic nregistrarile acesteia, dupa un anumit atribut (sau ale unui grup de atribute), numit index, n scopul optimizarii cautarii si localizarii ulterioare a anumitor date. Indexul se defineste la definirea structurii tabelei. Cheia primara este considerata automat index. Pentru stabili un index pentru un cmp, setam proprietatea Indexed acelui cmp (din Field Properties) pe valoarea Yes(No Duplicates). Adugarea de nregistrri ntr-o baz de date: se realizeaza adaugand noi instante la sfarsitul tabelei in campurile goale sau se apasa clic dreapta pe marginea uneia dintre linii si se alege optiunea New Record tergerea de nregistrri ntr-o baz de date: clic dreapta pe marginea instantei respective-Delete record optiunea Form-adaugam campurile dorite in formular prin drag&drop(tragerea cu mouse-ul pe suprafata formularului)-se realizeaza alte formatari optionale asupra formularului -salvare

11. Introducerea datelor n baza de date folosind formulare simple:se deschide formularul prin dublu clic pe acesta-se execut clic pe 12.
butonul , care are ca efect saltul la sfritul bazei de date i creearea unei nregistrri vide care urmeaz a fi completat. Operaia se repet de cte ori este necesar. Formatarea textului:se deschide formularul in Design view(Clic dreapta pe numele formularului-Design view)-se selecteaza eticheta ce trebuie formatata-se formateaza la fel ca si in celelalte programe din pachetul Office folosind bara de formatare Formatting(Form/Report) (aceasta se activeaza din meniul View-Toolbars- Formatting(Form/Report))

13. Schimbarea culorii fondului ntr-un formular: se deschide formularul in Design view(Clic dreapta pe numele formularului-Design 14.
view)-clic dreapta pe eticheta sau pe fundalul formularului-Fill/Back color Importul unei imagini sau fiier text ntr-un formular: Se selecteaz pictograma Image de pe caseta cu instrumente, se traseaz o zon dreptunghiulara cu mouse-ul (drag&drop). La eliberarea butonului se deschide o fereastr care permite cutarea i selectarea imaginii dorite. Se poate redimensiona cu mouse-ul.

15. Modificarea modului de aranjare a obiectelor n formular: se deschide formularul n modul Design View. Se selecteaz obiectul cu
mouse-ul (executm clic pe obiect) i folosind tehnica drag&drop l plasm n locul dorit pe formular. 16. Conectarea la o baz de date existent: Conectarea formularului se va face la o tabel sau la o interogare (query) a bazei de date n care se lucreaz, n scopul prelurii anumitor cmpuri ale acesteia, aa cum a fost precizat la capitolul Crearea formularelor n Design View:

Se deschide formularul n modul Design View; Se execut clic pe pictograma Properties de pe bara de pictograme (sau clic dreapta ntr-o zon liber din seciunea Detail si alegem din meniul local Properties); n fereastra care se deschide selectm Form n loc de Detail din lista ascuns; De la proprietatea Record Source vom selecta tabela/interogarea pentru care crem formularul(clic pe sageata de la lista ascunsa). In momentul selectrii tabelei/interogrii, se va deschide o caset ce conine toate cmpurile acesteia.

Caseta ce conine cmpurile tabelei/interogrii se poate deschide i din meniul View->Field list (avnd formularul deschis tot n modul Design View).

17. Cutarea unei nregistrri:deschidem tabelul sau formularul in care dorim sa cautam o inregistrare facand dublu clic pe acestameniul Edit-Find

18. Crearea unor interogri: Interogrile reprezint modaliti de selecie i afiare a informaie din unul sau mai multe surse
(tabele sau alte interogri), formulate cu ajutorul unor condiii logice. Exista urmatoarele tipuri de interogari: interogri simple sau de selecie (folosind condiii logice), interogri pentru actualizare - delete query, update query i append query,interogri ncruciate sau bidimensionale. I. Interogari simple sau de selectie Pentru a defini o interogare de selecie selectm opiunea Queries din fereastra Database, apoi butonul Create query in design view. Ca efect, va aprea o fereastra, din care selectm consecutiv (n orice ordine) tabelele necesare i pentru fiecare acionm butonul Add. Dup selectarea tabelelor / interogrilor acionm butonul Close. Odata adaugat un table in fereastra interogarii se vor alege campurile care se doresc a fi afisate si se stabilesc criteriile pe care trebuie sa le stabileasca datele(conditiile de selectie). Condiiile de selecie sunt expresii logice care vor fi verificate pentru ca articolele fiierelor surs s fie trecute n fiierul virtual rezultat al interogrii. Operatorii folosii sunt cei de comparare: < (mai mic),<= (mai mic sau egal),> (mai mare), >= (mai mare sau egal),<> (diferit), = (egal) i / sau cei logici: And (i logic) i Or (sau logic). Exemple: Considerm tabela surs de mai jos:

1. Dorim s afim toate persoanele care au vrsta cuprins ntre 30 i 40 de ani i care au studii universitare:

Operatorul And este aplicat la nivel de cmp (>=30 And <=40) i ntre cmpuri (condiiile puse asupra cmpurilor Vrsta i Nivel studii sunt pe aceeai linie). 2. Dorim s afim toate persoanele care nu au vrsta cuprins ntre 40 i 50 de ani sau care au studii Liceale:

Operatorul Or este aplicat la nivel de cmp (<=40 Or >=50) i ntre cmpuri (condiiile puse asupra cmpurilor Vrsta i Nivel studii sunt pe linii diferite). 3. Pentru selectarea unor submulimi de valori se pot utiliza caracterele de nlocuire: "*" - nlocuiete un grup de caractere i "?" - nlocuiete un caracter. Dorim s afim persoanele care au telefon fix n reeaua RDS:

Cuvntul Like este asociat automat de sistem la folosirea acestor caractere de nlocuire. De asemenea, ntr-o interogare putem utiliza condiiile IS NULL i IS NOT NULL cu semnificaia de valori vide, respectiv nevide ntr-o coloan. Dac dorim afiarea persoanelor care nu au adres de e-mail:

Interogri de sortare a nregistrrilor Dup ce am definit condiiile de selecie, putem stabili condiii de sortare pentru unul sau mai multe cmpuri. De exemplu, pentru afiarea persoanelor n ordine alfabetic executm clic n rndul Sort al casetei, n dreptul cmpului Nume i din lista derulant alegem opiunea Ascending.

II. Interogari pentru actualizare - delete query, update query i append query Interogari de excludere (tergere) a unor nregistrri (Delete Query) 1. Crem interogarea n modul Design View: selectm Query din fereastra Database i alegem modul de proiectare Design View. 2. Includem tabela pentru care se execut interogarea. 3. Selectm Delete Query din meniul Query. Ca rezultat, titlul ferestrei se schimb n Delete Query, iar n partea de jos a ferestrei apare rndul Delete. 4. Din lista cmpurilor tabelei, care apare afisat n partea de sus a ferestrei, selectm cmpurile care vor fi afiate n interogare sau pentru care vor fi specificate condiii de selecie i le "tragem" n celulele respective ale liniei Field din partea de jos. Ca rezultat, n celulele respective apare automat, pentru fiecare cmp, opiunea Where (din engleza - Unde, n care). 5. Introducem n celulele liniei Criteria condiiile seleciei (condiiile pe care trebuie s le ndeplineasc nregistrrile care vor fi terse, n dreptul cmpului corespunztor). 6. Salvam interogarea. 7. Rulam interogarea facand dublu clic pe aceasta. 8. Deschidem tabela pentru a vedea rezultatul interogarii. Exemplu: Pentru tabela urmtoare:

Eliminarea persoanelor care au studii "Liceale":

Interogri de actualizare a nregistrrilor (Update Query) Se utilizeaz n cazul n care este necesar modificarea unui numr mare de nregistrari, respectnd aceeai modalitate de modificare. Vom descrie n continuare modul de definire a unei interogri de actualizare. 1. Crem interogarea n modul Design View: selectm Query din fereastra Database i alegem modul de proiectare Design View. 2. Includem tabela pentru care se execut interogarea. 3. Selectm Update Query din meniul Query. Ca rezultat, titlul ferestrei se modific n Update Query, iar n partea de jos apare rndul Update To. 4. Includem (prin tragere) n celulele rndului Field cmpurile care dorim s apar n interogare sau cele pentru care vom stabili criterii de actualizare. 5. Pentru ca anumite cmpuri ale tabelei s fie afiate n interogarea de actualizare trebuie s introducem n rndul Update To numele cmpului cuprins ntre paranteze drepte, altfel acesta nu va fi afiat. De asemenea, putem completa automat un cmp calculat, care nu a fost completat iniial n tabel. De exemplu, dac avem tabela Medii, care are cmpurile: Numele i prenumele elevului, Media sem I, Media Sem II i Media general, iar cmpul Media general nu a fost completat iniial pentru nici o nregistrare, vom trece n dreptul cmpului Media general de pe rndul Update: ([Media sem I]+[Media sem II])/2.

6.

Introducem n rndul Criteria condiia pe care trebuie s o ndeplineasc nregistrrile care vor fi modificate.

Interogri de adugare a nregistrrilor (Append Query) Se utilizeaz n cazul n care este necesar adugareavunui set de nregistrri dintr-o tabel n alt tabel. Aceasta va selecta datele care tebuie adugate i le va trimite n cmpurile tabelei destinaie. Vom descrie n continuare modul de definire a unei interogri de adugare. 1. Crem interogarea n modul Design View: selectm Query din fereastra Database i alegem modul de proiectare Design View. 2. Includem tabela pentru care se execut interogarea. 3. Includem (prin "tragere") n celulele rndului Field cmpurile care dorim s apar n interogare sau cele pentru care vom stabili criterii de adugare. 4. Selectm Append Query din meniul Query. Indicm tabela destinaie.

5. 6.

Ca rezultat, titlul ferestrei se modific n Append Query, iar n partea de jos apare rndul Append To. Introducem n rndul Criteria condiia pe care trebuie s o ndeplineasc nregistrrile care vor fi preluate. Precizm pe linia Append To numele cmpului destinaie (doar n cazul n care nu au acelai nume).

Daca dorim sa renuntam la un table adaugat intr-o interogare facem clic dreapta pe acesta si alegem optiunea Remove Table. Daca dorim sa mai adaugam alte tabele facem clic dreapta pe fereastra interogarii si alegem optiunea Show Table. Salvarea unei interogari: File-Save.

19. Filtre: adugare, eliminare: filrele ne ajuta sa vizualizam doar acele date care indeplinesc o conditie aleasa de noi dar realizeaza nici un fel de modificare in structura tabelei. Pentru filtrarea datelor dintr-o tabel, interogare sau formular trebuie ca modul de vizualizare curent s fie Datasheet View. Operaiile referitoare la filtrarea datelor se gsesc n meniul Records:

Modaliti de filtrare 1)Filter By Selection- cnd dorim selectarea articolelor care conin o anumit valoare pe care ne-am poziionat anterior: Ne poziionm pe valoarea cutat la unul din articole; Selectm Records->Filter->Filter By Selection; Repetm paii anteriori pn obinem setul de date dorit. 2)Filter Excluding Selection- cnd dorim selectarea articolelor care NU conin o anumit valoare: Ne poziionm pe valoarea cutat la unul din articole; Selectm Records->Filter->Filter Excluding Selection; Repetm paii anteriori pn obinem setul de date dorit. 3)Advanced Filter/Sort...- cnd dorim selectarea articolelor care ndeplinesc anumite condiii: Selectm Records->Filter->Advanced Filter/Sort...; Se deschide fereastra Filter care este, de fapt, o fereastr de proiectare a unei interogri, iar condiia de filtrare se stabilete n rndul Criteria, aa cum se procedeaz la proiectarea unei interogri simple. Pentru a fi aplicat criteriul de filtrare se selecteaz Records>Apply Filter/Sort. Pentru anularea filtrrii, se selecteaz Records->Remove Filter/Sort Exemplu: Fie tabela urmtoare:

Pentru a afia doar medicamentele care sunt produse de SC Prima SRL i care au pretul>3 se stabilesc criteriile urmtoare:

dup care se alege Records->Apply Filter/Sort. 20. Crearea unui raport: Un raport reprezinta un mod mai ordonat de prezentarea a datelor ce poate fi tiparit. Pentru a crea un raport alegem din optiunile bazei de date Reports si la fel ca si celelalte obiecte ale unei baze de date si un raport poate fi creat fie in modul Design in care il proiectam manual, fie in modul Wizard in care suntem asistati de catre program in realizarea lui. 21. Modificarea unui raport: clic dreapta pe raport creat-Design view si modificam orice obiect din raport folosind bara de instrumente atasata sau facand clic dreapta pe obiectul ce dorim a fi modificat si alegem optiunea dorita. 22. Crearea, modificarea unui antet i subsol: daca antetul sau subsolul unui raport nu este activ facem clic dreapta pe raport-Report Header/Footer

Aplicatii Microsoft Access


1.

2.
3.

4.
5. 6. 7.

Realizati o baza de date numita scoala.mdb. In acesta baza de date creati tabelul Elevi={Nume, Prenume, Nr matricol, Clasa, Purtare} care va avea cheia primara Nr matricol. Adaugat 5 inregistrari in tabela. Stergeti prima inregistrare din tabela si adaugati la sfarsit inca una cu numele, prenumele, numarul matricol, clasa si nota voastra la purtare. Realizati un formular simplu care sa contina toate datele tabelului. Colorati fundalul formularului, textul continut de acesta si mariti dimensiunea textului. Inserati si o imagine in formular. Adaugati in tabela inca 2 inregistrari folosind formularul creat. Realizati o interogare care sa afiseze doar acei elevi din clasa a XII-a MI.

8.

Realizati o introgare care sa stearga elevul cu numarul matricol 1. (Daca nu aveti un elev cu numarul matricol 1 adaugati unui inainte sa realizati introgarea). 9. Realizati o interogare care sa modifice pentru toti elevii din clasa a XI-a MI nota la purtare cu 9. 10. Realizati o interogare care sa afiseze numele elevilor care sunt din clasa a XII-a MI si au media la purtare cuprinsa intre 8 si10 11. Realizati un filtru care sa afiseze doar elevii din clasa a XII-a MI. 12. Realizati un raport care sa contina in antet numele vostru, colorat in verde si pe un fundal galben, iar in corpul acestuia toate datele tabelului colorate in albastru. In subsolul raportului inserati o imagine.