Sunteți pe pagina 1din 3

CONTAR.SI Cuenta las celdas, dentro del rango, que no estn en blanco y que cumplen con el criterio especificado.

Sintaxis CONTAR.SI(rango;criterio) Rango es el rango dentro del cual desea contar las celdas.

Criterio es el criterio en forma de nmero, expresin, referencia a celda o texto, que determina las celdas que se van a contar. Por ejemplo, los criterios pueden expresarse como 32, "32", ">32", "manzanas" o B4. Observaciones Microsoft Excel proporciona funciones adicionales que se pueden usar para analizar los datos basndose en una condicin. Para calcular una suma basada en una cadena de texto o un nmero dentro de un rango, use la funcin de hoja de clculo SUMAR.SI . Para hacer que una frmula devuelva uno de dos valores segn una condicin, como una bonificacin por ventas basada en un importe de ventas especificado, utilice la funcin de hoja de clculo SI. Para contar celdas que estn vacas o no, use las funciones CONTARA y CONTAR.BLANCO. Ejemplo 1: frmulas CONTAR.SI comunes El ejemplo puede resultar ms fcil de entender si lo copia en una hoja de clculo en blanco. Cmo? A 1 2 3 4 5 naranjas melocotones manzanas Frmula =CONTAR.SI(A2:A5;"manzanas") =CONTAR.SI(A2:A5,A4) =CONTAR.SI(A2:A5,A3)+CONTAR.SI(A2:A5,A2) =CONTAR.SI(B2:B5;">55") =CONTAR.SI(B2:B5,"<>"&B4) =CONTAR.SI(B2:B5,">=32")CONTAR.SI(B2:B5,">85") 54 75 86 Descripcin (resultado) Nmero de celdas con manzanas en la primera columna anterior (2) Nmero de celdas con melocotones en la primera columna anterior (2) Nmero de celdas con naranjas y manzanas en la primera columna anterior (3) Nmero de celdas con un valor superior a 55 en la segunda columna anterior (2) Nmero de celdas con un valor distinto a 75 en la segunda columna anterior (2) Nmero de celdas con un valor superior o igual a 32 e inferior o igual a 85 en la segunda columna anterior (3) Datos manzanas B Datos 32

Ejemplo 2: frmulas CONTAR.SI que usan caracteres comodn y que gestionan valores vacos El ejemplo puede que sea ms sencillo de entender si lo copia en una hoja de clculo vaca.

Cmo? A 1 2 3 4 5 6 7 manzanas Frmula =CONTAR.SI(A2:A7,"*es") =CONTAR.SI(A2:A7,"?????es") =CONTAR.SI(A2:A7,"*") =CONTAR.SI(A2:A7,"<>"&"*") =CONTAR.SI(B2:B7,"No") / FILAS(B2:B7) YeS Descripcin (resultado) Nmero de celdas que acaban con las letras "les" en la primera columna anterior (4) Nmero de celdas que acaban con las letras "les" y tienen exactamente 8 letras en la primera columna anterior (2) Nmero de celdas que contienen texto en la primera columna anterior (4) Nmero de celdas que no contienen texto en la primera columna anterior (2) El nmero medio de votos negativos, incluidas las celdas vacas de la segunda columna anterior, con el formato de porcentaje sin cifras decimales (33%) El nmero medio de votos positivos, excluidas las celdas vacas de la segunda columna anterior, con el formato de porcentaje sin cifras decimales (50%) naranjas melocotones NO No Datos manzanas B Datos Yes

=CONTAR.SI(B2:B7,"S") / (FILAS(B2:B7) CONTAR.SI(B2:B7, "<>"&"*"))

FUNCION CONTAR.SI Esta funcin es una combinacin de las funcines CONTAR y SI , tiene dos argumentos, el primero es el rango cuyas celdas se desean contar y el segundo es el criterio que determina que celda sera contada o no

con esta misma tabla podramos preguntar cuntos hombres hay