Sunteți pe pagina 1din 5

BENEMRITA UNIVERSIDAD AUTNOMA DE PUEBLA

PREPARATORIA 2 DE OCTUBRE DE 1968

MATERIA: INFORMTICA III

-ALGORITMOS-

PROFESORA: MINERVA GMEZ MARCOS

ALUMNA: LORENA CUAYA CYOTL

GRADO: 3 DM SALUD

CICLO ESCOLAR: 2013-2014

EJERCICIOS EN CLASE 1. ELABORA UN PROGRAMA QUE REALICE RESULTADO, POR EJEMPLO LO SIGUIENTE. Datos de entrada: Num1, Num2 Datos de salida: Producto Proceso: Producto<-Num1*Num2
LA MULTIPLICACIN DE

NMEROS Y NOS DE

Proceso Multiplicacin Escribir "Dame el primer nmero" ; Leer Num1 ; Escribir "Dame el segundo nmero" ; Leer Num2 ; Producto<-Num1*Num2 Escribir "El resultado de ", Num1, "*", Num2 " es: ", Producto; FinProceso

2. MANUEL

TIENE UN HERMANO MENOR EN

AO DE PRIMARIA Y NO PUEDE APRENDERSE LAS

TABLAS DE MULTIPLICAR, POR LO QUE NECESITA UN PROGRAMA QUE DADO EL NMERO DE TABLA DE MULTIPLICAR SE LA MUESTRE COMO A CONTINUACIN SE DESCRIBE, EJEMPLO:

PROGRAMA QUE MUESTRA LA TABLA DE MULTIPLICAR DE UN NMERO. ESCRIBE (VALOR INTRODUCIDO POR EL USUARIO) TABLA DE MULTIPLICAR DEL NMERO 5. 5*1=5 5*2=10... Datos de entrada: Nmero de tabla Datos de salida: Resultado de tabla Proceso: Productos

UN NMERO:

Proceso TablasMultiplicar Escribir "Dame el nmero de la tabla a practicar" Leer Numtabla Escribir Numtabla, "x1= ", Numtabla*1 ; Escribir Numtabla, "x2= ", Numtabla*2 ; Escribir Numtabla, "x3= ", Numtabla*3 ; Escribir Numtabla, "x4= ", Numtabla*4 ; Escribir Numtabla, "x5= ", Numtabla*5 ; Escribir Numtabla, "x6= ", Numtabla*6 ; Escribir Numtabla, "x7= ", Numtabla*7 ; Escribir Numtabla, "x8= ", Numtabla*8 ; Escribir Numtabla, "x9= ", Numtabla*9 ; Escribir Numtabla, "x10= ", Numtabla*10 ; FinProceso

UN

EMPLEADO DESEA CALCULAR EL PAGO NETO QUE PERCIBE RESULTANTE DE LAS SIGUIENTES

IMSS 5%, INFONAVIT 16%, ISPT 23% A PARTIR DEL PAGO BRUTO BASADO EN UNA JORNADA EN HORAS CON PRECIO DE $100.00 POR HORA. (15 DAS Y JORNADA DE 8 HORAS MXIMO)
DEDUCCIONES

Datos de entrada: Horas y das trabajados Datos de salida: Pagoneto Proceso: Pagoneto<-(Horas*100)*Dias-(Horas*100)*Dias*.44 ; Proceso PagoNeto Escribir "Dame el nmero de horas trabajadas" ; Leer Horas Escribir "Dame el nmero de das trabajados" ; Leer Dias Pagoneto<-(Horas*100)*Dias-(Horas*100)*Dias*.44 ; Escribir "El resultado es: ", Pagoneto FinProceso

TAREA DEL DA 12 DE NOV DE 2013 Determinar cules son sus datos de entrada, salida y su proceso, as como elaborar su algoritmo de cada uno de los siguientes ejercicios: 1.- PROGRAMA QUE PIDA LA TEMPERATURA EN GRADOS CELSIUS Y LA CONVIERTA FAHRENHEIT (Y VICEVERSA) MOSTRANDO EN PANTALLA UN MENSAJE DEL TIPO Datos de entrada: Grados Celsius y Grados Fahrenheit Datos de Salida: Conversin de Grados Celsius a Fahrenheit y viceversa Proceso: Conversin<-(Gradoscel*9/5)+(32) ; y Conversin2<- (Gradosfah-32)/(1.8);
A GRADOS

Proceso Grados Escribir "Dame la temperatura en grados Celsius" ; Leer Gradoscel; Conversin<-(Gradoscel*9/5)+(32) ; Escribir Gradoscel," Grados Celsius son: ", Conversin " Grados Fahrenheit" Escribir "Dame la temperatura en grados Fahrenheit " ; Leer Gradosfah; Conversin2<- (Gradosfah-32)/(1.8); Escribir Gradosfah " Grados Fahrenheit son: ", Conversin2 " Grados Celsius" FinProceso

2.- MIRIAM NECESITA REALIZAR UN EXPERIMENTO DONDE LA MEDIDA DEL AZCAR SE DA EN ONZAS
Y DESEA CONOCER SU EQUIVALENTE A GRAMOS Y KILOGRAMOS PARA PODER LLEVAR A CABO EL PROCESO DE MEZCLADO DE DICHO TRABAJO.

Datos de entrada: Cantidad de Onzas Datos de Salida: Conversin a gramos y kilogramos Proceso: Kilogramos<- (Onzas*0.0283495); y Gramos<- (Onzas*28.350);

Proceso ConversinDeOnzas Escribir "Dame la cantidad de Onzas" Leer Onzas Kilogramos<- (Onzas*0.0283495); Escribir "La cantidad de Onzas equivale a: ", Kilogramos " Kilogramos " Gramos<- (Onzas*28.350); Escribir "La cantidad de Onzas equivale a: ", Gramos " Gramos " FinProceso

3.- UNA CASA DE VALORES PRESENTA A SUS USUARIOS LAS CONVERSIONES DE SU DINERO (MONEDA NACIONAL) A OTRAS DIVISAS COMO EL EURO, DLAR, YEN, DLAR CANADIENSE. PRESENTAR UN ALGORITMO PARA RESOLVER ESTE PROCESO. Datos de entrada: Moneda Nacional Datos de salida: Conversin de la Moneda Nacional a otras divisas Proceso: Euro Dinero/17.4, Dlar Dinero/12.89, Yen Dinero/0.1289 y DolarCanadiense Dinero/12.35

Proceso ConversinDinero Escribir "Dame la cantidad de dinero" Leer Dinero Escribir "La conversin de su dinero en Euro es: ", Dinero/17.4 Escribir "La conversin de su dinero en Dlar es: ", Dinero/12.89 Escribir "La conversin de su dinero en Yen es: ", Dinero/0.1289 Escribir "La conversin de su dinero en Dlar Canadiense es: ", Dinero/12.35 FinProceso