Sunteți pe pagina 1din 7

SEDE SANTANDER DE QUILICHAO, Carrera 9 # 2 97 / 2 Piso

Celular: 3218151725; Telfono: (2) 829 00 62


e-mail: cafemiza@hotmail.com
SEDE CAMPESTRE LOS ROBLES, Popayn: Kilmetro 8 va al Sur
Celulares: 311-7194163 - 3163613587
e-mail: calbertovidal@hotmail.com, slhenaop@gmail.com
www.fup.edu.co


FUNDACIN UNIVERSITARIA DE POPAYN
Personera Jurdica No. 10161 de 1983
Nit. 891.501.835-6
SEDE NORTE DEL CAUCA

CAPITULO 5. FUNCIONES
Este captulo es uno de los ms importantes del curso, pues en su comprensin y manejo est la base de
Excel. Que es una hoja de clculo sino una base de datos que utilizamos con una serie de frmulas para
evitar tener que recalcular por cada cambio que hacemos

6.1 Comprender las funciones
El asistente para funciones.- Existen muchos tipos de funciones; matemticas, estadsticas, de fecha,
cientficas, etc, alguna de las cuales contiene una sintaxis bastante ms difcil que la autosuma, por ejemplo.
Existen funciones que realizan complejos clculos y que tan slo nos piden unos datos especficos.
Si no recordamos la sintaxis de una funcin, podemos hacerlo con el Asistente de funciones el cual, nos
guiar paso a paso hasta obtener el resultado buscado.

Sintaxis de una funcin: nombre_funcin(argumento1;argumento2;...;argumentoN)

Siguen las siguientes reglas:
- Si la funcin va al comienzo de una frmula debe empezar por el signo =.
- Los argumentos o valores de entrada van siempre entre parntesis. No dejes espacios antes o despus de
cada parntesis.
- Los argumentos pueden ser valores constantes (nmero o texto), frmulas o funciones.
- Los argumentos deben de separarse por un punto y coma ;.

Las funciones deben mantener unas reglas de sintaxis tal y como se indica en el siguiente ejemplo:
=SUMA(A1:A200;100)

En el ejemplo, se sumar todo el rango A1:A200 y aparte el nmero 100. Es decir, que dentro de los
parntesis que forman el contenido de la funcin, hay dos argumentos a sumar.




Programa Acadmico:
INGENIERA INDUSTRIAL
Curso (Asignatura):
INFORMTICA
Docente:
Alejandra Garca Lanchero





SEDE SANTANDER DE QUILICHAO, Carrera 9 # 2 97 / 2 Piso
Celular: 3218151725; Telfono: (2) 829 00 62
e-mail: cafemiza@hotmail.com
SEDE CAMPESTRE LOS ROBLES, Popayn: Kilmetro 8 va al Sur
Celulares: 311-7194163 - 3163613587
e-mail: calbertovidal@hotmail.com, slhenaop@gmail.com
www.fup.edu.co


FUNDACIN UNIVERSITARIA DE POPAYN
Personera Jurdica No. 10161 de 1983
Nit. 891.501.835-6
SEDE NORTE DEL CAUCA
6.2 Funciones Matemticas y trigonomtricas
La funcin Autosuma.- Es quiz la funcin ms utilizada en una hoja de clculo. Por ello, Excel proporciona
un botn exclusivo para la funcin Autosuma en la barra de herramientas.
Para utilizar una funcin, podemos escribirla manualmente o bien utilizar el Asistente para funciones que
nos ir guiando paso a paso en la construccin de la funcin.
1. Escribe en una hoja nueva unos cuantos nmeros y despus coloca el cursor bajo esa misma lista,
2. Pulsa el botn Autosuma situado en la barra de herramientas estndar
Observa que Excel detecta lo que queremos sumar y lo marca con puntos suspensivos intermitentes. Ahora
podemos aceptar pulsando Intro o bien seleccionar con el mouse la zona que queremos sumar y pulsa
Intro.
Otra forma de hacerlo es la siguiente:
1. Borra el contenido de la celda que contiene la frmula
2. Selecciona toda el rea numrica, la ltima celda incluida
3. Pulsa el botn Autosuma.
En este caso, marcamos directamente el rango que queremos sumar, por lo que Excel lo suma
directamente. Con el cursor situado en la celda que contiene la frmula, observa la barra de frmulas.
La funcin tiene entre parntesis la celda inicial del rango a sumar y la celda final separadas por dos puntos.
Desde aqu podemos modificar manualmente el rango.
Ejercicio: de valores a las celdas A1, A2, A3, A4 y realice la siguiente operacin con la funcin autosuma:
(A1+A3) + (A2-A4)
Funcin RCUAD: La sintaxis de la funcin RCUAD tiene los siguientes argumentos:
Nmero Obligatorio. El nmero cuya raz cuadrada desea obtener. Si el nmero es negativo, RCUAD
devuelve el valor de error #NUM!
Ejercicio: escriba en A1 el valor de -16, en la siguiente celda escriba la funcin as: =RCUAD (16) y enter,
luego en la siguiente celda vuelve a escribir la funcin pero esta vez as: =RCUAD(A1), CUAL ES EL
RESULTADO?





SEDE SANTANDER DE QUILICHAO, Carrera 9 # 2 97 / 2 Piso
Celular: 3218151725; Telfono: (2) 829 00 62
e-mail: cafemiza@hotmail.com
SEDE CAMPESTRE LOS ROBLES, Popayn: Kilmetro 8 va al Sur
Celulares: 311-7194163 - 3163613587
e-mail: calbertovidal@hotmail.com, slhenaop@gmail.com
www.fup.edu.co


FUNDACIN UNIVERSITARIA DE POPAYN
Personera Jurdica No. 10161 de 1983
Nit. 891.501.835-6
SEDE NORTE DEL CAUCA
Funcin POTENCIA: Realiza el clculo de elevar un nmero a la potencia indicada.
Ejemplo: =POTENCIA(2;5) devuelve 32

Funcin REDONDEAR: La funcin REDONDEAR redondea un nmero a un nmero de decimales
especificado. Por ejemplo, si la celda A1 contiene 23,7825 y desea redondear ese valor a dos posiciones
decimales, puede usar la siguiente frmula:
=REDONDEAR(A1; 2), El resultado de esta funcin es 23,78.
Actividad No.1: investigar las siguientes funciones, para qu sirven?, cmo se utilizan?, y dar un ejemplo.
M.C.D, MDETERM, ALEATORIO y SUMAR.SI
6.2.1 Funciones con argumento otra funcin.
Funciones anidadas.- Se llaman as aquellas funciones que actan como argumento de otra funcin, es
decir, que se encuentran dentro de otra funcin. En el proceso de clculo, Excel realiza primero el clculo de
la funcin interior y despus, el resultado de la funcin exterior teniendo ya en cuenta el resultado que se
ha obtenido con la funcin interior.
Por ejemplo, la funcin: =RAIZ(POTENCIA(20;3))
Primero calcular el resultado de la funcin interior, o sea, de la potencia, cuyo resultado es 8.000 y luego
se calcular el resultado de la exterior, teniendo en cuenta ya este resultado.
Excel tambin permite que una funcin se convierta en argumento de otra funcin, de esta forma podemos
realizar operaciones realmente complejas en una simple celda. Por ejemplo=MAX(SUMA(A1:A4);B3) , esta
frmula consta de la combinacin de dos funciones, la suma y el valor mximo. Excel realizar primero la
suma SUMA(A1:A4) y despus calcular el valor mximo entre el resultado de la suma y la celda B3.
6.3 Funciones Lgicas
La funcin =SI().- Una de las funciones ms potentes que se utilizan en Excel es la funcin =SI(). Esta funcin
tiene la siguiente estructura:
=SI (condicin;verdadero;falso).
Donde condicin es una condicin que se tiene que cumplir. Si sta se cumple, se ejecutar verdadero, o en
caso contrario, se ejecutar falso. Por ejemplo:
=SI(A3>B12;"Correcto";"Incorrecto")





SEDE SANTANDER DE QUILICHAO, Carrera 9 # 2 97 / 2 Piso
Celular: 3218151725; Telfono: (2) 829 00 62
e-mail: cafemiza@hotmail.com
SEDE CAMPESTRE LOS ROBLES, Popayn: Kilmetro 8 va al Sur
Celulares: 311-7194163 - 3163613587
e-mail: calbertovidal@hotmail.com, slhenaop@gmail.com
www.fup.edu.co


FUNDACIN UNIVERSITARIA DE POPAYN
Personera Jurdica No. 10161 de 1983
Nit. 891.501.835-6
SEDE NORTE DEL CAUCA
Si la celda A3 es mayor que la celda B12, aparecer la palabra Correcto. En caso contrario, aparecer la
palabra Incorrecto.
=SI(A1="Bajo mnimos";"Quiebra";"Normal")
Si la celda A1 contiene la palabra Bajo mnimos, en la celda actual aparecer la palabra Quiebra. En caso
contrario, aparecer la palabra Normal.
=SI(O(A1=B1;C1=D1);"Bien";"Mal")
Aqu ha de cumplirse una de las dos condiciones. Ntese la utilizacin del operador O.

6.3 Funciones Estadsticas.
La funcin promedio.- Otra interesante funcin es la llamada =PROMEDIO(). Funciona exactamente igual
que la suma, pero no existe ningn botn; por lo que debemos introducirla manualmente. Cuando
introducimos una funcin mediante el teclado, podemos escribirla por completo o hacer lo siguiente:
1. Borra el contenido de la ltima frmula.
2. Escribe lo siguiente: =PROMEDIO(
3. Selecciona con el mouse el rango de nmeros. Fjate como la frmula va tomando dicho rango y se va
escribiendo sola.
4. Cierra el parntesis escribindolo a mano.
5. El resultado obtenido es la media de los datos numricos.






Otra forma de hacerlo es:
1. Borra el contenido de la ltima frmula y sita el cursor en ella.





SEDE SANTANDER DE QUILICHAO, Carrera 9 # 2 97 / 2 Piso
Celular: 3218151725; Telfono: (2) 829 00 62
e-mail: cafemiza@hotmail.com
SEDE CAMPESTRE LOS ROBLES, Popayn: Kilmetro 8 va al Sur
Celulares: 311-7194163 - 3163613587
e-mail: calbertovidal@hotmail.com, slhenaop@gmail.com
www.fup.edu.co


FUNDACIN UNIVERSITARIA DE POPAYN
Personera Jurdica No. 10161 de 1983
Nit. 891.501.835-6
SEDE NORTE DEL CAUCA
2. Pulsa el botn funcin de la barra de herramientas estndar

3. Pulsa a la izquierda la opcin Estadsticas.
4. Sube la lista deslizable de la ventana derecha hasta encontrar la funcin PROMEDIO y pulsa un click sobre
ella.
5. Observa la lnea de estado de la ventana; nos explica para qu sirve esa funcin. Acepta.
6. Ahora nos pide qu celdas o rango de celdas queremos utilizar para saber el resultado del promedio de
datos. Podemos pulsar click en las celdas que nos interesen, escribirlas a mano o bien seleccionar un rango
de datos de la hoja. Selecciona el rango adecuado y acepta.
funciones MAX, MIN
1. En la columna A escribe una lista de valores (10 datos)
2. Sita el cursor en la celda inmediatamente despus del ltimo dato
3. Escribe la funcin MAX con el rango de datos que escribiste anteriormente
4. Haz lo mismo con la funcin MIN

NOTA:
Los argumentos pueden ser nmeros, o nombres, matrices o referencias que contengan nmeros.
Si el argumento es una matriz o una referencia, slo se utilizarn los nmeros contenidos en la
matriz o en la referencia.
Si el argumento no contiene nmeros, MAX devuelve 0.
Los argumentos que sean valores de error o texto que no se pueda traducir a nmeros provocan
errores.
Si desea incluir valores lgicos y representaciones textuales de nmeros en una referencia como
parte del clculo, utilice la funcin MAXA.
Actividad No.2: investigar las siguientes funciones, para qu sirven?, cmo se utilizan?, y dar un ejemplo.
CONTAR, MEDIANA
6.4 Funciones de bsqueda y referencia.

Funcin COINCIDIR(valor_buscado; matriz_buscar_en; tipo_de_coincidencia)
La funcin COINCIDIR busca un elemento especificado en un rango (rango: dos o ms celdas de una hoja.
Las celdas de un rango pueden ser adyacentes o no adyacentes.) de celdas y, a continuacin, devuelve la





SEDE SANTANDER DE QUILICHAO, Carrera 9 # 2 97 / 2 Piso
Celular: 3218151725; Telfono: (2) 829 00 62
e-mail: cafemiza@hotmail.com
SEDE CAMPESTRE LOS ROBLES, Popayn: Kilmetro 8 va al Sur
Celulares: 311-7194163 - 3163613587
e-mail: calbertovidal@hotmail.com, slhenaop@gmail.com
www.fup.edu.co


FUNDACIN UNIVERSITARIA DE POPAYN
Personera Jurdica No. 10161 de 1983
Nit. 891.501.835-6
SEDE NORTE DEL CAUCA
posicin relativa de ese elemento en el rango. Por ejemplo, si el rango A1:A3 contiene los valores 5, 25 y 38,
la frmula
=COINCIDIR(25;A1:A3;0) devuelve el nmero 2, porque 25 es el segundo elemento en el rango.
Use COINCIDIR en lugar de una de las funciones BUSCAR cuando necesite conocer la posicin de un
elemento en un rango en lugar del elemento en s. Por ejemplo, puede usar la funcin COINCIDIR para
proporcionar un valor para el argumento fila de la funcin INDICE.
Funcin BUSCAR(...)
Esta funcin busca un valor en un rango de una columna o una fila o una matriz. Debes indicar el valor a
buscar, dnde quieres que busque y de dnde obtendrs el resultado.
Ejemplo: Tenemos en la columna B una lista de nombres de amig@s y en la columna C sus e-mails,
escribimos en la celda A1 el nombre del amig@ del cual queremos buscar el e-mail. Escogemos en la celda
E1 la funcin BUSCAR y le pasamos como parmetros:
"valor_buscado= A1", "vector_de_comparacin= B:B" y "vector_resultado = C:C". Nos devuelve como
resultado el e-mail perteneciente a la persona buscada.

6.5 Funciones de texto.
Funcin CARACTER(nmero) Devuelve el carcter especificado por el nmero de cdigo correspondiente al
cdigo de caracteres ASCII.
Ejemplo: =CARACTER(76) devuelve L
Funcin CODIGO(texto) Esta funcin devuelve el cdigo ASCII del primer caracter del texto pasado como
parmetro.
Ejemplo: =CODIGO("L") devuelve 76
Funcin CONCATENAR(texto1; texto2; ...; textoN) Devuelve una cadena de caracteres con la unin de los
textos pasados como parmetros. Esta funcin es de utilidad cuando tenemos texto como puedan ser el
nombre completo de una persona pero est dividido en distintas celdas y en alguna ocasin queremos
fundir el nombre completo en una sola celda.
Ejemplo: =CONCATENAR("Antonio ";"Gutierrez ";"Fernandez " ) devuelve Antonio Gutierrez Fernandez





SEDE SANTANDER DE QUILICHAO, Carrera 9 # 2 97 / 2 Piso
Celular: 3218151725; Telfono: (2) 829 00 62
e-mail: cafemiza@hotmail.com
SEDE CAMPESTRE LOS ROBLES, Popayn: Kilmetro 8 va al Sur
Celulares: 311-7194163 - 3163613587
e-mail: calbertovidal@hotmail.com, slhenaop@gmail.com
www.fup.edu.co


FUNDACIN UNIVERSITARIA DE POPAYN
Personera Jurdica No. 10161 de 1983
Nit. 891.501.835-6
SEDE NORTE DEL CAUCA
Actividad No.3.: investigar las siguientes funciones, para qu sirven?, cmo se utilizan?, y dar un ejemplo.
NOMPROPIO, T