Sunteți pe pagina 1din 11

Disee un algoritmo que permita validar la lectura de un nmero que sea de

tres cifras, calcular e imprimir la sumatoria de sus dgitos.


Proceso Sdecifras3
Definir R,U,C,N,D,AUX Como Entero;
Repetir
Escribir "Digite un numero de tres cifras";
Leer N;
Hasta Que (N > 99) & (N < 1000);
AUX<-N/10;
U<-N%10;
C<-AUX/10;
D<-AUX%10;
R<-U+D+C;
Escribir "La suma de los digitos es ",R;
FinProceso

Disee un algoritmo que permita leer un nmero sin importar cuantas cifras
tenga, calcule e imprima la suma de sus dgitos.
Proceso Cifras
R1<-0;
U<-0;
S<-0;
Repetir
Escribir "Digite un numero de cualquier cifra positivo";
Leer N;
Hasta Que N > 0;
Repetir
R1<-N/10;
U<-N%10;
N<-R1;
S<-S+U;
Hasta Que R1 = 0;
Escribir "La suma de los digitos es ",S;
FinProceso

Disee un algoritmo que permita leer un nmero, validar que sea de cinco
cifras y calcular:
Si el digito del centro es cero entonces imprima 0
Si el digito del centro es primo, calcule su cuadrado
Si el digito del centro es impar, calcule su cubo.
Proceso Sdecifras5
Definir N,DC,C,CU Como Entero;
Repetir
Escribir "Digite un numero de cinco cifras";
Leer N;
Hasta Que (N > 9999) & (N < 100000);
DC<-N/100
DC<-DC%10;
Si DC = 0 Entonces
Escribir "El numero es cero ",DC;
Sino
Si (DC = 2)|(DC = 3)|(DC = 5)|(DC = 7) Entonces
C<-DC*DC;
Escribir "El cuadrado es: ",C;
Sino
CU<-DC*DC*DC;
Escribir "El cubo es: ",CU;
FinSi
FinSi
FinProceso

Disee un algoritmo que calcule el rea de un tringulo.

Proceso Triangulo
Escribir "Digite la base del triangulo";
Leer B;
Escribir "Digite la Altura del triangulo";
Leer H;
A<-B*H/2;
Escribir "El Area del triangulo es ",A;
FinProceso

Disee un algoritmo que lea dos nmeros. Si los dos son pares sumarles 5, Si los dos
son impares sumarles 10 y si uno es par y otro impar sumarle 50.

Proceso NumerosI
Escribir "Digite un numero positivo";
Leer N1;
Escribir "Digite un numero positivo";
Leer N2;
Si (N1%2=0) & (N2%2=0) Entonces
N1<-N1+5;
N2<-N2+5;
Escribir N1;
Escribir N2;
Sino
Si (N1%2=0) | (n2%2=0) Entonces
N1<-N1+50;
N2<-N2+50;
Escribir N1;
Escribir N2;
Sino
N1<-N1+10;
N2<-N2+10;
Escribir N1;
Escribir N2;
FinSi
FinSi

FinProceso

Disee un algoritmo que lea tres nmeros, evaluar cul es el mayor, cual el
menor y cual el nmero medio(mitad)
Proceso nmeros
escribir "Digite primer nmero";
leer num1;
escribir "Digite segundo nmero";
leer num2;
escribir "Digite tercer nmero";
leer num3;
si (num1=num2)|(num1=num3)|(num2=num3)Entonces
Escribir "Dos o tres nmeros son iguales";

Sino

si (num1>num2) & (num1>num3) Entonces


escribir "el nmero mayor es: ",num1;
si (num2>num3)Entonces
escribir "el nmero del centro es: ",num2;
escribir "el nmero menor es: ",num3;
Sino
escribir "el nmero del centro es: ",num3;
escribir "el nmero menor es: ",num2;
FinSi
Sino
si (num2>num1) & (num2>num3) Entonces
escribir "el nmero mayor es: ",num2;
si (num1>num3)Entonces
escribir "el nmero del centro es: ",num1;
escribir "el nmero menor es: ",num3;
Sino
Escribir "el nmero del centro es: ",num3;
Escribir "el nmero menor es: ",num1;
Finsi

Sino
Si (num3>num1) & (num3>num2) Entonces
escribir "el numero mayor es: ",num3;
Si (num1>num3)Entonces
Escribir "el nmero del centro es: ",num1;
Escribir "el nmero menor es: ",num2;
Sino
Escribir "el nmero del centro es: ",num2;
Escribir "el nmero menor es: ",num1;
FinSi
Finsi
FinSi
FinSi
FinSi
FinProceso

DUA que imprima todos los divisores exactos de un nmero ledo

Proceso Divisores
Definir N,I Como Entero;
Escribir "Digite un nmero";
Leer N;
Para I<-1 Hasta N Con Paso 1 Hacer
Si N%I=0 Entonces
Escribir I;
FinSi
FinPara
FinProceso

DUA que imprima el factorial de cada divisor exacto de un nmero ledo

Proceso Divisores
Definir N Como Entero;
I<-0;
Escribir "Digite un nmero";
Leer N;
Para I<-1 Hasta N Con Paso 1 Hacer
Si N%I=0 Entonces
F<-1;
Para J<-1 Hasta I Con Paso 1 Hacer
F<-F*J;
FinPara
Escribir "El divisor es ",I," Su factorial es ",F;
FinSi
FinPara
FinProceso

DUA que imprima los primeros n trminos de la serie Fibonacci( esta serie
se forma con dos nmeros iniciales 0 y 1 y el siguiente nmero se forma
con la suma de los dos anteriores 0,1,1,2,3,5,8,13,21....n)
Proceso Fibonacci
C<-0;
U<-1;

Escribir " Favor digite el numero de cantidades a generar";


Leer n;
Escribir "Termino 1 :" ,C;
Escribir "Termino 2 :", U;
Para i<-2 Hasta n Con Paso 1 Hacer
V<-C + U;
C<-U;
U<-V;
Escribir "Termino ",I,": ", V;
FinPara
FinProceso

DUA que imprima el resultado de n trminos de la serie


1/2 - 2/4 + 3/6 - 4/8 + 5/10 6/12 + 7/14
Proceso Serie
P<-0;
N<-0;
Escribir "El programa realiza las operaciones de suma y resta de Fraccionarios de esta serie: 1/2 - 2/4 + 3/6 - 4/8
+ 5/10 - 6/12 + 7/14";
Escribir " Favor digite las cantidades a sumar";
Leer a;
Para i<-1 Hasta a Con Paso 2 Hacer
P<-P+0.5;
FinPara
Para j<-2 Hasta a Con Paso 2 Hacer
N<-N-0.5;
FinPara
R<-P+N;
Si R = 0.5 Entonces
Escribir "El resultado de la fraccin simplificada es: 1/2";
Sino
Escribir "El resultado es: ",R;
FinSi
FinProceso

Men de Opciones
Proceso Menu
Para c <-1 Hasta 3 Con Paso 1 Hacer
Escribir "MENU DE OPCIONES";
Escribir "1. CALCULA PROMEDIO";
Escribir "2. CALCULA PROMEDIO E IMPRIME APROBADO O REPROBADO";
Escribir "3. PARA N ALUMNOS CALCULA PROMEDIO E IMPRIME APROBADO O
REPROBADO";
Escribir "0. PARA SALIR DIGITA CERO";
Escribir "Introduce un nuemero de opcin";
Leer opcion;
Segun opcion Hacer

1:
Escribir "Introduce el numero de control y nombre del alumno";
Leer N_Control,Nombre;
Escribir "Introduce las 5 calificaciones";
Leer c1,c2,c3,c4,c5;
promedio<-(c1+c2+c3+c4+c5)/5;
Escribir " BOLETA DE CALIFICACIONES CON PROMEDIO";
Escribir "Numero de control: ", N_Control, " Nombre del alumno:",Nombre;
Escribir "Calificaciones: ";
Escribir " ",c1;
Escribir " ",c2;
Escribir " ",c3;
Escribir " ",c4;
Escribir " ",c5;
Escribir " ";
Escribir "Promedio final ",promedio;
2:
Escribir "Introduce el numero de control y nombre del alumno ";
Leer N_Control,Nombre;
Escribir "Introduce las 5 calificaciones";
leer c1,c2,c3,c4,c5;
promedio<-(c1+c2+c3+c4+c5)/5;
Escribir " BOLETA DE CALIFICACIONES CON PROMEDIO";
Escribir "Numero de control: ", N_Control, " Nombre del alumno:",Nombre;
Escribir "Calificaciones: ";
Escribir " ",c1;
Escribir " ",c2;
Escribir " ",c3;
Escribir " ",c4;
Escribir " ",c5;
Escribir " ";
Escribir "Promedio final ",promedio;
Si promedio>=6 Entonces
Escribir " APROBADO";
Sino

Escribir " REPROBADO";


FinSi
3:
contador <-1;
Escribir "Cuantos alumnos van a ser? ";
Leer N;
Mientras contador<=N Hacer
Escribir "Introduce el numero de control y nombre del alumno ",contador, ":";
Leer N_Control,Nombre;
Escribir "Introduce las 5 calificaciones";
Leer c1,c2,c3,c4,c5;
promedio<-(c1+c2+c3+c4+c5)/5;
Escribir " BOLETA DE CALIFICACIONES CON PROMEDIO";
Escribir "Numero de control: ", N_Control, " Nombre del alumno: ",Nombre;
Escribir "Calificaciones: ";
Escribir " ",c1;
Escribir " ",c2;
Escribir " ",c3;
Escribir " ",c4;
Escribir " ",c5;
Escribir " ";
Escribir "Promedio final ",promedio;
Si promedio>=6 Entonces
Escribir " APROBADO";
Sino
Escribir " REPROBADO";
FinSi
contador<-contador + 1;
FinMientras
De Otro Modo:
Escribir "Opcion equivocada";
FinSegun
FinPara
FinProceso

Men de Opciones

Proceso Opciones
Repetir
Limpiar Pantalla;
Escribir "MENU DE OPCIONES";
Escribir "1. rea triangulo";
Escribir "2. rea Circulo";
Escribir "3. rea Rectngulo";
Escribir "4. rea Cuadrado";
Escribir "5. Salir";
Escribir "Introduce un numero de opcin";
Leer opcin;
Segn opcin Hacer
1:
Escribir "Digite la base del tringulo";
Leer B;
Escribir "Digite la Altura del tringulo";
Leer H;
A<-B*H/2;
Escribir "El rea del tringulo es ",A;

2:
Escribir "Digite el radio del circulo";

Leer R;
AC<-PI*(R*R);
Escribir "El rea del tringulo es ",AC;

3:
Escribir "Digite la base del Rectngulo";
Leer B;
Escribir "Digite la Altura del Rectngulo";
Leer H;
A<-B*H;
Escribir "El rea del Rectngulo es ",A;
4:
Escribir "Digite un lado del Cuadrado";
Leer B;
A<-B*B;
Escribir "El rea del Cuadrado es ",A,"cm^2";
5:
Escribir "Gracias por utilizar este programa";
De Otro Modo:
De Otro Modo:
Escribir "Opcin equivocada";
FinSegun
Esperar tecla;
Hasta Que opcin = 5
FinProceso