Sunteți pe pagina 1din 15

show interfaces trunk

show spanning-tree
show vlan brief
show vtp status
show standby brief
show ip route
Show mac-address command
show storm-control
sho storm-control f0/6 unicast
sho storm-control f0/6 broadcast
sho storm-control f0/6 multicast
show port-security
sho port-security interface f0/6
show errdisable recovery
show ip dhcp snooping
(HOSTA: 172.16.100.101/24, DFG 172.16.100.1;
HOSTB: 172.16.200.101/24, DFG 172.16.200.1).
(Also is DHCP)For this lab, the AAA server will be a
radius server on Host C (172.16.99.50)
connected to DLS1's F0/6 interface.
Configure PC-C to with the 172.16.99.50
with a default-gateway of 172.16.99.1.
Ensure that PC-C has connectivity to
the gateway and all four switches.
##DHCP
ip
ip
ip
ip
!
ip

dhcp
dhcp
dhcp
dhcp

excluded-address
excluded-address
excluded-address
excluded-address

172.16.99.1 172.16.99.150
172.16.100.1 172.16.100.150
172.16.150.1 172.16.150.150
172.16.200.1 172.16.200.150

dhcp pool VLAN99_DHCP


network 172.16.99.0 255.255.255.0
dns-server 99.99.99.99
default-router 172.16.99.1

!
ip dhcp pool VLAN100_DHCP
network 172.16.100.0 255.255.255.0
dns-server 99.99.99.99
default-router 172.16.100.1
ip dhcp pool VLAN150_DHCP
network 172.16.150.0 255.255.255.0
dns-server 99.99.99.99
default-router 172.16.150.1
ip dhcp pool VLAN200_DHCP
network 172.16.200.0 255.255.255.0
dns-server 99.99.99.99
default-router 172.16.200.1
###AAA###
!!Do all Switches!!
aaa new-model
user admin privilege 15 password cisco12345
radius server RADIUS

address ipv4 172.16.99.50 auth-port 1812 acct-port 1813


key WinRadius
exit
aaa authentication login REMOTE-CONTROL group radius local
line vty 0 4
login authentication REMOTE-CONTROL
exit
####Also####
Repeat the below configuration on all unused switch ports on ALL switches.
ALS1(config)# interface range fa0/1
5, f0/14-16, gi0/1-2
ALS1(config-if-range)# switchport mode access
ALS1(config-if-range)# switchport access vlan 999
ALS1(config-if-range)# shutdown
ALS1(config)# vlan 999
ALS1(config-vlan)# state suspend

DLS1#show run
Building configuration...
Current configuration : 2460 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname DLS1
!
boot-start-marker
boot-end-marker
!
!
!
!!
vtp mode Server
vtp version 2
ip routing
!
!
no aaa new-model
system mtu routing 1500
ip routing
ip dhcp relay information trust-all
!
!
!
!
!
!
!
!
DLS1(config)#spanning-tree vlan 99,100 root primary
DLS1(config)#spanning-tree vlan 200 root secondary

!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 99-100 priority 24576
spanning-tree vlan 200 priority 28672
!
vlan internal allocation policy ascending
!
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
switchport trunk encapsulation dot1q
switchport trunk native vlan 666
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet0/8
switchport trunk encapsulation dot1q
switchport trunk native vlan 666
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet0/9
switchport trunk encapsulation dot1q
switchport trunk native vlan 666
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet0/10
switchport trunk encapsulation dot1q
switchport trunk native vlan 666
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet0/11
switchport trunk encapsulation dot1q
switchport trunk native vlan 666
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet0/12
switchport trunk encapsulation dot1q
switchport trunk native vlan 666
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet0/13

!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan99
ip address 172.16.99.3 255.255.255.0
standby 99 ip 172.16.99.1
standby 99 priority 150
standby 99 preempt
!
interface Vlan100
ip address 172.16.100.3 255.255.255.0
standby 100 ip 172.16.100.1
standby 100 priority 150
standby 100 preempt
!
interface Vlan200
ip address 172.16.200.3 255.255.255.0
standby 200 ip 172.16.200.1
standby 200 preempt
!
ip classless
ip http server
ip http secure-server
!
!
!
!
!
line con 0
line vty 5 15
!
end

DLS1#
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@

DLS2#show run
Building configuration...
Current configuration : 2435 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname DLS2
!
boot-start-marker
boot-end-marker
!
!
!
ip routing
!
no aaa new-model
system mtu routing 1500
ip routing
ip dhcp relay information trust-all
!
!
!
!
!
!
DLS2(config)#spanning-tree vlan 99,100 root secondary
DLS2(config)#spanning-tree vlan 200 root primary
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 99-100 priority 28672
spanning-tree vlan 200 priority 24576
!
vlan internal allocation policy ascending
!
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4

!
interface FastEthernet0/5
!
interface FastEthernet0/6
shutdown
!
interface FastEthernet0/7
switchport trunk encapsulation dot1q
switchport trunk native vlan 666
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet0/8
switchport trunk encapsulation dot1q
switchport trunk native vlan 666
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet0/9
switchport trunk encapsulation dot1q
switchport trunk native vlan 666
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet0/10
switchport trunk encapsulation dot1q
switchport trunk native vlan 666
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet0/11
switchport trunk encapsulation dot1q
switchport trunk native vlan 666
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet0/12
switchport trunk encapsulation dot1q
switchport trunk native vlan 666
switchport mode trunk
switchport nonegotiate
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!

interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
!
interface Vlan99
ip address 172.16.99.4 255.255.255.0
standby 99 ip 172.16.99.1
standby 99 preempt
!
interface Vlan100
ip address 172.16.100.4 255.255.255.0
standby 100 ip 172.16.100.1
standby 100 preempt
!
interface Vlan200
ip address 172.16.200.4 255.255.255.0
standby 200 ip 172.16.200.1
standby 200 priority 150
standby 200 preempt
!
ip classless
ip http server
ip http secure-server
!
!
!
!
!
line con 0
line vty 5 15
!
end
DLS2#
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@

ALS1#show run
Building configuration...
Current configuration : 6143 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!

hostname ALS1
!
boot-start-marker
boot-end-marker
!
!
!
!
no aaa new-model
system mtu routing 1500
!
!
!!
vtp mode client
!
!
ip dhcp snooping vlan 100,200
ip dhcp snooping
!
!
!
!
!
!
errdisable recovery cause psecure-violation
errdisable recovery interval 30
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
switchport access vlan 200
switchport mode access
switchport port-security maximum 2
switchport port-security
switchport port-security mac-address sticky
storm-control broadcast level pps 1k 300
storm-control multicast level 40.00 25.00
storm-control unicast level 65.00 35.00
storm-control action trap
spanning-tree portfast
ip dhcp snooping limit rate 20
!
interface FastEthernet0/7
switchport trunk native vlan 666
switchport mode trunk

switchport nonegotiate
ip dhcp snooping trust
!
interface FastEthernet0/8
switchport trunk native vlan 666
switchport mode trunk
switchport nonegotiate
ip dhcp snooping trust
!
interface FastEthernet0/9
switchport trunk native vlan 666
switchport mode trunk
switchport nonegotiate
ip dhcp snooping trust
!
interface FastEthernet0/10
switchport trunk native vlan 666
switchport mode trunk
switchport nonegotiate
ip dhcp snooping trust
!
interface FastEthernet0/11
switchport trunk native vlan 666
switchport mode trunk
switchport nonegotiate
ip dhcp snooping trust
!
interface FastEthernet0/12
switchport trunk native vlan 666
switchport mode trunk
switchport nonegotiate
ip dhcp snooping trust
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
switchport access vlan 100
switchport mode access
switchport port-security maximum 2
switchport port-security
switchport port-security mac-address sticky
storm-control broadcast level pps 1k 300
storm-control multicast level 40.00 25.00
storm-control unicast level 65.00 35.00
storm-control action trap
spanning-tree portfast
ip dhcp snooping limit rate 20
!
interface FastEthernet0/16
switchport access vlan 100
switchport mode access
switchport port-security maximum 2
switchport port-security
switchport port-security mac-address sticky
storm-control broadcast level pps 1k 300
storm-control multicast level 40.00 25.00
storm-control unicast level 65.00 35.00
storm-control action trap

spanning-tree portfast
ip dhcp snooping limit rate 20
!
interface FastEthernet0/17
switchport access vlan 100
switchport mode access
switchport port-security maximum 2
switchport port-security
switchport port-security mac-address sticky
storm-control broadcast level pps 1k 300
storm-control multicast level 40.00 25.00
storm-control unicast level 65.00 35.00
storm-control action trap
spanning-tree portfast
ip dhcp snooping limit rate 20
!
interface FastEthernet0/18
switchport access vlan 100
switchport mode access
switchport port-security maximum 2
switchport port-security
switchport port-security mac-address sticky
storm-control broadcast level pps 1k 300
storm-control multicast level 40.00 25.00
storm-control unicast level 65.00 35.00
storm-control action trap
spanning-tree portfast
ip dhcp snooping limit rate 20
!
interface FastEthernet0/19
switchport access vlan 100
switchport mode access
switchport port-security maximum 2
switchport port-security
switchport port-security mac-address sticky
storm-control broadcast level pps 1k 300
storm-control multicast level 40.00 25.00
storm-control unicast level 65.00 35.00
storm-control action trap
spanning-tree portfast
ip dhcp snooping limit rate 20
!
interface FastEthernet0/20
switchport access vlan 100
switchport mode access
switchport port-security maximum 2
switchport port-security
switchport port-security mac-address sticky
storm-control broadcast level pps 1k 300
storm-control multicast level 40.00 25.00
storm-control unicast level 65.00 35.00
storm-control action trap
spanning-tree portfast
ip dhcp snooping limit rate 20
!
interface FastEthernet0/21
switchport access vlan 100
switchport mode access
switchport port-security maximum 2
switchport port-security

switchport port-security mac-address sticky


storm-control broadcast level pps 1k 300
storm-control multicast level 40.00 25.00
storm-control unicast level 65.00 35.00
storm-control action trap
spanning-tree portfast
ip dhcp snooping limit rate 20
!
interface FastEthernet0/22
switchport access vlan 100
switchport mode access
switchport port-security maximum 2
switchport port-security
switchport port-security mac-address sticky
storm-control broadcast level pps 1k 300
storm-control multicast level 40.00 25.00
storm-control unicast level 65.00 35.00
storm-control action trap
spanning-tree portfast
ip dhcp snooping limit rate 20
!
interface FastEthernet0/23
switchport access vlan 100
switchport mode access
switchport port-security maximum 2
switchport port-security
switchport port-security mac-address sticky
storm-control broadcast level pps 1k 300
storm-control multicast level 40.00 25.00
storm-control unicast level 65.00 35.00
storm-control action trap
spanning-tree portfast
ip dhcp snooping limit rate 20
!
interface FastEthernet0/24
switchport access vlan 100
switchport mode access
switchport port-security maximum 2
switchport port-security
switchport port-security mac-address sticky
storm-control broadcast level pps 1k 300
storm-control multicast level 40.00 25.00
storm-control unicast level 65.00 35.00
storm-control action trap
spanning-tree portfast
ip dhcp snooping limit rate 20
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan99
ip address 172.16.99.101 255.255.255.0
!
ip default-gateway 172.16.99.1
ip http server

ip http secure-server
ip sla enable reaction-alerts
!
line con 0
line vty 5 15
!
end
ALS1#
ALS1#
ALS1#
ALS1#

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@

ALS2#show run
Building configuration...
Current configuration : 3534 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ALS2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
system mtu routing 1500
ip subnet-zero
!
!
!!
vtp mode client
!
!
ip dhcp snooping vlan 100,200
ip dhcp snooping
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending

!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
switchport access vlan 200
switchport mode access
switchport port-security
spanning-tree portfast
ip dhcp snooping limit rate 20
!
interface FastEthernet0/7
switchport trunk native vlan 666
switchport mode trunk
switchport nonegotiate
ip dhcp snooping trust
!
interface FastEthernet0/8
switchport trunk native vlan 666
switchport mode trunk
switchport nonegotiate
ip dhcp snooping trust
!
interface FastEthernet0/9
switchport trunk native vlan 666
switchport mode trunk
switchport nonegotiate
ip dhcp snooping trust
!
interface FastEthernet0/10
switchport trunk native vlan 666
switchport mode trunk
switchport nonegotiate
ip dhcp snooping trust
!
interface FastEthernet0/11
switchport trunk native vlan 666
switchport mode trunk
switchport nonegotiate
ip dhcp snooping trust
!
interface FastEthernet0/12
switchport trunk native vlan 666
switchport mode trunk
switchport nonegotiate
ip dhcp snooping trust
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!

interface FastEthernet0/15
switchport access vlan 200
switchport mode access
switchport port-security
spanning-tree portfast
ip dhcp snooping limit rate
!
interface FastEthernet0/16
switchport access vlan 200
switchport mode access
switchport port-security
spanning-tree portfast
ip dhcp snooping limit rate
!
interface FastEthernet0/17
switchport access vlan 200
switchport mode access
switchport port-security
spanning-tree portfast
ip dhcp snooping limit rate
!
interface FastEthernet0/18
switchport access vlan 200
switchport mode access
switchport port-security
spanning-tree portfast
ip dhcp snooping limit rate
!
interface FastEthernet0/19
switchport access vlan 200
switchport mode access
switchport port-security
spanning-tree portfast
ip dhcp snooping limit rate
!
interface FastEthernet0/20
switchport access vlan 200
switchport mode access
switchport port-security
spanning-tree portfast
ip dhcp snooping limit rate
!
interface FastEthernet0/21
switchport access vlan 200
switchport mode access
switchport port-security
spanning-tree portfast
ip dhcp snooping limit rate
!
interface FastEthernet0/22
switchport access vlan 200
switchport mode access
switchport port-security
spanning-tree portfast
ip dhcp snooping limit rate
!
interface FastEthernet0/23
switchport access vlan 200
switchport mode access
switchport port-security

20

20

20

20

20

20

20

20

spanning-tree portfast
ip dhcp snooping limit rate 20
!
interface FastEthernet0/24
switchport access vlan 200
switchport mode access
switchport port-security
spanning-tree portfast
ip dhcp snooping limit rate 20
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan99
ip address 172.16.99.102 255.255.255.0
no ip route-cache
!
ip default-gateway 172.16.99.1
ip http server
ip http secure-server
!
control-plane
!
!
line con 0
line vty 5 15
!
end
ALS2#
ALS2#
ALS2#
ALS2#

S-ar putea să vă placă și