Sunteți pe pagina 1din 11

CCNA4: Commands

WAN Technologies

Cisco Networking Academy Program


CCNA 4: WAN Technologies v3.1.1

CCNA 4 Commands

Page 1 of 11

Created by Tijl De Troyer

Module 1: Scaling IP Addresses_____________________________________________3


1.1

NAT and PAT_____________________________________________________________3

1.1.1
1.1.2
1.1.3
1.1.4
1.1.5

1.2

DHCP___________________________________________________________________5

1.2.1
1.2.2
1.2.3

Configuring static NAT_________________________________________________________3


Configuring dynamic NAT______________________________________________________3
Configuring NAT Overload (PAT)________________________________________________4
Verifying NAT and PAT configuration_____________________________________________4
Troubleshooting NAT and PAT configuration________________________________________4
Configuring DHCP Operation____________________________________________________5
Verifying DHCP Operation______________________________________________________5
Troubleshooting DHCP Configuration_____________________________________________5

Module 3: Point-to-Point Protocol (PPP)_____________________________________6


2.1

Configuring HDLC Encapsulation____________________________________________6

2.2

Troubleshooting a Serial Interface____________________________________________6

2.3

Configuring PPP Encapsulation______________________________________________6

2.4

Configuring PPP Authentication_____________________________________________6

2.5

Verifying the Serial PPP Encapsulation Configuration___________________________7

2.6

Troubleshooting the Serial PPP Encapsulation Configuration_____________________7

Module 3: ISDN and DDR_________________________________________________7


3.1

Configuring ISDN BRI_____________________________________________________7

3.2

Configuring ISDN PRI_____________________________________________________8

3.3

Verifying the ISDN Configuration____________________________________________8

3.4

Troubleshooting the ISDN Configuration______________________________________8

3.5

Defining Static Routes for DDR______________________________________________8

3.6

Specifying Interesting Traffic for DDR________________________________________9

3.7

Configuring DDR Dialer Information_________________________________________9

3.8

Configuring Dialer Profiles__________________________________________________9

3.9

Verifying the DDR Configuration____________________________________________10

Module 5: Frame Relay__________________________________________________10


4.1

Basic Frame Relay Configuration___________________________________________10

4.2

Verifying Operation and Confirming Connectivity_____________________________10

4.3

Configuring Subinterfaces__________________________________________________10

4.4

Configuring Optional Commands___________________________________________11

CCNA 4 Commands

Page 2 of 11

Created by Tijl De Troyer

1 Module 1: Scaling IP Addresses


1.1

1.1.1

NAT and PAT


Configuring static NAT

Router(config)#ip nat inside source static local-ip global-ip


Router(config)#interface type number
//inside interface
Router(config-if)#ip nat inside
Router(config-if)#interface type number
//outside interface
Router(config-if)#ip nat outside
Example:
Router(config)#ip nat inside source static 10.1.1.2 179.9.8.80
Router(config)#interface eth0
//inside interface
Router(config-if)#ip nat inside
Router(config-if)#interface ser0
//outside interface
Router(config-if ip nat outside

1.1.2

Configuring dynamic NAT

Router(config)#ip nat pool name start-ip end-ip {netmask netmask | prefix-length


prefix-length}
Router(config)#access-list access-list-number permit source [source-wildcard]
Router(config)#ip nat inside source list access-list-number pool name
Router(config)#interface type number
//inside interface
Router(config-if)#ip nat inside
Router(config-if)#interface type number
//outside interface
Router(config-if)#ip nat outside
Example:
Router(config)#ip nat pool nat-pool1 179.9.8.80 179.9.8.95 netmask 255.255.255.0
Router(config)#access-list 1 permit 10.0.0.0 0.0.255.255
Router(config)#ip nat inside source list 1 pool nat-pool1
Router(config)#interface eth0
//inside interface
Router(config-if)#ip nat inside
Router(config-if)#interface ser0
//outside interface
Router(config-if)#ip nat outside

CCNA 4 Commands

Page 3 of 11

Created by Tijl De Troyer

1.1.3

Configuring NAT Overload (PAT)

Router(config)#list access-list-number permit source [source-wildcard]


Router(config)#ip nat inside source list access-list-number interface interface
overload
Router(config)#ip nat pool name ip-address {netmask netmask | prefix-length
prefix-length}
Router(config)#ip nat inside source list access-list-number pool name overload
Router(config)#interface type number
//inside interface
Router(config-if)#ip nat inside
Router(config-if)#interface type number
//outside interface
Router(config-if)#ip nat outside
Example:
Router(config)#access-list 1 permit 10.0.0.0 0.0.255.255
Router(config)#ip nat inside source list 1 interface serial0 overload
Router(config)#ip nat pool nat-pool2 179.9.8.20 netmask 255.255.255.240
Router(config)#ip nat inside source list 1 pool nat-pool2 overload
Router(config)#interface eth0
//inside interface
Router(config-if)#ip nat inside
Router(config-if)#interface ser0
//outside interface
Router(config-if)#ip nat outside

1.1.4

Verifying NAT and PAT configuration

clear ip nat translation


clear ip nat translation inside global-ip local-ip [outside local-ip global-ip]
clear ip nat translation protocol inside global-ip global-port local-ip local-port
[outside local-ip local-port global-ip global-port]
show ip nat translations
show ip nat statistics

1.1.5

Troubleshooting NAT and PAT configuration

debug ip nat
debug ip nat detailed

CCNA 4 Commands

Page 4 of 11

Created by Tijl De Troyer

1.2
1.2.1

DHCP
Configuring DHCP Operation

Router(config)#ip dhcp pool name


Router(config-dhcp)#network network-number [mask|/prefix-length]
Router(config-dhcp)#domain-name domain
Router(config-dhcp)#dns-server address [address2address8]
Router(config-dhcp)#netbios-name-server address [address2address8]
Router(config-dhcp)#default-router address [address2address8]
Router(config-dhcp)#lease {days[hours][minutes] | infinite}
Router(config)#ip dhcp excluded-address ip-address [end-ip-address]
If dhcp-client and dhcp-server are not on the same segment, and separated by a router,
the DHCPDISCOVER broadcasts are blocked. By using the helper address feature, a
router can be configured to accept a broadcast request for a UDP service and then
forward it as a unicast to a specific IP address.
Example: Router(config-if)#ip helper-address address

1.2.2

Verifying DHCP Operation

Router#show
Router#show
Router#show
Router#show

1.2.3

ip
ip
ip
ip

dhcp
dhcp
dhcp
dhcp

binding [address]
conflict [address]
database [url]
server statistics

Troubleshooting DHCP Configuration

Router#debug
Router#debug
Router#debug
Router#debug

ip
ip
ip
ip

CCNA 4 Commands

dhcp
dhcp
dhcp
dhcp

server
server events
server packets
server linkage

Page 5 of 11

Created by Tijl De Troyer

2 Module 3: Point-to-Point Protocol (PPP)


In module 2: no commands

2.1

Configuring HDLC Encapsulation

Router(config-if)#encapsulation hdlc

2.2

Troubleshooting a Serial Interface

Router#show interface s0
Router#show controllers s0
Router#debug serial interface
Router#debug arp
Router#debug frame-relay lmi
Router#debug frame-relay events
Router#debug ppp negotiation
Router#debug ppp packet
Router#debug ppp errors
Router#debug ppp chap

2.3

Configuring PPP Encapsulation

Router#config terminal
Router(config)#interface serial 0
Router(config-if)#encapsulation ppp
Router(config-if)#compress [predictor | stac]
Router(config-if)#ppp quality number_1-100
Router(config-if)#ppp multilink

2.4

Configuring PPP Authentication

Router(config)#hostname name
//case sensitive
Router(config)#username name password password
// Router(config)#service password-encryption
Router(config-if)#encapsulation ppp
Router(config-if)#ppp authentication {chap | chap pap | pap chap | pap}
Router#show interface s0
Router(config-if)#ppp chap hostname hostname
Router(config-if)#ppp chap password secret

CCNA 4 Commands

Page 6 of 11

Created by Tijl De Troyer

2.5

Verifying the Serial PPP Encapsulation Configuration

Router#show interfaces
Router#debug ppp authentication
Router#undebug all

Troubleshooting the Serial PPP Encapsulation


Configuration

2.6

Router#debug ppp {packet | negotiation |error | chap}

3 Module 3: ISDN and DDR


3.1

Configuring ISDN BRI

Router(config)#isdn switch-type switch-type


Router(config-if)#isdn switch-type switch-type

//basic-ni for national ISDN


//this interface only

Router(config)#interface bri interface-number


Router(config-if)#isdn spid1 spid-number [ldn]
Router(config-if)#isdn spid2 spid-number [ldn]

//ldn: local dial number

Router(config)#isdn switch-type none


Example:
Router(config)#isdn switch-type basic-ni
Router(config)#interface bri 0/0
Router(config-if)#isdn spid1 51055540000001 5554000
Router(config-if)#isdn spid1 51055540010001 5554001

CCNA 4 Commands

Page 7 of 11

Created by Tijl De Troyer

3.2

Configuring ISDN PRI

Routers connect to PRI by using T1/E1, there is no interface pri!


Router(config)#isdn switch-type switch-type

//primary-ni for national ISDN

Router(config)#controller {t1 | e1} {slot/port}


Router(config-controller)#framing {sf | esf}
//for T1
Router(config-controller)#framing {crc4 | no-crc4} [australia]
Router(config-controller)#linecode {ami | b8zs | hdb3 }
Router(config-controller)#pri-group [timeslots range]
Router(config)#interface serial {slot/port: | unit:} {23 | 15}

//for E1

Attention: S0/0.23 refers to a subinterface (for example: frame relay, vlans)


S0/0:23 refers to a channel (PRI)

3.3

Verifying the ISDN Configuration

Router#show
Router#show
Router#show
Router#show

3.4

isdn status
interfaces bri0/0
isdn active
dialer

Troubleshooting the ISDN Configuration

Router#debug isdn q921


Router#debug isdn q931

3.5

Defining Static Routes for DDR

Router(config)#ip route net-prefix mask {address | interface} [distance] [permanent]


Example:
Router(config)#ip route 10.40.0.0 255.255.0.0 10.1.0.1
Router(config)#ip route 0.0.0.0 0.0.0.0 10.1.0.2

CCNA 4 Commands

Page 8 of 11

//default route

Created by Tijl De Troyer

3.6

Specifying Interesting Traffic for DDR

Router(config)#dialer-list dialer-group-num protocol protocol-name {permit | deny |


list access-list-number}
Example:
Router(config)#dialer-list 1 protocol ip permit

//without access-list, all ip traffic

Router(config)#dialer-list 1 protocol ip list 101


Router(config)#access-list 101 deny tcp any any eq ftp
Router(config)#access-list 101 deny tcp any any eq telnet
Router(config)#access-list 101 permit ip any any

3.7

//with access-list
//no ftp
//no telnet
//all other ip

Configuring DDR Dialer Information

Router(config)#username username password password


Router(config)#interface bri interface-number
Router(config-if)#encapsulation ppp
Router(config-if)#ppp authentication chap
Router(config-if)#ip address ip-address subnet
Router(config-if)#dialer-group group-number

//same number as with dialer-list

Router(config-if)#dialer map protocol next-hop-address [name hostname]


[speed 56 | 64] [broadcast] dial-string
Example:
Remote(config-if)#dialer map ip 129.30.255.253 name Gent 5551000
Router(config-if)#dialer idle-timeout seconds

3.8

Configuring Dialer Profiles

Router(config)#interface dialer dialer-number


Router(config-if)#ip address ip-address subnet
Router(config-if)#encapsulation ppp
Router(config-if)#ppp authentication chap
Router(config-if)#dialer remote-name remote-name
Router(config-if)#dialer string ldn
Router(config-if)#dialer pool pool-number
Router(config-if)#dialer group group-number
Router(config)#interface bri0/0
Router(config-if)#dialer pool-member number priority priority-number

CCNA 4 Commands

Page 9 of 11

Created by Tijl De Troyer

3.9

Verifying the DDR Configuration

Router#show dialer interface interface


Router#show isdn active
Router#debug ppp authentication
Router#debug ppp negotiation
Router#debug ppp error

4 Module 5: Frame Relay


4.1

Basic Frame Relay Configuration

Router(config)#interface serial interface-number


Router(config-if)#ip address ip-address subnet
Router(config-if)#encapsulation frame-relay [cisco | ietf]
Router(config-if)#frame-relay lmi-type {ansi | cisco | q933i}
Router(config-if)#bandwith kilobits
Router(config-if)#frame-relay inverse-arp [protocol] [dlci]
Router(config-if)#no shutdown

4.2

Verifying Operation and Confirming Connectivity

Router#show
Router#show
Router#show
Router#show

4.3

//11.1 or earlier

frame-relay pvc
interfaces serial
frame-relay map
frame-relay lmi

Configuring Subinterfaces

Router(config)#interface serial number


Router(config-if)#no ip address
Router(config-if)#interface serial number.subinterface-number {multipoint | pointto-point}
Router(config-if)#ip unnumbered interface

//point-to-point and using ip

Router(config-if)#frame-relay interface-dlci dlci-number

CCNA 4 Commands

Page 10 of 11

Created by Tijl De Troyer

4.4

Configuring Optional Commands

Router(config-if)#frame-relay map protocol protocol-address dlci [broadcast] [ietf |


cisco | payload-compress packet-by-packet]
//when inverse arp disabled
Router(config-if)#keepalive number
Router(config-if)#frame-relay local-dlci number

CCNA 4 Commands

Page 11 of 11

Created by Tijl De Troyer

S-ar putea să vă placă și