Sunteți pe pagina 1din 48

Lab Assignment: 4

INWK 6117

Group 2
Vignesh Puli Janardhanan (B00567154)
Alagappan Vairavan (B00566817)
Kanika Poply (B00558593)

Group 3
Srinivas Yadalla (B00564873)
Vignesh Murali (B00571459)
Srinath Jayraman (B00561608)

1. Enable debugging on each router and show the output:

2. Show ip route. Discuss the output?


We can see all four loopbacks in 9R4 routing table.

3. Show ip route < loopback of YR4/XR4> on YR4/XR4. Discuss the output?


It displays the route to 172.16.3.3 from 9R4 i.e. 172.16.2.2

4. Show mpls traffic-eng tunnels. Discuss the output?


This command displays the explicit route followed and information about the tunnel
running from 172.16.1.1 to 172.16.4.4.

5. Show mpls traffic-eng tunnels brief. Discuss the output.


It shows that LSP tunnels are running from 9R1 to 10R1

6. Ping from 10R2 to 9R2


10R2#ping
Protocol [ip]:
Target IP address: 10.1.3.3
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 10.1.21.2
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.3.3, timeout is 2 seconds:
Packet sent with a source address of 10.1.21.2
!!!!!

Ping from 9R2 to 10R2


9r2#ping
Protocol [ip]:
Target IP address: 10.1.3.3
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 10.1.2.2
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.3.3, timeout is 2 seconds:
Packet sent with a source address of 10.1.2.2
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
9r2#

7. Trace route from tunnel head to tunnel end and also the vice versa?
9r2#traceroute
Protocol [ip]:

Target IP address: 10.1.3.3


Source address: 10.1.2.2
Numeric display [n]:
Timeout in seconds [3]:
Probe count [3]:
Minimum Time to Live [1]:
Maximum Time to Live [30]:
Port Number [33434]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Type escape sequence to abort.
Tracing the route to 10.1.3.3
1
2
3
4
5

10.1.12.1 0 msec 0 msec 0 msec


192.168.14.4 0 msec 0 msec 4 msec
192.168.44.14 0 msec 0 msec 4 msec
192.168.41.1 0 msec 0 msec 4 msec
10.1.21.2 0 msec 0 msec *

10R2#traceroute
Protocol [ip]:
Target IP address: 10.1.2.2
Source address: 10.1.3.3
Numeric display [n]:
Timeout in seconds [3]:
Probe count [3]:
Minimum Time to Live [1]:
Maximum Time to Live [30]:
Port Number [33434]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Type escape sequence to abort.
Tracing the route to 10.1.2.2

1 10.1.21.1 0 msec 0 msec 0 msec


2 192.168.141.4 0 msec 0 msec 0 msec
3 192.168.14.1 4 msec 0 msec 0 msec
4 10.1.12.2 4 msec 0 msec *

Trace route for explicitly defined path:


10R2#traceroute
Protocol [ip]:
Target IP address: 10.1.2.2
Source address: 10.1.3.3
Numeric display [n]:
Timeout in seconds [3]:
Probe count [3]:
Minimum Time to Live [1]:
Maximum Time to Live [30]:
Port Number [33434]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Type escape sequence to abort.
Tracing the route to 10.1.2.2

1 10.1.21.1 0 msec 0 msec 0 msec


2 192.168.41.4 0 msec 0 msec 4 msec
3 192.168.44.4 0 msec 0 msec 4 msec
4 192.168.14.1 0 msec 0 msec 4 msec
5 10.1.12.2 0 msec 0 msec *

8. Submit running configuration of all the routers?


Running Configuration on 9S1
9S1(config)#do show run
Building configuration...

Current configuration : 1841 bytes


!

version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 9S1
!
!
no aaa new-model
system mtu routing 1500
vtp domain inwk
vtp mode transparent
ip subnet-zero
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 2
name B
!
vlan 3
name C

!
vlan 4
name D
!
vlan 12,14
!
!
interface GigabitEthernet0/1
switchport access vlan 12
switchport mode access
!
interface GigabitEthernet0/2
switchport access vlan 12
switchport mode access
!
interface GigabitEthernet0/3
shutdown
!
interface GigabitEthernet0/4
switchport mode access
!
interface GigabitEthernet0/5
shutdown
!
interface GigabitEthernet0/6
shutdown
!
interface GigabitEthernet0/7
shutdown

!
interface GigabitEthernet0/8
!
interface GigabitEthernet0/9
shutdown
!
interface GigabitEthernet0/10
!
interface GigabitEthernet0/11
shutdown
!
interface GigabitEthernet0/12
switchport mode access
!
interface GigabitEthernet0/13
!
interface GigabitEthernet0/14
switchport access vlan 14
switchport mode access
!
interface GigabitEthernet0/15
switchport access vlan 14
switchport mode access
!
interface GigabitEthernet0/16
!
interface GigabitEthernet0/17
!
interface GigabitEthernet0/18

!
interface GigabitEthernet0/19
!
interface GigabitEthernet0/20
!
interface GigabitEthernet0/21
!
interface GigabitEthernet0/22
!
interface GigabitEthernet0/23
!
interface GigabitEthernet0/24
shutdown
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface GigabitEthernet0/27
!
interface GigabitEthernet0/28
!
interface Vlan1
no ip address
!
ip classless
ip http server
!
!

control-plane
!
!
line con 0
line vty 5 15
!
!
monitor session 1 source vlan 1 rx
monitor session 1 destination interface Gi0/23
end

Running configuration on 10S1


10s1#sh run
Building configuration...

Current configuration : 1907 bytes


!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 10s1
!
no logging console
!
no aaa new-model
system mtu routing 1500

vtp domain INWK


vtp mode transparent
ip subnet-zero
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 2-4,21,41
!
!
interface GigabitEthernet0/1
switchport access vlan 21
switchport mode access
!
interface GigabitEthernet0/2
switchport access vlan 21
switchport mode access
!
interface GigabitEthernet0/3
shutdown
!
interface GigabitEthernet0/4
switchport access vlan 41

switchport mode access


!
interface GigabitEthernet0/5
shutdown
!
interface GigabitEthernet0/6
shutdown
!
interface GigabitEthernet0/7
shutdown
!
interface GigabitEthernet0/8
shutdown
!
interface GigabitEthernet0/9
shutdown
!
interface GigabitEthernet0/10
shutdown
!
interface GigabitEthernet0/11
shutdown
!
interface GigabitEthernet0/12
switchport mode access
!
interface GigabitEthernet0/13
shutdown
!

interface GigabitEthernet0/14
switchport access vlan 41
switchport mode access
!
interface GigabitEthernet0/15
switchport access vlan 41
switchport mode access
!
interface GigabitEthernet0/16
shutdown
!
interface GigabitEthernet0/17
shutdown
!
interface GigabitEthernet0/18
shutdown
!
interface GigabitEthernet0/19
shutdown
!
interface GigabitEthernet0/20
shutdown
!
interface GigabitEthernet0/21
shutdown
!
interface GigabitEthernet0/22
shutdown
!

interface GigabitEthernet0/23
shutdown
!
interface GigabitEthernet0/24
shutdown
!
interface GigabitEthernet0/25
shutdown
!
interface GigabitEthernet0/26
shutdown
!
interface GigabitEthernet0/27
shutdown
!
interface GigabitEthernet0/28
shutdown
!
interface Vlan1
no ip address
!
ip classless
ip http server
!
!
!
control-plane
!
!

line con 0
line vty 5 15
!
end

Running Configuration on 9R1


9R1#sh run
Building configuration...
Current configuration : 2293 bytes
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 9R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
!
!
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!
mpls traffic-eng tunnels
no mpls ip
!
!
!
!

voice-card 0
!
!
!
!
!
!
license udi pid C3900-SPE100/K9 sn FOC15074H97
hw-module pvdm 0/0
!
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.1.1 255.255.255.255
!
!
interface Tunnel1
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 172.16.4.4
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 6667
tunnel mpls traffic-eng path-option 1 explicit identifier 910
tunnel mpls traffic-eng path-option 2 dynamic
!
no routing dynamic
!
interface GigabitEthernet0/0
ip address 10.1.12.1 255.255.255.0
duplex auto
speed auto
mpls ip
!
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto

!
!
interface GigabitEthernet0/2
ip address 192.168.14.1 255.255.255.0
duplex auto
speed auto
mpls traffic-eng tunnels
mpls ip
!
ip rsvp bandwidth 100000
!
interface Serial0/0/0
no ip address
shutdown
no fair-queue
no clock rate 2000000
!
!
interface Serial0/0/1
no ip address
shutdown
no clock rate 2000000
!
!
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
router-id 172.16.1.1
log-adjacency-changes
network 172.16.1.1 0.0.0.0 area 0
network 192.168.14.0 0.0.0.255 area 0
!
router bgp 1
no synchronization
bgp router-id 172.16.1.1
bgp log-neighbor-changes
neighbor 10.1.12.2 remote-as 10
neighbor 172.16.4.4 remote-as 1
neighbor 172.16.4.4 update-source Loopback0
neighbor 172.16.4.4 next-hop-self
no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
ip explicit-path identifier 910 enable
next-address 172.16.2.2

next-address 172.16.3.3
next-address 172.16.4.4
!
!
!
!
!
nls resp-timeout 1
cpd cr-id 1
!
!
control-plane
!
!
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/2/0
!
voice-port 0/2/1
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end
Running Configuration on 9R2
9r2#sh run
Building configuration...
Current configuration : 1468 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec

no service password-encryption
!
hostname 9r2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 2
ip subnet-zero
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.1.2.2 255.255.255.255
!
interface GigabitEthernet0/0
ip address 10.1.12.2 255.255.255.0
duplex auto
speed auto
media-type rj45
negotiation auto
!
interface GigabitEthernet0/1

no ip address
shutdown
duplex auto
speed auto
media-type rj45
negotiation auto
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
ip address 169.1.24.2 255.255.255.0
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 10
no synchronization
bgp router-id 10.1.2.2
bgp log-neighbor-changes
network 10.1.2.2 mask 255.255.255.255
neighbor 10.1.12.1 remote-as 1
no auto-summary
!
ip classless
!
!
ip http server

no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end
9r2#

Running Configuration on 9R4


9R4#show run
Building configuration...

Current configuration : 1857 bytes


!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!

hostname 9R4
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
no logging console
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 2
ip subnet-zero
ip cef
!
!
!
!
!
no mpls ip
mpls traffic-eng tunnels
voice-card 0
no dspfarm
!
!
!
!
!

!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.2.2 255.255.255.255
!
interface GigabitEthernet0/0
ip address 192.168.44.4 255.255.255.0
duplex auto
speed auto
media-type rj45
negotiation auto
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth 100000
!

interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
media-type rj45
negotiation auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
ip address 192.168.14.4 255.255.255.0
duplex auto
speed auto
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth 100000
!
interface Serial2/0/0
bandwidth 155000
ip address 192.168.141.4 255.255.255.0
mpls traffic-eng tunnels
clock rate 2000000
ip rsvp bandwidth 155000
!

interface Serial2/1/0
no ip address
shutdown
clock rate 2000000
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
router-id 172.16.2.2
log-adjacency-changes
network 172.16.2.2 0.0.0.0 area 0
network 192.168.14.0 0.0.0.255 area 0
network 192.168.44.0 0.0.0.255 area 0
network 192.168.141.0 0.0.0.255 area 0
!
ip classless
!
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!

voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/2/0
!
voice-port 0/2/1
!
voice-port 0/3/0
!
voice-port 0/3/1
!
!
!
!
!
!
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
scheduler allocate 20000 1000
!
End

Running configuration on 10R1


10R1#sh run
Building configuration...

Current configuration : 2506 bytes


!
! Last configuration change at 14:58:28 UTC Tue May 8 2012
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 10R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
!
!
!
no ipv6 cef

ip source-route
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
mpls traffic-eng tunnels
mpls label protocol ldp
!
!
!
!
voice-card 0
!
!
!
!
!
!
license udi pid C3900-SPE100/K9 sn FOC15032SEG
hw-module pvdm 0/0
!
!
!
!

redundancy
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.4.4 255.255.255.255
!
!
interface Tunnel1
ip unnumbered Loopback0
tunnel mode mpls traffic-eng
tunnel destination 172.16.1.1
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth 6667
tunnel mpls traffic-eng path-option 1 explicit identifier 1
tunnel mpls traffic-eng path-option 2 dynamic
!
no routing dynamic
!
interface GigabitEthernet0/0
ip address 10.1.21.1 255.255.255.0
duplex auto

speed auto
mpls traffic-eng tunnels
!
ip rsvp bandwidth 100000
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
interface GigabitEthernet0/2
ip address 192.168.41.1 255.255.255.0
duplex auto
speed auto
mpls traffic-eng tunnels
!
ip rsvp bandwidth 100000
!
interface Serial0/0/0
no ip address
shutdown
no clock rate 2000000
!
!
interface Serial0/0/1
bandwidth 155000
ip address 192.168.141.1 255.255.255.0

mpls traffic-eng tunnels


no clock rate 2000000
!
ip rsvp bandwidth 155000
!
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
log-adjacency-changes
network 172.16.4.4 0.0.0.0 area 0
network 192.168.41.0 0.0.0.255 area 0
network 192.168.141.0 0.0.0.255 area 0
!
router bgp 1
no synchronization
bgp router-id 172.16.4.4
bgp log-neighbor-changes
neighbor 10.1.21.2 remote-as 20
neighbor 172.16.1.1 remote-as 1
neighbor 172.16.1.1 update-source Loopback0
neighbor 172.16.1.1 next-hop-self
no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!

!
ip explicit-path identifier 1 enable
next-address 172.16.3.3
next-address 172.16.2.2
next-address 172.16.1.1
!
!
!
!
!
nls resp-timeout 1
cpd cr-id 1
!
!
control-plane
!
!
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/2/0
!
voice-port 0/2/1
!
!
!
!

!
!
!
gatekeeper
shutdown
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end

Running configuration on 10R2


10R2#sh run
Building configuration...

Current configuration : 1447 bytes


!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 10R2
!
boot-start-marker

boot-end-marker
!
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 2
ip subnet-zero
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!

!
!
!
!
!
!
interface Loopback0
ip address 10.1.3.3 255.255.255.255
!
interface GigabitEthernet0/0
ip address 10.1.21.2 255.255.255.0
duplex auto
speed auto
media-type rj45
negotiation auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
media-type rj45
negotiation auto
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!

interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 20
no synchronization

bgp router-id 10.1.3.3


bgp log-neighbor-changes
network 10.1.3.3 mask 255.255.255.255
neighbor 10.1.21.1 remote-as 1
no auto-summary
!
ip classless
!
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
stopbits 1

line aux 0
stopbits 1
line vty 0 4
login
!
scheduler allocate 20000 1000
!
End
Running configuration on 10R4
10R4#sh run
Building configuration...

Current configuration : 1656 bytes


!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 10R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!

no network-clock-participate slot 2
ip subnet-zero
ip cef
!
!
!
!
!
no mpls ip
mpls traffic-eng tunnels
voice-card 0
no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!

!
!
!
!
interface Loopback0
ip address 172.16.3.3 255.255.255.255
!
interface GigabitEthernet0/0
ip address 192.168.44.14 255.255.255.0
duplex auto
speed auto
media-type rj45
negotiation auto
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth 100000
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
media-type rj45
negotiation auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto

speed auto
!
interface FastEthernet2/1
ip address 192.168.41.4 255.255.255.0
duplex auto
speed auto
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth 100000
!
interface Serial2/0/0
no ip address
shutdown
no fair-queue
!
interface Serial2/1/0
no ip address
shutdown
clock rate 2000000
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
log-adjacency-changes
network 172.16.3.3 0.0.0.0 area 0
network 192.168.41.0 0.0.0.255 area 0
network 192.168.44.0 0.0.0.255 area 0
!
ip classless

!
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/2/0
!
voice-port 0/2/1
!
voice-port 0/3/0
!
voice-port 0/3/1
!
!
!
!
!

!
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
scheduler allocate 20000 1000
!
End

9. How will you describe unequal cost load balancing from this lab?
Unequal cost load balancing in MPLS is done by using 16 hash buckets for next-hop which are
shared in rough rough propostion to configured tunnel bandwidth or load-share value.

10. Capture the output from the sniffer and comment on them?

Path message is contained in RSVP message. The explicit route followed is 192.168.14.4 192.168.141.1 - 172.16.4.4 to destination 172.16.1.1

ICMP echo request from 9R2 to 10R2

ICMP echo reply from 10R2 to 9R2

S-ar putea să vă placă și