Sunteți pe pagina 1din 10

************************************************************************

************************************************************************
***********************************************************************
Step 3: Configure basic settings for each router.
a. Disable DNS lookup.
b. Configure device names as shown in the topology.
c. Assign class as the encrypted privileged EXEC mode password.
d. Assign cisco as the console and vty passwords and enable login.
e. Encrypt the plain text passwords.
f. Configure a MOTD banner to warn users that unauthorized access is prohibited.
g. Configure logging synchronous for the console line.
h. Set the clock rate for all DCE serial interfaces at 128000.
i. Configure the IP addresses as listed in the Addressing Table.
j. Configure OSPF using Process ID 1 and advertise all networks. Ethernet interfaces should be
passive.
k. Create a local database on R3 with the username admin and password cisco with the
privilege level at 15.

hostname R1
enable secret class
line con 0
password cisco
login
line vty 0 4
password cisco
login
exit
service password-encryption
banner motd #
Enter TEXT message. End with the character '#'.
no unauthorized access#
copy run start
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

R1#######
#
Router(config)#Host R1
Router(config)#no ip domain-lookup
Router(config)#enable secret class
Router(config)#line con 0
Router(config)#pass cisco
Router(config)#login
Router(config-line)#logging synchronous
Router(config-line)#history size 100
Router(config-line)#exec-timeout 0 0
Router(config)#line vty 0 4
Router(config)#pass cisco
Router(config)#login
Router(config)#int s0/0/0
Router(config-if)#ip add 192.168.12.2
255.255.255.252
Router(config-if)#clock rate 128000
Router(config-if)#no shut
Router(config)#int g0/0
Router(config-if)#ip add 192.168.1.1 255.255.255.0
Router(config-if)#no shut
router ospf 1
network 192.168.1.0 0.0.0.255 area 0
network 192.168.12.0 0.0.0.3 area 0
passive-interface GigabitEthernet0/0

Step 1: Generate data traffic between R1 and


R3
Telnet from R1 to R3 using the IP address 192.168.3.1. Enter the password cisco to enter the
user EXEC mode. Enter the password class to enable global EXEC mode. Issue the show run
command to generate some Telnet traffic. Keep your Telnet session active for now.

From PC-A, browse to R3 using the 192.168.3.1 IP


address. Login as admin with the password cisco.
Keep the browser open after you have logged into R3.
PC-A, browse to R3 using the 192.168.3.1 IP address
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

R2#######
#
Router(config)#Host R2
Router(config)#no ip domain-lookup
Router(config)#enable secret class
Router(config)#line con 0
Router(config)#pass cisco
Router(config)#login

Router(config-line)#logging synchronous
Router(config-line)#history size 100
Router(config-line)#exec-timeout 0 0
Router(config)#line vty 0 4
Router(config)#pass cisco
Router(config)#login
Router(config)#int s0/0/0
Router(config-if)#ip add 192.168.12.2
255.255.255.252
Router(config-if)#clock rate 128000
Router(config-if)#no shut
Router(config)#int s0/0/1
Router(config-if)#ip add 192.168.23.1
255.255.255.252
Router(config-if)#clock rate 128000
Router(config-if)#no shut
Router(config)#int g0/0
Router(config-if)#ip add 192.168.2.1 255.255.255.0
Router(config-if)#no shut

router ospf 1
network 192.168.2.0 0.0.0.255 area 0
network 192.168.12.0 0.0.0.3 area 0
network 192.168.23.0 0.0.0.3 area 0
passive-interface GigabitEthernet0/0

Step 1: Configure NetFlow capture.


Configure NetFlow data capture on both serial interfaces.
Capture data from ingress and egress packets.
R2(config)# interface s0/0/0
R2(config-if)# ip flow ingress
R2(config-if)# ip flow egress

R2(config-if)# interface s0/0/1


R2(config-if)# ip flow ingress
R2(config-if)# ip flow egress

Step 2: Configure NetFlow data export.


R2(config)# ip flow-export destination 192.168.2.3
9996

Verify the NetFlow configuration.


a. Issue the show ip flow interface command to review the
NetFlow capture interface information.
R2# show ip flow interface
Serial0/0/0
ip flow ingress
ip flow egress
Serial0/0/1
ip flow ingress
ip flow egress

show ip flow export command to review the NetFlow


data export information.
R2# show ip flow export

Step 1: Generate data traffic between R1 and


R3.

Display a summary of the NetFlow accounting statistics.


On R2, issue the show ip cache flow command to display changes
to the summary of NetFlow data, including packet size distribution, IP
flow information, captured protocols, and interface activity. Notice the
protocols now display in the summary data.
R2# show ip cache flow

End the Telnet and browser sessions.


a. Issue the exit command on R1 to disconnect from
the Telnet session to R3.
b. Close the browser session on PC-A.

On R2, issue the clear ip flow stats command


to clear NetFlow accounting statistics.
R2# clear ip flow stats

Re-issue the show ip cache flow command to verify


that the NetFlow accounting statistics have been
reset.
R2# show ip cache flow
Explore NetFlow Collector and Analyzer Software

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

R3#######
#
Router(config)#Host R3
Router(config)#no ip domain-lookup
Router(config)#enable secret class
Router(config)#line con 0
Router(config)#pass cisco
Router(config)#login
Router(config-line)#logging synchronous
Router(config-line)#history size 100
Router(config-line)#exec-timeout 0 0
Router(config)#line vty 0 4
Router(config)#pass cisco
Router(config)#login
Router(config-line)#exit
Router(config)#service password-encryption
Router(config)#int s0/0/0
Router(config-if)#ip add 192.168.23.2
255.255.255.252
Router(config-if)#clock rate 128000
Router(config-if)#no shut
Router(config)#int g0/0

Router(config-if)#ip add 192.168.3.1 255.255.255.0


Router(config-if)#no shut
router ospf 1
network 192.168.3.0 0.0.0.255 area 0
network 192.168.23.0 0.0.0.255 area 0
passive-interface GigabitEthernet0/0

k. Create a local database on R3 with the username


admin and password cisco with the privilege level at
15.
username admin privilege 15 secret cisco

From R3, issue the ping 192.168.1.1 repeat 1000


command to ping the R1 G0/0 interface. This will
generate ICMP traffic through R2.
ping 192.168.1.1 repeat 1000

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

S-ar putea să vă placă și