Sunteți pe pagina 1din 12

Archivo: /home/byron/Escritorio/type a practicos

///Evaluacin de habilidades prcticas de ScaN: OSPF


#####Bilding1
hostname East
no ip domain-lookup
enable secret cisco
line console 0
logging synchronous
password cisco
login
line aux 0
password cisco
login
line vty 0 15
password cisco
login
service password-encryption
banner motd @Authorized acces only!@
interface serial 0/0/0
bandwidth 128
clock rate 12800
ip address 192.168.100.22 255.255.255.252
description 2-Central
ip ospf cost 7500
ip ospf message-digest-key 1 md5 xyz_OSPF
ip ospf authentication message-digest
no shutdown
exit
interface gi 0/0
ip address 192.168.8.1 255.255.255.0
description Manage-1A
no shutdown
interface gi 0/1
ip address 192.168.9.1 255.255.255.0
description Clerk-1C
no shutdown
exit
OSPF
router ospf 1
router-id 1.1.1.1
area 0 authentication message-digest
network 192.168.100.20 0.0.0.3 area 0
network 192.168.8.0 0.0.0.255 area 1
network 192.168.9.0 0.0.0.255 area 1
passive-interface GigabitEthernet0/0
passive-interface GigabitEthernet0/1
no auto-summary
exit
####################
########HQ
hostname Central
no ip domain-lookup
enable secret cisco
line console 0
logging synchronous
password cisco
login

Pgina 1 de 12

Archivo: /home/byron/Escritorio/type a practicos


line aux 0
password cisco
login
line vty 0 15
password cisco
login
service password-encryption
banner motd @Authorized acces only @
ip route 0.0.0.0 0.0.0.0 s0/1/0
interface serial 0/0/0
bandwidth 128
ip address 192.168.100.21 255.255.255.252
description 2-East
ip ospf cost 7500
ip ospf message-digest-key 1 md5 xyz_OSPF
ip ospf authentication message-digest
no shutdown
exit
interface serial 0/0/1
bandwidth 128
ip address 192.168.100.37 255.255.255.252
description 2-West
clock rate 128000
ip ospf message-digest-key 1 md5 xyz_OSPF
ip ospf authentication message-digest
no shutdown
exit
interface serial 0/1/0
bandwidth 128
ip address 203.0.113.18 255.255.255.248
description 2-INTERNET
no shutdown
exit
OSPF
router ospf 1
router-id 2.2.2.2
area 0 authentication message-digest
default-information originate
network 192.168.100.20 0.0.0.3 area 0
network 192.168.100.36 0.0.0.3 area 0
passive-interface Serial0/1/0
no auto-summary
exit
ACCESS LIST
ip access-list standard TELNET-BLOCK
permit host 198.51.100.5
line vty 0 15
access-class TELNET-BLOCK in
interface serial 0/1/0
ip access-group 101 in
exit
#######################
###### SITE 2
hostname West

Pgina 2 de 12

Archivo: /home/byron/Escritorio/type a practicos


no ip domain-lookup
enable secret cisco
line console 0
logging synchronous
password cisco
login
line vty 0 15
password cisco
login
service password-encryption
banner motd @Authorized acces only.@
interface serial 0/0/1
bandwidth 128
ip address 192.168.100.38 255.255.255.252
description 2-Central
ip ospf message-digest-key 1 md5 xyz_OSPF
ip ospf authentication message-digest
no shutdown
interface gi 0/1
no shutdown
interface gi 0/1.2
encapsulation dot1q 2
ip address 10.10.2.1 255.255.255.0
interface gi 0/1.4
encapsulation dot1q 4
ip address 10.10.4.1 255.255.255.0
interface gi 0/1.8
encapsulation dot1q 8
ip address 10.10.8.1 255.255.255.0
interface gi 0/1.15
encapsulation dot1q 15
ip address 10.10.15.1 255.255.255.0
interface gi 0/1.25
encapsulation dot1q 25
ip address 10.10.25.1 255.255.255.0
exit
OSPF
router ospf 1
router-id 3.3.3.3
passive-interface GigabitEthernet0/1
network 192.168.100.36 0.0.0.3 area 0
network 10.10.2.0 0.0.0.255 area 2
network 10.10.4.0 0.0.0.255 area 2
network 10.10.8.0 0.0.0.255 area 2
network 10.10.15.0 0.0.0.255 area 2
no auto-summary
passive-interface g0/1.2
passive-interface g0/1.4
passive-interface g0/1.8
passive-interface g0/1.15
exit
ROUTE SUMMARIZATION
interface serial 0/0/1
ip summary-address eigrp 100 10.10.0.0 255.255.240.0
DHCP
ip dhcp excluded-address 10.10.2.1 10.10.2.5

Pgina 3 de 12

Archivo: /home/byron/Escritorio/type a practicos


ip dhcp excluded-address 10.10.4.1 10.10.4.5
ip dhcp excluded-address 10.10.8.1 10.10.8.5
ip dhcp pool vlan2pool
network 10.10.2.0 255.255.255.0
default-router 10.10.2.1
dns-server 192.168.200.225
ip dhcp pool vlan4pool
network 10.10.4.0 255.255.255.0
default-router 10.10.4.1
dns-server 192.168.200.225
ip dhcp pool vlan8pool
network 10.10.8.0 255.255.255.0
default-router 10.10.8.1
dns-server 192.168.200.225
exit
ACCESS LIST
access-list 1 permit 10.10.15.0 0.0.0.255
interface gi0/1.25
ip access-group 1 out
#######SW-A
hostname Bldg1
no ip domain-lookup
enable secret cisco
line console 0
logging synchronous
password cisco
login
line vty 0 15
password cisco
login
service password-encryption
banner motd @Authorized acces only!@
ip default-gateway 10.10.25.1
vlan 2
name dept1
vlan 4
name dept2
vlan 8
name dept3
vlan 15
name NetAdmin
vlan 25
name manage
vlan 99
name safe
interface vlan 25
ip address 10.10.25.254 255.255.255.0
no shutdown
interface fa0/5
switchport mode acces
switchport acces vlan 2
interface fa0/10
switchport mode acces
switchport acces vlan 4
interface fa0/15

Pgina 4 de 12

Archivo: /home/byron/Escritorio/type a practicos


switchport mode acces
switchport acces vlan 8
interface fa0/24
switchport mode acces
switchport acces vlan 15
interface range fa0/6-9,fa0/11-14,fa0/16-23
switchport mode acces
switchport acces vlan 99
shutdown
interface range gi0/1-2
switchport mode acces
switchport acces vlan 99
shutdown
ETHERCHANNEL
interface range fa0/1-2
channel-group 1 mode active
interface port-channel 1
switchport mode trunk
interface range fa0/3-4
channel-group 2 mode active
interface port-channel 2
switchport mode trunk
exit
PVST+
spanning-tree
spanning-tree
spanning-tree
spanning-tree
spanning-tree

mode
vlan
vlan
vlan
vlan

rapid-pvst
2 root primary
4 root primary
8 root secondary
15 root secondary

SECURITY
interface fa0/5
switchport port-security
switchport port-security violation restrict
switchport port-security maximum 2
switchport port-security mac-address sticky
interface fa0/10
switchport port-security
switchport port-security violation restrict
switchport port-security maximum 2
switchport port-security mac-address sticky
interface fa0/15
switchport port-security
switchport port-security violation restrict
switchport port-security maximum 2
switchport port-security mac-address sticky
interface fa0/24
switchport port-security
switchport port-security violation restrict
switchport port-security maximum 2
switchport port-security mac-address sticky
#######SW-B

Pgina 5 de 12

Archivo: /home/byron/Escritorio/type a practicos


hostname Bldg2
no ip domain-lookup
enable secret cisco
line console 0
logging synchronous
password cisco
login
line vty 0 15
password cisco
login
service password-encryption
banner motd @Authorized acces only!@
SSH
ip ssh version 2
ip domain-name ccnaPTSA.com
crypto key generate rsa
username netadmin password SSH_secret9
line vty 0 4
login local
transport input ssh
line vty 5 15
login local
transport input ssh
ip default-gateway 10.10.25.1
vlan 2
name dept1
vlan 4
name dept2
vlan 8
name dept3
vlan 15
name NetAdmin
vlan 25
name manage
vlan 99
name safe
interface vlan 25
ip address 10.10.25.253 255.255.255.0
no shutdown
interface gi 1/1
switchport mode trunk
ETHERCHANNEL
interface range fa0/3-4
channel-group 2 mode active
interface port-channel 2
switchport mode trunk
interface range fa0/5-6
channel-group 3 mode active
interface port-channel 3
switchport mode trunk
PVST+
spanning-tree mode rapid-pvst
######### SW-C
hostname Bldg3
no ip domain-lookup
enable secret cisco

Pgina 6 de 12

Archivo: /home/byron/Escritorio/type a practicos


line console 0
logging synchronous
password cisco
login
line vty 0 15
password cisco
login
service password-encryption
banner motd @Authorized acces only !@
ip default-gateway 10.10.25.1
vlan 2
name dept1
vlan 4
name dept2
vlan 8
name dept3
vlan 15
name NetAdmin
vlan 25
name manage
vlan 99
name safe
interface vlan 25
ip address 10.10.25.252 255.255.255.0
no shutdown
interface fa0/7
switchport mode acces
switchport acces vlan 2
interface fa0/10
switchport mode acces
switchport acces vlan 4
interface fa0/15
switchport mode acces
switchport acces vlan 8
interface fa0/24
switchport mode acces
switchport acces vlan 15
ETHERCHANNEL
interface range fa0/1-2
channel-group 1 mode active
no shutdown
interface port-channel 1
switchport mode trunk
interface range fa0/5-6
channel-group 3 mode passive
no shutdown
interface port-channel 3
switchport mode trunk
PVST+
spanning-tree
spanning-tree
spanning-tree
spanning-tree
spanning-tree

mode
vlan
vlan
vlan
vlan

rapid-pvst
2 root secondary
4 root secondary
8 root primary
15 root primary

Pgina 7 de 12

Archivo: /home/byron/Escritorio/type a practicos


Port Fast BPDU Guard
interface range fa0/7, fa0/10, fa0/15, fa0/24
spanning-tree portfast
spanning-tree bpduguard enable
no shutdown

////////Evaluacin de habilidades prcticas de RSE


// agregar nslookup domain para 100%
[[Site1]]
enable
conf t
hostname Site-1
enable secret cisco
line con 0
logging synchronous
password cisco
login
exit
line vty 0 15
login
exit
service password-encryption
banner motd Warning!
int s0/0/0
bandwidth 128
ip address 192.168.10.105 255.255.255.252
description [Police and Central]
clock rate 128000
no shutdown
exit
ip route 0.0.0.0 0.0.0.0 s0/0/0
[[HQ]]
enable
conf t
interface Serial0/0/0
bandwidth 128
ip address 192.168.10.106 255.255.255.252
no shutdown
exit
interface Serial0/0/1
bandwidth 128
ip address 192.168.10.114 255.255.255.252
clock rate 128000
no shutdown

Pgina 8 de 12

Archivo: /home/byron/Escritorio/type a practicos


exit
interface g0/0
ip address 192.168.18.41 255.255.255.248
no shutdown
exit
interface Serial0/1/0
ip address 198.51.100.1 255.255.255.240
no shutdown
ip route 0.0.0.0 0.0.0.0 s0/1/0
ip route 192.168.200.0 255.255.252.0 s0/0/1
[[Site2]]
enable
conf t
// agregar la ip de la int s 0/0/0
interface Serial0/0/1
bandwidth 128
ip address 192.168.10.113 255.255.255.252
no shutdown
ip route 0.0.0.0 0.0.0.0 s0/0/1
ip route 192.168.200.0 255.255.252.0 s0/0/0
[[Site1]]
router ospf 10
passive-interface g0/0.45
passive-interface g0/0.47
passive-interface g0/0.101
exit
interface s0/0/0
bandwidth 128
ip ospf cost 7500
exit
[[HQ]]
router ospf 10
router-id 2.2.2.2
network 192.168.10.104 0.0.0.3 area 0
network 192.168.10.112 0.0.0.3 area 0
network 192.168.18.40 0.0.0.7 area 0
passive-interface g0/0
exit
interface s0/0/0
bandwidth 128
ip ospf cost 7500
exit
interface s0/0/1
bandwidth 128
exit
[[Site2]]
router ospf 10
router-id 3.3.3.3
network 192.168.10.112 0.0.0.3 area 0
///// agregarlar las redes ver las redes con do show ip route connected
exit
interface s0/0/1
bandwidth 128
exit

//encender las interfaces de los router que esta apagadas

Pgina 9 de 12

Archivo: /home/byron/Escritorio/type a practicos


[[SW1]]
enable
conf t
vlan 45
name records
exit
vlan 47
name library
exit
vlan 101
name manage
exit
int g0/1
switchport mode trunk
no shutdown
exit
int g0/2
switchport mode trunk
no shutdown
exit
int fa0/10
switchport mode access
switchport access vlan 45
exit
int fa0/15
switchport mode access
switchport access vlan 47
exit
ip default-gateway 192.168.101.1
interface vlan 101
ip address 192.168.101.2 255.255.255.0
exit
int range fa0/1-9, fa0/11-14, fa0/16-24
switchport mode access
shutdown
exit
[[SW2]]
enable
conf t
vlan 45
name records
exit
vlan 47
name library
exit
vlan 101
name manage
exit
int g0/1
switchport mode trunk
no shutdown
exit
int fa0/3
switchport mode access
switchport access vlan 45
exit
int fa0/21
switchport mode access
switchport access vlan 47
exit
ip default-gateway 192.168.101.1

Pgina 10 de 12

Archivo: /home/byron/Escritorio/type a practicos

Pgina 11 de 12

interface vlan 101


ip address 192.168.101.3 255.255.255.0
exit
int range fa0/1-2, fa0/4-20, fa0/22-24
switchport mode access
shutdown
exit
[[Site1]]
ip dhcp excluded-address 192.168.45.1 192.168.45.20
ip dhcp excluded-address 192.168.47.1 192.168.47.20
ip dhcp pool VLAN45
network 192.168.45.0 255.255.255.0
default-router 192.168.45.1
dns-server 192.168.18.100
exit
ip dhcp pool VLAN47
network 192.168.47.0 255.255.255.0
default-router 192.168.47.1
dns-server 192.168.18.100
exit
*****SET CLIENTS TO DHCP*****
[[HQ]]
ip nat inside source static 192.168.18.46 198.51.100.14
interface g0/0
ip nat inside
exit
interface s0/1/0
ip nat outside
exit
ip nat pool INTERNET 198.51.100.3 198.51.100.13 netmask 255.255.255.240
ip nat inside source list 1 pool INTERNET
ip nat inside source static 192.168.18.46 198.51.100.14
ip access-list standard 1
permit 192.168.45.0 0.0.0.255
permit 192.168.47.0 0.0.0.255
permit 192.168.200.0 0.0.3.255
exit
interface Serial0/1/0
ip access-group 101 in
exit
access-list 1 permit 192.168.45.0 0.0.0.255
access-list 1 permit 192.168.47.0 0.0.0.255
access-list 1 permit 192.168.200.0 0.0.3.255
ip access-list standard MANAGE
permit host 203.0.113.18
exit
access-list 101 permit ip host 203.0.113.18 any
access-list 101 permit tcp any host 198.51.100.14 eq www
access-list 101 permit tcp any any established
access-list 101 deny ip any any
line vty 0 15
access-class MANAGE in
password cisco
login
exit
[[Site1]]
interface g0/0
no sh

Archivo: /home/byron/Escritorio/type a practicos


exit
interface g0/0.45
encapsulation dot1Q 45
ip address 192.168.45.1 255.255.255.0
exit
interface g0/0.47
encapsulation dot1Q 47
ip address 192.168.47.1 255.255.255.0
exit
interface g0/0.101
encapsulation dot1Q 101
ip address 192.168.101.1 255.255.255.0
exit

Pgina 12 de 12

S-ar putea să vă placă și