Sunteți pe pagina 1din 3

If Storage Agent is configured add the following lines:

---------------------------------------------------------ENABLELanfree
LANFREECommmethod
LANFREETCPport

YES
TCPIP
1500

Removing the Existing rmt devices:


---------------------------------lsdev -Cctape | grep rmt | xargs -n1 | grep rmt | xargs -n1 rmdev -dl
lsdev -Cctape | grep smc | xargs -n1 | grep smc | xargs -n1 rmdev -dl
Configuring the Storage Agent:
-----------------------------dsmsta setstorageserver myname=<Storage Agent Name>
mypassword=dbstivoli myhladdress=<Storage Agent IP> servername=<TSM
Server Name> serverpassword=dbstivoli hladdress=<TSM Server IP>
lladdress=11500
Listing the serial Numbers:
--------------------------lsdev -Cc tape | awk '{ print $1 }' | while read TAPESS
do
SNs=`lscfg -vpl $TAPESS | grep "Serial Number" | awk '{ print $2 }'`
echo $TAPESS $SNs
done
Installing the ATAPE Drivers for IBM tape Devices:
-------------------------------------------------installp -acXd /tmp/Atape.10.2.80.0.bin Atape.driver

Default AIX (DSM.SYS) file:


---------------------------SErvername
<Server Name>
COMMMethod
TCPip
TCPPort
11500
TCPServeraddress
<TSM Server IP Address>
PASSWORDAccess
Generate
Schedmode
Prompted
NODEName
<Node Name>
TCPClientaddress
<Node IP Address>
TCPClientport
11501
HTTPPort
11581
MANAGEDServices Schedule
SCHEDLOGName
/opt/tivoli/tsm/client/ba/bin/dsmsched.log
ERRORLOGName
/opt/tivoli/tsm/client/ba/bin/dsmerror.log
exclude.backup
/proc
exclude.backup
/opt
exclude.backup
/var/tmp
exclude.backup
/tmp
exclude.backup
/systemlogs
SCHEDLOGRETENTION 14
ERRORLOGRETENTION 14

Script to Define Paths in UNIX Platforms:


----------------------------------------#!/bin/ksh
#
#
# Description: Verify Tape Serial Match for Storage Agent and TSM
Library Manager. This is only for AIX System and for ATL
#
Drives.
#
for TAPE in $(lscfg | grep rmt | awk '{print $2}')
do
SERIAL=$(lscfg -vl ${TAPE} | grep -w Serial | awk -F'.' '{ print $NF
}')
TSMDRIVE=`dsmadmc -id=rakarma -pa=Sahithi123 -commadel "select
drive_name,drive_serial from drives where drive_serial='$SERIAL'" |
grep -i $SERIAL | sed -e '/^ANR/d' | sed -e '/^ANS/d' |awk -F, '
{print $1}'`
TSMSERIAL=`dsmadmc -id=rakarma -pa=Sahithi123 -commadel "select
drive_name,drive_serial from drives where drive_serial='$SERIAL'" |
grep -i $SERIAL | sed -e '/^ANR/d' | sed -e '/^ANS/d' |awk -F, '
{print $2}'`
TSMLIB=`dsmadmc -id=rakarma -pa=Sahithi123 -commadel "select
LIBRARY_NAME,drive_serial from drives where drive_serial='$SERIAL'" |
grep -i $SERIAL | sed -e '/^ANR/d' | sed -e '/^ANS/d' |awk -F, '
{print $1}'`
if [ "$SERIAL" -eq "$TSMSERIAL" ]
then
echo def path `hostname`_STA $TSMDRIVE srctype=server desttype=drive
libr=$TSMLIB device=/dev/$TAPE online=yes
fi
done

Select Command to verify the Device and Serial Numbers on the TSM
server:
-----------------------------------------------------------------------select
tab1.source_name,tab1.destination_name,tab1.device,tab1.online,tab2.d
rive_serial from paths tab1,drives tab2 where
tab1.destination_name=tab2.drive_name and tab1.source_name='SAPMR1
_STA'

checking the storage agent version:


----------------------------------# lslpp -l tivoli.tsm.StorageAgent.*
Fileset
Level

State

Description

--------------------------------------------------------------------------Path: /usr/lib/objrepos
tivoli.tsm.StorageAgent.rte
5.4.1.0 COMMITTED IBM Tivoli Storage
Agent
Runtime

Path: /etc/objrepos
tivoli.tsm.StorageAgent.rte
5.4.1.0

COMMITTED

IBM Tivoli Storage

Agent
Runtime

Secured Copy:
------------scp downloads/* username@penguin.example.net:uploads/
scp SourceFile user@host:directory/TargetFile

Command to get the inventory using Tapeutil:


------------------------------------------tapeutil -f /dev/smc0 inv

S-ar putea să vă placă și