Sunteți pe pagina 1din 13

Following Passwords can be configured on a Router:

Console Password:
CORVIT-R1(config)# line console 0
CORVIT-R1(config-line)# password cisco123
CORVIT-R1(config-line)# login

Auxiliary Password:
CORVIT-R1(config)# line aux 0
CORVIT-R1(config-line)# password cisco123
CORVIT-R1(config-line)# login

Telnet/VTY Password:
CORVIT-R1(config)# line vty 0 871
CORVIT-R1(config-line)# password cisco123
CORVIT-R1(config-line)# login

Enable Mode Password:


CORVIT-R1(config)# enable password cisco

Enable Secret Password:


CORVIT-R1(config)# enable secret ccna

Bringing an Interface Up:

Router# configure terminal


Router(config)# hostname CORVIT-R1
CORVIT-R1(config)# interface serial 1/0
CORVIT-R1(config-if)# ip address 1.1.1.1 255.0.0.0
CORVIT-R1(config-if)# encapsulation hdlc
CORVIT-R1(config-if)# clock rate 64000
CORVIT-R1(config-if)# no shutdown

Router# configure terminal


Router(config)# hostname CORVIT-R2
CORVIT-R2(config)# interface serial 1/0
CORVIT-R2(config-if)# ip address 1.1.1.2 255.0.0.0
CORVIT-R2(config-if)# encapsulation hdlc
CORVIT-R2(config-if)# no shutdown

CCNA (R&S) [200-120] Compiled by: Usama Safdar


To verify whether the links are up or not:

Issue Show ip interface brief command in enable mode

Taking Backup using TFTP server:

Router> enable
Router# configure terminal
Router(config)# hostname CORVIT-R1
CORVIT-R2(config)# interface ethernet 1
CORVIT-R2(config-if)# ip address 10.1.1.5 255.0.0.0
CORVIT-R2(config-if)# no shutdown

Step1: Click on Start Run Type ncpa.cpl Double click on Local Area Connection
Step2: Click on Properties button under General TAB. Step3: Double Click on Internet Protocol Version 4
(TCP/IPv4) .
Step4: Assign an IP address/Subnet Mask with default gateway as mentioned in the figure.
Step5: Run TFTP software to make 10.1.1.1 a TFTP server.

CORVIT-R1# copy running-config tftp

CCNA (R&S) [200-120] Compiled by: Usama Safdar


CORVIT-R1# copy startup-config tftp

CDP (CISCO Discovery Protocol):

CORVIT-R1# show cdp


CORVIT-R1# show cdp neighbors
CORVIT-R1# show cdp neighbors detail

Disabling CDP Globally :


CORVIT-R1(config)# no cdp run

Disabling CDP on Interface :


CORVIT-R1(config)# interface serial 1/0
CORVIT-R1(config-if)# no cdp enable

IP Routing

Static:
CORVIT-R1# configure terminal
CORVIT-R1(config)# ip route 200.100.100.0 255.255.255.0 1.1.1.2

CORVIT-R2# configure terminal


CORVIT-R2(config)#ip route 200.100.50.0 255.255.255.0 1.1.1.1

RIP:
CORVIT-R1(config)# router rip
CORVIT-R1(config-router)# network 1.0.0.0
CORVIT-R1(config-router)# network 200.100.50.0

CORVIT-R2(config)# router rip


CORVIT-R2(config-router)# network 1.0.0.0
CORVIT-R2(config-router)# network 200.100.100.0

RIPv2:
CORVIT-R1# configure terminal
CORVIT-R1(config)# router rip
CORVIT-R1(config)# version 2
CORVIT-R1(config-router)# network 1.0.0.0
CORVIT-R1(config-router)# network 200.100.50.0

CORVIT-R2# configure terminal


CORVIT-R2(config)# router rip
CORVIT-R1(config)# version 2
CORVIT-R2(config-router)# network 1.0.0.0
CORVIT-R2(config-router)# network 200.100.100.0

IGRP:
CORVIT-R1(config)# router igrp 10

CCNA (R&S) [200-120] Compiled by: Usama Safdar


CORVIT-R1(config-router)# network 1.0.0.0
CORVIT-R1(config-router)# network 200.100.50.0

CORVIT-R2(config)# router igrp 10


CORVIT-R2(config-router)# network 1.0.0.0
CORVIT-R2(config-router)# network 200.100.100.0

EIGRP:
CORVIT-R1(config)# router eigrp 10
CORVIT-R1(config-router)# network 1.0.0.0
CORVIT-R1(config-router)# network 200.100.50.0

CORVIT-R2(config)# router eigrp 10


CORVIT-R2(config-router)# network 1.0.0.0
CORVIT-R2(config-router)# network 200.100.100.0

OSPF Single Area:


CORVIT-R1(config)# router ospf 1
CORVIT-R1(config-router)# network 1.0.0.0 0.255.255.255 area 0
CORVIT-R1(config-router)# network 200.100.50.0 0.0.0.255 area 0

CORVIT-R2(config)# router ospf 2


CORVIT-R2(config-router)# network 1.0.0.0 0.255.255.255 area 0
CORVIT-R2(config-router)# network 200.100.100.0 0.0.0.255 area 0

OSPF Multi Area:

CORVIT-R1(config)# router ospf 1


CORVIT-R1(config-router)# network 1.0.0.0 0.255.255.255 area 0
CORVIT-R1(config-router)# network 200.100.50.0 0.0.0.255 area 0

CORVIT-R2(config)#router ospf 1
CORVIT-R2(config-router)#network 1.0.0.0 0.255.255.255 area 0
CORVIT-R2(config-router)#network 200.100.100.0 0.0.0.255 area 1

ACL (Access Control List):

CCNA (R&S) [200-120] Compiled by: Usama Safdar


Standard ACL :
CORVIT-R2(config)# access-list 10 deny 1.1.1.1 0.0.0.0
CORVIT-R2(config)# access-list 10 permit any
OR
CORVIT-R2(config)# access-list 10 deny host 1.1.1.1
CORVIT-R2(config)# access-list 10 permit any

Applying Access List


CORVIT-R2(config)# interface serial 1/1
CORVIT-R2(config-if)# ip access-group 10 in

CORVIT-R2# show access-list

Extended ACL:
CORVIT-R2 (config) # access-list 110 deny tcp 1.1.1.1 0.0.0.0 1.1.1.2 0.0.0.0 eq 23
CORVIT-R2 (config) # access-list 110 permit ip any any

Applying Extended ACL on CORVIT-R2


CORVIT-R2 (config) # interface serial 1/1
CORVIT-R2 (config-if) # ip access-group 110 in

NAT/PAT

Static NAT:
CORVIT(config)# ip nat inside source static 192.168.1.1 1.1.1.2
CORVIT(config)# ip nat inside source static 192.168.1.2 1.1.1.3
CORVIT(config)# ip nat inside source static 192.168.1.3 1.1.1.4

Applying Static NAT


CORVIT(config)# interface fastEthernet 0/0
CORVIT(config-if)# ip nat inside
CORVIT(config)# interface serial 1/1

CCNA (R&S) [200-120] Compiled by: Usama Safdar


CORVIT(config-if)# ip nat outside

Dynamic NAT:
1. Creating Source List using Access List

CORVIT(config)# access-list 10 permit 192.168.1.1


CORVIT(config)# access-list 10 permit 192.168.1.2
CORVIT(config)# access-list 10 permit 192.168.1.3

2. Configuring Dynamic NAT on CORVIT Router

CORVIT(config)# ip nat pool CORVIT 1.1.1.1 1.1.1.3 netmask 255.0.0.0


CORVIT(config)# ip nat inside source list 10 pool CORVIT

3. Applying Dynamic NAT

CORVIT(config)# interface fastEthernet 0/0


CORVIT(config-if)# ip nat inside
CORVIT(config)# interface serial 1/1
CORVIT(config-if)# ip nat outside

PAT (Port Address Translation):

1. Creating Source List using Access List

CORVIT(config)# access-list 20 permit 192.168.1.1


CORVIT(config)# access-list 20 permit 192.168.1.2
CORVIT(config)# access-list 20 permit 192.168.1.3

2. Configuring Dynamic NAT on CORVIT Router

CORVIT(config)# ip nat pool CORVIT 1.1.1.2 1.1.1.2 netmask 255.0.0.0


CORVIT(config)# ip nat inside source list 20 pool CORVIT overload

3. Applying Dynamic NAT

CORVIT(config)# interface fastEthernet 0/0


CORVIT(config-if)# ip nat inside
CORVIT(config)# interface serial 1/1
CORVIT(config-if)# ip nat outside

Verifications:

CORVIT# show ip nat translations


CORVIT# debug ip nat

SWITCHING

CCNA (R&S) [200-120] Compiled by: Usama Safdar


Creating VLAN:

SW-CORVIT# configure terminal


SW-CORVIT(config)# vlan 2
SW-CORVIT(config-vlan)# name Accounts

SW-CORVIT# show vlan


SW-CORVIT# show vlan brief

Access Port:

SW-CORVIT# configure terminal


SW-CORVIT(config)# interface fastEthernet 0/1
SW-CORVIT(config-if)# switchport mode access
SW-CORVIT(config-if)# switchport access vlan 1
SW-CORVIT(config-if)# end

Trunk Port:

Static:
SW-CORVIT(config)# interface gigabitEthernet 0/1
SW-CORVIT(config-if)# switchport trunk encapsulation dot1q
SW-CORVIT(config-if)# switchport mode trunk

Dynamic:
SW-CORVIT(config)# interface gigabitEthernet 0/1
SW-CORVIT(config-if)# switchport trunk encapsulation dot1q
SW-CORVIT(config-if)# switchport mode dynamic desirable

VTP (VLAN Trunking Protocol):

SW-CORVIT# show vtp status

SW-CORVIT(config)# vtp mode client


SW-CORVIT(config)# vtp mode transparent
SW-CORVIT(config)# vtp mode server

STP (Spanning Tree Protocol):

SW-A(config)# interface range gigabitEthernet 0/1 - 2


SW-A(config-if-range)# switchport trunk encapsulation dot1q
SW-A(config-if-range)# switchport mode trunk

SW-B(config)# interface range gigabitEthernet 0/1 - 2

CCNA (R&S) [200-120] Compiled by: Usama Safdar


SW-B(config-if-range)# switchport trunk encapsulation dot1q
SW-B(config-if-range)# switchport mode trunk

Verification :

SW-A# show interfaces trunk


SW-A#show spanning-tree

EXAM LAB 1: EIGRP Lab

Question

Your company has just added R3 router to the existing network. But currently no routing updates are
being exchanged between R3 and the network. All other connectivity, including Internet access are
working properly.

The task is to identify the fault(s) and correct the router configuration to provide full connectivity
between the routers.

All passwords on all routers are set to cisco.

IP addresses are listed in the chart below.

CCNA (R&S) [200-120] Compiled by: Usama Safdar


Solution:

R3#show running-config

R3>enable (you have to enter cisco as its password here)

R3#configure terminal

CCNA (R&S) [200-120] Compiled by: Usama Safdar


R3(config)#no router eigrp 22

R3(config)#router eigrp 212

R3(config-router)#network 192.168.60.0

R3(config-router)#network 192.168.77.0

R3(config-router)#no auto-summary

R3(config-router)#end

R3#copy running-config startup-config

R1#show running-config

R1>enable (you have to enter cisco as its password here)

R1#configure terminal

R1(config)#router eigrp 212

R1(config-router)#network 192.168.77.0

R1(config-router)#end

CCNA (R&S) [200-120] Compiled by: Usama Safdar


R1#copy running-config startup-config

EXAM Lab 2: Extended ACL

Solution:

We should create an access-list and apply it to the interface which is connected to the Server LAN
because it can filter out traffic from both Sw-2 and Core networks. The Server LAN network has been
assigned addresses of 172.22.242.17 172.22.242.30 so we can guess the interface connected to
them has an IP address of 172.22.242.30 (.30 is the number shown in the figure). Use the show
running-config command to check which interface has the IP address of 172.22.242.30.

Corp1#show running-config

CCNA (R&S) [200-120] Compiled by: Usama Safdar


Corp1#configure terminal

Our access-list needs to allow host C 192.168.33.3 to the Finance Web Server 172.22.242.23 via web
(port 80)

Corp1(config)#access-list 100 permit tcp host 192.168.33.3 host 172.22.242.23 eq 80

Deny other hosts access to the Finance Web Server via web

Corp1(config)#access-list 100 deny tcp any host 172.22.242.23 eq 80

All other traffic is permitted

Corp1(config)#access-list 100 permit ip any any

Apply this access-list to Fa0/1 interface (outbound direction)

CCNA (R&S) [200-120] Compiled by: Usama Safdar


Corp1(config)#interface fa0/1
Corp1(config-if)#ip access-group 100 out

Corp1(config-if)#end

Corp1#copy running-config startup-config

CCNA (R&S) [200-120] Compiled by: Usama Safdar

S-ar putea să vă placă și