Sunteți pe pagina 1din 1

EVALUARE INITIALA LA INFORMATICA

CLASA A X-A, PROFIL REAL, TIMP ALOCAT: 30 min

VARIANTA 1
1. Se citesc n, n>5 numere intregi.
a) Sa se calculeze suma i media geometric a acestora. (1p)
b) Sa se calculeze suma numerelor pare. (2p)
a
2. Se citesc numaratorul si numitorul unei fractii . Sa se afiseze fractia
b
simplificata. ( citire=1p, calcul cmmdc=1p, afisare = 1p) (3p)
3. In urma executarii secventei s<-10; pentru i=2,6 pas 2 executa s<-s+i;
sfarsit_pentru; valoarea lui s va fi: ( 1p)

a) 16 b) 22 c) 30
4. Urmatorul algoritm calculeaza a , cu a si b numere naturale. Ce valoare se va
b

afisa pentru a= 20, b=3 ? (2p)


intreg a,b;
citeste a,b;
i<-b; p<-1;
cat timp i>0 executa
p<-p*a;
i<-i-1;
sfarsit_cat_timp;
scrie p;

VARIANTA 2
1. Se citesc n, n>5 numere intregi.
a) Sa se calculeze produsul i media aritmetric a acestora. (1p)
b) Sa se calculeze produsul numerelor impare. (2p)
2. Se citesc n, n>10 numere de la tastatura. Sa afiseze cate sunt divizibile cu 2, cate
sunt divizibile cu 3 si cate divizibile cu 6.
( divizibile cu 2=1p, divizibile cu 3=1p, divizibile cu 6=1p) (3p)
3.In urma executarii secventei i<-3; cat timp i<10 executa i<-i+3; scrie i;
sfarsit_cat_timp; valorile vor fi: ( 1p)

a) 3,6,9 b) 6,9,12 c) 6,9


4.Urmatorul algoritm calculeaza 2 n , cu n numar natural. Ce valoare se va
afisa pentru n= 10 ? Scrieti pasii algoritmului si valorile lui p si i. (2p)
intreg n;
citeste n;
i<-b; p<-1;
cat timp i>0 executa
p<-p*2;
i<-i-1;
sfarsit_cat_timp;
scrie p;

PROFESOR LA DISCIPLINELE DE INFORMATIC


ANDRIAN DASCAL