Sunteți pe pagina 1din 17

Ministerul Educaiei, Culturii i Cercetrii

Universitatea Tehnic a Republicii Moldova

Departamentul Ingineria Software i Automatic

Raport
Lucrarea de laborator Nr.1

la disciplina: Reele de calculatoare

Tema:

A efectuat:

A verificat:
Chiinu 2017

Obiective
Partea 1: Efectuarea configuraiei de baz pentru S1 i S2

Partea 2: Configurarea PC-urile

Partea 3: Configurarea interfeelor de gestionare a comutatoarelor

Figura 1. Conexiunea dispozitivelor

Figura 2. Tabelul de adresare

Partea 1: Configurarea configuraiei de baz pentru S1 i S2


Executm paii urmtori pentru S1 i S2.
Pasul 1: Configurm S1 cu un nume de gazd (hostname).

Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname S1

Pasul 2: Configurarea parolei de consol i parolei a modului priveligiat EXEC.

S1(config)#enable secret class


S1(config)#line console 0
S1(config-line)#password cisco

Pasul 3: Verificm configuraiile de parole pentru S1.

S1(config)#do show run

hostname S1
!
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1
!
line con 0
password cisco
login
!

Pasul 4: Configurm un banner MOTD.

S1(config)#banner motd #
Enter TEXT message. End with the character '#'.
Authorized access only.Violators will be prosecuted to the full extent of the law.#

Pasul 5: Salvm fiierul de configurare n NVRAM.

S1#copy running-config startup-config


Destination filename [startup-config]?
Building configuration...
[OK]

Pasul 6: Repetm paii 1 pna la 5 pentru S2.

Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname S2
S2(config)#enable secret class
S2(config)#line console 0
S2(config-line)#password cisco
S2(config-line)#login
S2(config-line)#exit
S2(config)#do show run
Building configuration...

Current configuration : 1144 bytes


!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname S2
!
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1
!
!
line con 0
password cisco
login
!
S2(config)#banner m
S2(config)#banner motd #
Enter TEXT message. End with the character '#'.
Authorized access only.Violators will be prosecuted to the full extent of the law.#

S2#copy running-config st
S2#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

Partea 2: Configurarea PC-urile


Configurm PC1 i PC2 cu adresele IP.

Pasul 1: Configurm ambele PC-uri cu adresele IP.


Figura 3. Configurarea adresei IP pentru PC1

Figura 4. Configurarea adresei IP pentru PC2.

Pasul 2: Verificm conectivitatea la comutatoare.


Figura 5. Verificrea conectrii PC1 cu S1.

Partea 3: Configurarea interfeelor de gestionare a comutatoarelor


Configurm S1 i S2 cu o adres IP.

Pasul 1: Configurm S1 cu o adres IP.

Authorized access only.Violators will be prosecuted to the full extent of the law.

User Access Verification

Password:

S1>en
S1>enable
Password:
S1#conf t
S1#conf terminal
Enter configuration commands, one per line. End with CNTL/Z.
S1(config)#interface vlan 1
S1(config-if)#ip ad
S1(config-if)#ip address 192.168.1.253 255.255.255.0
S1(config-if)#no shutdown

S1(config-if)#
%LINK-5-CHANGED: Interface Vlan1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up

Pasul 2: Configurm S2 cu o adres IP.

Authorized access only.Violators will be prosecuted to the full extent of the law.
User Access Verification

Password:

S2>en
S2>enable
Password:
S2#conf t
S2#conf terminal
Enter configuration commands, one per line. End with CNTL/Z.
S2(config)#interface vlan 1
S2(config-if)#ip ad
S2(config-if)#ip address 192.168.1.254 255.255.255.0
S2(config-if)#no shutdown

S2(config-if)#
%LINK-5-CHANGED: Interface Vlan1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up

Pasul 3: Verificm configuraia adresei IP pentru S1 i S2.

S1#show ip int
S1#show ip interface b
S1#show ip interface brief

S2#show ip int
S2#show ip interface br
S2#show ip interface brief

Pasul 4: Salvm configuraiile pentru S1 i S2 n NVRAM.

S1#copy running-config st
S1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

S2#copy running-config st
S2#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Pasul 5: Verificm conectivitatea la reea.

Figura 4. Ping the IP addres for PC2.

Figura 6. Ping the IP address for S1.


Figura 7. Ping the address for S2.

Obiective
Configurarea hostnames i adreselor IP pentru cele dou switch-uri Cisco Internetwork
Operating System (IOS) utiliznd interfaa de linie de comand (CLI).

Utiliznd comenzile Cisco IOS pentru a specifica sau limita accesul la configuraiile
dispozitivelor.

Utilizarea comenzilor IOS pentru a salva configuraia care ruleaz.

Configurarea dispozitivelor gazd cu adrese IP.

Verificarea conectivitii dintre cele dou PC-uri i dispozitive terminale.

Cerine
De utilizat o conexiune consol pentru a accesa fiecare switch.

De denumit switch-urile ASw-1 i ASw-2.

De utilizat parola 8ubRu pentru toate liniile.


De utilizat porola secret C9WrE.

De criptat toate parolele de text.

Includerea cuvntului warning n bannerul MOTD (Message-of-the-Day).

Configurarea adreselor pentru toate dispozitivele conform tabelului de adresare.

Salvarea configurailor.

Verificarea conectivitii ntre toate dispozitivele.

Figura 8. Tabelul de adresare

Figura 9. Conexiunile consol pentru fiecare switch

Configurarea switch-lui ASw-1

Configurm cu un nume de gazd (hostname)

Switch>en
Switch>enable
Switch#conf t
Switch#conf terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname ASw-1

Configurarea parolei de consol i parolei a modului priveligiat.


ASw-1(config)#enable secret C9WrE
ASw-1(config)#line con
ASw-1(config)#line console 0
ASw-1(config-line)#password 8ubRu
ASw-1(config-line)#login
ASw-1(config-line)#exit
ASw-1(config)#line v
ASw-1(config)#line vty 0 15
ASw-1(config-line)#password 8ubRu
ASw-1(config-line)#login
ASw-1(config-line)#exit
ASw-1(config)#do show run

!
line con 0
password 8ubRu
login
!
line vty 0 4
password 8ubRu
login
line vty 5 15
password 8ubRu
login
Criptarea parolelor
ASw-1(config)#se
ASw-1(config)#service p
ASw-1(config)#service password-encryption
ASw-1(config)#do show run
Building configuration...

!
hostname ASw-1
!
enable secret 5 $1$mERr$SaNwwC5v8zEgCJlbT5gY8.
!
!
line con 0
password 7 0879594C3B0C
login
!
line vty 0 4
password 7 0879594C3B0C
login
line vty 5 15
password 7 0879594C3B0C
login
!

Includerea cuvntului warning n banner MOTD


ASw-1(config)#bannet m
ASw-1(config)#banner m
ASw-1(config)#banner motd #
Enter TEXT message. End with the character '#'.
warning#

Configurarea adreselor conform tabelului de adresare


ASw-1(config)#int
ASw-1(config)#interface v
ASw-1(config)#interface vlan 1
ASw-1(config-if)#ip add
ASw-1(config-if)#ip address 172.16.5.35 255.255.255.0
ASw-1(config-if)#no shutdown

Figura 10. Configurarea adresei IP i MAC pentru host User-1

ASw-1(config-if)#
%LINK-5-CHANGED: Interface Vlan1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up


ASw-1(config)#^Z
ASw-1#
%SYS-5-CONFIG_I: Configured from console by console

Salvarea configuraiilor executate


ASw-1#copy r
ASw-1#copy running-config st
ASw-1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

Configurarea switch-lui ASw-2

Configurm cu un nume de gazd (hostname)

Switch>en
Switch>enable
Switch#conf t
Switch#conf terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname ASw-2

Configurarea parolei de consol i parolei a modului priveligiat.


ASw-2(config)#enable secret C9WrE
ASw-2(config)#line cons
ASw-2(config)#line console 0
ASw-2(config-line)#password 8ubRu
ASw-2(config-line)#login
ASw-2(config-line)#exit
ASw-2(config)#line v
ASw-2(config)#line vty 0 15
ASw-2(config-line)#password 8ubRu
ASw-2(config-line)#login
ASw-2(config-line)#exit
ASw-2(config)#do show run
Building configuration...
!
line con 0
password 8ubRu
login
!
line vty 0 4
password 8ubRu
login
line vty 5 15
password 8ubRu
login
!

Criptarea parolelor
ASw-2(config)#service password-encryption
ASw-2(config)#do show run
Building configuration...

!
line con 0
password 7 0879594C3B0C
login
!
line vty 0 4
password 7 0879594C3B0C
login
line vty 5 15
password 7 0879594C3B0C
login
!

Includerea cuvntului warning n banner MOTD


ASw-2(config)#banner m
ASw-2(config)#banner motd #
ASw-2(config)#banner motd #
Enter TEXT message. End with the character '#'.
warning#
Configurarea adreselor conform tabelului de adresare
ASw-2(config)#int
ASw-2(config)#interface v
ASw-2(config)#interface vlan 1
ASw-2(config-if)#ip add
ASw-2(config-if)#ip address 172.16.5.40 255.255.255.0
ASw-2(config-if)#no shutdown
Figura 11. Configurarea adresei IP i MAC pentru host User-2

ASw-2(config-if)#
%LINK-5-CHANGED: Interface Vlan1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up

Salvarea configuraiilor executate


ASw-2#copy r
ASw-2#copy running-config st
ASw-2#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

Verificarea conectivitii ntre toate dispozitivele.


Figura 12. Conectivitatea ntre dispozitive