Sunteți pe pagina 1din 14

URRUNAGA ESPINOZA

DIEGO ANDRES
1.- Con lo visto en clase, realice los siguientes problemas con la herra-
mienta Pseint [Nivel 1].
a) Cree un programa donde pida su edad, pero que salga una alerta en
caso ingrese un numero negativo o mayor de 100 años

1 Algoritmo PRÁCTICA1A
2 Denir edad Como Entero
3 Escribir ÏNGRESE SU EDAD:"
4 leer edad;
5 si (edad <0 O edad >100)
6 Escribir "dato invalido"
7 SiNo
8 escribir "su edad es" edad
9 FinSi
10 FinAlgoritmo

b) Cree un programa donde pida ingresar 5 notas, y que salga una alerta
en caso no ingrese un número de [0, 20] y dar un promedio de dichas notas.

1 Algoritmo tarea1b
2 DEFINIR NOTA1 COMO REAL
3 DEFINIR NOTA2 COMO REAL
4 DEFINIR NOTA3 COMO REAL
5 DEFINIR NOTA4 COMO REAL
6 DEFINIR NOTA5 COMO REAL
7 DEFINIR PROMEDIO COMO REAL
8 ESCRIBIR ÏNGRESE NOTA 1:"
9 LEER NOTA1

1
2

10 SI (NOTA1<= 20 Y NOTA1>=0)
11 ESCRIBIR ÏNGRESE NOTA 2:"
12 LEER NOTA2
13 SI (NOTA2<= 20 Y NOTA2>=0)
14 ESCRIBIR ÏNGRESE NOTA 3:"
15 LEER NOTA3
16 SI (NOTA3<= 20 Y NOTA3>=0)
17 ESCRIBIR ÏNGRESE NOTA 4:"
18 LEER NOTA4
19 SI (NOTA4<= 20 Y NOTA4>=0)
20 ESCRIBIR ÏNGRESE NOTA 5:"
21 LEER NOTA5
22 SI (NOTA5<= 20 Y NOTA5>=0)
23 ESCRIBIR "SU PROMEDIO ES:"
24 PROMEDIO<-(NOTA1+NOTA2+NOTA3+NOTA4+NOTA5)/5
25 Escribir PROMEDIO;
26 SiNo
27 ESCRIBIR "NOTA INVALIDAD"
28 FinSi
29 SiNo
30 ESCRIBIR "NOTA INVALIDAD"
31 FinSi
32 SiNo
33 ESCRIBIR "NOTA INVALIDAD"
34 FinSi
35 SiNo
36 ESCRIBIR "NOTA INVALIDAD"
37 FinSi
38 SiNo
39 ESCRIBIR "NOTA INVALIDAD"
40 FinSi
41 FINALGORITMO

c)Cree un programa donde use el item 1a y diga si es menor o mayor de


edad

1 Algoritmo PRACTICA1C
2 Denir edad Como Entero
3 Escribir ÏNGRESE SU EDAD:"
3

4 leer edad;
5 si (edad <0 O edad >100)
6 Escribir "dato invalido"
7 SiNo
8 si (edad >= 18)
9 Escribir .eres mayor de edad"
10 sino
11 escribir .eres menor de edad"
12 FinSi
13 FinSi
14 FinAlgoritmo

d) Cree un programa donde pida la suma de los primeros 10 números


primos

1 Algoritmo Práctica1d
2 denir num Como Entero
3 denir cont Como Entero
4 denir divnum Como Entero
5 num<-0
6 Mientras (num<=30)
7 divnum<-0
8 para cont<-1 hasta 30 con paso 1 Hacer
9 si (num mod cont ==0)
10 divnum<-divnum + 1
11 FinSi
12 FinPara
13 si (divnum =2)
14 escribir num
15 FinSi
16 num<-num + 1
17 FinMientras
18 FinAlgoritmo

e) Cree un programa donde pida ingresar un número N y que imprima


los N-esimos términos de la sucesión de
bonacci 1 1 2 3 5 8 13 21...

1 Algoritmo práctica1e
2 Denir a como entero
4

3 Denir b Como Entero


4 denir cont Como Entero
5 denir limit como entero
6 cont<-0
7 a<-1
8 b<-0
9 escribir "MOSTRAR LOS N-ESIMOS NÚMEROS DE FIBONACCI"
10 ESCRIBIR "N:"
11 leer limit
12 Mientras (cont<limit)
13 a<-a+b
14 cont<-cont+1
15 Escribir a
16 si (cont <limit)
17 b<-a+b
18 cont<-cont + 1
19 escribir b
20 FinSi
21 FinMientras
22 FinAlgoritmo

f ) Cree un programa donde pida ingresar un número N y de como resul-


tado la suma de los N primeros números naturales

1 Algoritmo práctica1f
2 Denir num como entero
3 denir suma Como Entero
4 Escribir "digite el valor de n para la suma de los n numeros naturales:"
5 leer num
6 suma<-num*(num+1)/2
7 Escribir "la suma es:"suma;
8 FinAlgoritmo

g) Cree un programa donde pida ingresar un número N y de como resul-


tado la suma de los N primeros números pares

1 Algoritmo práctica1g
2 Denir num como entero
3 denir suma Como Entero
4 Escribir "digite el valor de n para la suma de los n numeros pares:"
5

5 leer num
6 suma<-num*(num+1)
7 Escribir "la suma es:"suma;
8 FinAlgoritmo

h) Cree un programa donde pida ingresar un número N y de como resul-


tado la suma de los N primeros números impares

1 Algoritmo practica1h
2 Denir num como entero
3 denir suma Como Entero
4 Escribir "digite el valor de n para la suma de los n numeros impares:"
5 leer num
2
6 suma<-num
7 Escribir "la suma es:"suma;
8 FinAlgoritmo

i ) Cree un programa donde pida ingresar un número N y de como resul-


tado la suma de los N primeros números al cuadrado

1 Algoritmo práctica1i
2 Denir num como entero
3 denir suma Como Entero
4 Escribir"digite n para sumar los n primeros numeros al cuadrado:"
5 leer num
6 suma<-num*(num+1)*(2*num+1)/6
7 Escribir "la suma es:"suma;
8 FinAlgoritmo

2. Con lo visto en clase, realice los siguientes problemas con la herramienta


Pseint [Nivel 2].

a) Cree un programa que imprima los 40 primeros números primos

1 Algoritmo práctica2a
2 denir num Como Entero
3 denir cont Como Entero
4 denir divnum Como Entero
5 num<-0
6 Mientras (num<=174)
7 divnum<-0
8 para cont<-1 hasta 174 con paso 1 Hacer
6

9 si (num mod cont ==0)


10 divnum<-divnum + 1
11 FinSi
12 FinPara
13 si (divnum =2)
14 escribir num
15 FinSi
16 num<-num + 1
17 FinMientras
18 FinAlgoritmo

b) Cree un programa donde ingrese un número N y luego imprima los


N-esimos números primos

1 Algoritmo práctica2b
2 denir num Como Entero
3 denir cont Como Entero
4 denir divnum Como Entero
5 denir limitador como entero
6 denir contadorp como entero
7 escribir "digite n para obtener los n-ésimos números primos"
8 leer limitador
9 limitador<-limitador
10 contadorp<-0
11 Mientras (num >=0 y contadorp<limitador)
12 divnum<-0
13 para cont<-1 hasta num con paso 1 Hacer
14 si (num mod cont ==0)
15 divnum<-divnum + 1
16 FinSi
17 FinPara
18 si (divnum =2)
19 contadorp<-contadorp+1
20 FinSi
21 si (divnum=2)
22 Escribir num
23 FinSi
24 num<-num + 1
25 FinMientras
7

26 FinAlgoritmo

c) Cree un programa donde use el item 2b y pregunte si desea [si/no]


seguir con el programa

Algoritmo práctica2c
denir num Como Entero
denir cont Como Entero
denir divnum Como Entero
denir limitador como entero
denir contadorp como entero
denir estable como entero
letra<-"si"
Mientras (letra=="si") Hacer
escribir "digite n para obtener los n-ésimos numero primos"
leer limitador
num<-estable
contadorp<-0
Mientras (num >=0 y contadorp<limitador)
divnum<-0
para cont<-1 hasta num con paso 1 Hacer
si (num mod cont ==0)
divnum<-divnum + 1
FinSi
FinPara
si (divnum =2)
contadorp<-contadorp+1
FinSi
si (divnum=2)
Escribir num
FinSi
num<-num + 1
FinMientras
Escribir "deseas continuar?"
leer letra
Fin Mientras
FinAlgoritmo

d) Cree un programa donde pida ingresar 4 números y los ordene de mayor


a menor
8

Algoritmo práctica2d
denir a Como real
denir b Como Real
Denir c Como Real
denir d Como Real
Escribir ïngresa el primer número"
leer a;
escribir ïngresa el segundo número"
leer b;
Escribir ïngrese el tercer número"
leer c;
escribir ïngrese el cuarto número"
leer d;
si (a >b) y (b>c) y (c>d)
Escribir a b c d
FinSi
si (a >c) y (c>d) y (d>b)
Escribir a c d b
FinSi
si (a >d) y (d>b) y (b>c)
Escribir a d b c
FinSi
si (a >d) y (d>c) y (c>b)
Escribir a d c b
FinSi
si (a >b) y (b>d) y (d>c)
Escribir a b d c
FinSi
si (a >c) y (c>b) y (b>d)
Escribir a d c b
FinSi
si (b >c) y (c>d) y (d>a)
Escribir b c d a
FinSi
si (b >d) y (d>a) y (a>c)
Escribir b d a c
FinSi
si (b >a) y (a>c) y (c>d)
9

Escribir b a c d
FinSi
si (b >a) y (a>d) y (d>c)
Escribir b a d c
FinSi
si (b >d) y (d>c) y (c>a)
Escribir b d c a
FinSi
si (b >c) y (c>a) y (a>d)
Escribir b c a d
FinSi
si (c >d) y (d>a) y (a>b)
Escribir c d a b
FinSi
si (c >a) y (a>b) y (b>d)
Escribir c a b d
FinSi
si (c >b) y (b>d) y (d>a)
Escribir c b d a
FinSi
si (c >b) y (b>a) y (a>d)
Escribir c b a d
FinSi
si (c >a) y (a>d) y (d>b)
Escribir c a d b
FinSi
si (c >d) y (d>b) y (b>a)
Escribir c b a d
FinSi
si (d >a) y (a>b) y (b>c)
Escribir d a b c
FinSi
si (d >b) y (b>c) y (c>a)
Escribir d b c a
FinSi
si (d >c) y (c>a) y (a>b)
Escribir d c a b
FinSi
10

si (d >c) y (c>b) y (b>a)


Escribir d ç "b .a
FinSi
si (d >b) y (b>a) y (a>c)
Escribir d b a c
FinSi
si (d >a) y (a>c) y (c>b)
Escribir d a c b
FinSi
FinAlgoritmo

e) Cree un programa donde pida ingresar 4 números y los ordene de menor


a mayor

Algoritmo práctica2e
denir a Como real
denir b Como Real
Denir c Como Real
denir d Como Real
Escribir ïngresa el primer número"
leer a;
escribir ïngresa el segundo número"
leer b;
Escribir ïngrese el tercer número"
leer c;
escribir ïngrese el cuarto número"
leer d;
si (a <b) y (b<c) y (c<d)
Escribir a b c d
FinSi
si (a <c) y (c<d) y (d<b)
Escribir a c d b
FinSi
si (a <d) y (d<b) y (b<c)
Escribir a d b c
FinSi
si (a <d) y (d<c) y (c<b)
Escribir a d c b
FinSi
11

si (a <b) y (b<d) y (d<c)


Escribir a b d c
FinSi
si (a <c) y (c<b) y (b<d)
Escribir a d c b
FinSi
si (b <c) y (c<d) y (d<a)
Escribir b c d a
FinSi
si (b<d) y (d<a) y (a<c)
Escribir b d a c
FinSi
si (b <a) y (a<c) y (c<d)
Escribir b a c d
FinSi
si (b<a) y (a<d) y (d<c)
Escribir b a d c
FinSi
si (b <d) y (d<c) y (c<a)
Escribir b d c a
FinSi
si (b <c) y (c<a) y (a<d)
Escribir b c a d
FinSi
si (c <d) y (d<a) y (a<b)
Escribir c d a b
FinSi
si (c <a) y (a<b) y (b<d)
Escribir c a b d
FinSi
si (c <b) y (b<d) y (d<a)
Escribir c b d a
FinSi
si (c <b) y (b<a) y (a<d)
Escribir c b a d
FinSi
si (c <a) y (a<d) y (d<b)
Escribir c a d b
12

FinSi
si (c <d) y (d<b) y (b<a)
Escribir c b a d
FinSi
si (d <a) y (a<b) y (b<c)
Escribir d a b c
FinSi
si (d <b) y (b<c) y (c<a)
Escribir d b c a
FinSi
si (d <c) y (c<a) y (a<b)
Escribir d c a b
FinSi
si (d <c) y (c<b) y (b<a)
Escribir d c b a
FinSi
si (d <b) y (b<a) y (a<c)
Escribir d b a c
FinSi
si (d <a) y (a<c) y (c<b)
Escribir d a c b
FinSi
3. Con lo visto en clase, realice los siguientes problemas con la herramienta
Pseint [Nivel 3].

a) Sea la ecuación cuadrática ax2 + bx + c = 0. Sabemos que dicha


ecuación tiene dos soluciones. Cree un programa donde ingrese los valores a,
b y c validando que a 6= 0, es decir, que si ingresara a = 0 el programa no
le permita seguir y le siga pidiendo el valor de a y luego imprima las raíces
de la ecuación

Algoritmo práctica3a
denir a Como Real
denir b Como Real
denir c como real
denir error Como Caracter
Denir x1 como real
denir x2 Como Real
a<-0
13

escribir "sea ax2+bx+c=0 denir variables a,b,c para hallar raíces"


Mientras (a==0)
escribir "valor a:"
leer a;
si (a=0)
escribir .a<>0"
FinSi
FinMientras
escribir "valor b:"
leer b;
Escribir "valor c:"
leer c;
2 1
x1<-(-b+ (b − 4 ∗ a ∗ c) /2)/2 ∗ a
2 1
x2<-(-b- (b − 4 ∗ a ∗ c) /2)/2 ∗ a
Escribir las raíces de la ecuación son: x1 y x2
FinAlgoritmo

b) Sea la matriz... Cree un programa donde ingrese 9 números y que


presenten los elementos de la matriz y que imprima su determinante. Ejemplo
de ingreso: num1 = 3 num4 = 10 num7 = 9 num2 = 1 num5 = 8 num8 = -1
num3 = 2 num6 = 0 num9 = 5

Algoritmo sint itulo


Denir num1 Como Entero
Denir num2 Como Entero
Denir num3 Como Entero
Denir num4 Como Entero
Denir num5 Como Entero
Denir num6 Como Entero
Denir num7 Como Entero
Denir num8 Como Entero
Denir num9 Como Entero
denir determinante Como Entero
escribir ïngrese los elementos de la matriz para hallar su determinante"
Escribir "(num1 num4 num7)"
Escribir "(num2 num5 num8)"
Escribir "(num3 num6 num9)"
Escribir "num1: "
leer num1
14

Escribir "num2: "


leer num2
Escribir "num3: "
leer num3
Escribir "num4: "
leer num4
Escribir "num5: "
leer num5
Escribir "num6: "
leer num6
Escribir "num7: "
leer num7
Escribir "num8: "
leer num8
Escribir "num9: "
leer num9
determinante<-num1*(num5*num9-num8*num6)-num4*(num2*num9-num8*num3)
+num7*(num2*num6-num5*num3)
escribir "la determinante es:"determinante;
FinAlgoritmo