Sunteți pe pagina 1din 11

Configuration Track, IP SLA and HSRP amar.techstuff@gmail.

com

DESIGN SCOPE

 Our Organization is connected to 3rd Party .

 Connection is via 4 Leased lines - Link 1 , Link 2 , Link 3 and Link 4

 We need to achieve connectivity between PC1 user in Our Organization and paygmy server in 3rd Party network .

 Traffic should be through Link 1 and in case Link 1 goes down it should failover to Link 2 .

 (Incase Link1 comes up traffic should switchback to Link1 again . )

 If Link1 and Link2 both goes down then the traffic should move through Link3.
 (Incase any link link1 or link2 comes the traffic should move through that link)

 Incase all the 3 goes down traffic should move through Link4.
1
 (Incase any link link1 or link2 comes the traffic should move through that link)

CONFIGURATION

STEP 1:-Configuration of IP addresses on interfaces on R1 R2 R3 and R4

R1

(Config)#

interface FastEthernet0

description LAN

ip address 192.168.1.2 255.255.255.0

no shut

interface Serial0

description Link1

ip address 13.1.1.1 255.255.255.252

no shut

interface Serial1

description Link2

ip address 13.2.1.1 255.255.255.252

no shut

R2

interface FastEthernet0

description LAN

ip address 192.168.1.3 255.255.255.0

no shut

interface Serial0

description Link3

ip address 24.1.1.1 255.255.255.252

no shut

interface Serial1

description Link4

ip address 24.2.1.1 255.255.255.252

no shut

2
!

R3

interface Loopback3  Can ignore at this moment .

description PROD-APP-SERVER

ip address 3.3.3.3 255.255.255.255

interface FastEthernet0

description LAN

ip address 5.5.5.2 255.255.255.0

no shut

interface Serial0

description Link1

ip address 13.1.1.2 255.255.255.252

no shut

interface Serial1

description Link2

ip address 13.2.1.2 255.255.255.252

no shut

R4

interface Loopback4  Can ignore at this moment .

description UAT_APP_SERVER

ip address 4.4.4.4 255.255.255.255

interface FastEthernet0

description LAN

ip address 5.5.5.3 255.255.255.0

no shut

interface Serial0

description Link3

ip address 24.1.1.2 255.255.255.252

no shut

interface Serial1

description Link4

ip address 24.2.1.2 255.255.255.252

no shut

3
!

STEP 2:- Adding routing (static)

R1

ip route 3.3.3.3 255.255.255.255 13.1.1.2 50 name PROD_APP_PRIMARY_PATH  Can ignore at this moment

ip route 3.3.3.3 255.255.255.255 13.2.1.2 60 name PROD_APP_SEC_PATH  Can ignore at this moment

ip route 4.4.4.4 255.255.255.255 FastEthernet0  Can ignore at this moment

ip route 5.5.5.5 255.255.255.255 Serial0 10 name paygmserver

ip route 5.5.5.5 255.255.255.255 Serial1 20 name paygmserver

ip route 24.0.0.0 255.0.0.0 FastEthernet0

R2

ip route 3.3.3.3 255.255.255.255 FastEthernet0  Can ignore at this moment

ip route 4.4.4.4 255.255.255.255 24.1.1.2 50 name UAT_APP_SERVER  Can ignore at this moment

ip route 4.4.4.4 255.255.255.255 24.2.1.2 60 name UAT_APP_SERVER  Can ignore at this moment

ip route 5.5.5.5 255.255.255.255 Serial0 10 name paygmserver

ip route 5.5.5.5 255.255.255.255 Serial1 20 name paygmserver

ip route 13.0.0.0 255.0.0.0 FastEthernet0

R3

ip route 0.0.0.0 0.0.0.0 Serial0 50

ip route 0.0.0.0 0.0.0.0 Serial1 60

R4

ip route 0.0.0.0 0.0.0.0 Serial0 50

ip route 0.0.0.0 0.0.0.0 Serial1 60

STEP 3:- Configuration of HSRP

R1

interface FastEthernet0  HSRP INTERFACE

standby 10 ip 192.168.1.1 Configuration of Virtual IP

standby 10 priority 115 Making the priority higher than R2’s HSRP INTERFACE so that R1 should Active.

R2

interface FastEthernet0  HSRP INTERFACE

standby 10 ip 192.168.1.1  Configuration of Virtual IP

R3

interface FastEthernet0

standby 5 ip 5.5.5.1

standby 5 priority 105

standby 5 preempt

R4

4
interface FastEthernet0

standby 5 ip 5.5.5.1

standby 5 preempt

STEP 4:- Configuration of IP sla and Track

R1

(Config)#

ip sla monitor 1

type echo protocol ipIcmpEcho 13.1.1.2 source-ipaddr 13.1.1.1

frequency 5

ip sla monitor schedule 1 start-time now

ip sla monitor 2

type echo protocol ipIcmpEcho 13.2.1.2 source-ipaddr 13.2.1.1

ip sla monitor schedule 2 start-time now 

track 100 rtr 1 -

track 200 rtr 2 

STEP 5 :- Applying track to the HSRP

interface FastEthernet0

standby 10 track 100

standby 10 track 200

Failover Testing
Pre-Checks

Currently able to ping paygm server 5.5.5.5 on port 10019 from PCI

Current Path = PC1->R1->LINK1->R3->5.5.5.5

R1 HSRP – PRIORITY 115-ACTIVE

R1 TRACK 100 UP TRACK 200 UP

R2 HSRP- PRIORITY 100(DEFAULT)-STANDBY

LINK 1

5
Failover Testing

Step 1-Link 1 to be shut

Current Path = PC1->R1->LINK2->R3->5.5.5.5

R1 HSRP – PRIORITY 105-ACTIVE got decrease by 10 since Link1 is gone down

R1 TRACK 100 -DOWN TRACK 200 –UP track100 is down since Link1 is gone down

R2 HSRP- PRIORITY 100(default)-STANDBY

LINK 2

6
Step 2- Unshut Link 1

Current Path = PC1->R1->LINK1->R3->5.5.5.5

R1 HSRP – PRIORITY 115-ACTIVE the priority got increased by10 since the Link1 is up now

R1 TRACK 100 UP TRACK 200 UP Track 100 is up now since link 1 is up now

R2 HSRP- PRIORITY 100(default)-STANDBY

Step 3- Shut link 1 and then Shut link 2

7
LINK 1 & 2 down

Track 100 & 200


down

NOT ABLE TO
PING???

THE PROBLEM IS WITH REVERSE ROUTE

NEED TO HAVE HSRP TRACK ENABLE ON PAYGM END ALSO

Configuring the HSRP track on the 3rd Party Network


R3

ip sla monitor 1

type echo protocol ipIcmpEcho 13.1.1.1 source-ipaddr 13.1.1.2

frequency 5

ip sla monitor schedule 1 start-time now

8
ip sla monitor 2

type echo protocol ipIcmpEcho 13.2.1.1 source-ipaddr 13.2.1.2

frequency 5

ip sla monitor schedule 2 start-time now

interface FastEthernet0

description LAN

ip address 5.5.5.2 255.255.255.0

speed auto

standby 5 ip 5.5.5.1

standby 5 priority 105

standby 5 preempt

standby 5 track 100 decrement 4  Configuring decrement of 4 in the priority once the track 100 is down

standby 5 track 200 decrement 4  Configuring decrement of 4 in the priority once the track 200 is down

TRACK 100 & 200


ARE DOWN

R4 NOW BECOME
ACTIVE

LINK 3

Current Path = PC1->R2->LINK3->R4->5.5.5.5

9
R1 HSRP – PRIORITY 95-STANDBY

R1 TRACK 100 -DOWN TRACK 200 -DOWN

R2 HSRP- PRIORITY 100(default)-ACITVE  ACTIVE SINCE R1 PRIORITY IS NOW 95

R3 HSRP – PRIORITY 97-STANDBY

R3 TRACK 1 -DOWN TRACK 2 -DOWN

R4 HSRP- PRIORITY 100(default)-ACITVE  ACTIVE SINCE R1 PRIORITY IS NOW 97

Step 4- Shut link 3

Current Path = PC1->R2->LINK4->R4->5.5.5.5

R1 HSRP – PRIORITY 95-STANDBY

R1 TRACK 1 -DOWN TRACK 2 -DOWN

R2 HSRP- PRIORITY 100(default)-ACITVE

LINK 4

Step 5- Unshut link 2

PROBLEM –Since link2 is up , track 200 on R1 is up

but still the traffic is moving through link4 and not link2 since R2 is still active

10
TRACK 200 IS UP

SOLUTION – To enable preemption on R1

LINK2

Notes by – Amar Chavan

For Query on above topics contact me on

11

S-ar putea să vă placă și