Sunteți pe pagina 1din 3

Algoritmo média Inicio

Var

nome: caracter Algoritmo para calcular


média entre três notas
n1,n2,n3,media:real

início

escreval ”digite o nome do aluno:” Digite Primeira Nota

leia( nome)

escreval ”digite primeira nota:”

leia (n1) N1

escreval ”digite segunda nota:”

leia (n2) Digite Segunda Nota


escreval“digite terceira nota:”

leia(n3)

media(((n1*2)+(n2*3)+(n3*5))/10) N2
escreval(”o aluno”,Nome,”teve Media”,media)

fim
Digite Terceira Nota

N3

média(((n1*2)+(n2*3)+(n3*
5))/10)

O aluno,nome,teve
Media,media

FIM
Algoritmo intervalo
Inicio
Var
Digite um número
n1:real

Início

escreval (“digite um número:”) N1

leia( n1)

se ((n1>=0) e( n1 < 25))então ((n1>=0)e( n1 < 25))

escreval(“intervalo de zero a vinte e cinco”)


Intervalo de zero a vinte cinco
fimse

se ((n1>=25) e( n1<50)) então

escreval (“intervalo de vinte e cinco a cinquenta”) ((n1>=25) e (n1<50))

fimse
Intervalo de vinte e cinco a cinquenta
se ((n1>=50)e( n1< 75))então

escreval (“intervalo de cinquenta a setenta e cinco”)


((n1>=50) e( n1< 75))
fimse

se ((n1>=75)e(n1<=100)) então
Intervalo de cinquenta a setenta e
escreval(“intervalo de setenta e cinco a cem”) cinco

fimse
( (n1>=75)e(n1<=100))
se (n1 < 0)ou(n1>100)

escreval(“fora de intervalo”)
Intervalo de setenta e cinco e cem
fimse

((n1>0) e( n1< 100))


fim algoritmo

Fora de intervalo

FIM
Inicio
Algoritmo área
Digite o valor da base
Var

Al,ba,be,bam,cal,call :real

início ba

escreval(“digite o valor da base:”)


Digite o valor da altura
leia(ba)

escreval(“digite o valor da altura:”)

leia(al) al

se (ba=al) então
cal(base*h)/2
cal(ba*al)/2

escreval(“perímetro da área é:”,cal)


perímetro da área é:`` cal
senão se(ba>al)ou(ba<al)então

escreva(“digite a base maior:”)


digite a base maior
leia (bam)

ecreva(“digite a base menor:”)


bam
leia (be)

call(bam+be)*al/2)
digite a base menor
escreval(“área do trapézio :,call)

fim se
be
fim algoritmo

call(bam+be)*al/2)

área do trapézio :,call

FIM