Sunteți pe pagina 1din 5

LAboratorul 2.

Ziua săptămânii în cuvinte

În acest caz, trebuie să adăugați un modul (în cazul unui tabel care stabilește data specificată), care vă
permite să specificați ziua.

Modulul funcționează după cum urmează: data este introdusă în celula D1, ziua săptămânii este afișată
automat în celula D2

Rezolvați această problemă în două moduri:

1) Utilizarea formatării celulare.

2) Cu funcții încorporate.

Performanța sarcinii:

Modulul 1 - Utilizarea formatării celulelor

Determinarea zilei din săptămână utilizând formatul celular. Dacă introduceți o dată în celulă, de
exemplu, 01/01/2012, Excel va reacționa automat la acest text cu privire la dată și îl va format în
consecință:

Pentru a obține ziua din săptămână în această celulă, trebuie să o formatați prin apelarea casetei de
dialog Formatare celulă, trecând la modul de toate formatele, în câmpul Type specificați DDDD.:
Modulul ar trebui să arate astfel:

Modulul 2 - Utilizarea funcțiilor încorporate

Să presupunem că nu avem nevoie de numele zilei săptămânii în forma specificată în Excel, ci luând în
considerare declinația (miercuri, miercuri, miercuri) sau cu o scrisoare de capital.

În acest caz, puteți utiliza funcțiile IF și DENNED. Funcția DENNED vă permite să determinați ziua
săptămânii la o anumită dată.

Puteți să o introduceți prin apelarea funcției principale și selectarea categoriei din listă.

data și ora.

Sintaxa funcției este următoarea:

ZI (data-număr, tip)
Returnează ziua săptămânii corespunzătoare primului argument (date_num_number_format). Ziua
săptămânii va fi reprezentată ca un număr întreg în intervalul de la 1 la 7 (implicit, 1 este duminică, 7
este sâmbătă).

Tip este un număr care determină numerotarea zilelor din săptămână. Tipul argumentelor

pot avea următoarele valori:

1 (sau goală) - atunci 1 este duminică; 2 - 1 corespunde luni;

3 - 0 corespunde luni și 6 - duminică.

Funcția IF compară valoarea celulei cu valoarea specificată și, în funcție de rezultatul comparației (true
sau false), returnează valoarea dorită.
De exemplu, funcția

=ЕСЛИ(ДЕНЬНЕД(D1;2)=5;"Пятница";"Другой день")
returnează textul "vineri" dacă ziua din săptămână pentru data specificată a fost vineri, altfel textul este
"O altă zi".

O funcție IF poate avea funcții imbricate. De exemplu:

=ЕСЛИ(ДЕНЬНЕД(I1;2)=5;"Пятница";ЕСЛИ(ДЕНЬНЕД(I1;2)=2;"Вторник";
"Другой день"))
returnează textul "vineri" dacă ziua din săptămână pentru data specificată a fost vineri, altfel
textul este "O altă zi".
O funcție IF poate avea funcții imbricate. De exemplu:
=ЕСЛИ(ДЕНЬНЕД(I1;2)=5;"Пятница";ЕСЛИ(ДЕНЬНЕД(I1;2)=2;"Втор
ник";
"Другой день"))
În mod similar, trebuie să creați funcții imbricate pentru toate zilele săptămânii.
Modulele rezultate pot fi mutate în jurul foii de lucru și copiate în alte coli. Prin corectarea
linkului din formula, puteți schimba locația celulelor de intrare și ieșire: nu le plasați într-o
singură coloană, ci într-un rând.
Ca urmare a sarcinii 1, ar trebui să aveți două module care să funcționeze pentru toate zilele
săptămânii.