Sunteți pe pagina 1din 9

NOTE: Just because the software package is loaded, or if the driver is

loaded, does not mean there is a HBA card installed in the system.
(A "forceload" in /etc/system will load the driver regardless if the hardware
is there or not).
#See the current OS levels
#OS Version and kernel patch
uname -a
#Maintenance level (based on month/year,
# i.e. "Solaris 8 2/02" is Feb/2002 code release)
grep Solaris /etc/issue
#List patches
showrev -p
#Get to latest OBP, go to sunsolve.sun.com, then to hardware, then model
prtconv -V
#See adapters, drivers, and microcode
#COMMON to VENDORS

#System error log file (other than /var/adm/messages.*


# and /var/log/syslog.*):
#Solaris 10 only
/var/fm/fmd/fltlog
#look up/view an error
fmtdump -v
fmadm
#view and error code from the logs
http://www.sun.com/msg/
#See what hardware is there
/usr/platform/sun4u/sbin/prtdiag | awk '/PCI/ {print $NF}'
ls -l /dev/cfg/c0
#add to /etc/system
forceload: drv/fp
forceload: drv/ssd
forceload: drv/pcisch
# NOTE: run as root user (otherwise you don't see everything)
cfgadm -l
cfgadm -al
cfgadm -al <controller_id>
cfgadm -al -o show_FCP_dev <controller_id>
cfgadm -o show_SCSI_LUN -al
cfgadm -o show_FCP_dev -al
# configure command - not a show command
cfgadm -c configure c# c#
#NOTE: Some of the luxadm commands require the devices to
# be configured with cfgadm first.
luxadm -e port
luxadm -e dump_map `HBA path from above command'
luxadm -e dump_map /devices/pci@23d,600000/SUNW,qlc@1/fp@0,0
luxadm -e dump_map /dev/fc/fp0
luxadm -e forcelip `HBA path'
luxadm probe
luxadm display '/dev/rdsk/cXtXdX'
#NOTE: run as root user (otherwise you don't see everything)
# Solaris 10 only, and the last releases of Solaris 9
fcinfo hba-port
fcinfo hba-port -l
fcinfo hba-port -l 210000e08b86f07d
fcinfo -port -slp 210000e08b86f07d
fcinfo remote-port -slp 210000e08b86f07d
#Devices listed with WWN
iostat -XMzxn
#If Emulex
#add to /etc/system
forceload: drv/clone
#NOTE: Only in solaris 10
#List lots of info about each HBA by port
fcinfo hba-port | grep WWN
#*** Use French: fibre (re not er)
# does not give the WWN, but does list instances
prtpicl -v -c obp-device
#List out known HBAs in system device tree
grep lpfc\"$ /etc/path_to_inst
"/pci@8,700000/lpfc@2" 0 "lpfc"
"/pci@8,700000/lpfc@3" 1 "lpfc"
"/pci@8,700000/fibre-channel@2" 2 "lpfc"
"/pci@8,700000/fibre-channel@3" 3 "lpfc"
#you have 2 Emulex cards:
# instance 0 is interface card 2
# instance 1 is interface card 3
#Entry needed for forceload in /etc/system
grep clone /etc/system
forceload: drv/clone
#See if driver is loaded
modinfo | grep lpfc
110 78162000 512d2 185 1 lpfc (Emulex LightPulse FC SCSI/IP)
#Number of HBA instances/devices
prtdiag -v | grep fibre
#List adapaters
/usr/sbin/lpfc/lputil
#Software version of Driver
pkginfo -l lpfc | awk '/VERSION/ {print $3}'
#Firmware, FCode
echo "quit" | /usr/sbin/lpfc/dfc | grep lpfc
#Get HBA config info
fcinfo hba-port -l
#Firmware, FCode
/usr/sbin/lpfc/dfc
hbaconfig
quit
#Firmware, i.e '0' is instance number
/usr/sbin/lpfc/lputil rev 0
#Lputil s/w version
/usr/sbin/lpfc/lputil version
#Get WWN for each HBA
/usr/sbin/lpfc/lputil listhbas
#Get WWN for each HBA and LUNs on that HBA
/usr/sbin/lpfc/lputil fcpmap 0
#Get persistent binding WWN
/usr/sbin/lpfc/lputil shownodes 0
#manage HBAs (firmware, reset, etc)
#script/menu at OS level (like HBAnyware)
/usr/sbin/lpfc/lptuil
HBANYWARE GUI
#HBAnyware graphic
#start an X windows on the system you are on
export DISPLAY=$YOURIP:0
/usr/sbin/hbanyware/hbanyware
HBANYWARE CLI
/usr/sbin/hbanyware/hbacmd listhbas
/usr/sbin/hbanyware/hbacmd hbattrib $WWPN
#If Qlogic
##Entry needed for forceload in /etc/system
forceload: drv/qlc
#List info about HBA
prtpicl -v -c scsi-fcp
prtpicl -v -c scsi-fcp | grep port-wwn
prtpicl -v -c scsi-fcp | grep devfs-path
#See if driver is loaded
grep qlc /etc/system
forceload: drv/qlc
#Number of HBA instances/devices
prtdiag -v | grep qlc
#Frimware Driver
modinfo | grep qlc
27 10257975 26bc0 153 1 qlc (Qlogic FCA Driver v0.40.5)
#OR
grep Driver /var/adm/messages* | grep Qlogic
#Get HBA config info
fcinfo hba-port -l
#Fcode
# RUN AS ROOT (otherwise you don't see everything)
luxadm fcode_download -p
#Software version of Driver
#32 bit
pkginfo -l SUNWqlc | grep VERSION
#64 bit
pkginfo -l SUNWqlcx | grep VERSION
#Get Model type of Driver
pkginfo -l SUNWqlc | grep NAME
#See devices on Qlogic
luxadm probe
#See devices HBA (WWN)
luxadm display 50060482c465135c
#See devices on Qlogic
luxadm probe
#See devices HBA (WWN)
luxadm display 50060482c465135c
#See disk device
luxadm display /dev/rdsk/c3t50060482C465135Cd14s2
#See the configurable devices
# RUN AS ROOT (otherwise you don't see everything)
cfgadm -al | grep fc-fabric
#Configure "fc-fabric" items (output from cfgadm -al)
#Where '#' is the controller number
# RUN AS ROOT (otherwise you don't see everything)
luxadm -e port
#List Powerpath info
#Software
pkginfo -L EMCpower
#Devices
iostat -En | grep EMC
format < /dev/null | grep EMC
#Files that need modification
The software package for the HBA should make entries in
/etc/system
**** NOTE: if you install VxFS later, lwp_default_stksize value
may be changed (additional later entry in /etc/system).
#If Emulex
You will need to add entries for the targets in
vi /kernel/drv/sd.conf
#Add to the end of the file (example):
#
# 66-71, 102-121 BCV
#
name="sd" parent="lpfc" target=0 lun=102;
name="sd" parent="lpfc" target=0 lun=103;
name="sd" parent="lpfc" target=0 lun=104;
...
name="sd" parent="lpfc" target=0 lun=119;
name="sd" parent="lpfc" target=0 lun=120;
name="sd" parent="lpfc" target=0 lun=121;
#
# LUNs: b7-ca (hex), 183-202 (decimal) SRDF
#
name="sd" parent="lpfc" target=0 lun=183;
name="sd" parent="lpfc" target=0 lun=184;
name="sd" parent="lpfc" target=0 lun=185;
...
name="sd" parent="lpfc" target=0 lun=200;
name="sd" parent="lpfc" target=0 lun=201;
name="sd" parent="lpfc" target=0 lun=202;

vi /kernel/drv/lpfc.conf
log-verbose=0x10;
log-only=1;
fcp-bind-method=2;
# BEGIN: LPUTIL-managed Persistent Bindings
fcp-bind-WWPN="5006048acc18f567:lpfc0t0";
# "5006048acc18f547:lpfc1t1";
automap=2;
fcp-on=1;
lun-queue-depth=20;
tgt-queue-depth=512;
no-device-delay=1;
network-on=0;
xmt-que-size=256;
scan-down=1;
linkdown-tmo=60;
nodev-holdio=0;
nodev-tmo=60;
delay-rsp-err=0;
check-cond-err=0;
num-iocbs=2048;
num-bufs=1024;
topology=2;
ip-class=3;
fcp-class=3;
use-adisc=0;
extra-io-tmo=0;
post-ip-buf=128;
dqfull-throttle-up-time=1;
dqfull-throttle-up-inc=1;
zone-rscn=1;
ack0=0;
cr-delay=0;
cr-count=1;
discovery-threads=1;
class-code=0x00020000;
flow_control="duplx" queue="qfifo" disk="scdk" tape="sctp";
use-lomempages=0;
link-speed=0;
fdmi-on=0;
#If Qlogic/Sun, you will need to modify
vi /etc/system
set sd:sd_max_throttle=20
*for the Leadville Qlogic Sun driver (HBA)
set fcp:ssfcp_enable_auto_configuration=1
#PowerPath - 60 sec timeout
set sd:sd_io_time = 0x3c
#Non-PowePath - 120 sec timeout
set sd:sd_io_time = 0x78
#file it creates - no need to modify
/kernel/drv/md.conf,/kernel/drv/qlc.conf
/kernel/drv/fp.conf, vi /kernel/drv/scsi_vhci.conf
#Must do a reconfigure reboot
touch /reconfigure;init 6
If Emulex
#Persistent Binding
/usr/sbin/lpfc/lputil
=> 5. Persistent Bindings
=> 5. Bind Automapped Targets
Loop for each adapter
Yes to bind all auto-mapped targets
=> 2. Bind by port name
touch /reconfigure;init 6
When disks are presented:
Emulex
Solaris 2.6: drvconfig;disks
Solaris >=2.7: devfsadm -v -C -c disks OR devfsadm -v
If VxVM: vxdctl enable
Qlogic
#See devices on Qlogic
luxadm probe
#See devices HBA (WWN)
luxadm display 50060482c465135c
#See disk device
luxadm display /dev/rdsk/c3t50060482C465135Cd14s2
#See the configurable devices
# RUN AS ROOT (otherwise you don't see everything)
cfgadm -al | grep fc-fabric
#Configure "fc-fabric" items (output from cfgadm -al)
#Where '#' is the controller number
# RUN AS ROOT (otherwise you don't see everything)
luxadm -e port
#configure connected ports
cfgadm -c configure c# c#
#WWN
If Emulex
#Menu driven
/usr/sbin/lpfc/lputil
#Get WWN for each HBA
/usr/sbin/lpfc/lputil listhbas
#Get WWN for each HBA and LUNs on that HBA
/usr/sbin/lpfc/lputil fcpmap 0
#Get persistent binding WWN
/usr/sbin/lpfc/lputil shownodes 0
If QLogic
#See devices on Qlogic
luxadm probe
#See devices HBA (WWN)
luxadm display 50060482c465135c
#Load software, drivers and firmware
#NOTE: You may need to modify lines for the APPROPRIATE version
If Emulex
#Driver
cd /tmp
tar xvf /mnt/solaris/emulex_hba/602f/lpfc-6.02f-sparc.tar
pkgadd -d . lpfc.1
packages? all
man pages? yes
enable IP? no
conflicting files? yes
continue? yes
packages? q #You are back to the beginning
reboot
#Firmware
/usr/sbin/lpfc/lputil
3 - firmware maintenance
1 - load firmware image
filename? /mnt/solaris/emulex_hba/602f/cd392a3.awc
0 - exit
0 - exit
#Software - HBAnyware
#Must have Java 1.4 loaded
cd /tmp
gzip -dc /mnt/solaris/emulex_hba/602f/HBAnyware-2.1a18-sparc.tar.gz\
| tar xvf -
pkgadd -d . HBAnyware
reboot
#Persistent Binding
/usr/sbin/lpfc/lputil
=> 5. Persistent Bindings
=> 5. Bind Automapped Targets
Loop for each adapter
Yes to bind all auto-mapped targets
=> 2. Bind by port name
touch /reconfigure;init 6
If QLogic
#Drivers downloaded from www.sun.com/storage/san
#Driver
cd /tmp
zcat /mnt/solaris/sun_hba/SAN_4[1].4.6_install_it.tar.Z | \
tar xvf -
cd SAN_4.4.6_install_it
./install_it
install? y
Patchpro search? n
reboot
# RUN AS ROOT (otherwise you don't see everything)
cfgadm -al | grep fc-fabric
luxadm -e port
#configure connected ports
cfgadm -c configure c# c#
#EMC ECC package
cd /mnt/EMC/ECC/Control_Center_5.2
./install_master.sh `pwd`
/opt/ecc
n
ECC-servername
#default
#default
Y
Y
/opt/ecc/exec/start_master.csh
#Multipath
#EMC PowerPath
#Must have a valid PowerPath license for this host
cd /tmp
zcat /mnt/EMC/PowerPath/PowerPath4.4/solaris/EMCPower.SOLARIS.4.4.0.
tar.Z |\
tar xvf -
pkgadd -d . EMCpower
opt
y
/etc/emcpreg -install
/etc/powermt check_registration
devfsadm -v
/etc/powermt config
/etc/powermt save
iostat -En | grep EMC
#Install Veritas product now for DMP
# and/or Volume Mgt (if applicable)
#Enable Multipathing (MPXIO)
#enable MPXIO
vi /kernel/drv/scsi_vhci.conf
vi /kernel/drv/fp.conf
stmsboot -e
#update vfstab and dumpadm
stmsboot -u
luxadm -e port
#makes /dev/fc/fp#
#by all controllers
cfgadm -c
#by specific controllers
cfgadm -c configure c# [c#] ...
#enable MPXIO
stmsboot -e
#update MPXIO and reboot to configure
stmsboot -u
#disable MPXIO
stmsboot -d
#list devices on a controller
stmsboot -l c#
#list all paths
stmsboot -L
#SUN rebranded HBA Part numbers
#Must have a sunsolve account to see this information.
http://sunsolve.sun.com/handbook_private/Devices/Fibre_Channel/FIBRE_TOC.html
#Supported
http://www.emulex.com/products/fc/index.html
http://www.emulex.com/ts/index.html

S-ar putea să vă placă și