Sunteți pe pagina 1din 40

UNIDAD 2 – ETAPA2 TALLER DE

FUNDAMENTOS DE PROGRAMACIÓN

TRABAJO PRESENTADO POR:


MARIAN QUINTERO RODRIGUEZ
COD: 1070602454

TRABAJO PRESENTADO A:
FREDY ALEXANDER CASTELLANOS

ALGORITMOS

UNIVERSIDAD NACIONAL ABIERTA YA DISTANCIA (UNAD)


INGENIERIA DE SISTEMAS
20 DE MARZO DE 2018
INTRODUCCION

Durante el siguiente documento estudiaremos, fundamentos de programación en el


pseint, este es un editor e intérprete de programas escritos en Pseudo Código
permite crear, almacenar, ejecutar y corregir fácilmente programas en Pseudo
Código, la sencillez del lenguaje Pseudo Código lo hacen ideal para aprender de la
programación.

Permite escribir programas con instrucciones condicionales (Si-Entonces-Sino,


Según) y ciclos (Mientras, Hasta Que, Para), y también usar valores numéricos
(números decimales), lógicos, caracteres y arreglos. También provee funciones de
entrada/salida y algunas funciones matemáticas.
OBJETIVOS

 Controlar y dominar los fundamentos básicos de programación y los algoritmos


 Estudiar la ciencia y arte de diseñar algoritmos para la resolución sistemática
de problemas de cualquier índole.
 Obtener una buena comprensión de la programación sin importar el lenguaje
con que se trabaje.
Nombre estudiante: MARIAN QUINTERO RODRIGUEZ

1. Ejercicio No.01: Desarrolle un Algoritmo que de las instrucciones para


preparar un plato típico de su región que sea suficiente para 4 invitados

Planteamiento del problema a resolver: Desarrolle un Algoritmo que de las instrucciones para
preparar un plato típico de su región que sea suficiente para 4 invitados
Que datos no Que datos no Tipo Formulas a Requiere Requiere
conozco y se conozco, pero aplicar si se condicion ciclos (si /
deben solicitar (si los puedo Variables requieren al (si / no) no) _
se requiere más calcular requeridas cuales
filas por favor Tipo Variable
anexarlas)

NO NO NO NO NO NO NO

Codigo.

//NOMBRE DEL AUTOR :MARIAN QUINTERO

//FECHA: 19/03/2018

// DOY FE QUE ESTE EJERCICIIO ES DE MI AUTORIA, EN CASO DE ENCONTARA


PLAGIIO, LA NOTA DE TODO MI TRABAJO DEBE SER CERO ADEMAS

// DE LAS RESPECTIVAS ANCIONES A QUE HAYA LUGAR//

Proceso Receta

Escribir "Receta huevos Rancheros para 4 personas"


escribir " "

escribir "Ingredientes"

escribir "****************************************"

escribir "100 gramos jamón"

escribir "100 gramos tocineta"

escribir "8 huevos"

escribir "2 tomates pelados y picados en cuadritos"

escribir "1 cebolla redonda"

escribir "1/2 pimentón"

escribir "3 cucharadas aceite"

escribir "sal y pimienta al gusto "

escribir " "

Escribir "Preparacion"

escribir "****************************************"

escribir "En un sartén coloca el aceite."

escribir "Sofría la panceta junto con la cebolla y ir agregando el"

escribir "resto de los ingredientes poco a poco hasta formar un guiso."

escribir "Colocar el guiso en un molde o refractaria antiaderente."

escribir "Colocar sobre ese guiso los ocho huevos enteros (SIN BATIR) espolvorear
con sal y pimienta"

escribir "tapar con papel aluminio y meter al horno por 10 minutos a 90 grados C."

escribir "Y listo buen provecho"

Escribir " "

Escribir "****************AUTOR: MARIAN QUINTERO****************"

Escribir " "


2. Ejercicio No.02: Desarrolle un Diagrama o Algoritmo que permita leer dos
valores y escribir la suma, resta, multiplicación y división de estos números.

Planteamiento del problema a resolver: Realizar la suma, resta, multiplicación y división de dos
números

Que datos no Que datos no Tipo Formulas a Requiere Requiere


conozco y se conozco, pero aplicar si se condicion ciclos (si /
deben solicitar (si los puedo Variables requieren al (si / no) no) _
se requiere más calcular requeridas cuales
filas por favor Tipo Variable
anexarlas)

a Suma Entero a Suma<-a+b no no

b Resta Entero b Resta<-a-b

Multiplicación Multiplicación
<-a*b

División División<-a/b

Codigo

//NOMBRE DEL AUTOR :MARIAN QUINTERO

//FECHA: 19/03/2018

// DOY FE QUE ESTE EJERCICIIO ES DE MI AUTORIA, EN CASO DE ENCONTARA


PLAGIIO, LA NOTA DE TODO MI TRABAJO DEBE SER CERO ADEMAS

// DE LAS RESPECTIVAS ANCIONES A QUE HAYA LUGAR//


Proceso OPERACIONES

definir a,b,s,r,m,d como numerico;

Escribir "Escriba el primer numero";

Leer a;

Escribir "Escriba el segundo numero numero";

Leer b;

s<-a+b;

Escribir "El resultado de la Suma es:",s;

r<-a-b;

Escribir "El resultado de la Resta es:",r;

m<-a*b;

Escribir "El resultado de la Multiplicacion es:",m;

d<-a/b;

Escribir "El resultado de la Division es:",d;

Escribir " ";

Escribir "****************AUTOR: MARIAN QUINTERO****************";

Escribir " ";

FinProceso
DIAGRAMA DE FLUJO:
3. Ejercicio No. 03 Desarrolle un Algoritmo que permita leer un valor entero,
calcular su cuadrado y mostrar su resultado.

Planteamiento del problema a resolver: Calcular el cuadrado de un entero

Que datos no Que datos no Tipo Formulas a Requiere Requiere


conozco y se conozco, pero aplicar si se condicion ciclos (si /
deben solicitar (si los puedo Variables requieren al (si / no) no) _
se requiere más calcular requeridas cuales
filas por favor Tipo Variable
anexarlas)

n C(cuadrado) entero n C<-n*n no no

2.- Código:

//NOMBRE DEL AUTOR :MARIAN QUINTERO

//FECHA: 19/03/2018

// DOY FE QUE ESTE EJERCICIIO ES DE MI AUTORIA, EN CASO DE


ENCONTARA PLAGIIO, LA NOTA DE TODO MI TRABAJO DEBE SER CERO
ADEMAS

// DE LAS RESPECTIVAS ANCIONES A QUE HAYA LUGAR//

Proceso cuadrado
Definir n,c como numero;

Escribir "Digite un Numero entero";

leer n;

c<-n*n;

Escribir "El cuadrado del numero es:", c;

Escribir " ";

Escribir "****************AUTOR: MARIAN QUINTERO****************";

Escribir " ";

FinProceso

DIAGRAMA DE FLUJO:
4. Ejercicio 4:Desarrollar un diagrama o algoritmo que permita ingresar el radio de
un circulo para determinar el área del mismo (consultar la formula), y mostrar
su resultado

Planteamiento del problema a resolver: radio de un circulo para determinar el área del mismo

Que datos no Que datos no Tipo Formulas a Requiere Requiere


conozco y se conozco, pero aplicar si se condicion ciclos (si /
deben solicitar (si los puedo Variables requieren al (si / no) no) _
se requiere más calcular requeridas cuales
filas por favor Tipo Variable
anexarlas)

r entero r no no

a A(área) real a a<-pi*(r^2) no no

//NOMBRE DEL AUTOR :MARIAN QUINTERO

//FECHA: 19/03/2018

// DOY FE QUE ESTE EJERCICIIO ES DE MI AUTORIA, EN CASO DE


ENCONTARA PLAGIIO, LA NOTA DE TODO MI TRABAJO DEBE SER CERO
ADEMAS

// DE LAS RESPECTIVAS ANCIONES A QUE HAYA LUGAR

Proceso areacirculo

Definir a,r,p Como numerico;

Escribir "ingrese el Radio del circulo";


Leer r;

a<-pi*(r^2);

Escribir "el area del circulo es:",a," CM2";

Escribir " ";

Escribir "****************AUTOR: MARIAN QUINTERO****************";

Escribir " ";

FinProceso

Diagrama de flujo
5. Ejercicio 5: Desarrollar un Algoritmo que permita determinar la
hipotenusa de un triángulo rectángulo conocido los valores de las
longitudes de los catetos
Planteamiento del problema a resolver: calcular la Hipotenuza

Que datos no Que datos no Tipo Formulas a Requiere Requiere


conozco y se conozco, pero aplicar si se condicion ciclos (si /
deben solicitar (si los puedo Variables requieren al (si / no) no) _
se requiere más calcular requeridas cuales
filas por favor Tipo Variable
anexarlas)

Cateto 1 real Ct1 no no

Cateto 2 real Ct2 no no

hipotenuza hip real hip<-


rc(ct1^2+ct2^
Chipotenuza) 2);

Codigo

//NOMBRE DEL AUTOR :MARIAN QUINTERO

//FECHA: 19/03/2018

// DOY FE QUE ESTE EJERCICIIO ES DE MI AUTORIA, EN CASO DE


ENCONTARA PLAGIIO, LA NOTA DE TODO MI TRABAJO DEBE SER CERO
ADEMAS

// DE LAS RESPECTIVAS ANCIONES A QUE HAYA LUGAR//

Proceso Hipotenusa

//se calculara el valor de la Hipotenusa teniendo el valor de los 2 catetos

definir ct1,ct2,hip como numerico;


Escribir "ingrese el valor del primer Cateto";

Leer ct1;

Escribir "ingrese el valor del segundo Cateto";

Leer ct2;

hip<-rc(ct1^2+ct2^2);

Escribir "El valor de la Hipotenisa es:",hip," Cm2";

Escribir " ";

Escribir "****************AUTOR: MARIAN QUINTERO****************";

Escribir " ";

FinProceso

Diagrama de flujo
6. Ejercicio 6: Desarrollar un diagrama o algoritmo que leer la
temperatura en grados centígrados y muestre su resultado en
Fahenheit y kelvin.

Planteamiento del problema a resolver: convertido de temperaturas

Que datos no Que datos no Tipo Formulas a Requiere Requiere


conozco y se conozco, pero aplicar si se condicion ciclos (si /
deben solicitar (si los puedo Variables requieren al (si / no) no) _
se requiere más calcular requeridas cuales
filas por favor Tipo Variable
anexarlas)

centigrados real c no no

Fahenheit F(Fahenheit) real f f<-(c*9)/5+32 no no

kelvin K (kelvin) real k k<-c+273; no no

//NOMBRE DEL AUTOR :MARIAN QUINTERO

//FECHA: 19/03/2018

// DOY FE QUE ESTE EJERCICIIO ES DE MI AUTORIA, EN CASO DE


ENCONTARA PLAGIIO, LA NOTA DE TODO MI TRABAJO DEBE SER CERO
ADEMAS

// DE LAS RESPECTIVAS ANCIONES A QUE HAYA LUGAR//

Proceso Temperatura

// se ingresa la temperatura en grados centigrados y se convierte a grados


Fahenheit y kelvin
Definir c,k,f como numero;

Escribir "ingrese la temperatura en grados Centigrados";

Leer c;

k<-c+273;

Escribir "Su equivalencia en grados Kelvin es:", k;

f<-(c*9)/5+32;

Escribir "Su equivalencia en grados Fahenheit es:", f;

Escribir " ";

Escribir "****************AUTOR: MARIAN QUINTERO****************";

Escribir " ";

FinProceso

Diagrama de flujo
7 ejercicio 7: Desarrollar un algoritmo que permita ingresar un valor en
millas y lo convierta a kilómetros, centímetros y yarda.

Planteamiento del problema a resolver: convertido de temperaturas

Que datos no Que datos no Tipo Formulas a Requiere Requiere


conozco y se conozco, pero aplicar si se condicion ciclos (si /
deben solicitar (si los puedo Variables requieren al (si / no) no) _
se requiere más calcular requeridas cuales
filas por favor Tipo Variable
anexarlas)

Kilómetros K(kilometros real k k<-m*1.609 no no

Millas F(Fahenheit) real M no no

Yardas K (kelvin) real Y ya<-m*1760 no no

centimetros C(centímetros) real c c<-k*100000 no no

//NOMBRE DEL AUTOR :MARIAN QUINTERO

//FECHA: 19/03/2018

// DOY FE QUE ESTE EJERCICIIO ES DE MI AUTORIA, EN CASO DE


ENCONTARA PLAGIIO, LA NOTA DE TODO MI TRABAJO DEBE SER CERO
ADEMAS

// DE LAS RESPECTIVAS ANCIONES A QUE HAYA LUGAR//

Proceso Distancia

// convierte una distancia de millas a kilómetros, centímetros y yardas.

Definir k,m,ya,c Como Real;


Escribir "Por favor ingrese na distancia expresada en MILLAS:";
leer m;
k<-m*1.609;
Escribir m," Millas equivale a:", k," Kilometros";
c<-k*100000;
Escribir m," Millas equivale a:", c," Centimetros";
ya<-m*1760;
Escribir m," Millas equivale a:", ya," Yardas";
Escribir " ";
Escribir "****************AUTOR: MARIAN QUINTERO****************";
Escribir " ";
FinProceso

Digrama de flujo
7. Ejercicio 17: Diseñar un diagrama o algoritmo que permita leer dos
valores V1 y V2 y determine cuál es el mayor y cuál es el menor o si
son iguales

Planteamiento del problema a resolver: convertido de temperaturas

Que datos no Que datos no Tipo Formulas a Requiere Requiere


conozco y se conozco, pero aplicar si se condicion ciclos (si /
deben solicitar (si los puedo Variables requieren al (si / no) no) _
se requiere más calcular requeridas cuales
filas por favor Tipo Variable
anexarlas)

Numero 1 entero A si a>b no

Numero 2 entero b no

//FECHA: 19/03/2018
// DOY FE QUE ESTE EJERCICIIO ES DE MI AUTORIA, EN CASO DE
ENCONTARA PLAGIIO, LA NOTA DE TODO MI TRABAJO DEBE SER CERO
ADEMAS
// DE LAS RESPECTIVAS ANCIONES A QUE HAYA LUGAR//
Proceso Mayor
definir a,b Como Entero;
Escribir "Digite 2 numeros para saber cual es el mayor";
escribir "Digite el primer numero:";
leer a;
escribir "Digite el segundo numero:";
leer b;
si a==b Entonces
Escribir "los dos numeros son iguales";
Sino
si a>b Entonces
Escribir "El primer numero es el mayor ",a, " y el segundo es el
menor ",b,;
Sino
Escribir "El segundo numero es el mayor ",b, " y el primero es el
menor ",a,;
FinSi
FinSi
Escribir " ";
Escribir "****************AUTOR: MARIAN QUINTERO****************";
Escribir " ";

FinProceso

Diagrama de flujo
8. Ejercicio 18: Diseñe un diagrama o algoritmo que permita leer dos
números N1 y N2 e indicar si uno de los dos divide exactamente al otro.
Planteamiento del problema a resolver: Division exacta

Que datos no Que datos no Tipo Formulas a Requiere Requiere


conozco y se conozco, pero aplicar si se condicion ciclos (si /
deben solicitar (si los puedo Variables requieren al (si / no) no) _
se requiere más calcular requeridas cuales
filas por favor Tipo Variable
anexarlas)

Numero 1 real N1 No no

Numero 2 real N2 no no

resultado real d d<-n1 MOD si d=0


n2;

//NOMBRE DEL AUTOR :MARIAN QUINTERO


//FECHA: 19/03/2018
// DOY FE QUE ESTE EJERCICIIO ES DE MI AUTORIA, EN CASO DE
ENCONTARA PLAGIIO, LA NOTA DE TODO MI TRABAJO DEBE SER CERO
ADEMAS
// DE LAS RESPECTIVAS ANCIONES A QUE HAYA LUGAR//
Proceso Division
Definir n1,n2,d Como Real;
Escribir "Ingrese el primer numero:";
Leer n1;
Escribir "Ingrese el segundo numero:";
Leer n2;
d<-n1 MOD n2;
si d=0 entonces
escribir "El numero 2 SI divide exactamente al numero 1";
Sino

escribir "El numero 2 divide NO exactamente al numero 1";

FinSi
Escribir " ";
Escribir "****************AUTOR: MARIAN QUINTERO****************";
Escribir " ";

FinProceso

Diagrama de flujo
9. Ejercicio 19: Desarrollar un Diagrama o Algoritmo que permita el
ingreso de dos valore X1 y X2 donde indique si el resultado de dividir
la suma de los números entre la resta de X1 – X2 es exacta
Planteamiento del problema a resolver: División de la suma y la resta de 2 numeros

Que datos no Que datos no Tipo Formulas a Requiere Requiere


conozco y se conozco, pero aplicar si se condicion ciclos (si /
deben solicitar (si los puedo Variables requieren al (si / no) no) _
se requiere más calcular requeridas cuales
filas por favor Tipo Variable
anexarlas)

Numero 1 real x1 No no

Numero 2 real x2 no no

suma real s s<-x1+x2 no No

Resta Real r r<-x1-x2 no no

division real d d<-s MOD r; si d=0

//NOMBRE DEL AUTOR :MARIAN QUINTERO


//FECHA: 19/03/2018
// DOY FE QUE ESTE EJERCICIIO ES DE MI AUTORIA, EN CASO DE
ENCONTARA PLAGIIO, LA NOTA DE TODO MI TRABAJO DEBE SER CERO
ADEMAS
// DE LAS RESPECTIVAS ANCIONES A QUE HAYA LUGAR//
Proceso Dividesumaentreresta
definir x1,x2,s,r,d Como Real;
EScribir "19. Desarrollar un Diagrama o Algoritmo que permita el ingreso de
dos valore X1 y X2 donde indique si el resultado de dividir la suma de los números
entre la resta de X1 - X2 es exacta";
escribir " ";
escribir "Digite dos numeros";
escribir "Digite el primer numero:";
leer x1;
escribir "Digite el segundo numero:";
leer x2;
s<-x1+x2;
r<-x1-x2;
d<-s MOD r;
si d==0 entonces
Escribir "la division de la suma ",s, " entre la resta ",r," de los 2 numeros
es EXACTA";
Sino
Escribir "la division de la suma ",s," entre la resta ",r," de los 2 numeros
NO es EXACTA";
FinSi
Escribir " ";
Escribir "****************AUTOR: MARIAN QUINTERO****************";
Escribir " ";

FinProceso

Diagrama de flujo
10. Ejercicio 20: Desarrollar un Diagrama o Algoritmo que permita el
ingreso de 3 números Num1, Num2, Num3 e indicar si la suma de
los 3 números es par o impar
Planteamiento del problema a resolver: decir si la suma de 3 numeros es par o impar

Que datos no Que datos no Tipo Formulas a Requiere Requiere


conozco y se conozco, pero aplicar si se condicion ciclos (si /
deben solicitar (si los puedo Variables requieren al (si / no) no) _
se requiere más calcular requeridas cuales
filas por favor Tipo Variable
anexarlas)

Numero 1 entero N1 no No

Numero 2 entero N2 no No

Numero 3 entero N3 no no

suma entero s s<- si (s no


num1+num2+ MOD
num3 2)=0

//NOMBRE DEL AUTOR :MARIAN QUINTERO


//FECHA: 19/03/2018
// DOY FE QUE ESTE EJERCICIIO ES DE MI AUTORIA, EN CASO DE
ENCONTARA PLAGIIO, LA NOTA DE TODO MI TRABAJO DEBE SER CERO
ADEMAS
// DE LAS RESPECTIVAS ANCIONES A QUE HAYA LUGAR//
Proceso SumaImparopar
//20. Desarrollar un Diagrama o Algoritmo que permita el ingreso de 3
números Num1, Num2, Num3 e indicar si la suma de los 3 números es par o impar.
definir num1,num2,num3,s como entero;
escribir "Desarrollar un Diagrama o Algoritmo que permita el ingreso de 3
números Num1, Num2, Num3 e indicar si la suma de los 3 números es par o impar.";
escribir " ";
escribir " Ingrese el numero 1:";
leer num1;
escribir " Ingrese el numero 2:";
leer num2;
escribir " Ingrese el numero 3:";
leer num3;
s<-num1+num2+num3;
escribir "La suma de los 3 numeros es: ",s;

si (s MOD 2)=0 Entonces


Escribir "Es Par";
Sino
Escribir "Es Impar";
FinSi
Escribir " ";
Escribir "****************AUTOR: MARIAN QUINTERO****************";
Escribir " ";
FinProceso

Diagrama de flujo
11. Ejercicio 25: Desarrollar un Algoritmo que permita determinar la fecha
un día después a una fecha ingresada (tenga en cuenta meses de
30, 31, 28 días, cambio de año, ejemplo 31-12-2004 el día siguiente
será 1-1-2005)
Planteamiento del problema a resolver: dia siguiente

Que datos no Que datos no Tipo Formulas a Requiere Requiere


conozco y se conozco, pero aplicar si condicional ciclos (si /
deben solicitar (si los puedo Variables se (si / no) no) _
se requiere más calcular requeridas requieren cuales
filas por favor Tipo Variable
anexarlas)

dia entero N1 Dia+1 Si Dia =31 No

Si Dia =30

Si Dia =28

Si Dia = 29

Mes entero N2 Mes+1 Caso No


1,3,5,7,8,10

Caso
4,6,9,11

año entero N3 Año+1 no no


Año mod 4
=0

Algoritmo fecha_siguiente
//NOMBRE DEL AUTOR :MARIAN QUINTERO
//FECHA: 19/03/2018
// DOY FE QUE ESTE EJERCICIIO ES DE MI AUTORIA, EN CASO DE
ENCONTARA PLAGIIO, LA NOTA DE TODO MI TRABAJO DEBE SER CERO
ADEMAS
// DE LAS RESPECTIVAS ANCIONES A QUE HAYA LUGAR//

Escribir " Ingrese la fecha en el siguiente formato:DD/MM/AAAA"


Escribir "ingrese el dia por favor"
leer Dia
Escribir "Ingrese el mes por favor"
Leer Mes
Escribir "ingrese el año por favor"
Leer Año
Segun Mes Hacer
Caso 1,3,5,7,8,10:
Si Dia = 31 Entonces
Escribir "Si la fecha que ingresaste es",Dia,"/",Mes,"/",Año
Escribir "El dia posterior a la fecha que ingresaste sera:"
,1,"/",Mes+1,"/",Año
sino
Escribir "Si la fecha que ingresaste es
",Dia,"/",Mes,"/",Año
Escribir "El dia posterior a la fecha que ingresaste
sera:",Dia+1,"/",Mes,"/",Año

FinSi
Caso 4,6,9,11:
Si Dia = 30 Entonces
Escribir "Si la fecha que ingresaste
es",Dia,"/",Mes,"/",Año
Escribir "El dia posterior a la fecha que ingresaste
sera:" ,1,"/",Mes+1,"/",Año
sino
Escribir "Si la fecha que ingresaste es
",Dia,"/",Mes,"/",Año
Escribir "El dia sposterior a la fecha que ingresaste
sera:",Dia+1,"/",Mes,"/",Año

FinSi
Caso 2:
Si Año mod 4 = 0 Entonces
Si Dia =28 Entonces
Escribir "Si la fecha que ingresaste
es",Dia,"/",Mes,"/",Año
Escribir "El dia posterior a la fecha que
ingresaste sera:" ,1,"/",Mes+1,"/",Año
Sino
Escribir "Si la fecha que ingresaste es
",Dia,"/",Mes,"/",Año
Escribir "El dia posterior a la fecha que
ingresaste sera:",Dia+1,"/",Mes,"/",Año
FinSi
sino
Si Dia = 29 Entonces
Escribir "Si la fecha que ingresaste
es",Dia,"/",Mes,"/",Año
Escribir "El dia posterior a la fecha que ingresaste
sera:" ,1,"/",Mes+1,"/",Año
sino
Escribir "Si la fecha que ingresaste es
",Dia,"/",Mes,"/",Año
Escribir "El dia posterior a la fecha que ingresaste
sera:",Dia+1,"/",Mes,"/",Año
Finsi
FinSi

Caso 12:
Si Dia = 31 Entonces
Escribir "Si la fecha que ingresaste
es",Dia,"/",Mes,"/",Año
Escribir "El dia posterior a la fecha que ingresaste
sera:", 1,"/",1,"/",Año+1
Sino
Escribir "Si la fecha que ingresaste
es:",Dia,"/",Mes,"/",Año
Escribir "El dia posterior a la fecha que ingresaste
sera:",Dia+1,"/",Mes,"/",Año
FinSi
FinSegun

Escribir " "


Escribir "****************AUTOR: MARIAN QUINTERO****************"
Escribir " "

FinAlgoritmo

Diagrama de flujo

12. Ejercicio 23 : Se pide desarrollar el algoritmo del juego “Adivina


un Número”, con las siguientes características:
a) El número debe estar en el rango de 1 a 1000 (generado
aleatoriamente)
b) Debe tener dos niveles nivel básico y nivel experto, el nivel básico no
tendrá restricciones en número de oportunidades, además se le dará
indicaciones como “Caliente”, “Frio.. El Nivel experto solo tendrá 5
oportunidades con mensajes de ayuda “lejos”, “cerca”
13. Al finalizar debe informar el número de intentos realizados antes de
encontrar la respuesta correcta
Planteamiento del problema a resolver: numero al azar

Que datos no Que datos no Tipo Formulas a Requiere Requiere


conozco y se conozco, pero aplicar si condicional ciclos (si /
deben solicitar (si los puedo Variables se (si / no) no) _
se requiere más calcular requeridas requieren cuales
filas por favor Tipo Variable
anexarlas)

nivel entero nivel Si nivel==1

Si nivel==2

Num adivininar entero num_adi

Num digitado entero num num<- Mientras


azar(1000) num<>nu
+1 m_adi Y
num_adi<>
0 Hacer

intentos intentos<-0

//NOMBRE DEL AUTOR :MARIAN QUINTERO


//FECHA: 19/03/2018
// DOY FE QUE ESTE EJERCICIIO ES DE MI AUTORIA, EN CASO DE
ENCONTARA PLAGIIO, LA NOTA DE TODO MI TRABAJO DEBE SER CERO
ADEMAS
// DE LAS RESPECTIVAS ANCIONES A QUE HAYA LUGAR//

Proceso Adivina_Numero

Definir intentos, nivel,num_adi,num Como Entero;


Escribir "Adivine el Numero entre 1 a 1000";
escribir "Elija el nivel";
escribir "1 Nivel Basico";
escribir "2 Nivel Avanzado";
leer nivel;
Si nivel==1 Entonces

intentos<-0;
num<- azar(1000)+1;

Escribir "Adivine el numero (de 1 a 1000):";


Escribir "Pulse 0 (cero) para terminar en cualquier
momento";
Leer num_adi;

Mientras num<>num_adi Y num_adi<>0 Hacer

Si num =num_adi-10 O num=num_adi+10 Entonces


Escribir "Caliente";
SiNo
Escribir "Frio";
FinSi

Leer num_adi;
//Mientras num_adi<>0 Hacer
intentos<-intentos+1;
// finmientras
FinMientras

Si num=num_adi Entonces
Escribir "Exacto! Usted adivino en ",11-intentos,"
intentos.";
Escribir " ";
Escribir "****************AUTOR: MARIAN
QUINTERO****************";
Escribir " ";
SiNo
Escribir "El numero era: ",num;
FinSi
Escribir " ";
Escribir "****************AUTOR: MARIAN
QUINTERO****************";
Escribir " ";

Sino
intentos<-10;
num <- azar(1000)+1;

Escribir "Adivine el numero (de 1 a 1000):";


Leer num_adi;
Mientras num_adi<>num Y intentos>1 Hacer
Si num>num_adi Entonces
Escribir "Muy bajo";
SiNo
Escribir "Muy alto";
FinSi
intentos <- intentos-1;
Escribir "Le quedan ",intentos," intentos:";
Leer num_adi;
FinMientras

Si num_adi=num Entonces
Escribir "Exacto! Usted adivino en ",11-intentos,"
intentos.";
Escribir " ";
Escribir "****************AUTOR: MARIAN
QUINTERO****************";
Escribir " ";
SiNo
Escribir "El numero era: ",num;
Escribir " ";
Escribir "****************AUTOR: MARIAN
QUINTERO****************";
Escribir " ";
FinSi
FinSi
FinProceso
13 ejercicio 23: Desarrolle un Diagrama o Algoritmo que permita determinar
la nota mínima que usted debe sacar en el examen final del curso
Algoritmos de acuerdo a las condiciones actuales 75% y 25%(final), esta
nota debe estar representada tanto en puntos y en nota (0..5.0).

//NOMBRE DEL AUTOR :MARIAN QUINTERO


//FECHA: 19/03/2018
// DOY FE QUE ESTE EJERCICIIO ES DE MI AUTORIA, EN CASO DE
ENCONTARA PLAGIIO, LA NOTA DE TODO MI TRABAJO DEBE SER CERO
ADEMAS
// DE LAS RESPECTIVAS ANCIONES A QUE HAYA LUGAR//

Proceso Notas
// se calculara la nota que necesita un estudiante en el examen final para ver si
aprueba o no
Definir n1,n2,n3,n4,ef,nf,nfe como real;
Escribir "Digite las cuatro notas parciales las cuales equivalen al 75% de la
nota final y asi calcular la nota que necesita en el examen final para ser promovido";
Escribir "Digite su Primer 15% nota:";
leer n1;
Escribir "Digite su segunda 20% nota:";
leer n2;
Escribir "Digite su tercera 20% nota:";
leer n3;
Escribir "Digite su cuarta 20% nota:";
leer n4;
nf<-((n1*15/100)+(n2*20/100)+(n3*20/100)+(n4*20/100));
escribir "su nota acumulada en el 75% es:",nf;
ef<-3.0-nf;
nfe<-(ef/(25/100));
Escribir "para el examen final necesita:", nfe, " Que equivale a la nota :",ef;
Escribir " ";
Escribir "****************AUTOR: MARIAN QUINTERO****************";
Escribir " ";
FinProceso
Diagrama de flujo

15 ejercicio 27: Es necesario realizar un algoritmo que funcione como una


calculadora con las 4 funciones básicas (opcional puede incluir otra
función). El algoritmo termia y entrega el resultado al presionar la tecla

//NOMBRE DEL AUTOR :MARIAN QUINTERO

//FECHA: 19/03/2018

// DOY FE QUE ESTE EJERCICIIO ES DE MI AUTORIA, EN CASO DE


ENCONTARA PLAGIIO, LA NOTA DE TODO MI TRABAJO DEBE SER CERO
ADEMAS

// DE LAS RESPECTIVAS ANCIONES A QUE HAYA LUGAR//


Algoritmo Calculadora_Operaciones_Basicas
EScribir "Calculadora Operaciones Basicas"
Escribir "Digite el numero el signo (+, -, *, /) el siguiente numero e igual para el
resultado"
Escribir "Digite el primer Numero:"
leer n1
Escribir "Digite el signo de la operacion"
leer signo
Escribir "Digite el segundo Numero:"
leer n2
Escribir "Digite = para el resultado"
leer igual
si igual="="
si signo="+"
r=n1+n2
escribir "El resultado de la suma es :",r
Sino
si signo="-"
r=n1-n2
escribir "El resultado de la Resta es :",r
Sino
si signo="*"
r=n1+n2
escribir "El resultado de la multiplicacion es
:",r
sino
r=n1/n2
escribir "El resultado de la Division es :",r
FinSi
FinSi
FinSi
FinSi
Escribir " ";
Escribir "****************AUTOR: MARIAN QUINTERO****************";
Escribir " ";
FinProceso
Diagrama de flujo
CONCLUSIONES

Durante este documento podemos concluir que: Este curso facilita el aprendizaje a
todos aquellos que queremos aprender a programar y a los programadores
autoformados que carecen de fundamentos de algoritmia. Para realizar este curso no
se necesitan conocimientos específicos previos. El curso está desarrollado de tal forma
que nosotros como alumnos podamos aprender de forma sencilla y muy práctica los
fundamentos de programación

FUENTES BIBLIOGRÁFICAS

 www.unad.edu.com

 https://drive.google.com/file/d/0B7nK_seE9Y9fcHhHdHhlbG5oSFk/view

 Tutoriales algoritmos – curso pseint, obtenido de:


https://www.youtube.com/channel/UC-u3395_fPX5XWKnNTnWHnQ

 Ejercicios Pseint – básicos, (2016) empezando por lo básico. Obtenido de:


https://www.youtube.com/watch?v=DHIi4dcaMEc

 Curso Pseint Aprendiendo a programar (27 de abril de 2015). Tomado de:


https://www.youtube.com/watch?v=m6TlSLD61Y0

 Ejercicios pseint (26 de mayo de 2014), ciclo mientras y para. Tomado de:
https://www.youtube.com/watch?v=EcYYbta6RCc