Sunteți pe pagina 1din 6

Bucles anidados.

Un bucle dentro de otro bucle.

Problemas muchosholas

i,j entero

Para i  1 hasta 3

Para j  1 hasta 4

Escribir “Hola ”,i,j,”\n”

finPara

finPara

Fin

Hola 11

Hola 12

Hola 13

Hola 14

Hola 21

Hola 22

Hola 23

Hola 24

Hola 31

Hola 32

Hola 33

Hola 34
Elabore un algoritmo que muestre las tablas desde el uno hasta la tabla del 10

Tabla del 1:

1x1=1

1x2=2

1x3=3

1 x 12 = 12

Tabla del 2:

2x1=2

2x2=4

2x3=6

2 x 12 = 24

Tabla del 3:

3x1=3

3x2=6

3x3=9

3 x 12 = 36

Tabla del 10:

10 x 1 = 10

10 x 2 = 20

10 x 3 = 30

10 x 12 = 120
Problema tablaDeMultiplicar

i, j entero

Para i  1 hasta 10

Escribir “Tabla del : ”, i

Para j  1 hasta 12

Escribir i,”x”, j, “=”, i*j, “\n”

finPara

finPara

Fin

Elabore un algoritmo donde el usuario ingresa el número de estudiantes, ingresa 8 notas


(enteras) de cada estudiante y muestre el mejor promedio. (Validar las notas)

Programa notasEstudiantes

i,j,n,suma,nota entero

promedio, promedioM real

Escribir “Ingrese número de estudiantes”

Leer n

suma  0

promedioM 0

Para i  1 hasta n

Para j  1 hasta 8

hacer

Escribir “Ingrese nota”

Leer nota

Mientras(nota<0 o nota>20)

suma  suma + nota


finPara

promedio  suma / 8

Si (promedio > promedioM)

promedioM  promedio

finSi

finPara

Escribir “El mejor promedio es: ”, promedioM

Fin

Caso Ajedrez:

Una Rey deprimido por la muerte de su hijo en la guerra agradecido por el juego que un sabio
inventó para el (Chaturanga o Ajedrez), le dijo “Pídeme lo que quieras”, el sabio le pidió lo
siguiente:

1 grano de trigo por la primera casilla del tablero de ajedrez, 2 por la segunda, 4 por la tercera,
así sucesivamente hasta terminar todo el tablero.

Elabore un algoritmo que calcule cuantos granos de trigo se le deberá entregar al sabio.

Programa Ajedrez

i, suma entero

suma  0

Para i  1 hasta 64

suma  suma + 2 ^ (i-1)

finPara

Escribir “El sabio quiere ”, suma, “ granos de trigo”

Fin
Elabore un algoritmo que muestre los valores enteros y positivos a y b (sin considerar cero) que
cumplen lo siguiente: a^2+b^2=1894

Programa ecuacionEntera

a,b entero

encontrado booleano

a0

b0

encontrado  falso

Mientras( encontrado = falso y a<=1893^0.5 y b <=1893^0.5)

aa+1

Mientras ( encontrado = falso y b <=1893^0.5)

bb+1

Si( a*a+b*b=1894 )

encontrado  verdadero

finSi

finMientras

finMientras

Si (encontrado=verdadero)

Escribir “Los valores de a y b son: ”, a, “ y ”, b

Sino

Escribir “No se encontró los valores”

finSi

Fin
x + 2 = 10

x  -1

encontrado  Falso

Mientras ( encontrado = Falso y x<=8)

xx+1

Si ( x + 2 = 10)

encontrado  Verdadero

finSi

finMientras

Si ( encontrado = Verdadero )

Escribir “El valor de x es: ”,x

Sino

Escribir “No se encontró el valor de x”

finSi