Sunteți pe pagina 1din 42

Practical-01: Introduction to computer network

Router
A router is a networking device that forwards data packets between computer networks. Routers
perform the traffic directing functions on the Internet. Data sent through the internet, such as
a web page or email, is in the form of data packets. A packet is typically forwarded from one
router to another router through the networks that constitute an internetwork (e.g. the Internet)
until it reaches its destination node.

A router is connected to two or more data lines from different networks.[b] When a data packet
comes in on one of the lines, the router reads the network address information in the packet to
determine the ultimate destination. Then, using information in its routing table or routing policy,
it directs the packet to the next network on its journey.
Router may have interfaces for different types of physical layer connections, such as copper
cables, fiber optic, or wireless transmission. It can also support different network
layer transmission standards. Each network interface is used to enable data packets to be
forwarded from one transmission system to another. Routers may also be used to connect two or
more logical groups of computer devices known as subnets, each with a different network prefix.

Wireless Router
A wireless router is a device that enables wireless network packet forwarding and routing, and
serves as an access point in a local area network. It works much like a wired router but replaces
wires with wireless radio signals to communicate within and to external network environments.
It can function as a switch and as an Internet router and access point.

Network Switch
A network switch (also called switching hub, bridging hub, officially MAC bridge[1]) is
a computer networking device that connects devices on a computer network by using packet
switching to receive, process, and forward data to the destination device.
A network switch is a multiport network bridge that uses hardware addresses to process and
forward data at the data link layer (layer 2) of the OSI model. Some switches can also process
data at the network layer (layer 3) by additionally incorporating routing functionality. Such
switches are commonly known as layer-3 switches or multilayer switches.
Switches are most commonly used as the network connection point for hosts at the edge of a
network. In the hierarchical internetworking model and similar network architectures, switches
are also used deeper in the network to provide connections between the switches at the edge.
Connections
Connections are used to connect two devices using ports that have the same connection types on
both devices.

Connection type Connects these devices Picture

Automatic connect All except console

Straight through PC, server, laptop or printer to switch


PC, server, laptop or printer to hub
PC, server, laptop or printer to modem
PC, server, laptop or printer to cloud
Router to switch, hub, modem, cloud.
Crossover PC, server, laptop or printer to PC
PC, server, laptop or printer to server
PC, server, laptop or printer to printer
PC, server, laptop or printer to laptop
switch to switch, hub
hub to hub
Router w/o serial to router
Fiber All with fiber ports

Phone Cloud to DSL , Modem VoIP to analog


phone,
Analog phone to analog phone.
Coaxial Cloud to cable, Modem cable modem
to Co-Ax splitter(hub)
Co-Ax splitter to TV
Cable modem to TV,
Cloud TV to TV
Serial DCE Router cloud to Router

Serial DTE Router cloud to Router

Console PC/Laptop/Generic to Router/switch


Serial Cable
A serial cable is a cable used to transfer information between two devices using a serial
communication protocol. The form of connectors depends on the particular serial port used. A
cable wired for connecting two DTEs directly is known as a null modem cable.

Data Terminal Equipment (DTE)


DTE is an end instrument that converts user information into signals or reconverts received
signals.

These can also be called tail circuits.

Data Circuit- Terminating Equipment (DCE)


DCE is a device that sits between the data terminal equipment and a data transmission circuit. It
is also called data communications equipment and data carrier equipment.

Usually, the DTE device is the terminal and DCE is a modem.

Straight through cable


A straight-through cable is a type of twisted pair cable that is used in local area networks to
connect a computer to a network hub such as a router. This type of cable is also sometimes
called a patch cable and is an alternative to wireless connections where one or more computers
access a router through a wireless signal.

Crossover cable
A crossover cable is a type of cable installation that is used for the interconnection of two similar
devices. It is enabled by reversing the transmission and receiving pins at both ends, so that output
from one computer becomes input to the other, and vice versa.

Serial links/cables connecting routers


Serial links btw multiple routers to propagate configure data because these links support daisy
chaining and can easily propagate commands over and over without much configuration.
End devices
The network devices that people are most familiar with are called end devices. These devices
form the interface between the human network and the underlying communication network.
Some examples of end devices are:
 Computers, laptops, file servers, web servers.
 Network printers
 VoIP phones
 Security cameras
 Mobile handheld devices.
Practical-02:To establish a connection among systems using a switch

The network consists of the following components:

• One Switch (2950-24).

• 5 End devices (PCs).

• Copper straight-through cable (connecting switch to PCs).

Steps
• Place one switch (2950-24).

• Place end devices (PCs).

• Configure each end device (IP address and subnet mask) as follows:

PC0:- IP address: 192.168.1.1 Subnet Mask: 255.255.255.0

PC1:- IP address: 192.168.1.2 Subnet Mask: 255.255.255.0

PC2:- IP address: 192.168.1.3 Subnet Mask: 255.255.255.0


PC3:- IP address: 192.168.1.4 Subnet Mask: 255.255.255.0

PC4:- IP address: 192.168.1.5 Subnet Mask: 255.255.255.0

• Connect each PC to the switch with a copper straight-through cable.

PDU Passing
Practical-03:To establish a connection among systems using a router

The network consists of the following components:

• One 1841 router.

• 2 End devices i.e. PCs.

• Copper crossover cable(connecting router to PCs)

Steps
• Place one router (1841).

• Place two end devices (PCs).

• Configure each end device(IP address, subnet mask and gateway)as follows:

The PCs are assigned configuration as follows:

PC0:-

IP Address: 192.168.1.4

Subnet Mask: 255.255.255.0

Gateway: 192.168.1.1

PC1:-

IP Address: 192.168.2.4

Subnet Mask: 255.255.255.0

Gateway: 192.168.2.1
• Connect each PC to the router with a copper crossover cable.

• Configure the router connections as follows:

The router is configured as follows:

Fast Ethernet 0/0:- Connected to PC0

IP Address: 192.168.1.1

Subnet Mask: 255.255.255.0

Fast Ethernet 0/1:- Connected to PC1

IP Address: 192.168.2.1

Subnet Mask: 255.255.255.0

IOS Commands(Configuring Router


Router>en

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#int fa0/0

Router(config-if)#ip address 192.168.1.4 255.255.255.0

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#%IP-4-DUPADDR: Duplicate address 192.168.1.4 on FastEthernet0/0,


sourced by 0010.119E.ED5B
Router(config-if)#exit

Router(config)#int fa0/1

Router(config-if)#ip address 192.168.2.4 255.255.255.0

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

PDU Passing
Practical-04:To establish a connection among two networks using a
Router

The network consists of the following components:

• One 1841 router.

• 4 End devices i.e PCs.

• Two switches 2950-24.

• Copper crossover cable (connecting router to switches and PCs to switches).

Steps
• Place one router (1841).

• Place two switches (2950-24)

• Place end devices (PCs).

• Configure each end device divided into two networks (IP address, subnet mask and
gateway)as follows:

The PCs are assigned configuration as follows:


PC0:- Connected to switch 0

IP Address: 192.168.1.4

Subnet Mask: 255.255.255.0

Gateway: 192.168.1.1

PC1:- Connected to switch 0

IP Address: 192.168.1.3

Subnet Mask: 255.255.255.0

Gateway: 192.168.1.1

PC2:- Connected to switch 1

IP Address: 192.168.2.4

Subnet Mask: 255.255.255.0

Gateway: 192.168.2.1

PC3:- Connected to switch 1

IP Address: 192.168.2.4

Subnet Mask: 255.255.255.0

Gateway: 192.168.2.1

• To each switch connect two PCs with a copper straight-through cable.

• Connect both switches to router with a copper straight-through cable.

• Configure the router connections as follows:

The router is configured as follows:


Fast Ethernet 0/0:- Connected to switch 0

IP Address: 192.168.1.1

Subnet Mask: 255.255.255.0

Fast Ethernet 0/1:- Connected to switch 1

IP Address: 192.168.2.1

Subnet Mask: 255.255.255.0

IOS Commands (Configuring Router)


Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config-if)#int fa0/0

Router(config-if)#ip address 192.168.1.1 255.255.255.0

Router(config-if)#no shutdown

Router(config-if)#exit

Router(config)#int fa0/1

Router(config-if)#ip address 192.168.2.1 255.255.255.0

Router(config-if)#no shutdown

PDU Passing
Practical-05:To establish a connection among two networks using a
dynamic routing

The network consists of the following components:

 Two Router-PT routers.


 End devices i.e. PCs.
 Two switches 2950-24.
 Copper straight-through cable(connecting switches to PCs )
 Serial DTE cable(Connecting two routers)

Steps
1. Place the two routers (Router-PT)
2. Place two switches (2950-24)
3. Place end devices (PCs).
4. Configure each end device divided into two networks (IP address, subnet mask and
gateway)as follows:

PC0:- Connected to switch 0

IP Address: 192.168.1.3

Subnet Mask: 255.255.255.0


Gateway: 192.168.1.1

PC1:- Connected to switch 0

IP Address: 192.168.1.4

Subnet Mask: 255.255.255.0

Gateway: 192.168.1.1

PC2:- Connected to switch 1

IP Address: 192.168.2.3

Subnet Mask: 255.255.255.0

Gateway: 192.168.2.1

Laptop-PT:- Connected to switch 1

IP Address: 192.168.2.4

Subnet Mask: 255.255.255.0

Gateway: 192.168.2.1

5. To each switch connect two PCs with a copper straight-through cable.


6. Connect both switches to two different routers with a copper straight-through cable.
7. Connect the routers through serial DTE cable.
8. Configure both the router connections as follows:

The Router0 is configured as follows:

Fast Ethernet 0/0:- Connected to switch 0

IP Address: 192.168.1.1

Subnet Mask: 255.255.255.0


Serial 2/0:-

IP Address: 10.10.0.2

Subnet Mask: 255.0.0.0

Port status: On

Clock rate: 64000

RIP Entry:

10.0.0.0

192.168.1.0 (Network to which iti is directly connected through switch)

The Router1 is configured as follows:

Fast Ethernet 0/1:- Connected to switch 1

IP Address: 192.168.2.1

Subnet Mask: 255.255.255.0

Serial 2/0:-

IP Address: 10.10.0.3

Subnet Mask: 255.0.0.0

Port status: On

RIP Entry:

10.0.0.0

192.168.1.0 (Network to which iti is directly connected through switch.

IOS Commands(Configuring Router)


Router>enable

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.

Router(config-if)#int fa0/0

Router(config-if)#ip address 192.168.1.1 255.255.255.0

Router(config-if)#no shutdown

Router(config-if)#exit

Router(config)#interface Serial2/0

Router(config-if)#ip address 10.10.0.2 255.0.0.0

Router(config)#no clock rate

Router(config)#port status on

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial2/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

Router(config)#router rip

Router(config-router)#network 192.168.1.0

Router(config-router)#network 10.0.0.0

Router(config-router)#port status on

Router(config-router)# no shutdown

Router 2:

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config-if)#int fa0/0

Router(config-if)#ip address 192.168.2.1 255.255.255.0

Router(config-if)#no shutdown

Router(config-if)#exit
Router(config)#interface Serial2/0

Router(config-if)#ip address 10.10.0.3 255.0.0.0

Router(config)# clock rate 64000

Router(config)#port status on

Router(config-if)#

%LINK-5-CHANGED: Interface Serial2/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

Router(config)#router rip

Router(config-router)#network 192.168.2.0

Router(config-router)#network 10.0.0.0

Router(config-router)#port status on

Router(config-router)# no shutdown

PDU Passing
Practical-06:To establish a connection among two router networks
using a static routing

The network consists of the following components:

 Two Router-PT routers.


 End devices i.e. PCs.
 Two switches 2950-24.
 Copper straight-through cable(connecting switches to PCs )
 Serial DTE cable(Connecting two routers)
Steps
1. Place the two routers (Router-PT)
2. Place two switches (2950-24)
3. Place end devices (PCs).
4. Configure each end device (divided into two networks)as follows:

The PCs are assigned configuration as follows:

PC0:- (Connected to switch 0)

IP Address: 192.168.1.3

Subnet Mask: 255.255.255.0

Gateway: 192.168.1.1

PC1:- Connected to switch 1

IP Address: 192.168.2.3

Subnet Mask: 255.255.255.0

Gateway: 192.168.2.1

PC2:- Connected to switch 1

IP Address: 192.168.2.3

Subnet Mask: 255.255.255.0

Gateway: 192.168.2.1

Laptop-PT:- Connected to switch 1

IP Address: 192.168.2.4

Subnet Mask: 255.255.255.0

Gateway: 192.168.2.1
5. To each switch connect two PCs with a copper straight-through cable.
6. Connect both switches to two different routers with a copper straight-through cable.
7. Connect the routers through serial DTE cable.
8. Configure both the router connections as follows:

Router0 is configured as follows:

Fast Ethernet 0/0:- Connected to switch 0

IP Address: 192.168.1.1

Subnet Mask: 255.255.2

Serial 2/0:-

IP Address: 10.0.0.2

Subnet Mask: 255.0.0.0

Port Status: 0n

Clock rate: 64000

RIP Entry:

Network: 192.168.2.0

Mask: 255.255.255.0

Next hop: 10.10.0.3

The Router1 is configured as follows:

Fast Ethernet 0/0:- Connected to switch 1

IP Address: 192.168.2.1

Subnet Mask: 255.255.255.0


Serial 2/0:-

IP Address: 10.10.0.3

Subnet Mask: 255.0.0.0

Port status: On

Clock rate: 64000

Static Entry:

Network: 192.168.1.0

Mask: 255.255.255.0

Next hop: 10.10.0.2

IOS Commands (Configuring Router 0)


Router>enable

Router #configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config-if)#int FastEthernet0/0

Router(config-if)#ip address 192.168.1.1 255.255.255.0

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface Fast Ethernet0/0 changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Intereface Fast Ethernet0/0, changed state to up

Router(config-if)#exit

Router(config-if)#interface Serial2/0

Router(config-if)#ip address 10.10.0.2 255.0.0.0

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial2/0 changed state to down


Router(config-if)#clock rate 64000

Router(config-if)#

Router(config-if)#exit

Router(config-if)#

%LINK-5-CHANGED: Interface Serial2/0 changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface serial2/0, changed state to up

Router(config)#ip route 192.168.2.0 255.255.255.0 10.10.0.3

Router 2:

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config-if)#int fa0/0

Router(config-if)#ip address 192.168.2.1 255.255.255.0

Router(config-if)#no shutdown

Router(config-if)#exit

%LINK-5-CHANGED: Interface Fast ethernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Fast Ethernet0/0, changed state to up

Router(config-if)#exit

Router(config)#interface Serial2/0

Router(config-if)#ip address 10.10.0.3 255.0.0.0

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface Serial2/0, changed state to up


%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

Router(config-if)#exit

Router(config)#iproute 192.168.1.0 255.255.255.0 10.10.0.2


Practical-07:To establish a connection Between multiple networks
using two router

The network consists of following components:

 Four 2950-24 Switch


 Eight end devices i.e. PCs(numbered 0,1,2,3,4,5,6,7)
 Two Router-Pt routers
 Copper straight-through cable(connecting switches to PCs )
 Serial DTE cable(Connecting two routers)

Steps
1. Place the two routers (Router-PT)
2. Place four switches (2950-24)
3. Place eight end devices (PCs).
4. Configure each end device( divided into four networks each two end devices connected
to same switch )as follows:

The PCS are assigned as follows


PC0:- Connected to switch 0

IP Address: 192.168.1.3

Subnet Mask: 255.255.255.0


Gateway: 192.168.1.1

PC1:- Connected to switch 0

IP Address: 192.168.1.4

Subnet Mask: 255.255.255.0

Gateway: 192.168.1.1

PC2:- Connected to switch 1

IP Address: 192.168.2.3

Subnet Mask: 255.255.255.0

Gateway: 192.168.2.1

PC3:- Connected to switch 1

IP Address: 192.168.2.4

Subnet Mask: 255.255.255.0

Gateway: 192.168.2.1

PC4:- Connected to switch 2

IP Address: 192.168.3.3

Subnet Mask: 255.255.255.0

Gateway: 192.168.3.1

PC5:- Connected to switch 2

IP Address: 192.168.3.4

Subnet Mask: 255.255.255.0

Gateway: 192.168.3.1

PC6:- Connected to switch 3


IP Address: 192.168.4.3

Subnet Mask: 255.255.255.0

Gateway: 192.168.4.1

PC7:- Connected to switch 3

IP Address: 192.168.4.4

Subnet Mask: 255.255.255.0

Gateway: 192.168.4.1
5. To each switch connect four PCs (two PCs from two different network) with Copper
Straight-Through cable.
6. Connect both switches to two different routers (router-PT) with Copper Straight _through
cable
7. Connect the routers through serial DTE cable.
8. Configure both the router connection as follows

The Router0 is configured as follows:

Fast Ethernet 0/0:- Connected to switch 0

IP Address: 192.168.1.1

Subnet Mask: 255.255.255.0

Fast Ethernet 0/1:- Connected to switch 0

IP Address: 192.168.2.1

Subnet Mask: 255.255.255.0

Serial 2/0:-

IP Address: 10.10.0.2
Subnet Mask: 255.0.0.0

Port status: On

Clock rate: 2400

STATIC

(for network 192.168.3.0)

NETWORK: 192.168.3.0

Mask: 255.255.255.0

Next hop: 10.10.0.3

(for network 192.168.4.0)

NETWORK: 192.168.3.0

Mask: 255.255.255.0

Next hop: 10.10.0.3

The Router1is configured as follows:

Fast Ethernet 0/0:- Connected to switch 1

IP Address: 192.168.3.1

Subnet Mask: 255.255.255.0

Fast Ethernet 0/1:- Connected to switch 1

IP Address: 192.168.4.1

Subnet Mask: 255.255.255.0

Serial 2/0:-

IP Address: 10.10.0.3

Subnet Mask: 255.0.0.0


Clock rate: 2400

STATIC entry:

(For network 192.168.1.0)

NETWORK: 192.168.1.0

Mask: 255.255.255.0

Next hop:10.10.0.2

(for network 192.168.4.0)

NETWORK: 192.168.3.0

Mask: 255.255.255.0

Next hop: 10.10.0.2

IOS Commands (Configuring Router 0)


Router>enable

Router #configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config-if)#int FastEthernet0/0

Router(config-if)#ip address 192.168.1.1 255.255.255.0

Router(config-if)#

Router(config-if)#exit

Router(config-if)#int FastEthernet1/0

Router(config-if)#ip address 192.168.2.1 255.255.255.0

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface Fast Ethernet1/0 changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on interface Fast Ethernet1/0, changed state to up


Router(config-if)#exit

Router(config-if)#int FastEthernet1/0

Router(config-if)#

Router(config-if)#exit

Router(config-if)#int FastEthernet0/0

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface Fast Ethernet0/0 changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on interface Fast Ethernet0/0, changed state to up

Router(config-if)#exit

Router(config)#interface Serial2/0

Router(config-if)#ip address 10.10.0.2 255.0.0.0

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface Serial2/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

Clock rate 2400

IOS Commands (Configuring Router 1)

Router>enable

Router #configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config-if)#int FastEthernet0/0
Router(config-if)#ip address 192.168.3.1 255.255.255.0

Router(config-if)#noshutdown

Router(config-if)#

%LINK-5-CHANGED: Interface Fast Ethernet0/0 changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on interface Fast Ethernet0/0, changed state to up

Router(config-if)#exit

Router(config-if)#interface FastEthernet1/0

Router(config-if)#ip address 192.168.4.1 255.255.255.0

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface Fast Ethernet1/0 changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on interfaceFast Ethernet1/0, changed state to up

Router(config-if)#exit

Router(config)#interface Serial2/0

Router(config-if)#ip address 10.10.0.3 255.0.0.0

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial2/0, changed state to down

Router(config-if)#

%LINK-5-CHANGED: Interface Serial2/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up


Practical-08:To show multiple routing connection among three
routers

The network consists of the following components:

 Three Router-PT routers.


 Six End devices i.e. PCs(numbered 0,1,2,3,4,5,6,7).
 Three switches 2950-24.
 Copper straight-through cable(connecting switches to PCs )
 Serial DTE cable(Connecting two routers)

Steps
1. Place the threerouters (Router-PT)
2. Place three switches (2950-24)
3. Place sixend devices (PCs).
4. Configure each end device (two end devices in each network )as follows:

The PCs are assigned configuration as follows:

PC0:- Connected to switch 0

IP Address: 192.168.1.3

Subnet Mask: 255.255.255.0

Gateway: 192.168.1.1

PC1:- Connected to switch 0

IP Address: 192.168.1.4

Subnet Mask: 255.255.255.0

Gateway: 192.168.1.1

PC2:- Connected to switch 1

IP Address: 192.168.2.3

Subnet Mask: 255.255.255.0

Gateway: 192.168.2.1

PC3:- Connected to switch 1


IP Address: 192.168.2.4

Subnet Mask: 255.255.255.0

Gateway: 192.168.2.1

PC4:- Connected to switch 2

IP Address: 192.168.3.3

Subnet Mask: 255.255.255.0

Gateway: 192.168.3.1

PC5:- Connected to switch 2

IP Address: 192.168.3.4

Subnet Mask: 255.255.255.0

Gateway: 192.168.3.1

1. To each switch connect two PCs with a copper straight-through cable.


2. Connect the three switches to three different routers(router-PT) with a copper straight-
through cable.
3. Turn off the router 0 and 2 add WIC-IT and again turn on the routers
4. Turn off Router 1 and add 2WIC-IT and then turn it on
5. Connect the routers through serial DTE cable.
6. Configure both the router connections as follows:

The Router0 is configured as follows:

Fast Ethernet 0/0:- Connected to switch 0

IP Address: 192.168.1.1

Subnet Mask: 255.255.255.0

Serial 2/0:-

IP Address: 10.10.0.3
Subnet Mask: 255.0.0.0

Port status: on

Clock rate: 1200

Fast Ethernet 0/1:- Connected to switch 0

IP Address: 192.168.4.1

Subnet Mask: 255.255.255.0

STATIC

(for network 192.168.2.0)

NETWORK: 192.168.2.0

Mask: 255.255.255.0

Next hop: 11.0.0.3

(For network 192.168.3.0)

NETWORK: 192.168.3.0

Mask: 255.255.255.0

Next hop: 11.0.0.3

NETWORK: 11.0.0.0

Mask: 255.0.0.0

Next hop: 11.0.0.3

NETWORK: 12.0.0.0

Mask: 255.0.0.0

Next hop: 11.0.0.3


The Router1 is configured as follows:

Fast Ethernet 0/0:- Connected to switch 1

IP Address: 192.168.2.1

Subnet Mask: 255.255.255.0

Serial 2/0:-

IP Address: 11.10.0.3

Subnet Mask: 255.0.0.0

Port status: On

Clock Rate: 1200

Serial 2/0:-

IP Address: 12.0.0.2

Subnet Mask: 255.0.0.0

Port status: On

Clock Rate: 1200

(For network 192.168.1.0)

NETWORK: 192.168.1.0

Mask: 255.255.255.0

Next hop: 11.0.0.2

(For network 192.168.3.0)

NETWORK: 192.168.3.0

Mask: 255.255.255.0
Next hop: 12.0.0.3

The Router2 is configured as follows:

Fast Ethernet 0/0:- Connected to switch 2

IP Address: 192.168.3.1

Subnet Mask: 255.255.255.0

Serial 2/0:-

IP Address: 12.10.0.3

Subnet Mask: 255.0.0.0

Port status: On

Clock Rate: 1200

STATIC

(For network 192.168.1.0)

NETWORK: 192.168.1.0

Mask: 255.255.255.0

Next hop: 12.0.0.2

(For network 192.168.2.0)

NETWORK: 192.168.2.0

Mask: 255.255.255.0

Next hop: 12.0.0.2

NETWORK: 11.0.0.0

Mask: 255.0.0.0

Next hop: 12.0.0.2

NETWORK: 12.0.0.0

Mask: 255.0.0.0
Next hop: 12.0.0.2

IOS Commands (Configuring Router 0)


Router>enable

Router #configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config-if)#int FastEthernet0/0

Router(config-if)#ip address 192.168.1.1 255.255.255.0

Router(config-if)#no shut down

Router(config-if)#

%LINK-5-CHANGED: Interface Fast Ethernet0/0 changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Fast Ethernet0/0, changed state to up

Router(config-if)#exit

Router(config-if)#interface serial0/0

Router(config-if)#ip address 11.0.0.2 255.0.0.0

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface serial0/0 changed state to down

Router(config-if)#
Router(config-if)#exit

Router(config-if)#

%LINK-5-CHANGED: Interface serial0/0 changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on interface Serial0/0, changed state to up

Router(config)#interface serial0/0

Router(config-if)#clock rate 1200

Router(config-if)#

Router(config-if)#exit

Router(config)#

Router(config)# ip route 192.168.2.0 255.255.255.0 11.0.0.3

Router(config)# ip route 192.168.3.0 255.255.255.0 11.0.0.3

Router(config)# ip route 11.0.0.0255.255.255.0 11.0.0.3

Router(config)# ip route 12.0.0.0 255.255.255.0 11.0.0.3

IOS Commands (Configuring Router 1)


Router>enable

Router #configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config-if)#int FastEthernet0/0

Router(config-if)#ip address 192.168.2.1 255.255.255.0


Router(config-if)#no shut down

Router(config-if)#

%LINK-5-CHANGED: Interface Fast Ethernet0/0 changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Fast Ethernet0/0, changed state to up

Router(config-if)#exit

Router(config-if)#interface serial0/0

Router(config-if)#ip address 11.0.0.3 255.0.0.0

Router(config-if)#no shutdown

Router(config-if)#

%LINK-5-CHANGED: Interface serial0/0 changed state to up

Clock rate 1200

This command applies only to DCE interfaces

Router(config-if)#

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial 0/0, changed state to up

Router(config-if)#exit

Router(config-if)#int FastEthernet0/1

Router(config-if)#ip address 12.0.0.2 255.0.0.0

Router(config-if)#clock rate 1200

This command applies only to DCE interfaces

Router(config-if)#no shutdown
Router(config-if)#int FastEthernet0/0

Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/1 changed state to down

Router(config-if)#

%LINK-5-CHANGED: Interface Serial /1 changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial 0/1, changed state to up

Router(config-if)#exit

Router(config-if)#ip route 192.168.1.0 255.255.255.0 11.0.0.0

Router(config-if)#ip route 192.168.3.0 255.255.255.0 11.0.0.0

IOS COMMAND (ROUTER 2)

Router>enable

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config-if)#int fa0/0

Router(config-if)#ip address 192.168.3.1 255.255.255.0

Router(config-if)#no shutdown

Router(config-if)#exit

%LINK-5-CHANGED: Interface Fast ethernet0/0, changed state to up


%LINEPROTO-5-UPDOWN: Line protocol on Interface Fast Ethernet0/0, changed state to up

Router(config-if)#exit

Router(config)#interface Serial0/0

Router(config-if)#ip address 12.0.0.3 255.0.0.0

Router(config-if)#no shutdown

Router(config-if)#

Router(config)# clock rate 1200

Router(config)#port status on

Router(config-if)#

%LINK-5-CHANGED: Interface Serial0/0, changed state to up

Router(config)# clock rate 1200

Router(config-if)#

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up


Router(config-if)#exit

Router(config)#iproute 192.168.1.0 255.255.255.0 12.0.0.2

Router(config)#iproute 192.168.2.0 255.255.255.0 12.0.0.2

Router(config)#iproute 11.0.0.0255.0.0.0 12.0.0.2

Router(config)#iproute 12.0.0.0255.0.0.0 12.0.0.2

S-ar putea să vă placă și