Sunteți pe pagina 1din 11

USO DE COMODINES EN EXCEL

Caracteres comodín
Mostrar todo
Los siguientes caracteres comodín pueden usarse como criterios de comparación para filtros,
así como para buscar y reemplazar contenido.

Utilice Para buscar


Un único carácter
? (signo de interrogación)
Por ejemplo, Gr?cia buscará "Gracia" y "Grecia"
Un número de caracteres
* (asterisco)
Por ejemplo, *este buscará "Nordeste" y "Sudeste"
~ (tilde) seguida de Un signo de interrogación, un asterisco o una tilde.
?, *, o ~ Por ejemplo, fy91~? buscará "fy91?".

Uso de comodines (wildcards) en funciones de Excel

sábado, agosto 20, 2011

Cuando filtramos tablas o hacemos búsquedas en Excel podemos usar comodines (*, ?).
¿Podemos usarlos en las funciones? Bien, sí y no. Es decir, hay funciones que aceptan
comodines en los argumentos y otras que no.

Por ejemplo, queremos evaluar si una celda contiene cierto texto. En caso afirmativo el
resultado será "A", en caso negativo "B".

Obviamente =SI(A1="*no*";"A";"B") no funciona.

Pero veamos esta alternativa


Como pueden ver, =SI(ESNUMERO(HALLAR("no";A1));"A";"B") no requiere comodines para nuestro
ejemplo.

Podemos ver cómo funciona esta fórmula descomponiéndola en sus partes:

La función HALLAR da la primera posición en la cadena de texto del texto buscado

=HALLAR("no";A2)

Si el texto no aparece el resultado el #¡VALOR!

La función ESNUMERO evalúa si el resultado de HALLAR es numérico. Cuando lo es da VERDADERO,


cuando no lo es, también si el error, da FALSO. Estos resultados son los argumentos que usamos en SI.

Veamos un ejemplo más elaborado donde buscamos valores que en la segunda posición contienen
una "n" y en la cuarta posición una "o".
Como ven, en =SI(ESNUMERO(HALLAR("?n?o";A2));"A";"B") estamos usando el comodín "?" para
señalar que la primera y la tercera posición puede ser ocupada por cualquier valor, pero la segunda y
la cuarta deben ser "n" y "o" respectivamente.

La función COINCIDIR también acepta comodines.

También la función CONTAR.SI. Por ejemplo, en la lista anterior, si queremos contar todos los
nombres que terminan con la letra "o" usamos

=CONTAR.SI($A$2:$A$7;"*o")

De la misma manera SUMAR.SI comodines pero SUMAPRODUCTO no.

Instrucciones PARA REEMPLAZAR CADENAS

1. 1
Abre la hoja de cálculo de Microsoft Excel.

2. 2

Sostén presionada la tecla "Ctrl" y presiona la letra "H" para abrir la ventana "Buscar y
reemplazar".

3. 3

Introduce el término de búsqueda en el campo "Buscar" de la ventana "Buscar y


reemplazar".

4. 4

Agrega asteriscos en los lugares donde no estés seguro de una sección del texto. No es
necesario utilizar el comodín asterisco para indicar texto adicional al comienzo o al
final de un término de búsqueda. A modo de ejemplo la búsqueda de "hot" encontrará
"hot", "shot" o "hotter", incluso sin utilizar el comodín. Sin embargo, al agregar el
comodín en el medio del texto de búsqueda ayudará a ubicar texto muy diferente. Por
ejemplo, si escribes "tr*p" encontrará "trip" o "troop".

5. 5

Introduce el texto de reemplazo en el campo "Reemplazar con".

6. 6

Haz clic en "Reemplazar todo" para encontrar automáticamente y reemplazar todas las
coincidencias. Como alternativa, puedes hacer clic en "Reemplazar siguiente" o
"Buscar siguiente" para reemplazar o encontrar la siguiente coincidencia encontrada.

Uso de comodines ó Jokers en Fórmulas de Excel


Publicado por Obed Cruz en domingo, marzo 07, 2010 0 comentarios

Comodines Fórmulas

Un comodín es un carácter especial que representa a uno o más caracteres . Los comodines
más utilizados son el asterisco (*), que usualmente representa al cero ó demás caracteres
dentro de una cadena y el signo de interrogación (?), que representa a cualquier carácter.

Un comodín es un tipo de carácter meta. En los juegos de cartas, un comodín es una carta
designada dentro del mismo mazo de cartas (por ejemplo, el dos de picas), que puede ser
utilizado como si se tratara de cualquier carta posible.
Para que quede algo más claro, pueden descargar este libro donde trato de ser los más
explicito que me fue posible en los ejemplos.

Quiero ver ejemplos

/////####

Capítulo 5:

Excel. Usar comodines. Acciones que se


pueden realizar con una lista filtrada
 Titulos Universitarios Estudia tu carrera en línea, Obtén tu Titulo sin asistir a clase
www.aiu.eduEnlaces patrocinados

Usar comodines

Los comodines nos permiten realizar búsquedas cuando los criterios presentan algún grado de
indeterminación. Por ejemplo, supón que has invitado a tu casa, para ver una película, a un
amigo muy maniático que sólo ve películas cuyos títulos empiecen por la letra F. Puesto que
tienes muchas películas en casa y no recuerdas el título de todas, puedes hacer dos cosas:
mandar a tu amigo a tomar viento o usar los comodines de Excel para satisfacer las exigencias
de tu invitado. Puesto que supongo que no hace falta que te explique cómo debes hacer lo
primero, estudiemos la segunda opción que, diplomáticamente, es más correcta.

 Cursos de C# / VB.NET Conviértete en Programador .NET! Domina Microsoft Visual


Studio
educacionit.com.ar/Cursos-de-NETEnlaces patrocinados

Dispones de dos comodines:

ð El comodín asterisco (*) que representa a cualquier número de caracteres. Por ejemplo, el
criterio m* encontraría mesa, mus, matemáticas, etcétera.

ð El comodín interrogación (?) que representa a un sólo carácter. Por ejemplo, el criterio m?sa
encontraría misa, mesa, masa, etcétera, pero no melosa.

Nota
Los comodines pueden usarse en cualquier lugar del criterio, es decir, puedes usar m*, *m,
c*sa, N123?, ?ez, etcétera.

Veamos cómo llevar a cabo la búsqueda propuesta:

1. Selecciona una celda de la lista y activa el modo Filtro. Ahora elige la opción Filtro
personalizado... en la lista desplegable del encabezado Título. Excel mostrará el cuadro de
diálogo Autofiltro personalizado.

2. Como ya está seleccionado el operador es igual a, pasa al cuadro de la derecha y escribe f*.
Para terminar pulsa Aceptar.

Como puedes ver en la figura 10.20, la lista de títulos se ha reducido a aquellas cuyos títulos
comienzan por la letra F.

Figura 10.20. Películas y vídeos musicales cuyos nombres comienzan por la letra F

Evidentemente, puedes combinar el uso de operadores con las demás posibilidades que hemos
visto de los filtros personalizados. Con todas las opciones de las que dispones es seguro que en
todo momento podrás especificar aquella que necesites. Es cuestión de práctica.

Acciones que se pueden realizar con una lista filtrada


Con las listas filtradas, Excel puede llevar a cabo la mayoría de las operaciones que hemos
visto en los capítulos anteriores. Así, podrás sumar, ordenar o imprimir solamente las filas
visibles de la lista filtrada.

Por ejemplo, para ordenar una lista que esté filtrada se procede de la misma forma que si no lo
estuviera (tal y como aprendiste en el capítulo anterior).

Al salir del modo Filtrar, la lista original aparecerá en su totalidad pero la ordenación
realizada queda hecha, aunque solamente afecta a los registros resultantes del filtraje sobre los
cuales se hizo.

Lo mismo ocurre si das formato a las filas visibles de una lista filtrada. Cuando salgas del
modo Filtrar, sólo aparecerán con formato las filas que estaban visibles cuando la lista estaba
filtrada.

A continuación puedes ver cómo se comportan otros comandos cuando se aplican sobre una
lista filtrada.

ð Presentación preliminar: si realizas la presentación preliminar de una lista filtrada, sólo


aparecerán las celdas visibles.

ð Imprimir: si imprimes una hoja de cálculo que tenga una lista filtrada, sólo se imprimirán las
celdas visibles.

ð Gráficos: si creas un gráfico a partir de una lista filtrada, éste sólo representará los datos.

ð Autollenado: si extiendes el Autollenado sobre una lista filtrada, rellenarás únicamente las
celdas visibles de la lista.

ð Autosuma: si usas la herramienta Autosuma sobre una lista filtrada, sólo se sumarán los
valores visibles.

ð Autocalcular: la característica Autocalcular sólo tendrá en cuenta las celdas visibles al


realizar las operaciones.

ð Fórmulas: las fórmulas normales seguirán usando todas las filas de la lista para realizar los
cálculos (aunque estén ocultas), a no ser que utilices una función propia de listas, como la
función SUBTOTALES que veremos en el aparatado siguiente.

Insertar fórmulas en listas filtradas

En el caso de que quieras realizar operaciones sólo con las filas que quedan visibles después
de filtrar una lista, debes utilizar la función SUBTOTALES, ya que las funciones normales
(SUMA, PROMEDIO, etcétera) seguirán teniendo en cuenta todas las filas de la lista (ocultas
o no).
Por ejemplo, supón que quisiéramos calcular el promedio de duración de todas las películas de
Terror y Suspense (ver figura 10.19).

Si utilizas la función PROMEDIO(E11:E260) en la celda E287, el resultado será el promedio


de duración de todos los programas. Sin embargo, si usas la función SUBTOTALES(1;
E11:E260), el resultado será el promedio de duración de las películas visibles solamente.

La función SUBTOTALES tiene dos argumentos. El segundo (E11:E260) es el rango de


celdas sobre el que quieres operar. Es conveniente que selecciones todas las filas de la lista. El
primero (1) es un número que indica la operación que quieres realizar con ese rango. Los
números corresponden a las operaciones que puedes ver en la tabla 10.1.

Tabla 10.1. Código de las operaciones de la función SUBTOTALES

Número Función
1 PROMEDIO
2 COMTAR
3 CONTARA
4 MAX
5 MIN
6 PRODUCTO
7 DESVEST
8 DESVESTP
9 SUMA
10 VAR
11 VARP

Por tanto, SUBTOTALES (1; E11:E260) producirá un subtotal (es decir, una operación
realizada solamente sobre las filas visibles) de las celdas E11:E260 utilizando la función
PROMEDIO (que tiene el número uno en la tabla 10.1 que puedes observar en la página
anterior).

Uso de comodines en funciones de Excel


Cuando filtramos tablas o hacemos búsquedas en Excel podemos usar comodines (*, ?). ¿Podemos
usarlos en las funciones? Bien, sí y no. Es decir, hay funciones que aceptan comodines en los
argumentos y otras que no.
Si queremos contar todos los nombres que terminan con la letra "o" usamos
=CONTAR.SI($A$2:$A$7;"*o")

Uso de comodines (wildcards) en funciones de Excel

sábado, agosto 20, 2011

Cuando filtramos tablas o hacemos búsquedas en Excel podemos usar comodines (*, ?).
¿Podemos usarlos en las funciones? Bien, sí y no. Es decir, hay funciones que aceptan
comodines en los argumentos y otras que no.

Por ejemplo, queremos evaluar si una celda contiene cierto texto. En caso afirmativo el
resultado será "A", en caso negativo "B".

Obviamente =SI(A1="*no*";"A";"B") no funciona.

Pero veamos esta alternativa


Como pueden ver, =SI(ESNUMERO(HALLAR("no";A1));"A";"B") no requiere comodines para nuestro
ejemplo.

Podemos ver cómo funciona esta fórmula descomponiéndola en sus partes:

La función HALLAR da la primera posición en la cadena de texto del texto buscado

=HALLAR("no";A2)

Si el texto no aparece el resultado el #¡VALOR!

La función ESNUMERO evalúa si el resultado de HALLAR es numérico. Cuando lo es da VERDADERO,


cuando no lo es, también si el error, da FALSO. Estos resultados son los argumentos que usamos en SI.

Veamos un ejemplo más elaborado donde buscamos valores que en la segunda posición contienen
una "n" y en la cuarta posición una "o".
Como ven, en =SI(ESNUMERO(HALLAR("?n?o";A2));"A";"B") estamos usando el comodín "?" para
señalar que la primera y la tercera posición puede ser ocupada por cualquier valor, pero la segunda y
la cuarta deben ser "n" y "o" respectivamente.

La función COINCIDIR también acepta comodines.

También la función CONTAR.SI. Por ejemplo, en la lista anterior, si queremos contar todos los
nombres que terminan con la letra "o" usamos

=CONTAR.SI($A$2:$A$7;"*o")

De la misma manera SUMAR.SI comodines pero SUMAPRODUCTO no.