Sunteți pe pagina 1din 5

Basic Command of Extreme switch

COMMAND SHORTCUTS

All named components of the switch configuration must have a unique name.
Components are named using the create command. When you enter a command to configure a
named component, you do not need to use the whole keyword of the component. For example, to

create a VLAN, you must enter a unique VLAN name:

Once you have created the VLAN with a unique name, you can then eliminate the keyword vlan
from all other commands that require the name to be entered. For example, instead of entering
the switch command

create vlan engineering


config vlan engineering delete port 1:3,4:6
config engineering delete port 1:3,4:6

Similarly, on the Summit switch, instead of entering the command


config vlan engineering delete port 1-3,6
config engineering delete port 1-3,6

SUMMIT SWITCH NUMERICAL RANGES

Commands that require you to enter one or more port numbers on a Summit switch use the
parameter in the syntax. A portlist can be a range of numbers, for example:
port 1-3
You can add additional port numbers to the list, separated by a comma:
port 1-3,6,8

Resetting Back to Factory Configs:

Unconf switch  reset the switch back to factory configs

Unconf switch all  rest the switch back to factory configs and remove the users account
information
Show port collision
Show port configuration
Show port info detail
Show port packet
Show port rxerror
Show port stat
Show port txerror
Show port util (use the space bar to scroll through different utilization screens)

Configuring VLANS on an Extreme Switch

With all switches from Extreme Networks there is no need to create a “router interface” in order
to use VLANS. Since every port can be a router and the routing mechanism is built into the
switch fabric, VLAN configuration has become incredibly easy. When the switch is first started
up our of the box, there is a single VLAN called “Default” (VLAN 1) and contains all ports on
the switch. If you desire to add ports to other VLANS, you must first delete the port out of the
VLAN they are in. (for security purposes).

VLAN Basics

create vlan  crear vlan


config vlan ip x.x.x.x /xx  asignacion de IP a la vlan
config vlan add port n  agregar puertos a una vlan (i.e. port 1-48 or 1,2,8,10 or 1-10,5-20)
config vlan delete port n  borrrado de puertos de salida de una vlan

Assigning tags and designating Trunk (uplink) ports

Be default when you add ports to a VLAN, they are added untagged. Most user ports will be
untagged. The reason for adding tags to ports is to allow multiple VLAN traffic to traverse those
ports, as with trunk ports. Trunk ports (or Uplinks) can contain several thousand VLANS on a
single link. This is useful if you have more than one VLAN at an edge switch. In order to have
more than one VLAN on a uplink you will need to add an 802.1q tag to port. Please be aware
that Cisco’s VLAN numbers should be the same as a standard 802.1q tag number. (I.e. if you
want to trunk a Cisco switch using Vlan500 and Vlan600 to another standards based switch, the
VLAN tags should match up. Tag 500 and Tag 600 should be on that trunk)

Adding a 802.1q tag to a VLAN

config vlan add tag  Note: this number can be any number between 2 and 4096.

Making a port a “trunk” port

config vlan add port n tagged


How to load share ports (aka Fast Etherchannel)
To define a load sharing group, you assign a group of ports to a single logical port number.
To enable or disable loadsharing use the following commands.
Enable sharing grouping
To disable sharing:
Disable sharing
For example
Enable sharing 2 grouping 2-8

Routing on an Extreme Networks switch


Every switch from Extreme is a layer 3 switch. To enable routing, obviously you need more than
1 VLAN with an IP address on the switch. Once you have your desired number of VLANS
created, with their own unique IP address, you issue a single command to enable routing.
How to turn on routing

Type the command:


Enable ipforwarding
Note: you can also turn on or off routing for any single vlan on the switch.
(i.e. enable ipforwarding vlan or disable ipforwarding vlan )

You are now routing between VLANS.


Routing Protocols (getting routing to work with other switches)

All Extreme Networks switches support static routes, Rip v1/v2, OSPF, BGP and IS-IS. Just like
any router you must use a routing protocol in order for routers/switches to share routing
information.

Turning on OSPF Type the command:

config ospf add vlan area 0.0.0.0  This adds each VLAN to the OSPF Area 0
config ospf add vlan all area 0.0.0.0  You can also add all the VLANS

The following is a sample configuration:

create vlan HQ_10_0_2


create vlan HQ_10_0_3
create vlan LA_161_48_2
create vlan Chi_160_26_26
config vlan HQ_10_0_2 ipaddress 10.0.2.1 255.255.255.0
config vlan HQ_10_0_3 ipaddress 10.0.3.1 255.255.255.0
config vlan LA_161_48_26 ipaddress 161.48.2.26 255.255.255.0
config vlan Chi_160_26_26 ipaddress 160.26.2.1 255.255.255.0
create ospf area 0.0.0.5
create ospf area 0.0.0.6
enable ipforwarding
config ospf area 0.0.0.6 stub nosummary stub-default-cost 10
config ospf add vlan LA_161_48_2 area 0.0.0.6
config ospf add vlan Chi_160_26_26 area 0.0.0.5
config ospf add virtual-link 160.26.25.1 0.0.0.5
config ospf add vlan all
enable ospf

TRUNKING EXTREME – CISCO


Hi.
Several of our remote offices purchased some Extreme Summit X150 switches to replace a bunch of old unmanaged
switches so we could get more insight and control on the network. In order to prep for that, I'm playing with a Summit
X250 that I borrowed from a vendor. The problem is I can't get trunking to work between the X250 and the C2950 I've
got it connected to. The two switches can see each other's mac addresses, so I know they're communicating, I just
can't pass traffic over the trunk. Here's what I have:

Crossover cable between Summit X250 port 25 and Cisco 2950 port 3:

Cisco 2950 Side: Summit X250 Side:


(ip address 192.168.200.42) create vlan "MGT"
interface FastEthernet0/3 configure vlan MGT tag 1
switchport mode trunk configure vlan MGT add ports 25-26 tagged
switchport nonegotiate configure vlan MGT ipaddress 192.168.200.6
no ip address 255.255.255.128
duplex full enable ipforwarding vlan MGT
speed 100 configure ports 25 auto off speed 100 duplex full
switchport trunk allowed vlan all

Everything I've been able to find on the subject says that this should work, yet I can't ping between the two. Any
suggestions would be appreciated.

#sh int trunk

Port Mode Encapsulation Status Native vlan


Fa0/1 on 802.1q trunking 1
Fa0/3 on 802.1q trunking 1
Port Vlans allowed on trunk
Fa0/1 1-4094
Fa0/3 1-4094
Port Vlans allowed and active in management domain
Fa0/1 1,10,20,25,52,111,160,169,601,777
Fa0/3 1,10,20,25,52,111,160,169,601,777
Port Vlans in spanning tree forwarding state and not pruned
Fa0/1 1,10,20,25,52,111,160,169,601,777
Fa0/3 1,10,20,25,52,111,160,169,601,777

CISCO EXTREME
Cisco – Create 2 VLAN interfaces and basic Extreme – Create 2 VLANs and basic
configuration configuration

vlan dat create vlan data


vlan 2 name data configure vlan data tag 2
vlan 3 name voice configure vlan data ipaddress 10.0.2.1/24
exit create vlan voice
configure terminal configure vlan voice tag 3
interface vlan 2 configure vlan voice ipaddress 10.0.3.1/24
ip address 10.0.2.1 255.255.255.0 enable ipforwarding
no shutdown
interface vlan 3
ip address 10.0.3.1 255.255.255.0

-switch to pc on (vlan 2)
interface g0/4 -switch to pc on (vlan 2)
sw mode access configure vlan data add port 4 untagged
sw acc vlan 2 -switch to phone (vlan 3) and PC (vlan 2)
-switch to phone (vlan 3) and PC (vlan 2) configure vlan voice add port 4 tagged
interface g0/4 configure vlan data add port 4 untagged
switchport mode trunk -switch to phone (vlan 3)
switchport trunk encapsulation dot1q configure vlan voice add port 4 tagged
switchport access vlan 2 -switch to switch
-switch to phone (vlan 3) configure vlan default add port 1 tagged
interface g0/4 configure vlan data add port 1 tagged
switchport mode trunk configure vlan voice add port 1 tagged
switchport trunk encapsulation dot1q
-switch to switch
interface g0/4
switchport mode trunk
switchport trunk encapsulation dot1q

show interface g0/4 show port 4 information detail


show ip route show iproute
show cdp neigh show edp port all
show vlan show vlan
show mac-address-table show fdb
show run show config

write memory save


copy start tftp upload configuration vr vr-default 10.0.0.100
write erase unconfigure switch all

S-ar putea să vă placă și