Sunteți pe pagina 1din 20

Dual stack

Topologi

Konfigurasi
R1

interface Ethernet0/0

ip address 192.168.0.1 255.255.255.0

ipv6 address 2001::1/64

ipv6 ospf 1 area 0

interface Ethernet0/1

ip address 192.168.1.1 255.255.255.0

ipv6 address 2002::1/64

ipv6 ospf 1 area 0

ipv6 router ospf 1


ipv6 unicast-routing

R2

interface Ethernet0/0

ip address 192.168.1.2 255.255.255.0

ipv6 address 2002::2/64

ipv6 ospf 1 area 0

interface Ethernet0/1

ip address 192.168.2.1 255.255.255.0

ipv6 address 2003::1/64

ipv6 ospf 1 area 0

ipv6 router ospf 1

ipv6 unicast-routing

R3

interface Ethernet0/0

ip address 192.168.2.2 255.255.255.0

ipv6 address 2003::2/64

ipv6 ospf 1 area 0

interface Ethernet0/1

ip address 192.168.3.1 255.255.255.0

ipv6 address 2004::1/64

ipv6 ospf 1 area 0

ipv6 router ospf 1

ipv6 unicast-routing

Verifikasi
Show ip route R1
R1#show ipv6 route

IPv6 Routing Table - default - 7 entries

Codes: C - Connected, L - Local, S - Static, U - Per-user Static route

B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP

H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea

IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO

ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect

O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, la - LISP alt

lr - LISP site-registrations, ld - LISP dyn-eid, a - Application

C 2001::/64 [0/0]

via Ethernet0/0, directly connected

L 2001::1/128 [0/0]

via Ethernet0/0, receive

C 2002::/64 [0/0]

via Ethernet0/1, directly connected

L 2002::1/128 [0/0]

via Ethernet0/1, receive

O 2003::/64 [110/20]

via FE80::A8BB:CCFF:FE00:2000, Ethernet0/1

O 2004::/64 [110/30]

via FE80::A8BB:CCFF:FE00:2000, Ethernet0/1

L FF00::/8 [0/0]

via Null0, receive

R1#show ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2


i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP

a - application route

+ - replicated route, % - next hop override

Gateway of last resort is not set

172.16.0.0/32 is subnetted, 3 subnets

C 172.16.0.1 is directly connected, Loopback0

O 172.16.0.2 [110/11] via 192.168.1.2, 00:21:12, Ethernet0/1

O 172.16.0.3 [110/21] via 192.168.1.2, 00:20:50, Ethernet0/1

192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks

C 192.168.0.0/24 is directly connected, Ethernet0/0

L 192.168.0.1/32 is directly connected, Ethernet0/0

192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks

C 192.168.1.0/24 is directly connected, Ethernet0/1

L 192.168.1.1/32 is directly connected, Ethernet0/1

O 192.168.2.0/24 [110/20] via 192.168.1.2, 00:21:00, Ethernet0/1

O 192.168.3.0/24 [110/30] via 192.168.1.2, 00:20:50, Ethernet0/1

Pengujian ping dari R1 ke R3

R1#ping ipv6 2004::1 source Ethernet0/1 repeat 10

Type escape sequence to abort.

Sending 10, 100-byte ICMP Echos to 2004::1, timeout is 2 seconds:

Packet sent with a source address of 2002::1

!!!!!!!!!!

Success rate is 100 percent (10/10), round-trip min/avg/max = 1/1/1 ms

R1#
Pengujian traceroute dari R1 ke R3

R1#traceroute ipv6 2004::1

Type escape sequence to abort.

Tracing the route to 2004::1

1 2002::2 1 msec 0 msec 1 msec

2 2003::2 0 msec 1 msec 0 msec

R1#

Tunneling IPv6IP
Topologi

Konfigurasi
R1:

R1#show run int tun0

Building configuration...
Current configuration : 141 bytes

interface Tunnel0

no ip address

ipv6 address 2001::1/64

tunnel source Loopback0

tunnel mode ipv6ip

tunnel destination 172.16.0.3

end

R3:

R3#show run int tun0

Building configuration...

Current configuration : 141 bytes

interface Tunnel0

no ip address

ipv6 address 2001::2/64

tunnel source Loopback0

tunnel mode ipv6ip

tunnel destination 172.16.0.1

end

Verifikasi
Ping dari R1 ke R3

R1#ping 2001::2 source tun0 repeat 100

Type escape sequence to abort.

Sending 100, 100-byte ICMP Echos to 2001::2, timeout is 2 seconds:

Packet sent with a source address of 2001::1


!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Success rate is 100 percent (100/100), round-trip min/avg/max = 1/1/1 ms

R1#

Pengujian interface tunnel

R1#show int tun0

Tunnel0 is up, line protocol is up

Hardware is Tunnel

MTU 17920 bytes, BW 100 Kbit/sec, DLY 50000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation TUNNEL, loopback not set

Keepalive not set

Tunnel linestate evaluation up

Tunnel source 172.16.0.1 (Loopback0), destination 172.16.0.3

Tunnel Subblocks:

src-track:

Tunnel0 source tracking subblock associated with Loopback0

Set of tunnels with source Loopback0, 1 member (includes iterators), on interface <OK>

Tunnel protocol/transport IPv6/IP

Tunnel TTL 255

Tunnel transport MTU 1480 bytes

Tunnel transmit bandwidth 8000 (kbps)

Tunnel receive bandwidth 8000 (kbps)

Last input 00:00:44, output 00:00:44, output hang never

Last clearing of "show interface" counters 00:12:41

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/0 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec


5 minute output rate 0 bits/sec, 0 packets/sec

106 packets input, 14788 bytes, 0 no buffer

Received 0 broadcasts (0 IP multicasts)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

118 packets output, 13716 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 unknown protocol drops

0 output buffer failures, 0 output buffers swapped out

R1#

Pengujian traceroute dari R1 ke R3

R1#traceroute 2001::2

Type escape sequence to abort.

Tracing the route to 2001::2

1 2001::2 1 msec 1 msec 1 msec

R1#
Tunneling GRE
Topologi

Konfigurasi
Konfigurasi interface tun0 R1

R1#show run int tun0

Building configuration...

Current configuration : 121 bytes

interface Tunnel0

no ip address

ipv6 address 2001::1/64

tunnel source Loopback0


tunnel destination 172.16.0.3

end

konfigurasi tun0 R3

R3#show run int tun0

Building configuration...

Current configuration : 121 bytes

interface Tunnel0

no ip address

ipv6 address 2001::3/64

tunnel source Loopback0

tunnel destination 172.16.0.1

end

R3#

Verifikasi
Verifikasi interface tun0

R3#show int tun0

Tunnel0 is up, line protocol is up

Hardware is Tunnel

MTU 17916 bytes, BW 100 Kbit/sec, DLY 50000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation TUNNEL, loopback not set

Keepalive not set

Tunnel linestate evaluation up

Tunnel source 172.16.0.3 (Loopback0), destination 172.16.0.1

Tunnel Subblocks:

src-track:
Tunnel0 source tracking subblock associated with Loopback0

Set of tunnels with source Loopback0, 1 member (includes iterators), on interface <OK>

Tunnel protocol/transport GRE/IP

Key disabled, sequencing disabled

Checksumming of packets disabled

Tunnel TTL 255, Fast tunneling enabled

Tunnel transport MTU 1476 bytes

Tunnel transmit bandwidth 8000 (kbps)

Tunnel receive bandwidth 8000 (kbps)

Last input 00:01:16, output 00:01:06, output hang never

Last clearing of "show interface" counters 00:02:26

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/0 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

13 packets input, 1168 bytes, 0 no buffer

Received 0 broadcasts (0 IP multicasts)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

13 packets output, 1168 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 unknown protocol drops

0 output buffer failures, 0 output buffers swapped out

R3#

Pengujian ping R1 ke R3

R1#ping 2001::3 source tun0 repeat 100

Type escape sequence to abort.

Sending 100, 100-byte ICMP Echos to 2001::3, timeout is 2 seconds:


Packet sent with a source address of 2001::1

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Success rate is 100 percent (100/100), round-trip min/avg/max = 1/1/2 ms

R1#

Pengujian Traceroute R1 ke R3

R1#traceroute ipv6 2001::3

Type escape sequence to abort.

Tracing the route to 2001::3

1 2001::3 1 msec 1 msec 1 msec

R1#

Pengujian routing table untuk R3

R1#show ipv6 route

IPv6 Routing Table - default - 3 entries

Codes: C - Connected, L - Local, S - Static, U - Per-user Static route

B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP

H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea

IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO

ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect

O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, la - LISP alt

lr - LISP site-registrations, ld - LISP dyn-eid, a - Application

C 2001::/64 [0/0]

via Tunnel0, directly connected

L 2001::1/128 [0/0]

via Tunnel0, receive

L FF00::/8 [0/0]

via Null0, receive


R1#

Tunneling ISATAP
Topologi

Konfigurasi
Interface tun0 R1 dan routing static R1

R1#show run int tun0

Building configuration...

Current configuration : 174 bytes

interface Tunnel0
no ip address

no ip redirects

ipv6 address 2001:DB8:C18:1::/64 eui-64

no ipv6 nd ra suppress

tunnel source Loopback0

tunnel mode ipv6ip isatap

end

R1#show run | b ipv6 route

ipv6 route 2001:DB8::/32 Tunnel0

Interface tun0 dan routing static R2

R2#show run int tun0

Building configuration...

Current configuration : 174 bytes

interface Tunnel0

no ip address

no ip redirects

ipv6 address 2001:DB8:C18:2::/64 eui-64

no ipv6 nd ra suppress

tunnel source Loopback0

tunnel mode ipv6ip isatap

end

R2#show run | b ipv6 route

ipv6 route 2001:DB8::/32 Tunnel0

interface tun0 dan routing static R3

R3#show run int tun0

Building configuration...
Current configuration : 174 bytes

interface Tunnel0

no ip address

no ip redirects

ipv6 address 2001:DB8:C18:3::/64 eui-64

no ipv6 nd ra suppress

tunnel source Loopback0

tunnel mode ipv6ip isatap

end

R3#show run | b ipv6 route

ipv6 route 2001:DB8::/32 Tunnel0

Verifikasi
Interface tun0 R1

R1#show int tun0

Tunnel0 is up, line protocol is up

Hardware is Tunnel

MTU 17920 bytes, BW 100 Kbit/sec, DLY 50000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation TUNNEL, loopback not set

Keepalive not set

Tunnel linestate evaluation up

Tunnel source 172.16.0.1 (Loopback0)

Tunnel Subblocks:

src-track:

Tunnel0 source tracking subblock associated with Loopback0

Set of tunnels with source Loopback0, 1 member (includes iterators), on interface <OK>

Tunnel protocol/transport IPv6 ISATAP

Tunnel TTL 255


Tunnel transport MTU 1480 bytes

Tunnel transmit bandwidth 8000 (kbps)

Tunnel receive bandwidth 8000 (kbps)

Last input never, output never, output hang never

Last clearing of "show interface" counters 00:04:59

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/0 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts (0 IP multicasts)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

0 packets output, 0 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 unknown protocol drops

0 output buffer failures, 0 output buffers swapped out

Pengujian ping R1 ke R2

R1#ping ipv6 2001:DB8:C18:2:0:5EFE:AC10:2 source tun0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2001:DB8:C18:2:0:5EFE:AC10:2, timeout is 2 seconds:

Packet sent with a source address of 2001:DB8:C18:1:0:5EFE:AC10:1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Pengujian ping R1 ke R3

R1#ping ipv6 2001:DB8:C18:3:0:5EFE:AC10:3 source tun0

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2001:DB8:C18:3:0:5EFE:AC10:3, timeout is 2 seconds:


Packet sent with a source address of 2001:DB8:C18:1:0:5EFE:AC10:1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

R1#

Menampilkan routing table R1

R1#show ipv6 route

IPv6 Routing Table - default - 4 entries

Codes: C - Connected, L - Local, S - Static, U - Per-user Static route

B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP

H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea

IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO

ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect

O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, la - LISP alt

lr - LISP site-registrations, ld - LISP dyn-eid, a - Application

S 2001:DB8::/32 [1/0]

via Tunnel0, directly connected

C 2001:DB8:C18:1::/64 [0/0]

via Tunnel0, directly connected

L 2001:DB8:C18:1:0:5EFE:AC10:1/128 [0/0]

via Tunnel0, receive

L FF00::/8 [0/0]

via Null0, receive

R1#

NAT64
Topologi
Konfigurasi
R2# show run | b nat64

nat64 enable
nat64 prefix stateful 3001::/96

nat64 v6v4 static 2001::A00:A 10.0.0.10

R2#show run interface ethernet 0/0

Building configuration...

Current configuration : 148 bytes

interface Ethernet0/0

no ip address

nat64 enable

ipv6 address 2001::A00:B/128

ipv6 rip RIP enable

ipv6 rip RIP default-information only

end

R2#show run interface ethernet 0/1

Building configuration...

Current configuration : 78 bytes

interface Ethernet0/1

ip address 10.0.0.2 255.255.255.0

nat64 enable

end

R2#

Pengujian
Lakukan pengujian ping dari IPv4 ke alamat IPv4 nat4.

R3#ping 10.0.0.10
Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.0.0.10, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

R3#

Debug icmp ipv6 pada R1

R1# debug icmp ipv6

*Jun 26 03:35:21.242: ICMPv6: Received echo request, Src=3001::A00:1, Dst=2001::A00:A

*Jun 26 03:35:21.242: ICMPv6: Sent echo reply, Src=2001::A00:A, Dst=3001::A00:1

*Jun 26 03:35:21.243: ICMPv6: Received echo request, Src=3001::A00:1, Dst=2001::A00:A

*Jun 26 03:35:21.243: ICMPv6: Sent echo reply, Src=2001::A00:A, Dst=3001::A00:1

*Jun 26 03:35:21.243: ICMPv6: Received echo request, Src=3001::A00:1, Dst=2001::A00:A

*Jun 26 03:35:21.243: ICMPv6: Sent echo reply, Src=2001::A00:A, Dst=3001::A00:1

*Jun 26 03:35:21.244: ICMPv6: Received echo request, Src=3001::A00:1, Dst=2001::A00:A

*Jun 26 03:35:21.244: ICMPv6: Sent echo reply, Src=2001::A00:A, Dst=3001::A00:1

R1#

*Jun 26 03:35:21.244: ICMPv6: Received echo request, Src=3001::A00:1, Dst=2001::A00:A

*Jun 26 03:35:21.245: ICMPv6: Sent echo reply, Src=2001::A00:A, Dst=3001::A00:1

R1#

Tampilkan statistic nat64

R2#show nat64 statistics global

NAT64 Statistics

Global Statistics

Prefix: 64:FF9B::/96

Packets translated (IPv4 -> IPv6): 0

Packets translated (IPv6 -> IPv4): 0

Packets dropped: 0

Prefix: 3001::/96

Packets translated (IPv4 -> IPv6): 4


Packets translated (IPv6 -> IPv4): 0

Packets dropped: 0

R2#

S-ar putea să vă placă și