Sunteți pe pagina 1din 1

R1 R2

1.Algoritmul pentru determinarea maximului (descriere, 1.Algoritmul pentru determinarea oglinditului unui numar
pseudocod, exemplu) 3p (descriere, pseudocod, exemplu)

2.Scrieti secventele de program pentru urmatoarele cerinte: 2.Scrieti secventele de program pentru urmatoarele cerinte:

a)determinati suma cifrelor impare dintr-un numar natural n a)determinati produsul cifrelor pare dintr-un numar natural n
dat. 2p dat. 2p

b)determinati cel mai mare numar palindrom dintr-un sir de n b) determinati valoarea maxima și de câte ori apare aceasta
numere citite de la tastatura. 2p dintr-un sir de n numere citite de la tastatura. 2p

3. Scrieţi numărul care se va afişa dacă se citeşte valoarea 3. Scrieţi valorile care se vor afişa în urma executării
123456. (2p) algoritmului dacă se citesc numerele a=105, b=118 şi k=7. (2p)

citeşte a;
p←1; citeşte a, b, k;
b←0; t ← a;
cât timp a <> 0 execută p ← 0;
| c←a mod 10; ┌cât timp t<=b execută
│ ┌dacă a mod 2=0 atunci │┌dacă k=t mod 10 atunci
│ │ b ← b+c*p; ││ scrie t;
│ │altfel ││ p ← 1;
│ │ b ← b*10+c; │└sfarsit_daca;
│ └sfarsit_daca; │ t←t+1;
│ a ← a div 10; └sfarsit_cat_timp;
│ p ← p*10; ┌dacă p=0 atunci
└sfarsit_cat_timp; │ scrie -1;
scrie b; Sfarsit_daca;