Sunteți pe pagina 1din 7

Tabla de salvación

IP Privadas
A: 10.0.0.0 - 10.255.255.255
B: 172.16.0.0 - 172.31.255.255
C: 192.168.0.0 - 192.168.255.255

Restaurar router
show flash
delete vlan.dat
erase startup-config

Rutas estáticas
ip route red_destino mascar {gateway|interfaz_salida} [distancia_administrativa]
ip route 0.0.0.0 0.0.0.0 {gateway|interfaz_salida} [distancia_administrativa]
ip route red_destino mascar gateway interfaz_salida
ipv6 route ::/0 {gateway|interfaz_salida}

Router rip
router rip
version 2
no auto-summary
network red
default-information originate
passive-interface interfaz

Router on a Stick
interface g#/#.vlan_id
encapsulation dot1q vlan_id
ip address dirección mascara

VLANs
vlan vlan_id (1-1005)
name nombre
delete vlan.dat

Switch port
Básico
duplex [full|half|
speed [10|100|1000]
mdix auto

Asignar VLANs
switchport mode access
switchport access vlan vlan_id
switchport mode trunk
switchport trunk native vlan vlan_id
switchport trunk allowed vlan vlan_id,vlan_id,..,vlan_id-vlan_id
switchport
Seguridad
switchport mode access
switchport port-security
switchport port-security mac-address sticky
switchport port-security mac-address mac
switchport port-security maximum intentos
switchport port-security violation {protect|restrict|shutdown} (default shutdown)

Voz
switchport voice vlan vlan_id
mis qos trust [cos|device|cisco-phone|dscp|ip-precedence]
sh interface interfaz switchport

Comandos show
show interface interfaz
show start
show run
show flash
show version
show history
show ip interface interfaz
show ip interface brief
show interface
show mac-address-table
show mac address-table
show arp
show port-security interface [interface-id]
show interface trunk
show access-list [list_id]
ip access-list standard {list_id|nombre}
clear access-list counters {list_id|nombre}
show ip dhcp binding
show ip dhcp server statistics
show ip dhcp conflict
show ipv6 dhcp pool
show ipv6 dhcp binding
show ipv6 interface [interfaz]
debug ipv6 dhcp detail
show ip nat translations
show ip nat statistics
clear ip nat statistics
show ip nat translations verbose
clear ip nat translation *
debug ip nat
debug ip nat detailed
show cdp neighbors
show cdp neighbors detail
shos cdp interface
show lldp neighbors
show lldp neighbors detail
show lldp
show clock
show clock detail
show ntp associations
show ntp status
show logging
show logging {include|begin|section [keyword]}
show file system
dir
cd directory
pwd
dir usbflash0
show version
show license feature
show license udi
show license

Comandos config
Security password min-length 10
ssh
ip domain-name nombre
username nombre [secret|password] contraseña
crypto key generate rsa
ip ssh authentication-retries #deintentos
ip ssh time-out secs
ip ssh version 2
line vty 0 15
transport input ssh
login local
privilege level (0-15) - 15 el mas alto
exit

ACL
access-list list_id remark description
access-list list_id {deni|permit|remark} address wildcard
access-list list_id {deni|permit|remark} any
access-list list_id {deni|permit|remark} host address
ip access-list standard nombre

Aplicar ACL en interfaz


ip access-group {name|list_id} {in|out}
no ip access-group

Aplicar ACL a VTY


access-class list_id {in|out}

DHCPv4
ip dhcp excluded-address low_address [high_address]
ip dhcp pool pool_name
network network_number [mask|prefix_lenght]
default-router address [address...address]
dns-server address [address...address]
domain-name domain
lease {days [hours] [minutes]|infinite}
netbios-name-server address [address...address]
no service dhcp
service dhcp (enable by default)

Debug DHCPv4
access-list list_id permit udp any any eq 67
access-list list_id permit udp any any eq 68
debug ip dhcp server events

DHCPv4 Relay
ip helper-address dhcp_address

DHCPv4 client interface


ip address dhcp

SLACC
ipv6 unicast-routing

Stateless DHCPv6 server


ipv6 dhcp pool pool_name
dns-server dns_address
domain-name domain_name
interface #interfaz
ipv6 dhcp server pool_name
ipv6 nd other-config-flag

Stateless DHCPv6 client


ipv6 enable
ipv6 address autoconfig

Stateful DHCPv6 server


ipv6 dhcp pool pool_name
dns-server dns_address
domain-name domain_name
address prefix prefix_lenght lifetime time
interface #interfaz
ipv6 dhcp server pool_name
ipv6 nd managed-config-flag

Stateful DHCPv6 client


ipv6 enable
ipv6 address dhcp

DHCPv6 Relay
ipv6 dhcp relay destination dhcpv6_address

NAT estático
ip nata inside source static local_ip global_ip
interface interfaz
ip nat inside
interface interfaz
ip nat outside
NAT dinámico
access-list list_id permit source [wildcard ](privadas)
ip nat pool nombre start_ip end_ip {netmask mask | prefix_lenght prefix} (publicas)
ip nat inside source list list_id pool nombre
interface interfaz
ip nat inside
interface interfaz
ip nat outside

PAT dinámico
access-list list_id permit source [wildcard ](privadas)
ip nat pool nombre start_ip end_ip {netmask mask | prefix_lenght prefix} (publicas)
ip nat inside source list list_id pool nombre overload
interface interfaz
ip nat inside
interface interfaz
ip nat outside

PAT una dirección


access-list list_id permit source [wildcard ](privadas)
ip nat inside source list list_id interface interfaz1 overload
interface interfaz
ip nat inside
interface interfaz1
ip nat outside

Port forwarding
ip nat inside source {static {tcp|udp local_ip local_port global_ip global_port}} [extendable]
Verificar
ping address
tracert address
traceroute address

CDP
cdp run
no cdp run

CDP interfaces
cdp enable
no cdp enable

LLDP
lldp run
no lldp run

LLDP interfaces
lldp run
interface interfaz
lldp transmit
lldp receive
Reloj manual
clock set 00:00:00 month day year
clock timezone PT -8
clock summer-time PDT recurring

NTP server (UDP 123)


ntp server ip_address

Syslog
logging console
logging buffered

Syslog server (UDP 514)


logging ip_address
logging trap max_level
logging source-interface interfaz
interface loopback 0

Backing up
copy running-config tftp
copy running-config usbflash0
more usbname

Restoring
copy tftp running-config
copy usbname: running-config

Password Recovery
ROMMON - During booting ctrl+shift+f6+c
confreg 0x2142
reset

copy start run


conf t
enable secret password
config-register 0x2102
end copy run start
reload

Boot sytem command


conf t
boot system flash: nombre_imagen
exit
copy run start
reload

Install the license


lincese install location
reload
Evaluation
license accept end user agreement
license boot module módulo technology-package package_name
reaload

Uninstal the license


license boot module módulo technology-package package_name disable
reload
license clear feature_name
no license boot module módulo technology-package package_name

Back up license
license save file-sys:location

S-ar putea să vă placă și