Sunteți pe pagina 1din 5

Componente practico

Nombre del Estudiante: ALEXANDER RAMIREZ


Fecha: 08/11/2019 Lugar: FLORENCIA CAQUETA
Contacto: Skype?
Doy fe que los siguientes ejercicios son de mi autoría, en caso de encontrar
plagio la nota de todo mí trabajo debe ser de CERO además de las respectivas
sanciones a que haya lugar, El profesor en cualquier momento puede solicitar la
sustentación de uno o más ejercicios

1. Planteamiento del problema a resolver: convertir el diagrama proporcionado en


un seudocódigo, haciendo el análisis del mismo y utilizando las buenas
prácticas de programación.

El diagrama convierte un numero decimal en número binario, lo puede


descargar de aquí

Antes de salir debe mostrar su nombre y el de su empresa(ficticia)

Que datos no Que datos no Tipo Formulas a Requier Requiere


conozco y se conozco, pero Variables aplicar si se e ciclos (si
deben solicitar los puedo requeridas requieren condicio / no)
(si se requiere calcular Tipo Variable nal (si /
más filas por no)
favor anexarlas)
El numero El numero Entero numero Binario=”0” si si
decimal decimal a + binario
binario
caráct binario Binario=”1”
er +binario
entero resultado Numero=tr
unc(Núm./2
)
Diagrama
Producto a entregar
Seudocódigo en Pseint (Texto no la imagen)
Algoritmo DECIMAL_A_BINARIO
Definir Núm Como Entero
Definir resultado como real
Definir BINARIO como carácter
Escribir 'DIGITA EL NUMERO DECIMAL A CONVERTIR';
Leer Num
Num <- trunc(Num)
BINARIO <- ' '
Si Num>0 Entonces
Mientras Num>0 Hacer
resultado=Num MOD 2;
Si resultado=0 Entonces
BINARIO <- '0'+BINARIO
SiNo
BINARIO <- '1'+BINARIO
FinSi
Num <- trunc(Num/2)
FinMientras
Escribir "CONVERTIDO A BINARIO ES:";
Mostrar BINARIO
SiNo
Si Num=0 Entonces
Escribir "0";
SiNo
Escribir 'NO SE PUEDE CONVERTIR'
FinSi
FinSi
Escribir "JHON ALEXANDER RAMIREZ PERDOMO EMPRESA
TODOALGORITMOS";
FinAlgoritmo

Copiar captura de resultados con diferentes valores