Sunteți pe pagina 1din 71

ALGORITMOS E

PROGRAMAÇÃO I
AULA 06 – Introdução Portugol
Desvios
Prof. Msc. Salatiel Dantas
Prof. Dr. Marcos E. Cintra
PORTUGOL

• Na vida cotidiana, é comum lidarmos com situações em


que seja preciso tomar algum tipo de decisão:
• Se eu estudar, então serei aprovado em Algoritmo e Programação I;
• Se eu tiver dinheiro, então irei ao cinema hoje. Senão, irei estudar
para Algoritmo e Programação I;
• Se eu estiver disposto, então na segunda logo cedo irei na academia.
Senão, ire estudar Algoritmo e Programação I.

2
PORTUGOL

• Em muitos algoritmos pode ser preciso desviar a


execução do programa a partir de determinado valor:
• A Temperatura é menor que zero? Se sim, ligar módulo de ar-
condicionado. Senão, não fazer nada.
• Velocidade maior que 80km/h? Se sim, enviar mensagem de aviso
para redução de velocidade. Senão, pausar por 5 segundos.
• Tempo igual a 06h:30 min? Se sim, ligar despertador. Senão,
verificar novamente.

3
PORTUGOL

• Esse fluxograma, apresenta


dois caminhos de execução
que são definidos a partir do
valor de MEDIA.

4
PORTUGOL

• Esse fluxograma, apresenta


dois caminhos de execução
que são definidos a partir do
valor de MEDIA.

• Se MEDIA for maior ou igual a


7, então o fluxo segue para a
esquerda. Senão, o fluxo
segue para a direita.
5
PORTUGOL

• Para situações de desvio de fluxo o Portugol apresenta as


seguintes estruturas:
• Se;
• Se – Senao;
• Escolha.

6
PORTUGOL - SE

• A instrução SE sempre realiza um teste lógico e a partir do


resultado permite ou não a execução de um conjunto de
instruções.

• O teste lógico sempre retorna um valor booleano:


• MEDIA>=7 ?
• NOME = “ANA” ?

7
PORTUGOL - SE

• Sintaxe SE
SE (TESTE LÓGICO) ENTAO
INSTRUÇÕES
FIMSE

• Na condição SE as Instruções abaixo só executarão, se o


teste lógico apresentar valor VERDADEIRO.

8
PORTUGOL - SE

• Sintaxe SE
SE (0 > -1) ENTAO
ESCREVA(“0 é maior que -1”)
FIMSE

SE (“azul” < “vermelho”) ENTAO


ESCREVA(“O Céu é Azul”)
FIMSE
9
PORTUGOL - SE

• Sintaxe SE VERDADERIO

SE (0 > -1) ENTAO


ESCREVA(“0 é maior que -1”)
FIMSE
VERDADERIO

SE (“azul” < “vermelho”) ENTAO


ESCREVA(“O Céu é Azul”)
FIMSE
10
PORTUGOL - SE

• A instrução SE é conhecida como uma estrutura de


DECISÃO SIMPLES;
• Caso o teste lógico seja verdadeiro, um conjunto de
instruções subordinadas ao SE serão adicionadas à
execução do programa;
• Caso o teste lógico seja falso, o programa continuará sua
execução normalmente, sem executar o conjunto de
instruções subordinadas ao SE.
11

PORTUGOL - SE
VERDADERIO
TESTE LÓGICO

FALSO
Instruções N

Instruções M

12
PORTUGOL - SE
VERDADERIO
TESTE LÓGICO

O conjunto de
instruções N O conjunto de

FALSO
Só irão executar Instruções N instruções M
se o teste Lógico Irão executar
Anterior for independemente
verdadeiro do valor do teste
lógico

Instruções M

13
PORTUGOL - SE

algoritmo “MaiorIdade”
var
idade : inteiro
inicio
escreva(“Qual sua idade?”)
leia(idade)
se ( idade >= 18 ) entao
escreval(“ Você possui maior idade!”)
fimse
escreva(“Sua idade é ”, idade)
fimalgoritmo
14
PORTUGOL - SE
Teste Lógico do SE

algoritmo “MaiorIdade”
var Caso o valor da variável
idade seja maior que 18,
idade : inteiro a instrução entre o se e
inicio o fimse será executada.
escreva(“Qual sua idade?”)
leia(idade)
se ( idade >= 18 ) entao Esta instrução será
executada
escreval(“ Você possui maior idade!”) independentemente da
fimse instrução SE
escreva(“Sua idade é ”, idade)
fimalgoritmo
15
PORTUGOL - SE

algoritmo “Maior”
var
a,b : inteiro
inicio
leia(a)
leia(b)
se ( a > b ) entao
escreva(a, “é o maior”)
fimse
fimalgoritmo

16
PORTUGOL - SE

algoritmo “Maior”
var
a,b : inteiro
inicio
leia(a)
Caso o valor da variável
leia(b) a seja maior que o valor
se ( a > b ) entao da variável b, a
instrução entre o se e o
escreva(a, “é o maior”) fimse será executada.
fimse
fimalgoritmo

17
PORTUGOL - SE

• Vale ressaltar que o TESTE LÓGICO pode conter um


conjunto de operações relacionais combinadas com
operações lógicas pois estas retornam um valor booleano:

SE ((a > b) E (a <> 0)) ENTAO


ESCREVA(“a maior que b e diferente de zero”)
FIMSE

18
PORTUGOL

• Existem ainda situações em que pode ser necessário


executar ações diferentes para um caso verdadeiro e para
um caso falso.

• Exemplos:
• Um indivíduo que possui idade maior que dezesseis anos, pode
solicitar seu título de eleitor. Caso contrário, não pode solicitar;
• Um indivíduo que possui idade maior que dezoito anos, pode
solicitar sua carteira de motorista. Caso contrário, não pode
solicitar;
19
PORTUGOL

Caso a MÉDIA seja Caso a MÉDIA não


maior ou igual a seja maior ou igual
sete, o programa a sete, o programa
deve exibir esta deve exibir esta
mensagem mensagem

20
PORTUGOL – SE - SENÃO

• A instrução SE - SENÃO sempre realiza um teste lógico e a


partir do resultado executa um conjunto de instruções
ou outro conjunto de instruções.

• Sintaxe Se - Senão

SE (TESTE LÓGICO) ENTAO


INSTRUÇÕES A
SENAO
INSTRUÇÕES B
FIMSE
21
PORTUGOL – SE - SENÃO

SE (TESTE LÓGICO) ENTAO


INSTRUÇÕES A
SENAO
INSTRUÇÕES B
FIMSE

Nesta estrutura se o TESTE LÓGICO for VERDADEIRO será executado o conjunto


de INSTRUÇÕES A, se for FALSO será executado o conjunto de INSTRUÇÕES B.

22
PORTUGOL – SE - SENÃO

algoritmo “MaiorIdade”
var
idade : inteiro
inicio
escreval(“Qual sua idade?”)
leia(idade)
se ( idade >= 18 ) entao
escreval(“ Você possui maior idade!”)
senao
escreval(“ Você não possui maior idade!”)
fimse
fimalgoritmo

23
PORTUGOL – SE - SENÃO

algoritmo “MaiorIdade”
var
idade : inteiro
inicio
escreval(“Qual sua idade?”)
Caso o valor da variável
leia(idade) idade seja maior que 18,
se ( idade >= 18 ) entao esta instrução escreva
escreval(“ Você possui maior idade!”) será executada
senao
escreval(“ Você não possui maior idade!”)
fimse Caso o valor da variável
idade NÃO seja maior
fimalgoritmo que 18, esta instrução
escreva será executada

24
PORTUGOL – SE – SENÃO

• A instrução SE é conhecida como uma estrutura de


DECISÃO COMPOSTO;
• Caso o teste lógico seja verdadeiro, um conjunto de
instruções subordinadas ao SE serão adicionadas à
execução do programa;
• Caso o teste lógico seja falso, OUTRO conjunto de
instruções subordinadas ao SENÃO serão adicionadas à
execução do programa;
25

PORTUGOL – SE – SENÃO

VERDADERIO FALSO
TESTE LÓGICO

INSTRUÇÃO A INSTRUÇÃO B

INSTRUÇÃO M

26
PORTUGOL – SE – SENÃO

VERDADERIO FALSO
TESTE LÓGICO

A instrução A A instrução B
Só irá executar se Só irá executar se
o teste Lógico INSTRUÇÃO A INSTRUÇÃO B o teste Lógico
Anterior for Anterior for falso
verdadeiro

O Se Senão é mutuamente
A instrução M sempre
excludente, se a instrução A
INSTRUÇÃO M executará
executar, a instrução B não
independentemente de
executará e vice-versa
anteriormente ser executado
instrução A ou instrução B
27
PORTUGOL – SE - SENÃO

algoritmo “Maior”
var
a,b : inteiro
inicio
leia(a)
leia(b)
se ( a > b ) entao
escreva(a, “é o maior”)
senao
escreva(b, “é o maior”)
fimse
fimalgoritmo

28
PORTUGOL – SE - SENÃO
Caso o valor da variável
a seja maior que o valor
da variável b, esta
instrução escreva será
algoritmo “Maior” executada
var
a,b : inteiro Caso o valor da variável
inicio a NÃO seja maior que o
leia(a) valor da variável b, esta
leia(b) instrução escreva será
executada
se ( a > b ) entao
escreva(a, “é o maior”)
Em nenhuma situação
senao as duas instruções de
escreva(b, “é o maior”) escreva executarão de
fimse uma vez só
fimalgoritmo

29
PORTUGOL – SE – SENÃO

• A instrução SE – SENÃO deve ser sempre balanceada pelos


dois lados: SE e SENÃO;
• Não é permitido haver um SENÃO sem um SE, pois o
SENÃO é a instrução complementar de um SE;

30
PORTUGOL – SE – SENÃO

• A instrução SE – SENÃO deve ser sempre balanceada pelos


dois lados: SE e SENÃO;
• Não é permitido haver um SENÃO sem um SE, pois o
SENÃO é a instrução complementar de um SE;

SENAO
INSTRUÇÕES B PROIBIDO
FIMSE

31
PORTUGOL

• Existem também situações em que pode ser necessário


seja preciso verificar mais de uma condição para executar
alguma ação.

• Exemplos:
• Se não estiver ensolarado, não estender roupa. Mas se estiver
ensolarado e se estiver ventando, estender a roupa;
• Se idade menor ou igual a dezesseis anos, e se tiver autorização dos
pais, pode ir ao show de música. Senão, não pode ir ao show de
música.
32
PORTUGOL

Sim

33
PORTUGOL

Primeira condição. Caso


o valor do teste seja
verdadeiro o fluxo
segue pelo “Sim”
Sim

Segunda condição. Essa


condição só será
testada se a primeira
condição for verdadeira

34
PORTUGOL

Primeira condição. Caso


o valor do teste seja
verdadeiro o fluxo
segue pelo “Sim”
Sim
Depende

Segunda condição. Essa


condição só será
testada se a primeira
condição for verdadeira

35
PORTUGOL – SE / SE – SENÃO (ANINHADOS)

• Em Portugol tanto a instrução SE como a SE-SENÃO


podem ser aninhadas umas dentro das outras;
• As instruções SE e SE-SENÃO podem ser inseridas dentro
de outras instruções SE e SE-SENÃO ;

• Isso permite que alguns testes sejam subordinados a


testes anteriores.

36
PORTUGOL – SE / SE – SENÃO (ANINHADOS)

SE (TESTE LÓGICO 1) ENTAO


INSTRUÇÕES A
SENAO
SE (TESTE LÓGICO 2) ENTAO
INSTRUÇÕES B
SENAO
INSTRUÇÕES C
FIMSE
FIMSE
37
PORTUGOL – SE / SE – SENÃO (ANINHADOS)

Se o TESTE LÓGICO 1
SE (TESTE LÓGICO 1) ENTAO for verdadeiro, somente
a INSTRUÇÃO A será
INSTRUÇÕES A executada. As
SENAO
SE (TESTE LÓGICO 2) ENTAO
INSTRUÇÕES B
SENAO
INSTRUÇÕES C
FIMSE
FIMSE

38
PORTUGOL – SE / SE – SENÃO (ANINHADOS)

Se o TESTE LÓGICO 1
SE (TESTE LÓGICO 1) ENTAO for falso, a instrução
executada será o SENAO
INSTRUÇÕES A
SENAO
SE (TESTE LÓGICO 2) ENTAO
INSTRUÇÕES B
SENAO
INSTRUÇÕES C
FIMSE
FIMSE

39
PORTUGOL – SE / SE – SENÃO (ANINHADOS)

SE (TESTE LÓGICO 1) ENTAO


INSTRUÇÕES A
Dentro do SENAO há um
SENAO novo teste lógico
SE (TESTE LÓGICO 2) ENTAO aninhado no SE. Se o
TESTE LÓGICO 2 for
INSTRUÇÕES B verdadeiro, somente a
instrução B será
SENAO executada.

INSTRUÇÕES C
FIMSE
FIMSE

40
PORTUGOL – SE / SE – SENÃO (ANINHADOS)

SE (TESTE LÓGICO 1) ENTAO


INSTRUÇÕES A
SENAO
SE (TESTE LÓGICO 2) ENTAO
Se o TESTE LÓGICO 2
INSTRUÇÕES B for falso, somente a
SENAO instrução C será
executada.
INSTRUÇÕES C
FIMSE
FIMSE

41
PORTUGOL – SE / SE – SENÃO (ANINHADOS)
algoritmo “Maior”
var a,b : inteiro
inicio
leia(a)
leia(b)
se ( a > b ) entao
escreva(a, “ é o maior”)
senao
se ( a < b ) entao
escreva(b, “ é o maior”)
senao
escreva(a, “ é igual a ”,b)
fimse
fimse
fimalgoritmo
42
PORTUGOL – SE / SE – SENÃO (ANINHADOS)
algoritmo “Maior” Caso o valor da variável
a seja maior que o valor
var a,b : inteiro
da variável b, esta
inicio instrução escreva será
leia(a) executada
leia(b)
se ( a > b ) entao
escreva(a, “ é o maior”)
senao
se ( a < b ) entao
escreva(b, “ é o maior”)
senao
escreva(a, “ é igual a ”,b)
fimse
fimse
fimalgoritmo
43
PORTUGOL – SE / SE – SENÃO (ANINHADOS)
algoritmo “Maior” Caso o valor da variável
a seja maior que o valor
var a,b : inteiro
da variável b, esta
inicio instrução escreva será
leia(a) executada
leia(b)
se ( a > b ) entao Caso o valor da variável
escreva(a, “ é o maior”) a NÃO seja maior que o
senao valor da variável b, esta
instrução será
se ( a < b ) entao executada
escreva(b, “ é o maior”)
senao
escreva(a, “ é igual a ”,b)
fimse
fimse
fimalgoritmo
44
PORTUGOL – SE / SE – SENÃO (ANINHADOS)
algoritmo “Maior”
var a,b : inteiro Caso o valor da variável
b seja maior que o valor
inicio da variável a, esta
leia(a) instrução escreva será
leia(b) executada
se ( a > b ) entao
escreva(a, “ é o maior”)
senao
se ( a < b ) entao Caso o valor da variável
escreva(b, “ é o maior”) b NÃO seja maior que o
senao valor da variável a, esta
instrução será
escreva(a, “ é igual a ”,b)
executada
fimse
fimse
fimalgoritmo
45
PORTUGOL

• Existem também situações em que pode ser necessário


seja alguma ação específica para cada tipo de valor de uma
variável.

• Exemplos:
• Um menu de restaurante lhe dá diversas opções. Você escolhe uma
opção que é referente a um alimento específico;
• Uma calculadora comum lhe dá algumas opções de operação. Você
escolhe uma opção e ele realiza uma operação referente àquela
opção.
46
PORTUGOL - ESCOLHA

• Para as situações de escolha de opções e ações definidas


para cada opção, o Portugol nos fornece a instrução
ESCOLHA;

• A instrução ESCOLHA permite que, a partir de


determinado valor, selecionemos uma ação predefinida
referente àquele valor escolhido.

47
PORTUGOL - ESCOLHA
• Sintaxe:

ESCOLHA (VAR)
CASO V1 INSTRUÇÕES A
CASO V2 INSTRUÇÕES B
CASO V3 INSTRUÇÕES C
...
CASO Vn INSTRUÇÕES N
OUTROCASO INSTRUÇÕES X
FIMESCOLHA

48
PORTUGOL - ESCOLHA
ESCOLHA (VAR)
CASO V1 INSTRUÇÕES A
CASO V2 INSTRUÇÕES B
CASO V3 INSTRUÇÕES C
...
CASO Vn INSTRUÇÕES N
OUTROCASO INSTRUÇÕES X
FIMESCOLHA

• O caso a ser executado, é definido pelo valor inserido em VAR.


Caso VAR seja igual a V1, as INSTRUÇÕES A serão executadas.
Caso VAR seja igual a V2, as INSTRUÇÕES B serão executadas, e
assim por diante. 49
PORTUGOL - ESCOLHA
ESCOLHA (VAR)
CASO V1 INSTRUÇÕES A
CASO V2 INSTRUÇÕES B
CASO V3 INSTRUÇÕES C
...
CASO Vn INSTRUÇÕES N
OUTROCASO INSTRUÇÕES X
FIMESCOLHA

• OUTROCASO é a instrução predefinida para quando o valor de


VAR não for igual a nenhum dos valores V1 ... Vn;
• Geralmente é utilizado para capturar valores inválidos que
possam acontecer. 50
PORTUGOL - ESCOLHA

• Os valores definidos em cada caso, é definido pelo


programador desenvolvedor do algoritmo;
• Geralmente utiliza-se valores inteiros ou literais para
definir os casos.

51
PORTUGOL - ESCOLHA
algoritmo “ShowDoMilhão”
var resp : caractere
Inicio
escreva(“Qual o nome do cavalo branco de Napoleão?”)
escreva(“A – Morango”)
escreva(“B – Pégasus”)
escreva(“C – Mônaco”)
leia(resp)
Escolha (resp)
caso “A”
escreva(“Resposta Correta!”)
outrocaso
escreva(“Resposta Errada!”)
fimescolha
fimalgoritmo
52
PORTUGOL - ESCOLHA

algoritmo “ShowDoMilhão” Parte inicial do algoritmo.


var resp : caractere Exibe mensagens na tela
Inicio e espera valores para
serem armazenados nas
escreva(“Qual o nome do cavalo branco de Napoleão?”)
variável resp
escreva(“A – Morango”)
escreva(“B – Pégasus”)
escreva(“C – Mônaco”)
leia(resp)
Escolha (resp)
caso “A”
escreva(“Resposta Correta!”)
outrocaso
escreva(“Resposta Errada!”)
fimescolha
fimalgoritmo 53
PORTUGOL - ESCOLHA

algoritmo “ShowDoMilhão”
var resp : caractere
Inicio
escreva(“Qual o nome do cavalo branco de Napoleão?”)
escreva(“A – Morango”) A instrução escolha
escreva(“B – Pégasus”) verifica o valor da
escreva(“C – Mônaco”) variável resp e testa
com os valores dos
leia(resp) casos definidos logo
Escolha (resp) abaixo.
caso “A”
escreva(“Resposta Correta!”)
outrocaso
escreva(“Resposta Errada!”)
fimescolha
fimalgoritmo 54
PORTUGOL - ESCOLHA

algoritmo “ShowDoMilhão”
var resp : caractere
Inicio
escreva(“Qual o nome do cavalo branco de Napoleão?”)
escreva(“A – Morango”)
escreva(“B – Pégasus”)
escreva(“C – Mônaco”)
leia(resp) Se o valor da variável
Escolha (resp) resp for igual ao literal
caso “A” “A”, esta instrução de
escreva será executada.
escreva(“Resposta Correta!”)
outrocaso
escreva(“Resposta Errada!”)
fimescolha
fimalgoritmo 55
PORTUGOL - ESCOLHA

algoritmo “ShowDoMilhão”
var resp : caractere
Inicio
escreva(“Qual o nome do cavalo branco de Napoleão?”)
escreva(“A – Morango”)
escreva(“B – Pégasus”)
escreva(“C – Mônaco”)
leia(resp)
Escolha (resp)
Se o valor da variável
caso “A” resp não for igual ao
escreva(“Resposta Correta!”) literal “A”, esta instrução
outrocaso de escreva será
executada.
escreva(“Resposta Errada!”)
fimescolha
fimalgoritmo 56
PORTUGOL - ESCOLHA
Algoritmo “Operações”
var
a,b : inteiro
resp : caractere
inicio
escreva(“Digite dois números:”)
leia(a)
leia(b)
escreva(“A - Adição”)
escreva(“S - Subtração”)
escreva(“M – Multiplicação”)
leia(resp)
Escolha (resp)
caso “A”
escreva(a+b)
caso “S”
escreva(a–b)
caso “M”
escreva(a*b)
outrocaso: escreva(“Operação Inválida!”)
fimescolha
fimalgoritmo
57
PORTUGOL - ESCOLHA
Algoritmo “Operações” Parte inicial do algoritmo.
var Exibe mensagens na tela
a,b : inteiro e espera valores para
serem armazenados nas
resp : caractere
variáveis a e b
inicio
escreva(“Digite dois números:”)
leia(a)
leia(b)
escreva(“A - Adição”)
escreva(“S - Subtração”)
escreva(“M – Multiplicação”)
leia(resp)
Escolha (resp)
caso “A” escreva(a+b)
caso “S” escreva(a–b)
caso “M” escreva(a*b)
outrocaso: escreva(“Operação Inválida!”)
fimescolha
fimalgoritmo 58
PORTUGOL - ESCOLHA
Algoritmo “Operações” A instrução escolha
var verifica o valor da
a,b : inteiro variável resp e testa
com os valores dos
resp : caractere
casos definidos logo
inicio abaixo.
escreva(“Digite dois números:”)
leia(a)
leia(b)
escreva(“A - Adição”)
escreva(“S - Subtração”)
escreva(“M – Multiplicação”)
leia(resp)
Escolha (resp)
caso “A” escreva(a+b)
caso “S” escreva(a–b)
caso “M” escreva(a*b)
outrocaso: escreva(“Operação Inválida!”)
fimescolha
fimalgoritmo 59
PORTUGOL - ESCOLHA
Algoritmo “Operações”
var
a,b : inteiro
resp : caractere
inicio
escreva(“Digite dois números:”)
leia(a)
leia(b) Se o valor da variável
resp não for igual ao
escreva(“A - Adição”)
literal “A”, esta instrução
escreva(“S - Subtração”) de escreva será
escreva(“M – Multiplicação”) executada e realizará a
leia(resp) soma de A + B.
Escolha (resp)
caso “A” escreva(a+b)
caso “S” escreva(a–b)
caso “M” escreva(a*b)
outrocaso: escreva(“Operação Inválida!”)
fimescolha
fimalgoritmo 60
PORTUGOL - ESCOLHA
Algoritmo “Operações”
var
a,b : inteiro
resp : caractere
inicio
escreva(“Digite dois números:”)
leia(a)
leia(b)
escreva(“A - Adição”)
escreva(“S - Subtração”)
escreva(“M – Multiplicação”)
Se o valor da variável
leia(resp)
resp não for igual ao
Escolha (resp) literal “S”, esta instrução
caso “A” escreva(a+b) de escreva será
caso “S” escreva(a–b) executada e realizará a
caso “M” escreva(a*b) subtração de A - B.
outrocaso: escreva(“Operação Inválida!”)
fimescolha
fimalgoritmo 61
PORTUGOL - ESCOLHA
Algoritmo “Operações”
var
a,b : inteiro
resp : caractere
inicio
escreva(“Digite dois números:”)
leia(a)
leia(b)
escreva(“A - Adição”)
escreva(“S - Subtração”)
escreva(“M – Multiplicação”)
leia(resp)
Se o valor da variável
Escolha (resp)
resp não for igual ao
caso “A” escreva(a+b) literal “M”, esta
caso “S” escreva(a–b) instrução de escreva
caso “M” escreva(a*b) será executada e
outrocaso: escreva(“Operação Inválida!”) realizará a multiplicação
fimescolha de A * B.
fimalgoritmo 62
EXERCÍCIO 01

Calcular uma divisão entre dois números, mas, produzir um


alerta em caso de divisão por zero.

63
EXERCÍCIO 01

64
EXERCÍCIO 02

Calcular a área de um círculo, tendo como entrada o valor do


raio, que deve ser positivo.

65
EXERCÍCIO 02

66
EXERCÍCIO 03

Construa a calculadora de media da UFERSA


1 - Peca as três notas das provas do usuário;
2 - Calcule a média da UFERSA;
3 - Verifique se está aprovado, reprovado ou quanto precisa na quarta prova;

Observação:
Cálculo da Média:
Media((n1*2) + (n2*3) + (n3*4))/9
Se a Média < 3,5 esta reprovado;
Cálculo de quanto precisa na quarta prova para ser aprovado:
QuartaProva = (50 - (7*Media))/3

67
EXERCÍCIO 03

68
EXERCÍCIO 04

Desenvolva um algoritmo para calcular o custo de um


estacionamento urbano de acordo com o tipo de veículo. O
algoritmo deverá indicar as opções:
1 – moto – R$ 3,00 p/hora
2 – carro – R$ 5,00 p/hora
De acordo com a opção escolhida o algoritmo deverá receber
a quantidade de horas e calcular o valor total.

69
EXERCÍCIO 04

70
DÚVIDAS?
Contanto: salatiel.dantas@ufersa.edu.br