Sunteți pe pagina 1din 1

LUCRARE SCRISĂ LA INFORMATICĂ

PE SEMESTRUL I
CLASA A IX-A C

1. Variabilele x și y sunt de tip întreg și memorează câte un număr natural nenul. O expresie
echivalentă cu !(x%y!=0 || y<2) poate fi: (12p.)
a. x%y==y%x && y>1
b. (x+y)%y==0 || y>=1
c. (x/y)*y==x && y>=2
d. x%y==0 || y>2
2. Algoritmul alăturat este reprezentat în pseudocod.

citeşte n (număr întreg nenul)


┌dacă n<0 atunci
│ n-n
└■
s0
┌repetă
│ xn%10
│┌pentru i1,x execută
││ ss+x
│└■
│ n[n/10]
└până când n=0
scrie s
a) Scrieţi numărul afişat dacă se citeşte valoarea 2018. (12p.)
b) Scrieţi patru numere distincte din intervalul [10,103] care pot fi citite astfel încât, în urma
executării algoritmului, pentru fiecare dintre acestea, să se afișeze valoarea 100. (8p.)
c) Scrieţi în pseudocod un algoritm echivalent cu cel dat, înlocuind adecvat structura
pentru...execută cu o structură cu test inițial. (18p.)

Realizați câte un algoritm în pseudocod sau un program în C++ pentru fiecare dintre
următoarele probleme:
3. Se citeste de la tastatura un număr natural n și apoi n numere naturale. Afișați acele valori
palindrom din cele citite. (20p.)
4. Să se determine media aritmetică a valorilor prime mai mici sau egale cu n, unde n se citește
de la tastatură. (20p.)

Oficiu:10p