Sunteți pe pagina 1din 27

4.2.2.

4 Lab – Troubleshooting EtherChannel

Addressing Table
Device Interface IP Address Subnet Mask
S1 VLAN 99 192.168.1.11 255.255.255.0
S2 VLAN 99 192.168.1.12 255.255.255.0
S3 VLAN 99 192.168.1.13 255.255.255.0
PC-A NIC 192.168.0.2 255.255.255.0
PC-C NIC 192.168.0.3 255.255.255.0

VLAN Assignments
VLAN Name
10 User
99 Management

Objectives
1) Part 1: Build the Network and Load Device Configurations

2) Part 2: Troubleshoot EtherChannel

Background / Scenario
The switches at your company were configured by an inexperienced network administrator.
Several errors in the configuration have resulted in speed and connectivity issues. Your
manager has asked you to troubleshoot and correct the configuration errors and document
your work. Using your knowledge of EtherChannel and standard testing methods, find and
correct the errors. Ensure that all of the EtherChannels use Port Aggregation Protocol (PAgP),
and that all hosts are reachable.
Note: The switches used are Cisco Catalyst 2960s with Cisco IOS Release 15.0(2) (lanbasek9
image). Other switches and Cisco IOS versions can be used. Depending on the model and Cisco
4.2.2.4 Lab – Troubleshooting EtherChannel

IOS version, the commands available and output produced might vary from what is shown in
the labs.
Note: Make sure that the switches have been erased and have no startup configurations. If you
are unsure, contact your instructor.

Required Resources
• 3 Switches (Cisco 2960 with Cisco IOS Release 15.0(2) lanbasek9 image or comparable)
• 2 PCs (Windows 7, Vista, or XP with a terminal emulation program, such as Tera Term)
• Console cables to configure the Cisco IOS devices via the console ports
• Ethernet cables as shown in the topology
4.2.2.4 Lab – Troubleshooting EtherChannel

1) Part 1: Build the Network and Load Device Configurations

In Part 1, you will set up the network topology, configure basic settings on the PC hosts, and
load configurations on the switches.

Step 1: Cable the network as shown in the topology.

Step 2: Configure the PC hosts.

Step 3: Erase the startup and VLAN configurations and reload the switches.
4.2.2.4 Lab – Troubleshooting EtherChannel

Switch > enable


Switch# show startup-config
Switch# erase startup-config + enter
Switch# reload + enter

Step 4: Load switch configurations.


Load the following configurations into the appropriate switch. All switches have the same
passwords. The privileged EXEC password is class. The password for console and vty access is
cisco. As all switches are Cisco devices, the network administrator decided to use Cisco’s PAgP
on all port channels configured with EtherChannel. Switch S2 is the root bridge for all VLANs in
the topology.

Switch > enable


Switch# configure terminal
Switch(config)# “Paste hier de configuratie per switch”
4.2.2.4 Lab – Troubleshooting EtherChannel

S1 Configuration: S2 Configuration: S3 Configuration:


hostname S1 hostname S2 hostname S3
interface range f0/1-24, interface range f0/1-24, interface range f0/1-24,
g0/1-2 g0/1-2 g0/1-2
shutdown shutdown shutdown
exit exit exit
enable secret class enable secret class enable secret class
no ip domain lookup no ip domain lookup no ip domain lookup
line vty 0 15 line vty 0 15 line vty 0 15
password cisco password cisco password cisco
login login login
line con 0 line con 0 line con 0
password cisco password cisco password cisco
logging synchronous logging synchronous logging synchronous
login login login
exit exit exit
vlan 10 vlan 10 vlan 10
name User name User name User
vlan 99 vlan 99 vlan 99
Name Management name Management name Management
interface range f0/1-2 spanning-tree vlan 1,10,99 interface range f0/1-2
switchport mode trunk root primary interface range f0/3-4
channel-group 1 mode active interface range f0/1-2 switchport mode trunk
switchport trunk native switchport mode trunk channel-group 3 mode
vlan 99 channel-group 1 mode desirable
no shutdown desirable switchport trunk native
interface range f0/3-4 switchport trunk native vlan 99
vlan 99 no shutdown
channel-group 2 mode
desirable no shutdown interface f0/18
switchport trunk native interface range f0/3-4 switchport mode access
vlan 99 switchport mode trunk switchport access vlan 10
no shutdown channel-group 3 mode no shutdown
interface f0/6 desirable
interface vlan 99
switchport mode access switchport trunk native
vlan 99 ip address 192.168.1.13
switchport access vlan 10 255.255.255.0
interface vlan 99
no shutdown interface port-channel 3
ip address 192.168.1.12
interface vlan 99 255.255.255.0 switchport trunk native
ip address 192.168.1.11 vlan 99
interface port-channel 1
255.255.255.0 switchport mode trunk
switchport trunk native
interface port-channel 1 vlan 99
switchport trunk native switchport trunk allowed
vlan 99 vlan 1,99
switchport mode trunk interface port-channel 3
interface port-channel 2 switchport trunk native
switchport trunk native vlan 99
vlan 99 switchport trunk allowed
switchport mode access vlan 1,10,99
switchport mode trunk

Step 5: Save your configuration per switch

Switch > enable


Switch# copy running-config startup-config
4.2.2.4 Lab – Troubleshooting EtherChannel

2) Part 2: Troubleshoot EtherChannel


In Part 2, you must examine the configurations on all switches, make corrections if needed, and
verify full functionality.

Step 1: Troubleshoot S1.


a. Use the show interfaces trunk command to verify that the port channels are functioning as
trunk ports. = We kunnen port channels 1 en 2 niet zien. We krijgen geen informatie.

S1>enable
S1#show interfaces trunk

Do port channels 1 and 2 appear as trunked ports? = Nee

a. Use the show etherchannel summary command to verify that interfaces are configured in
the correct port channel, the proper protocol is configured, and the interfaces are in use.

S1>enable
S1#show etherchannel summary

Based on the output, are there any EtherChannel issues? If issues are found, record them in
the space provided below. = Ja
- Port Channel 1 is down + geconfigureerd met the Link Aggregation Control Protocol (LACP)
- de ports in Port-Channel functioneren independently (I = stand-alone) in P01 terwijl P2 code P
hebben.
4.2.2.4 Lab – Troubleshooting EtherChannel

b. Use the command show run | begin interface Port-channel command to view the running
configuration beginning with the first port channel interface.

S1>enable
S1#show run | begin interface Port-channel

S1#show run | begin interface Port-channel


interface Port-channel1
switchport trunk native vlan 99
switchport mode trunk
! Wat kan ik hieruit afleiden:
interface Port-channel2
switchport trunk native vlan 99
switchport mode access Port-channel 1 = switchport mode trunk
!
interface FastEthernet0/1 - FA0/1
switchport trunk native vlan 99
switchport mode trunk
o Channel-group 1 mode active = LACP
channel-group 1 mode active - FA0/2
!
interface FastEthernet0/2 o Channel-group 1 mode active = LACP
switchport trunk native vlan 99
switchport mode trunk
channel-group 1 mode active Port channel 2 = switchport mode acces
!
interface FastEthernet0/3
- FA0/3
switchport trunk native vlan 99 o Channel-group 2 mode desirables = PAgP
switchport mode access
channel-group 2 mode desirable - FA0/4
!
interface FastEthernet0/4
o Channel-group 2 mode desirables = PAgP
switchport trunk native vlan 99
switchport mode access
channel-group 2 mode desirable
!
interface FastEthernet0/5
shutdown
!
interface FastEthernet0/6
switchport access vlan 10
switchport mode access
!

interface GigabitEthernet0/1
shutdown
!
interface GigabitEthernet0/2
shutdown
!
interface Vlan1
no ip address
shutdown
!
interface Vlan99
mac-address 0002.4a9c.a001
ip address 192.168.1.11 255.255.255.0
!
!
line con 0
password cisco
logging synchronous
login
!
line vty 0 4
password cisco
login
line vty 5 15
password cisco
login
!
!
!
End
4.2.2.4 Lab – Troubleshooting EtherChannel

c. Resolve all problems found in the outputs from the previous show commands. Record the
commands used to correct the configurations.
Port-channel 1 = switchport mode trunk
- FA0/1 -> Channel-group 1 mode active = LACP
- FA0/2 -> Channel-group 1 mode active = LACP

Op FA0/1 en FA0/2 staat het LACP protocol geconfigureerd. We moeten dit verwijderen en
configureren naar het PAgP protocol:

S1>enable
S1#configure terminal
S1#interface range fastEthernet 0/1-2
S1(config-if-range)#no channel-group 1 mode active
S1(config-if-range)#channel-group 1 mode desirable
S1(config-if-range)#exit

Port channel 2 = switchport mode acces


- FA0/3 -> Channel-group 2 mode desirables = PAgP
- FA0/4 -> Channel-group 2 mode desirables = PAgP

Op port-channel 2 staat de switchport op mode acces. We moeten aanpassen naar trunk mode:

S1(config)#interface port-channel 2
S1(config-if)#switchport mode trunk

S1> enable
S1# copy running-config startup-config

d. Use the show interfaces trunk command to verify trunk settings.

S1>enable
S1#show interfaces trunk
4.2.2.4 Lab – Troubleshooting EtherChannel

e. Use the show etherchannel summary command to verify that the port channels are up and
in use.

S1>enable
S1#show etherchannel summary

- Port Channel status in use. En de code P bij de interfaces.


- We zien wel nog dat het Po1 nog het protocol LACP heeft (Ik heb de switch gereload):

S1>enable
S1#reload
4.2.2.4 Lab – Troubleshooting EtherChannel

S1 Configuration, zie rode aanpassingen:

S1 Configuration: S2 Configuration: S3 Configuration:


hostname S1
interface range f0/1-24, g0/1-2
shutdown
exit
enable secret class
no ip domain lookup
line vty 0 15
password cisco
login
line con 0
password cisco
logging synchronous
login
exit
vlan 10
name User
vlan 99
Name Management
interface range f0/1-2
switchport mode trunk
! channel-group 1 mode desirable
channel-group 1 mode active
switchport trunk native vlan 99
no shutdown
interface range f0/3-4
channel-group 2 mode desirable
switchport trunk native vlan 99
! switchport mode trunk
no shutdown
interface f0/6
switchport mode access
switchport access vlan 10
no shutdown
interface vlan 99
ip address 192.168.1.11
255.255.255.0
interface port-channel 1
switchport trunk native vlan 99
switchport mode trunk
interface port-channel 2
switchport trunk native vlan 99
switchport mode access
! switchport mode trunk
4.2.2.4 Lab – Troubleshooting EtherChannel

Step 2: Troubleshoot S2.


a. Issue the command to verify that the port channels are functioning as trunk ports. Record
the command used in the space provided below. = We kunnen maar 1 port channel zien.

S2>enable
S2#show interfaces trunk

Based on the output, are there any issues with the configurations? If issues are found,
record them in the space provided below. = Ja,
- Port Channel 3 is niet te vinden in deze output
- VLAN 10 is toegekend in Port Channel 1.

b. Issue the command to verify that interfaces are configured in the correct port channel and
the proper protocol is configured.

S2>enable
S2#show etherchannel summary

Based on the output, are there any EtherChannel issues? If issues are found, record them in
the space provided below. = Ja
- Port Channel 3 is down.

c. Use the command show run | begin interface Port-channel to view the running
configuration beginning with the first port-channel interface.
4.2.2.4 Lab – Troubleshooting EtherChannel

S2>enable
S2#show run | begin interface Port-channel

S2#show run | begin interface Port-channel


interface Port-channel1
switchport trunk native vlan 99
switchport trunk allowed vlan 1,99
switchport mode trunk
Wat kan ik hieruit afleiden:
!
interface Port-channel3
switchport trunk native vlan 99 Port-channel 1 = switchport trunk allowed vlan 1,99
switchport trunk allowed vlan 1,10,99
switchport mode trunk
o Vlan 10 ???
! - FA0/1
interface FastEthernet0/1
switchport trunk native vlan 99 - FA0/2
switchport trunk allowed vlan 1,99
switchport mode trunk
channel-group 1 mode desirable Port channel 3 = switchport trunk allowed vlan 1,10,99
!
interface FastEthernet0/2
- FA0/3
switchport trunk native vlan 99 o Shutdown = interface disabled, down
switchport trunk allowed vlan 1,99
switchport mode trunk - FA0/4
channel-group 1 mode desirable o Shutdown = interface disabled, down
!
interface FastEthernet0/3
switchport trunk native vlan 99
switchport trunk allowed vlan 1,10,99
switchport mode trunk
channel-group 3 mode desirable
shutdown
!
interface FastEthernet0/4
switchport trunk native vlan 99
switchport trunk allowed vlan 1,10,99
switchport mode trunk
channel-group 3 mode desirable
shutdown
!

interface GigabitEthernet0/1
shutdown
!
interface GigabitEthernet0/2
shutdown
!
interface Vlan1
no ip address
shutdown
!
interface Vlan99
mac-address 00e0.8f9a.1701
ip address 192.168.1.12 255.255.255.0
!
!
line con 0
password cisco
logging synchronous
login
!
line vty 0 4
password cisco
login
line vty 5 15
password cisco
login
!
!
!
!
end
4.2.2.4 Lab – Troubleshooting EtherChannel

d. Resolve all problems found in the outputs from the previous show commands. Record the
commands used to correct the configuration.
Port channel 3 = switchport trunk allowed vlan 1,10,99
- FA0/3 -> Shutdown = interface disabled
- FA0/4 -> Shutdown = interface disabled

Interfaces FA0/3 en FA0/4 zijn disabled, down. We moeten deze eerst enabled zetten.

S2>enable
S2#configure terminal
S2(config)#interface range fastEthernet 0/3-4
S2(config-if-range)#no shutdown
S2(config-if-range)#exit

Port-channel 1 = switchport trunk allowed vlan 1,99


o Vlan 10 ???
- FA0/1
- FA0/2

Op port-channel 1 is VLAN 10 niet ingesteld als Allowed VLAN:

S2(config)#interface port-channel 1
S2(config-if)#switchport trunk allowed vlan 1,10,99

S2>enable
S2#copy running-config startup-config

e. Issue the command to verify trunk settings.

S2> enable
S2#show interfaces trunk

VLAN 10 staat in de lijst bij allowed on trunk. Port Channel 3 kunnen we nog altijd niet zien omdat we
de configuratie nog moeten afwerken op S3.
4.2.2.4 Lab – Troubleshooting EtherChannel

f. Issue the command to verify that the port channels are functioning. Remember that port
channel issues can be caused by either end of the link.

S2>enable
S2#show etherchannel summary

- Po3 is nog altijd down, omdat S3 nog geconfigureerd moet worden.


4.2.2.4 Lab – Troubleshooting EtherChannel

S2 Configuration, zie rode aanpassingen:

S1 Configuration: S2 Configuration: S3 Configuration:


hostname S2
interface range f0/1-24, g0/1-2
shutdown
exit
enable secret class
no ip domain lookup
line vty 0 15
password cisco
login
line con 0
password cisco
logging synchronous
login
exit
vlan 10
name User
vlan 99
name Management
spanning-tree vlan 1,10,99 root
primary
interface range f0/1-2
switchport mode trunk
channel-group 1 mode desirable
switchport trunk native vlan 99
no shutdown
interface range f0/3-4
switchport mode trunk
channel-group 3 mode desirable
switchport trunk native vlan 99
! no shutdown
interface vlan 99
ip address 192.168.1.12
255.255.255.0
interface port-channel 1
switchport trunk native vlan 99
switchport trunk allowed vlan
1,99
! switchport trunk allowed 1,10,99
interface port-channel 3
switchport trunk native vlan 99
switchport trunk allowed vlan
1,10,99
switchport mode trunk
4.2.2.4 Lab – Troubleshooting EtherChannel

Step 3: Troubleshoot S3.


a. Issue the command to verify that the port channels are functioning as trunk ports.

S3>enable
S3#show interfaces trunk

Based on the output, are there any issues with the configurations? If issues are found,
record them in the space provided below. = Ja,
- Port Channel 2 is niet te vinden in deze output

b. Issue the command to verify that the interfaces are configured in the correct port channel
and that the proper protocol is configured.

S3>enable
S3#show etherchannel summary

Based on the output, are there any EtherChannel issues? If issues are found, record them in
the space provided below. = Ja
- Port Channel 2 wordt niet getoond
- Port Channel 3 is niet goed geconfigureerd: hier worden interfaces FA0/3 en FA0/4 gebruikt.
Maar Port-channel 3 op S3 hebben interfaces FA0/1 en FA0/2.

c. Use the command show run | begin interface Port-channel command to view the running
configuration beginning with the first port channel interface.
4.2.2.4 Lab – Troubleshooting EtherChannel

S3>enable
S3#show run | begin interface Port-channel

S3#show run | begin interface Port-channel


interface Port-channel3
switchport trunk native vlan 99 Wat kan ik hieruit afleiden:
switchport mode trunk
!
interface FastEthernet0/1
shutdown Port-channel 3
! - FA0/1
interface FastEthernet0/2
shutdown o Shutdown = interface disabled, down
! - FA0/2
interface FastEthernet0/3
switchport trunk native vlan 99 o Shutdown = interface disabled, down
switchport mode trunk
channel-group 3 mode desirable
! Port channel 2
interface FastEthernet0/4
switchport trunk native vlan 99 - FA0/3
switchport mode trunk
channel-group 3 mode desirable
o Channel-group 3 mode desirables
! - FA0/4

interface FastEthernet0/18 o Channel-group 3 mode desirables
switchport access vlan 10
switchport mode access

!
interface GigabitEthernet0/1
shutdown
!
interface GigabitEthernet0/2
shutdown
!
interface Vlan1
no ip address
shutdown
!
interface Vlan99
mac-address 00d0.97e4.4701
ip address 192.168.1.13 255.255.255.0
!
!
line con 0
password cisco
logging synchronous
login
!
line vty 0 4
password cisco
login
line vty 5 15
password cisco
login
!
!
end

d. Resolve all problems found. Record the commands used to correct the configuration.
4.2.2.4 Lab – Troubleshooting EtherChannel

Port channel 2
- FA0/3 -> Channel-group 3 mode desirables
- FA0/4 -> Channel-group 3 mode desirables

Interfaces FA0/3 en FA0/4 zijn ingesteld met Channel-group 3, maar deze interfaces horen bij Port-
channel2. We moeten deze interfaces dus aanpassen naar channel-group 2.

S3>enable
S3#configure terminal
S3(config)#interface range fastEthernet 0/3-4
S3(config-if-range)#channel-group 2 mode desirable
S3(config-if-range)#exit

Port-channel 3
- FA0/1 -> Shutdown = interface disabled, down
- FA0/2 -> Shutdown = interface disabled, down

Op port-channel 3 zijn de interfaces disabled, down. We moeten deze enabled zetten en al de overige
informatie van channel 3 toevoegen in de configuratie.

S3(config)#interface range fastEthernet 0/1-2


S3(config-if-range)#switchport mode trunk
S3(config-if-range)#switchport trunk native vlan 99
S3(config-if-range)#channel-group 3 mode desirable
S3(config-if-range)#no shutdown

S3>enable
S3#copy running-config startup-config

e. Issue the command to verify trunk settings. Record the command used in the space
provided below.

S3> enable
S3#show interfaces trunk

Po 2 en Po 3 staan in de lijst geconfigureerd.


4.2.2.4 Lab – Troubleshooting EtherChannel

f. Issue the command to verify that the port channels are functioning. Record the command
used in the space provided below.

S3>enable
S3#show etherchannel summary

- Po2 en Po3 zijn actief en zijn nu geconfigureerd met de juiste interfaces.


4.2.2.4 Lab – Troubleshooting EtherChannel

S3 Configuration, zie rode aanpassingen:

S1 Configuration: S2 Configuration: S3 Configuration:


hostname S3
interface range f0/1-24, g0/1-2
shutdown
exit
enable secret class
no ip domain lookup
line vty 0 15
password cisco
login
line con 0
password cisco
logging synchronous
login
exit
vlan 10
name User
vlan 99
name Management
interface range f0/1-2
! switchport mode trunk
! channel-group 3 mode desirable
! switchport trunk native vlan 99
! no shutdown
interface range f0/3-4
switchport mode trunk
! channel-group 2 mode desirable
channel-group 3 mode desirable
switchport trunk native vlan 99
no shutdown
interface f0/18
switchport mode access
switchport access vlan 10
no shutdown
interface vlan 99
ip address 192.168.1.13
255.255.255.0
! interface port-channel 2
! switchport trunk native vlan 99
! switchport mode trunk
interface port-channel 3
switchport trunk native vlan 99
switchport mode trunk
4.2.2.4 Lab – Troubleshooting EtherChannel

Step 4: Verify EtherChannel and Connectivity.


a. Use the show interfaces etherchannel command to verify full functionality of the port
channels.

S1>enable
S1#show interfaces etherchannel

We zien hier alle details van de interfaces:

S1#show interfaces etherchannel


----
FastEthernet0/1:
Port state = 1
Channel group = 1 Mode = Desirable-S1 Gcchange = 0
Port-channel = Po1 GC = 0x00000000 Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = PAgP

Flags: S - Device is sending Slow hello. C - Device is in Consistent state.


A - Device is in Auto mode. P - Device learns on physical port.
d - PAgP is down.
Timers: H - Hello timer is running. Q - Quit timer is running.
S - Switching timer is running. I - Interface timer is running.

Local information:
Hello Partner PAgP Learning Group
Port Flags State Timers Interval Count Priority Method Ifindex
Fa0/1 d U1/S1 H30s 1 0 128 Any 0

Partner's information:
Partner Partner Partner Partner Group
Port Name Device ID Port Age Flags Cap.
Fa0/1 S1 00E0.8F9A.177E Fa0/1 0 SC 10001

Age of the port in the current state: 00d:04h:07m:23s

----
FastEthernet0/2:
Port state = 1
Channel group = 1 Mode = Desirable-S1 Gcchange = 0
Port-channel = Po1 GC = 0x00000000 Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = PAgP

Flags: S - Device is sending Slow hello. C - Device is in Consistent state.


A - Device is in Auto mode. P - Device learns on physical port.
d - PAgP is down.
Timers: H - Hello timer is running. Q - Quit timer is running.
S - Switching timer is running. I - Interface timer is running.

Local information:
Hello Partner PAgP Learning Group
Port Flags State Timers Interval Count Priority Method Ifindex
Fa0/2 d U1/S1 H30s 1 0 128 Any 0

Partner's information:
Partner Partner Partner Partner Group
Port Name Device ID Port Age Flags Cap.
Fa0/2 S1 00E0.8F9A.177E Fa0/2 0 SC 10001

Age of the port in the current state: 00d:04h:07m:23s

----
FastEthernet0/3:
Port state = 1
Channel group = 2 Mode = Desirable-S1 Gcchange = 0
Port-channel = Po2 GC = 0x00000000 Pseudo port-channel = Po2
Port index = 0 Load = 0x00 Protocol = PAgP

Flags: S - Device is sending Slow hello. C - Device is in Consistent state.


A - Device is in Auto mode. P - Device learns on physical port.
4.2.2.4 Lab – Troubleshooting EtherChannel
d - PAgP is down.
Timers: H - Hello timer is running. Q - Quit timer is running.
S - Switching timer is running. I - Interface timer is running.

Local information:
Hello Partner PAgP Learning Group
Port Flags State Timers Interval Count Priority Method Ifindex
Fa0/3 d U1/S1 H30s 1 0 128 Any 0

Partner's information:
Partner Partner Partner Partner Group
Port Name Device ID Port Age Flags Cap.
Fa0/3 S3 00D0.97E4.4713 Fa0/3 0 SC 10001

Age of the port in the current state: 00d:00h:14m:44s

----
FastEthernet0/4:
Port state = 1
Channel group = 2 Mode = Desirable-S1 Gcchange = 0
Port-channel = Po2 GC = 0x00000000 Pseudo port-channel = Po2
Port index = 0 Load = 0x00 Protocol = PAgP

Flags: S - Device is sending Slow hello. C - Device is in Consistent state.


A - Device is in Auto mode. P - Device learns on physical port.
d - PAgP is down.
Timers: H - Hello timer is running. Q - Quit timer is running.
S - Switching timer is running. I - Interface timer is running.

Local information:
Hello Partner PAgP Learning Group
Port Flags State Timers Interval Count Priority Method Ifindex
Fa0/4 d U1/S1 H30s 1 0 128 Any 0

Partner's information:
Partner Partner Partner Partner Group
Port Name Device ID Port Age Flags Cap.
Fa0/4 S3 00D0.97E4.4713 Fa0/4 0 SC 10001

Age of the port in the current state: 00d:00h:14m:44s

----
Port-channel1:Port-channel1
Age of the Port-channel = 00d:04h:07m:23s
Logical slot/port = 2/1 Number of ports = 2
GC = 0x00000000 HotStandBy port = null
Port state =
Protocol = 2
Port Security = Disabled

Ports in the Port-channel:

Index Load Port EC state No of bits


------+------+------+------------------+-----------
0 00 Fa0/1 Desirable-Sl 0
0 00 Fa0/2 Desirable-Sl 0
Time since last port bundled: 00d:04h:07m:23s Fa0/2
----
Port-channel2:Port-channel2
Age of the Port-channel = 00d:04h:07m:23s
Logical slot/port = 2/2 Number of ports = 2
GC = 0x00000000 HotStandBy port = null
Port state =
Protocol = 2
Port Security = Disabled

Ports in the Port-channel:

Index Load Port EC state No of bits


------+------+------+------------------+-----------
0 00 Fa0/4 Desirable-Sl 0
0 00 Fa0/3 Desirable-Sl 0
Time since last port bundled: 00d:00h:14m:44s Fa0/3
4.2.2.4 Lab – Troubleshooting EtherChannel

b. Verify connectivity of the management VLAN.

Can S1 192.168.1.11 ping S2 192.168.1.12? Yes

Can S1 192.168.1.11 ping S3 192.168.1.13? Yes

Can S2 192.168.1.12 ping S3 192.168.1.13? Yes

c. Verify connectivity of PCs.


Can PC-A ping PC-C? Yes

If EtherChannels are not fully functional, connectivity between switches does not exist, or
connectivity between hosts does not exist. Troubleshoot to resolve any remaining issues.
Note: It may be necessary to disable the PC firewall for pings between the PCs to succeed.
4.2.2.4 Lab – Troubleshooting EtherChannel

Switch configuraties met aanpassingen:

S1 Configuration: S2 Configuration: S3 Configuration:


hostname S1 hostname S2 hostname S3
interface range f0/1-24, g0/1-2 interface range f0/1-24, g0/1-2 interface range f0/1-24, g0/1-2
shutdown shutdown shutdown
exit exit exit
enable secret class enable secret class enable secret class
no ip domain lookup no ip domain lookup no ip domain lookup
line vty 0 15 line vty 0 15 line vty 0 15
password cisco password cisco password cisco
login login login
line con 0 line con 0 line con 0
password cisco password cisco password cisco
logging synchronous logging synchronous logging synchronous
login login login
exit exit exit
vlan 10 vlan 10 vlan 10
name User name User name User
vlan 99 vlan 99 vlan 99
Name Management name Management name Management
interface range f0/1-2 spanning-tree vlan 1,10,99 root interface range f0/1-2
switchport mode trunk primary ! switchport mode trunk
! channel-group 1 mode desirable interface range f0/1-2 ! channel-group 3 mode desirable
channel-group 1 mode active switchport mode trunk ! switchport trunk native vlan 99
switchport trunk native vlan 99 channel-group 1 mode desirable ! no shutdown
no shutdown switchport trunk native vlan 99 interface range f0/3-4
interface range f0/3-4 no shutdown switchport mode trunk
channel-group 2 mode desirable interface range f0/3-4 ! channel-group 2 mode desirable
switchport trunk native vlan 99 switchport mode trunk channel-group 3 mode desirable
! switchport mode trunk channel-group 3 mode desirable switchport trunk native vlan 99
no shutdown switchport trunk native vlan 99 no shutdown
interface f0/6 ! no shutdown interface f0/18
switchport mode access interface vlan 99 switchport mode access
switchport access vlan 10 ip address 192.168.1.12 switchport access vlan 10
255.255.255.0
no shutdown no shutdown
interface port-channel 1
interface vlan 99 interface vlan 99
switchport trunk native vlan 99
ip address 192.168.1.11 ip address 192.168.1.13
255.255.255.0 switchport trunk allowed vlan 255.255.255.0
1,99
interface port-channel 1 ! interface port-channel 2
! switchport trunk allowed 1,10,99
switchport trunk native vlan 99 ! switchport trunk native vlan 99
interface port-channel 3
switchport mode trunk ! switchport mode trunk
switchport trunk native vlan 99
interface port-channel 2 interface port-channel 3
switchport trunk allowed vlan
switchport trunk native vlan 99 1,10,99 switchport trunk native vlan 99
switchport mode access switchport mode trunk switchport mode trunk
! switchport mode trunk
4.2.2.4 Lab – Troubleshooting EtherChannel

Switch 1:
S1#show running-config !
Building configuration... interface FastEthernet0/13
shutdown
Current configuration : 2082 bytes !
! interface FastEthernet0/14
version 12.2 shutdown
no service timestamps log datetime msec !
no service timestamps debug datetime msec interface FastEthernet0/15
no service password-encryption shutdown
! !
hostname S1 interface FastEthernet0/16
! shutdown
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1 !
! interface FastEthernet0/17
! shutdown
! !
no ip domain-lookup interface FastEthernet0/18
! shutdown
! !
spanning-tree mode pvst interface FastEthernet0/19
spanning-tree extend system-id shutdown
! !
interface Port-channel1 interface FastEthernet0/20
switchport trunk native vlan 99 shutdown
switchport mode trunk !
! interface FastEthernet0/21
interface Port-channel2 shutdown
switchport trunk native vlan 99 !
switchport mode trunk interface FastEthernet0/22
! shutdown
interface FastEthernet0/1 !
switchport trunk native vlan 99 interface FastEthernet0/23
switchport mode trunk shutdown
channel-group 1 mode desirable !
! interface FastEthernet0/24
interface FastEthernet0/2 shutdown
switchport trunk native vlan 99 !
switchport mode trunk interface GigabitEthernet0/1
channel-group 1 mode desirable shutdown
! !
interface FastEthernet0/3 interface GigabitEthernet0/2
switchport trunk native vlan 99 shutdown
switchport mode trunk !
channel-group 2 mode desirable interface Vlan1
! no ip address
interface FastEthernet0/4 shutdown
switchport trunk native vlan 99 !
switchport mode trunk interface Vlan99
channel-group 2 mode desirable mac-address 0002.4a9c.a001
! ip address 192.168.1.11 255.255.255.0
interface FastEthernet0/5 !
shutdown !
! !
interface FastEthernet0/6 !
switchport access vlan 10 line con 0
switchport mode access password cisco
! logging synchronous
interface FastEthernet0/7 login
shutdown !
! line vty 0 4
interface FastEthernet0/8 password cisco
shutdown login
! line vty 5 15
interface FastEthernet0/9 password cisco
shutdown login
! !
interface FastEthernet0/10 !
shutdown !
! !
interface FastEthernet0/11 End
shutdown
!
interface FastEthernet0/12
shutdown
4.2.2.4 Lab – Troubleshooting EtherChannel

Switch 2:
S2#show running-config !
Building configuration... interface FastEthernet0/11
shutdown
Current configuration : 2317 bytes !
! interface FastEthernet0/12
version 12.2 shutdown
no service timestamps log datetime msec !
no service timestamps debug datetime msec interface FastEthernet0/13
no service password-encryption shutdown
! !
hostname S2 interface FastEthernet0/14
! shutdown
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1 !
! interface FastEthernet0/15
! shutdown
! !
no ip domain-lookup interface FastEthernet0/16
! shutdown
! !
spanning-tree mode pvst interface FastEthernet0/17
spanning-tree extend system-id shutdown
spanning-tree vlan 1,10,99 priority 24576 !
! interface FastEthernet0/18
interface Port-channel1 shutdown
switchport trunk native vlan 99 !
switchport trunk allowed vlan 1,10,99 interface FastEthernet0/19
switchport mode trunk shutdown
! !
interface Port-channel3 interface FastEthernet0/20
switchport trunk native vlan 99 shutdown
switchport trunk allowed vlan 1,10,99 !
switchport mode trunk interface FastEthernet0/21
! shutdown
interface FastEthernet0/1 !
switchport trunk native vlan 99 interface FastEthernet0/22
switchport trunk allowed vlan 1,10,99 shutdown
switchport mode trunk !
channel-group 1 mode desirable interface FastEthernet0/23
! shutdown
interface FastEthernet0/2 !
switchport trunk native vlan 99 interface FastEthernet0/24
switchport trunk allowed vlan 1,10,99 shutdown
switchport mode trunk !
channel-group 1 mode desirable interface GigabitEthernet0/1
! shutdown
interface FastEthernet0/3 !
switchport trunk native vlan 99 interface GigabitEthernet0/2
switchport trunk allowed vlan 1,10,99 shutdown
switchport mode trunk !
channel-group 3 mode desirable interface Vlan1
! no ip address
interface FastEthernet0/4 shutdown
switchport trunk native vlan 99 !
switchport trunk allowed vlan 1,10,99 interface Vlan99
switchport mode trunk mac-address 00e0.8f9a.1701
channel-group 3 mode desirable ip address 192.168.1.12 255.255.255.0
! !
interface FastEthernet0/5 !
shutdown !
! line con 0
interface FastEthernet0/6 password cisco
shutdown logging synchronous
! login
interface FastEthernet0/7 !
shutdown line vty 0 4
! password cisco
interface FastEthernet0/8 login
shutdown line vty 5 15
! password cisco
interface FastEthernet0/9 login
shutdown !
! !
interface FastEthernet0/10 !
shutdown end
4.2.2.4 Lab – Troubleshooting EtherChannel

Switch 3:
S3#show running-config interface FastEthernet0/13
Building configuration... shutdown
!
Current configuration : 2082 bytes interface FastEthernet0/14
! shutdown
version 12.2 !
no service timestamps log datetime msec interface FastEthernet0/15
no service timestamps debug datetime msec shutdown
no service password-encryption !
! interface FastEthernet0/16
hostname S3 shutdown
! !
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1 interface FastEthernet0/17
! shutdown
! !
! interface FastEthernet0/18
no ip domain-lookup switchport access vlan 10
! switchport mode access
! !
spanning-tree mode pvst interface FastEthernet0/19
spanning-tree extend system-id shutdown
! !
interface Port-channel2 interface FastEthernet0/20
switchport trunk native vlan 99 shutdown
switchport mode trunk !
! interface FastEthernet0/21
interface Port-channel3 shutdown
switchport trunk native vlan 99 !
switchport mode trunk interface FastEthernet0/22
! shutdown
interface FastEthernet0/1 !
switchport trunk native vlan 99 interface FastEthernet0/23
switchport mode trunk shutdown
channel-group 3 mode desirable !
! interface FastEthernet0/24
interface FastEthernet0/2 shutdown
switchport trunk native vlan 99 !
switchport mode trunk interface GigabitEthernet0/1
channel-group 3 mode desirable shutdown
! !
interface FastEthernet0/3 interface GigabitEthernet0/2
switchport trunk native vlan 99 shutdown
switchport mode trunk !
channel-group 2 mode desirable interface Vlan1
! no ip address
interface FastEthernet0/4 shutdown
switchport trunk native vlan 99 !
switchport mode trunk interface Vlan99
channel-group 2 mode desirable mac-address 00d0.97e4.4701
! ip address 192.168.1.13 255.255.255.0
interface FastEthernet0/5 !
shutdown !
! !
interface FastEthernet0/6 !
shutdown line con 0
! password cisco
interface FastEthernet0/7 logging synchronous
shutdown login
! !
interface FastEthernet0/8 line vty 0 4
shutdown password cisco
! login
interface FastEthernet0/9 line vty 5 15
shutdown password cisco
! login
interface FastEthernet0/10 !
shutdown !
! !
interface FastEthernet0/11 !
shutdown end
!
interface FastEthernet0/12
shutdown
!

S-ar putea să vă placă și