Sunteți pe pagina 1din 5

RECAPITULARE _ IX

1. Ce valori s-au afişat în urma executării secvenţei pseudocod alăturate, dacă au fost citite, în această ordine,
valorile 15 11 39?
citeşte x
citeşte y,x
scrie x,y,x*y 15 11 165 39 11 430 15 39 585 39 11 429
2. Se consideră expresia logică, scrisă în limbajul pseudocod, alăturată.
Câte valori întregi pozitive, mai mici sau egale ca 9999, pot fi atribuite variabilei x astfel încât rezultatul evaluării
expresiei logice să fie ADEVĂRAT pentru fiecare astfel de valoare?
([x/13]>13) şi (18=[x/10]) 8 12 1 18
3. Fie n o variabilă care memorează un număr natural nenul. Care dintre următoarele operaţii de atribuire, scrise
în limbajul pseudocod, determină, în urma executării, memorarea în variabila x a cifrei unităţilor sumei tuturor
numerelor naturale pare din intervalul închis [1,n]?
x←([n/2]*[n/2]+1)%10 x←[n/2]*(([n/2]+1)%10) x←([n/2]*([n/2]+1))%10 x←[n/2]*[n/2]+1%10
4. Numerele întregi nenule memorate de variabilele x şi y au paritate diferită dacă şi numai dacă este adevărată
expresia logică:
x*y%2=0 (x%2=0) şi (y%2=1) (x%2=0) sau (y%2>0) (x+y)%2≠0
5. Care au fost valorile iniţiale memorate de variabilele x şi y dacă, la finalul executării secvenţei pseudocod
alăturate, valoarea variabilei z este 5 iar valorile memorate de variabilelor x şi y au devenit egale cu 23?
z←0
┌cât timp x≠y execută
│┌dacă x>y atunci x←x-y
││ altfel y←y-x
│└■
│ z←z+1
└■ x=138 şi y=115 x=23 şi y=115 x=230 şi y=115 x=23 şi y=23
6. Pentru câte perechi de valori distincte ale variabilelor x şi y, rezultatul evaluării expresiei logice x*x-
3x+2+y*y-6y+9=0, scrisă în limbajul pseudocod, este ADEVĂRAT? 1 3 2 0
7. Variabilele x şi y memorează câte un număr real nenul pozitiv. Pentru a atribui variabilei reale E rezultatul

expresiei aritmetice vom scrie în limbajul pseudocod operaţia de atribuire:


E←(1/(y*y)-y/x)/(x*y+x+5) E←(1/y*y-y/x)/(x*y+x+5)
E←(y*y-y/x)/(x*y+x+5) E←((1/y*y)-y/x)/x*y+x+5
8. Ştiind că variabila n memorează un număr natural nenul, ce valoare va avea variabila k la finalul executării
secvenţei pseudocod alăturate?
k←0; i←n
┌repetă
│ ┌dacă i%13=0 atunci k←k+i
│ └■
│ i←i-1
└până când i+n<0 j+i 6-i 5-i 6-j
9. Câte numere naturale se vor afişa în urma executării secvenţei pseudocod următoare?

15 10 30 25
10. Ce valoare va memora variabila c la finalul executării secvenţei pseudocod următoare?
100 -100 0 10
11. Se consideră următorul algoritm descris în limbajul pseudocod:

Scrieţi ce se afişează în urma executării algoritmului dacă x=10, y=20 şi n=76? r:0

12. Se consideră următorul algoritm descris în limbajul pseudocod:

Scrieţi un set de date de intrare astfel încât, în urma executării algoritmului, valoarea memorată de
variabila x să nu se modifice şi să se afişeze valoarea 1.Setul de date va fi format din trei numere naturale
x y 0 astfel încât x > y sau x=y=numere pare; de exemplu: 4 3 0
a. Se consideră următorul algoritm descris în limbajul pseudocod:

Dacă pentru x se citeşte valoarea 0 iar pentru n valoarea 2500, scrieţi un număr natural care poate fi citit
pentru variabila y astfel încât să se afişeze valoarea 1 la finalul executării algoritmului. 100 sau 99

13. Variabilele x şi y memorează câte un număr natural astfel încât x≠y.


Care dintre următoarele secvenţe pseudocod determină, în urma executării, memorarea în variabila m a celei mai
mici valori dintre suma şi produsul valorilor memorate de x şi y?
m←x+y ┌dacă m< x*y atunci m← y+x
m←x*y ┌dacă m> x+y atunci m← x+y └
dacă x+y< x*y atunci m← x*y │ altfel m ← x+y m←x a)513 b) 2010 c) 4,5,6,7,8,9,10,11,12,13
d) utilizate structurile repetă...până când,
dacă m>y atunci m← x+y │ altfel m ← x*y citeşte x,y {numere naturale nenule}
14. Se consideră algoritmul alăturat, descris în limbajul pseudocod. execută...cât timp etc
citeşte x,y {numere naturale nenule} z←0
┌dacă x≤y atunci
z←0 │┌repetă
┌cât timp x≤y execută ││┌dacă (y-x)%10=0 atunci
│┌dacă (y-x)%10=0 atunci │││ z←z+x
││└■
││ z←z+x ││ x←x+1
│└■ │└cât timp x≤y
│ x←x+1 └■
scrie z
└■
scrie z
a) Scrieţi ce se afişează în urma executării algoritmului dacă x=17 şi y=97?
b) Dacă pentru x se citeşte valoarea 2010, scrieţi un număr natural care poate fi citit pentru variabila y, astfel
încât să se afişeze valoarea 2010 la finalul executării algoritmului.
c) Dacă pentru y se citeşte valoarea 173, scrieţi toate valorile care pot fi citite pentru variabila x, astfel încât,
la finalul executării algoritmului, pentru fiecare valoare scrisă, să se afişeze valoarea 1581.
d) Scrieţi în pseudocod un algoritm echivalent cu cel dat, în care să se înlocuiască structura cât
timp...execută cu o altă structură repetitivă cu test final.
e) Scrieţi în pseudocod un algoritm echivalent cu cel dat, care să nu conţină nicio structură repetitivă.
15. Se citesc doua numere intregi a şi b(a<=b). Sa se calculeze numărul numerelor prime din intervalul [a,b].
16. Fie n număr întreg şi a, b numere reale astfel încât a<b . Câte numere întregi din intervalul închis [a,b] sunt
prime cu n?
17. Se citeşte un şir de numere întregi nenule(<10000) până la întâlnirea cifrei 0 şi un număr prim
p<32000.Câte numere dintre cele citite se împart exact la p?
18. Fie x un număr natural citit. Calculati suma cifrelor impare ale numărului x.
19. Se citesc numere intregi până la întâlnirea valorii 5. Sa se calculeze produsul numerelor divizibile la 3 si
suma celor pare mai mici decat 10 dintre cele introduse .
20. Scrieţi un algoritm în limbajul pseudocod care să citească succesiv termenii unui şir de numere naturale
până la întâlnirea valorii 0 care nu face parte din şir, şi apoi:
a) să determine şi să afişeze lungimea maximă a unei secvenţe din şir care începe şi se termină cu câte un
număr pătrat perfect;
b) să construiască şi să afişeze cel mai mic număr natural palindrom z cu proprietatea că z este strict mai
mare decât toţi termenii şirului citit.
21. Se citeste de la tastatura un nr natural cu 3 cifre, sa se afiseze pe cite un rand cifrele numarului obtinut prin
eliminarea cifrei din mijloc.
22. Scrie un program care sa afiseze de cite ori apare o cifra nenula c in scrierea tuturor numerelor naturale
mai mici sau egale cu un numar dat n. Cifra c si valoarea lui n se dau de la tastatura.
23. Sa se scrie toate modurile in care poate fi descompus un numar natural in suma de cuburi a doua numere
naturale. Daca nu exista , scrieti “ imposibil”.
24. Se citesc mai multe numere naturale pana se citeste un numar negative. Afisati primul numar care are
cei mai multi divizori SI ultimul numar are cei mai putini divizori primi.
25. se considera numarul n=2 a2+3b3, a, b numere distinct cu 1<=a<=10 ; 1<=b<=10 . Sa se afiseze toate
numerele n generate astfel, si , pentru fiecare numar, n generat, descompunerea lui in suma de 3 patrate.
26. un vector contine max 50 numere intregi. Lungimea vectorului si elementele sale se citesc de la tastatura.
Sa se afiseze cite dintre elemente au valoarea egala cu suma elementelor vecine.
27. un vector a contine max 100 nr intregi. Lungimea n a vectorului si elementele se citesc de la tastatura. Sa
se copieze intr-un vector b toate elementele din vectorul a care au valoarea egala cu codul ASCII al unei litere.
Sa se sorteze crescator vectorul b folosind metoda bulelor sis a se afiseze literele din vectorul b.
28. Sa se memorize intr-un vector n cifre. Sa se afiseze cel mai mic numar care se poate obtine cu aceste cifre.
29. se considera un vector a cu elemente numere intregi, cu lungimea n . sa se rearanjeze elementele vectorului
astfel incat numerele pare sa fie scrise inaintea numerelor impare.
30. se considera o matrice patrata cu elemente numere intregi cu dimensiunea nxn. Numarul n si dimensiunea
matricei se citesc de la tastatura. Sa se afiseze :
a. suma elementelor situate deasupra diagonelei principale
b. suma elementelor situate sub diagonal secundara
c. simetrica matricei fata de axa vertical care trece prin central matricei
d. simetrica matricei fata de axa orizontala care trece prin central matricei
e. simetrica matricei fata de diagonal principala
f. simetrica matricei fata de diagonal secundara
31. Se citesc numere naturale nenule până la citirea numărului 0. Sa se afiseze cel mai mic numar din sir (in
afara de 0 ) si sa se afiseze divizorii primi ai acestuia.
32. Se citeste un numar natural nenul n si apoi se citesc n numere intregi. Sa se determine media aritmetica a
numerelor pozitive dintre numerele intregi citite.
33. Se citeste un numar natural n.Sa se afiseze cea mai mare cifra a acestui numar si numarul sau de aparitii in
cadrul numarului (exemplu pt numarul 73375, cea mai mare cifra este 7 si are 2 aparitii in numar).
34. Se citeste o cifra c si apoi se citesc numere naturale până la citirea numărului 0. Sa se afiseze numerele din
sir care contin cifra c si pentru fiecare numar afisat sa se afiseze de cate ori contine cifra c. (Exemplu c=2,
numarul 3212 contine de 2 ori cifra c).
35. Se citeste un numar natural nenul n si apoi se citesc n numere naturale nenule .Sa se determine numarul
de divizori proprii ai fiecarui numar citit .
36. Se citesc numere naturale nenule până la citirea numărului 0. Sa se afiseze
a. cea mai mica cifra a fiecarui numar din sir.
b. numerele prime din sirul dat.
c. afiseze toti divizorii fiecarui numar citit care este divizibil cu k.
d. inversul fiecarui numar din sirul dat si sa se determine cate numere palindroame sunt in sir.
e. suma numerelor negative si cel mai mic numar pozitiv din sir.
f. numerele citite , pentru care suma cifrelor este numar impar (nr.122 are suma cifrelor 5 este nr.impar).

37. Se citeste un numar natural nenul n si apoi se citesc n numere naturale nenule. Sa se afiseze inversul
(oglinditul) fiecarui numar din sirul dat si sa se determine cate numere palindroame sunt in sir.Un numar
este palindrom daca este egal cu inversul sau.(pt n=4 si numerele 123,545,67,2002 se afiseaza:
321,545,76,2002 - 2 palindroame

38.

39.
40.
41.