Sunteți pe pagina 1din 3

ESTRUCTURA REPETITIVA

ESTRUCTURA PARA – HACER


Es aquella estructura de control que permite
ejecutar las sentencias un número repetido de
veces.
Por ejemplo: Visualizar “IDAT” 30 veces
Visualizar los 30 primeros números
Visualizar los primeros 50 cubos
Sintaxis:
Para variable valor inicial hasta valor
final Hacer
Sentencias
Fin Para
Solución: Visualizar “IDAT” 30 veces
Inicio
Para i1 hasta 30 Hacer
Escribir “IDAT”
Fin Para
Fin

Solución: Visualizar los 30 primeros números


Inicio
Para i1 hasta 30 hacer
Escribir i
Fin Para
Fin
Solución: Visualizar los primeros 50 cubos
Inicio
Para j1 hasta 50 hacer
Escribir ( j ↑ 3)
Fin Para
Fin
Ingrese 10 números, visualice un mensaje si el
número ingresado es par
Inicio
Leer N
Si N mod 2 =0 Entonces
Escribir “Par”
Fin Si
Leer M
Si M mod 2 =0 Entonces
Escribir “Par”
Fin Si
Leer P
Si P mod 2 =0 Entonces
Escribir “Par”
Fin Si
FIN
INICIO
Para i1 hasta 10 Hacer
Leer Numero
Si Numero MOD 2 =0 Entonces
Escribir “PAR”
Fin Si
Fin Para
FIN

INGRESE POR TECLADO 200 NUMEROS, VISUALICE EL


CUADRADO Y EL CUBO DE CADA NUMERO INGRESADO.
INICIO
Leer N
Escribir N ↑2 , N ↑3
Leer M
Escribir M ↑2 , M ↑3
Leer P
Escribir P ↑2 , P ↑3
...
FIN
INICIO
Para i 1 hasta 200 hacer
Leer N
Escribir N ↑2 , N ↑3
Fin Para
FIN
INGRESE POR TECLADO LOS SUELDOS DE 50 PERSONAS, AL
FINALIZAR EL PROCESO, VISUALICE LA SUMA DE TODOS
LOS SUELDOS INGRESADOS.

INICIO
LEER SUELDO
SUMA SUMA+SUELDO
LEER SUELDO1
SUMA  SUMA +SUELDO1
LEER SUELDO2
SUMA SUMA + SUELDO2
...
LEER SUELDO49
SUMA  SUMA + SUELDO49

ESCRIBIR SUMA
FIN

INICIO
SUMA  0 valor inicial de suma (acumula los
sueldos)
PARA i 1 HASTA 50 HACER
LEER SUELDO
SUMA SUMA + SUELDO acumular el sueldo
en SUMA
FIN PARA
ESCRIBIR SUMA al finalizar el Para escribir el
resultado de SUMA
FIN