Sunteți pe pagina 1din 1

10A

Fișă de lucru

(1,5p) I. Se consideră următorul algoritm scris în pseudocod:


citeşte a,b;
dacă a>b atunci
început
c←a; a←b; b←c;
sfârşit
d←0
pentru i=a,b execută
început
dacă i mod 2 =0 atunci
d←d+1
sfârşit
scrie d

II. Scrie algoritmi pentru rezolvarea următoarelor probleme:


(1,5p) 1. Se citeşte un număr natural n de la tastatură. Afişează produsul
cifrelor impare care compun numărul.
(1,5p) 2. Se citeşte un şir de numere atâta timp cât nu s-a dat valoarea 0.
Calculează suma numerelor impare şi suma numerelor pare din şir. Afişează
care sumă e mai mare.
(2p) 3. Se citesc de la tastatură două numere naturale. Afişează media
aritmetică a numerelor pare cuprinse între cele două numere.
(1p) 4. Se citeşte de la tastatură un număr natural x. Afişează suma
cifrelor care compun numărul.

Notă: Se acordă 2 puncte din oficiu.


Timp de lucru 50 min.