Sunteți pe pagina 1din 6

Configure loopbacks and additional addressing

Router(config)# interface loopback 8 Router(config-if)# ip address 192.168.8.1 255.255.255.0 Router(config-if)# interface loopback 9 Router(config-if)# ip address 192.168.9.1 255.255.255.0 Router(config-if)# interface loopback 10 Router(config-if)# ip address 192.168.10.1 255.255.255.0 Router(config-if)# interface loopback 11 Router(config-if)# ip address 192.168.11.1 255.255.255.0

2) Configure OSPF router identifier 2.2.2.2 on R2 and 3.3.3.3 on R3


Router(config)#router ospf 1 Router(config-router)#router-id x.x.x.x

3) ensure that all loopback interfaces are advertised in OSPF with the correct masks Place the loopback interface lo0 on R3 and the connection between R2 and R3 in OSPF area 0.
R3(config)#router ospf 1 R3(config-router)#network 192.168.23.0 0.0.0.7 area 0 R3(config-router)#network 192.168.3.0 0.0.0.255 area 0

4) On R2, place the loopback interfaces Lo120 through Lo123 on R2 in OSPF area1 and the connection between R2 and R3 in OSPF area 0.
R2(config)#router ospf 1 R2(config-router)#network R2(config-router)#network R2(config-router)#network R2(config-router)#network R2(config-router)#network 192.168.23.0 0.0.0.7 area 0 192.168.120.0 0.0.0.255 area 192.168.121.0 0.0.0.255 area 192.168.122.0 0.0.0.255 area 192.168.123.0 0.0.0.255 area

1 1 1 1

5)Summarize area 1 to the backbone with the most efficient mask.


R2(config)#router ospf 1 R2(config-router)# area 1 range 192.168.120.0 255.255.252.0

6)Propagate a default route from R3 into the OSPF domain.


R3(config)#router ospf 1 R3(config-router)#default-information originate always R3(config)#ip route 0.0.0.0 0.0.0.0 s0/0/1

7)Configure R1 to be in EIGRP AS 101, add the entire class C network, and disable automatic summarization.
R1(config)# router R1(config-router)# R1(config-router)# R1(config-router)# R1(config-router)# R1(config-router)# R1(config-router)# R1(config-router)# eigrp 101 no auto-summary network 192.168.12.0 network 192.168.1.1 network 192.168.110.0 network 192.168.111.0 network 192.168.112.0 network 192.168.113.0

8)Configure R2 to be in EIGRP AS 101, add only the link between R1 and R2 and disable automatic summarization.
R2(config)# router eigrp 101 R2(config-router)# no auto-summary R2(config-router)# network 192.168.12.0

9)Configure passive and non-passive interfaces for EIGRP and OSPF as appropriate. All loopback interfaces should be passive.
Router(config)# router eigrp 101 Router(config-router)# passive-interface serial 0/0/1 R1 s0/0/0 Passive int

10)Configure a static default route from R1 and R2 and avoid a recursive lookup.
R1(config)#ip route 0.0.0.0 0.0.0.0 s0/0/0 R1(config)# router eigrp 101 R1(config-router)#redistribute static

11)Redistribute EIGRP into OSPF with a metric of 1000


R2(config)#router ospf 1 R2(config-router)#redistribute eigrp 101 metric 1000 router ospf process-id redistribute eigrp AS [metric value] [metric-type type] [route-map maptag] [subnets] [tag tag-value]

12)On R2, filter R1 network 192.168.113.0 from being advertised to R3 Lab 4-2
R2(config)# access-list 1 permit 192.168.113.0 R2(config)# route-map SELECTED-DENY deny 10 R2(config-route-map)# match ip address 1 R2(config-route-map)# route-map SELECTED-DENY permit 20 R2(config)# router eigrp 1 R2(config-router)# redistribute ospf 1 route-map SELECTED-DENY metric 64 100 255 1 1500 Or R2(config-router)# redistribute ospf 1 route-map SELECTED-DENY

13)Enable BGP on both WAN links between R3 and R4. R3 is in AS 65101 and R4 is in BGP AS 65401 Lab 6-1
R3(config)# router R3(config-router)# R3(config-router)# R3(config-router)# bgp 65101 neighbor 172.16.34.4 remote-as 65401 neighbor 172.16.43.4 remote-as 65401 network 192.168.3.0 mask 255.255.255.0

14)Advertise R4s loopback interfaces into BGP


R4(config)# router R4(config-router)# R4(config-router)# R4(config-router)# bgp 65401 neighbor 172.16.34.3 remote-as 65101 neighbor 172.16.43.3 remote-as 65101 network 198.133.219.0 mask 255.255.255.224

R4(config-router)# network 209.165.200.224 mask 255.255.255.224

15)Modify the local preference on R3 so that AS 65101 prefers the T1 link to AS 65401 networks Lab 6-3
R3(config)# route-map PRIMARY_T1_IN permit 10 R3(config-route-map)# set local-preference 150 R3(config-route-map)# exit R3(config)# router bgp 65401 R3(config-router)# neighbor 172.16.34.4 route-map PRIMARY_T1_IN in R3(config)# route-map SECONDARY_T1_IN permit 10 R3(config-route-map)# set local-preference 125 R3(config-route-map)# exit R3(config)# router bgp 65401 R3(config-router)# neighbor 172.16.43.4 route-map SECONDARY_T1_IN in

16) Traffic exiting from R3 and returning to R3 should prefer the T1 link. Add a static route on R4 to 192.168.0.0/16 pointing to the T1 link to R3 and add the floating static route as a backup using the FT1 link Lab 6-1
R4(config)# ip route 192.168.0.0 255.255.0.0 s0/0/1 210 R4(config)# ip route 192.168.0.0 255.255.0.0 s0/1/0 220

17) Configure the IPv6 loopback and tunnel interfaces on R1 and R3.
R(config)#ipv6 unicast-routing R1(config)# interface tunnel0 R1(config-if)# tunnel mode ipv6ip R1(config-if)# tunnel source serial0/0/0 R1(config-if)# tunnel destination 192.168.23.3 R1(config-if)# ipv6 address FEC0::13:1/112 R3(config)# interface tunnel0 R3(config-if)# tunnel mode ipv6ip R3(config-if)# tunnel source serial0/0/1 R3(config-if)# tunnel destination 192.168.12.1 R3(config-if)# ipv6 address FEC0::13:3/112

18) Enable RIPng on R1 and R3 and configure the advertisement of the loopback and tunnel networks.
R1(config)#interface lo1 R1(config-if)#ipv6 address FEC0::11:1/112 R1(Config-if)#ipv6 rip rip1 enable R3(config)#interface lo3 R3(config-if)#ipv6 address FEC0::31:1/112 R3(Config-if)#ipv6 rip rip1 enable

R3(config)#ipv6 unicast-routing R3(config)#int s0/0/0 R3(config-if)#ipv6 rip rip1 enable R3(config-if)#o

You can have EIGRP summarize routes sent out an interface to make routing updates more efficient by using the ip summary-address eigrp as network mask command

Router(config)# interface serial 0/0/0 Router(config-if)# ip summary-address eigrp 1 192.168.48.0 255.255.254.0

5) You need to add the area 10 configuration to R2 and the area 20 configuration to R3 to complete the configuration Router(config)# router ospf 1 Router(config-router)# network 172.16.100.0 0.0.0.255 area 10 R3(config)# router ospf 1 R3(config-router)# network 192.168.8.0 0.0.3.255 area 20 6) Use the ip ospf network point-to-point command on the OSPF loopback interfaces on R2 and R3 interface loopback 100 ip ospf network point-to-point interface range lo 8 - 11 ip ospf network point-to-point 7) Summarize OSPF areas at the ABR R3(config)# router ospf 1 R3(config-router)# 8) Configure mutual redistribution between OSPF and EIGRP

R2(config)# router ospf 1 R2(config-router)# redistribute eigrp 1 subnets R2(config-router)# exit R2(config)# router eigrp 1 R2(config-router)# redistribute ospf 1 metric 10000 100 255 1 1500 or R2(config-router)# default-metric 10000 100 255 1 1500 R2(config-router)# redistribute ospf 1 Issue the show ip protocols command on the redistributing router, R2 9) Propagate a default route from R3 int the OSPF domain router ospf 1 default-information originate always R(config)#ip route 0.0.0.0 0.0.0.0 192.168.23.0

S-ar putea să vă placă și