Sunteți pe pagina 1din 47

12: EIGRP for IPv6

Rick Graziani
Cabrillo College

Rick.Graziani@cabrillo.edu
For more information please check out my Cisco Press book and video series:

IPv6 Fundamentals: A Straightforward IPv6 Fundamentals LiveLessons: A


Approach to Understanding IPv6 Straightforward Approach to Understanding IPv6
By Rick Graziani By Rick Graziani
ISBN-10: 1-58714-313-5 ISBN-10: 1-58720-457-6


12.1: Protocol and Concepts
IPv4 and IPv6 Routing Protocols
Exterior
Gateway
Interior Gateway Protocols Protocols
Distance Vector Link State Path Vector
Distance Vector Routing Link State Routing Path Vector
Protocols Protocols
IPv4 RIPv2 EIGRP OSPFv2 IS-IS BGP-4
RIPng EIGRP for OSPFv3 * IS-IS for BGP-4 for
IPv6 IPv6 IPv6 IPv6 or
MP-BGP
* OSPFv3 supports routing both IPv4 and IPv6.

The basic operations and algorithms you learned about


EIGRP for IPv4 also apply to EIGRP for IPv6.

EIGRP for IPv4 EIGRP for IPv6

Advertised routes IPv4 networks IPv6 prefixes

Distance vector Yes Yes

Convergence technology DUAL DUAL

Metric Default: Bandwidth & delay Default: Bandwidth & delay


Optional: Reliability and load Optional: Reliability and load
Transport protocol RTP RTP

Update messages Partial & bounded updates Partial & bounded updates

Neighbor discovery Hello packets/IPv4 Hello packets/IPv6 link-local

Source address; IPv4 address; IPv6 link-local address;


Destination address 224.0.0.10 IPv4 multicast FF02::A IPv6 multicast
Authentication Plain text and MD5 MD5

Router ID 32-bit router ID 32-bit router ID


Comparing EIGRP for IPv4 and IPv6
EIGRP for EIGRP for IPv6 EIGRP for EIGRP for IPv6
IPv6 IPv6 IPv6 IPv6
Neighbor Topology Routing Neighbor Topology Routing
Table Table Table Table Table Table

IPv6 Network

R1 IPv4 Network R2

EIGRP for EIGRP for IPv4 EIGRP for EIGRP for IPv4
IPv4 IPv4 IPv4 IPv4
Neighbor Topology Routing Neighbor Topology Routing
Table Table Table Table Table Table


Comparing EIGRP for IPv4 and IPv6
EIGRP for EIGRP for IPv6 EIGRP for EIGRP for IPv6
IPv6 IPv6 IPv6 IPv6
Neighbor Topology Routing Neighbor Topology Routing
Table Table Table Table Table Table

R1 R2
EIGRP Messages

Source IPv6: IPv6 link-local address


Destination IPv6: FF02::A or IPv6 link-local address


12.2: Classic EIGRP for IPv6
2001:DB8:CAFE:4::/64
Dual-stack Topology 192.168.4.0/24
2001:DB8:CAFE:1::/64 2001:DB8:CAFE:2::/64 2001:DB8:CAFE:3::/64 G0/0 2001:DB8:77::/64
FE80::1 FE80::2 FE80::3 :1/.1 FE80::77
G0/0 S0/0/0 S0/0/1
S0/0/0 S0/0/1 :2/.2 S0/1/0
:1/.1 :2/.2
R1 :1/.1 R2 :1/.1 R3 :1/.1 ISP
192.168.1.0/24 192.168.2.0/24 192.168.3.0/24 192.168.77.0/24

R2# show ip interface brief


Interface IP-Address OK? Method Status Protocol
Serial0/0/0 192.168.2.2 YES manual up up
Serial0/0/1 192.168.3.1 YES manual up up
R2# show ipv6 interface brief Note: Although perhaps uncommon, serial links are used
Serial0/0/0 [up/up] in this topology to more easily differentiate from LANs.
FE80::2
2001:DB8:CAFE:2::2 Same link-local address
Serial0/0/1 [up/up] Statically configured
FE80::2
2001:DB8:CAFE:3::1

2001:DB8:CAFE:4::/64
EIGRP for IPv4 192.168.4.0/24
2001:DB8:CAFE:1::/64 2001:DB8:CAFE:2::/64 2001:DB8:CAFE:3::/64 G0/0 2001:DB8:77::/64
FE80::1 FE80::2 FE80::3 :1/.1 FE80::77
Static (Default) Default
G0/0 S0/0/0 S0/0/1
S0/0/0 S0/0/1 :2/.2 S0/1/0
:1/.1 :2/.2
R1 :1/.1 R2 :1/.1 R3 :1/.1 ISP
192.168.1.0/24 192.168.2.0/24 192.168.3.0/24 192.168.77.0/24

R1 R2 R3
router eigrp 1 router eigrp 1 ip route 0.0.0.0 0.0.0.0
eigrp router-id 1.1.1.1 eigrp router-id 2.2.2.2 192.168.77.2
network 192.168.1.0 network 192.168.2.0 router eigrp 1
network 192.168.2.0 network 192.168.3.0 eigrp router-id 3.3.3.3
network 192.168.3.0
network 192.168.4.0
redistribute static

Review of EIGRP for IPv4 configurations



R1s IPv4 Routing Table 2001:DB8:CAFE:4::/64
192.168.4.0/24
2001:DB8:CAFE:1::/64 2001:DB8:CAFE:2::/64 2001:DB8:CAFE:3::/64 G0/0 2001:DB8:77::/64
FE80::1 FE80::2 FE80::3 :1/.1 FE80::77
Static (Default) Default
G0/0 S0/0/0 S0/0/1
S0/0/0 S0/0/1 :2/.2 S0/1/0
:1/.1 :2/.2
R1 :1/.1 R2 :1/.1 R3 :1/.1 ISP
192.168.1.0/24 192.168.2.0/24 192.168.3.0/24 192.168.77.0/24

R1# show ip route eigrp


<output omitted>
D*EX 0.0.0.0/0 [170/3193856] via 192.168.2.2, 00:00:16, Serial0/0/0
D 192.168.3.0/24 [90/2681856] via 192.168.2.2, 00:07:01, Serial0/0/0
D 192.168.4.0/24 [90/2684416] via 192.168.2.2, 00:05:14, Serial0/0/0
R1#


2001:DB8:CAFE:4::/64
Classic EIGRP for IPv6 192.168.4.0/24
2001:DB8:CAFE:1::/64 2001:DB8:CAFE:2::/64 2001:DB8:CAFE:3::/64 G0/0 2001:DB8:77::/64
FE80::1 FE80::2 FE80::3 :1/.1 FE80::77
G0/0 S0/0/0 S0/0/1
S0/0/0 S0/0/1 :2/.2 S0/1/0
:1/.1 :2/.2
R1 :1/.1 R2 :1/.1 R3 :1/.1 ISP
192.168.1.0/24 192.168.2.0/24 192.168.3.0/24 192.168.77.0/24

R1(config)# ipv6 unicast-routing Required


R1(config)# ipv6 router eigrp 2 EIGRP AS must match other routers
R1(config-rtr)# eigrp router-id 1.1.1.1
Uses same process for 32-bit router-id,
R1(config-rtr)# no shutdown
required command if there is no IPv4 address
R1(config-rtr)# exit
Required with some (older) IOSs
R1(config)# interface gigabitethernet 0/0
R1(config-if)# ipv6 eigrp 2
R1(config-if)# exit EIGRP for IPv6 is enabled on the interface,
R1(config)# interface serial 0/0/0 no network command
R1(config-if)# ipv6 eigrp 2
R1(config-if)#

2001:DB8:CAFE:4::/64
Classic EIGRP for IPv6 192.168.4.0/24
2001:DB8:CAFE:1::/64 2001:DB8:CAFE:2::/64 2001:DB8:CAFE:3::/64 G0/0 2001:DB8:77::/64
FE80::1 FE80::2 FE80::3 :1/.1 FE80::77
G0/0 S0/0/0 S0/0/1
S0/0/0 S0/0/1 :2/.2 S0/1/0
:1/.1 :2/.2
R1 :1/.1 R2 :1/.1 R3 :1/.1 ISP
192.168.1.0/24 192.168.2.0/24 192.168.3.0/24 192.168.77.0/24

R2(config)# ipv6 unicast-routing


R2(config)# ipv6 router eigrp 2
R2(config-rtr)# eigrp router-id 2.2.2.2
R2(config-rtr)# exit
R2(config)# interface serial 0/0/0
R2(config-if)# ipv6 eigrp 2
R2(config-if)# exit
R2(config)# interface serial 0/0/1
R2(config-if)# ipv6 eigrp 2
R2(config-if)#


2001:DB8:CAFE:4::/64
Classic EIGRP for IPv6 192.168.4.0/24
2001:DB8:CAFE:1::/64 2001:DB8:CAFE:2::/64 2001:DB8:CAFE:3::/64 G0/0 2001:DB8:77::/64
FE80::1 FE80::2 FE80::3 :1/.1 FE80::77
Static (Default) Default
G0/0 S0/0/0 S0/0/1
S0/0/0 S0/0/1 :2/.2 S0/1/0
:1/.1 :2/.2
R1 :1/.1 R2 :1/.1 R3 :1/.1 ISP
192.168.1.0/24 192.168.2.0/24 192.168.3.0/24 192.168.77.0/24
R3(config)# ipv6 unicast-routing
R3(config)# ipv6 route ::/0 2001:db8:77::2
R3(config)# ipv6 router eigrp 2
R3(config-rtr)# eigrp router-id 3.3.3.3
R3(config-rtr)# redistribute static
R3(config-rtr)# exit
R3(config)# interface serial 0/0/1
R3(config-if)# ipv6 eigrp 2
R3(config-if)# exit
R3(config)# interface gigabitethernet 0/0
R3(config-if)# ipv6 eigrp 2
R3(config-if)#

R1s Neighbor Table 2001:DB8:CAFE:4::/64
192.168.4.0/24
2001:DB8:CAFE:1::/64 2001:DB8:CAFE:2::/64 2001:DB8:CAFE:3::/64 G0/0 2001:DB8:77::/64
FE80::1 FE80::2 FE80::3 :1/.1 FE80::77
G0/0 S0/0/0 S0/0/1
S0/0/0 S0/0/1 :2/.2 S0/1/0
:1/.1 :2/.2
R1 :1/.1 R2 :1/.1 R3 :1/.1 ISP
192.168.1.0/24 192.168.2.0/24 192.168.3.0/24 192.168.77.0/24

R1# show ipv6 eigrp neighbors


EIGRP-IPv6 Neighbors for AS(2)
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 Link-local address: Se0/0/0 12 02:27:11 29 174 0 8
FE80::2
R1# Link-local address of R2s S0/0/0 interface

Note: Because a link local address is being used the egress interface or the
interface that the update was learned on must be included.

R1s Topology Table 2001:DB8:CAFE:4::/64
192.168.4.0/24
2001:DB8:CAFE:1::/64 2001:DB8:CAFE:2::/64 2001:DB8:CAFE:3::/64 G0/0 2001:DB8:77::/64
FE80::1 FE80::2 FE80::3 :1/.1 FE80::77
Default
G0/0 S0/0/0 S0/0/1
S0/0/0 S0/0/1 :2/.2 S0/1/0
:1/.1 :2/.2
R1 :1/.1 R2 :1/.1 R3 :1/.1 ISP
192.168.1.0/24 192.168.2.0/24 192.168.3.0/24 192.168.77.0/24
R1# show ipv6 eigrp topology DUAL is the same for both IPv4 and IPv6
EIGRP-IPv6 Topology Table for AS(2)/ID(1.1.1.1)
<Codes omitted> Link-local address of R2
P 2001:DB8:CAFE:3::/64, 1 successors, FD is 2681856
via FE80::2 (2681856/2169856), Serial0/0/0 Feasible distance and the
P 2001:DB8:CAFE:4::/64, 1 successors, FD is 2684416 successor R2s reported distance
via FE80::2 (2684416/2172416), Serial0/0/0
P 2001:DB8:CAFE:2::/64, 1 successors, FD is 2169856
via Connected, Serial0/0/0
P ::/0, 1 successors, FD is 3193856
via FE80::2 (3193856/2681856), Serial0/0/0
P 2001:DB8:CAFE:1::/64, 1 successors, FD is 28160
via Connected, GigabitEthernet0/0

R1s IPv6 Routing Table 2001:DB8:CAFE:4::/64
192.168.4.0/24
2001:DB8:CAFE:1::/64 2001:DB8:CAFE:2::/64 2001:DB8:CAFE:3::/64 G0/0 2001:DB8:77::/64
FE80::1 FE80::2 FE80::3 :1/.1 FE80::77
Static (Default) Default
G0/0 S0/0/0 S0/0/1
S0/0/0 S0/0/1 :2/.2 S0/1/0
:1/.1 :2/.2
R1 :1/.1 R2 :1/.1 R3 :1/.1 ISP
192.168.1.0/24 192.168.2.0/24 192.168.3.0/24 192.168.77.0/24

R1# show ipv6 route eigrp


IPv6 Routing Table - default - 7 entries
<output omitted>
Default route redistributed into EIGRP for IPv6
EX ::/0 [170/3193856]
via FE80::2, Serial0/0/0
D 2001:DB8:CAFE:3::/64 [90/2681856]
via FE80::2, Serial0/0/0
Administrative distance of EIGRP
D 2001:DB8:CAFE:4::/64 [90/2684416] and EIGRP metric
via FE80::2, Serial0/0/0
R1# Next-hop is link-local address of R2

2001:DB8:CAFE:4::/64
Manual Summarization 192.168.4.0/24
2001:DB8:CAFE:1::/64 2001:DB8:CAFE:2::/64 2001:DB8:CAFE:3::/64 G0/0
FE80::1 FE80::2 FE80::3 :1/.1
Summary
G0/0 S0/0/0 S0/0/1
S0/0/0 :2/.2 S0/0/1 :2/.2
:1/.1 R1 :1/.1 R2 :1/.1 R3
192.168.1.0/24 192.168.2.0/24 192.168.3.0/24
R3(config)# interface serial 0/0/1
R3(config-if)# ipv6 summary-address eigrp 2 2001:db8:f::/62

R1# show ipv6 route eigrp


<output omitted>
EX ::/0 [170/3193856]
via FE80::2, Serial0/0/0
D 2001:DB8:F::/62 [90/2809856]
Single, summarized route
via FE80::2, Serial0/0/0
D 2001:DB8:CAFE:3::/64 [90/2681856]
via FE80::2, Serial0/0/0
D 2001:DB8:CAFE:4::/64 [90/2684416]
via FE80::2, Serial0/0/0

2001:DB8:CAFE:4::/64
Verifying Summary/Static 192.168.4.0/24
2001:DB8:CAFE:1::/64 2001:DB8:CAFE:2::/64 2001:DB8:CAFE:3::/64 G0/0
FE80::1 FE80::2 FE80::3 :1/.1
Summary
G0/0 S0/0/0 S0/0/1
S0/0/0 :2/.2 S0/0/1 :2/.2
:1/.1 R1 :1/.1 R2 :1/.1Static (Default) R3
192.168.1.0/24 192.168.2.0/24 192.168.3.0/24
R3# show ipv6 protocols
<output omitted>
EIGRP-IPv6 Protocol for AS(2)
<output omitted>
Redistribution:
Redistributing protocol static
Address Summarization:
2001:DB8:F::/62 for Se0/0/1
Summarizing 4 components with metric 128256
IPv6 Routing Protocol is "static"
R3#


2001:DB8:CAFE:4::/64
EIGRP for IPv4 & EIGRP for IPv6 192.168.4.0/24
2001:DB8:CAFE:1::/64 2001:DB8:CAFE:2::/64 2001:DB8:CAFE:3::/64 G0/0 2001:DB8:77::/64
FE80::1 FE80::2 FE80::3 :1/.1 FE80::77
Default
G0/0 S0/0/0 S0/0/1
S0/0/0 S0/0/1 :2/.2 S0/1/0
:1/.1 :2/.2
R1 :1/.1 R2 :1/.1 R3 :1/.1 ISP
192.168.1.0/24 192.168.2.0/24 192.168.3.0/24 192.168.77.0/24
ipv6 unicast-routing router eigrp 1
interface GigabitEthernet0/0 network 192.168.1.0
ip address 192.168.1.1 255.255.255.0 network 192.168.2.0
ipv6 address FE80::1 link-local eigrp router-id 1.1.1.1
ipv6 address 2001:DB8:CAFE:1::1/64 !
ipv6 eigrp 2 ipv6 router eigrp 2
! eigrp router-id 1.1.1.1
interface Serial0/0/0
ip address 192.168.2.1 255.255.255.0
ipv6 address FE80::1 link-local
ipv6 address 2001:DB8:CAFE:2::1/64
ipv6 eigrp 2

12.3: Named EIGRP Configuration
2001:DB8:CAFE:4::/64
Named EIGRP Configuration 192.168.4.0/24
2001:DB8:CAFE:1::/64 2001:DB8:CAFE:2::/64 2001:DB8:CAFE:3::/64 G0/0 2001:DB8:77::/64
FE80::1 FE80::2 FE80::3 :1/.1 FE80::77
G0/0 S0/0/0 S0/0/1
S0/0/0 S0/0/1 :2/.2 S0/1/0
:1/.1 :2/.2
R1 :1/.1 R2 :1/.1 R3 :1/.1 ISP
192.168.1.0/24 192.168.2.0/24 192.168.3.0/24 192.168.77.0/24

Classic EIGRP requires separate EIGRP configuration modes


and commands.
Named EIGRP Configuration is more recent method of
configuring EIGRP for IPv4 and IPv6.
A single mode to gather all EIGRP commands in one place.
Uses address families unify EIGRP IPv4 and IPv6 configuration.
Named mode is required when using EIGRP for IPv6 routing and
VRFs (Virtual Routing and Forwarding).

2001:DB8:CAFE:4::/64
IPv4 AF Configuration 192.168.4.0/24
2001:DB8:CAFE:1::/64 2001:DB8:CAFE:2::/64 2001:DB8:CAFE:3::/64 G0/0 2001:DB8:77::/64
FE80::1 FE80::2 FE80::3 :1/.1 FE80::77
G0/0 S0/0/0 S0/0/1
S0/0/0 S0/0/1 :2/.2 S0/1/0
:1/.1 :2/.2
R1 :1/.1 R2 :1/.1 R3 :1/.1 ISP
192.168.1.0/24 192.168.2.0/24 192.168.3.0/24 192.168.77.0/24
R1(config)# ipv6 unicast-routing Required for configuring the IPv6 address family
R1(config)# router eigrp DUAL-STACK Virtual instance name. Does not have to match other
R1(config-router)# address-family ? routers
ipv4 Address family IPv4 AS numbers must match AS
ipv6 Address family IPv6 of neighbors for this AF
R1(config-router)# address-family ipv4 unicast autonomous-system 1
R1(config-router-af)# eigrp router-id 1.1.1.1
R1(config-router-af)# network 192.168.1.0 network commands used for IPv4 AF
R1(config-router-af)# network 192.168.2.0
R1(config-router-af)# exit-address-family
R1(config-router)#


2001:DB8:CAFE:4::/64
IPv6 AF Configuration 192.168.4.0/24
2001:DB8:CAFE:1::/64 2001:DB8:CAFE:2::/64 2001:DB8:CAFE:3::/64 G0/0 2001:DB8:77::/64
FE80::1 FE80::2 FE80::3 :1/.1 FE80::77
G0/0 S0/0/0 S0/0/1
S0/0/0 S0/0/1 :2/.2 S0/1/0
:1/.1 :2/.2
R1 :1/.1 R2 :1/.1 R3 :1/.1 ISP
192.168.1.0/24 192.168.2.0/24 192.168.3.0/24 192.168.77.0/24
R1(config)# ipv6 unicast-routing
R1(config)# router eigrp DUAL-STACK
R1(config-router)# address-family ipv4 unicast autonomous-system 1
R1(config-router-af)# eigrp router-id 1.1.1.1
R1(config-router-af)# network 192.168.1.0 Does not have to match but
must match AS for that AF on
R1(config-router-af)# network 192.168.2.0
the other routers.
R1(config-router-af)# exit-address-family
R1(config-router)# address-family ipv6 unicast autonomous-system 2
R1(config-router-af)# eigrp router-id 1.1.1.1

By default, ALL IPv6 interfaces are enabled for EIGRP for IPv6.


2001:DB8:CAFE:4::/64
Named EIGRP Configuration R2 192.168.4.0/24
2001:DB8:CAFE:1::/64 2001:DB8:CAFE:2::/64 2001:DB8:CAFE:3::/64 G0/0 2001:DB8:77::/64
FE80::1 FE80::2 FE80::3 :1/.1 FE80::77
G0/0 S0/0/0 S0/0/1
S0/0/0 S0/0/1 :2/.2 S0/1/0
:1/.1 :2/.2
R1 :1/.1 R2 :1/.1 R3 :1/.1 ISP
192.168.1.0/24 192.168.2.0/24 192.168.3.0/24 192.168.77.0/24
R2(config)# ipv6 unicast-routing
Virtual instance name. Does not have to match other
R2(config)# router eigrp DUAL-STACK routers
R2(config-router)# address-family ipv4 unicast autonomous-system 1
R2(config-router-af)# eigrp router-id 2.2.2.2 Must match other routers AS for IPv4 AF
R2(config-router-af)# network 192.168.2.0
*Sep 7 04:47:00.832: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 192.168.2.1
(Serial0/0/0) is up: new adjacency IPv4 adjacency with R1 comes up after
R2(config-router-af)# network 192.168.3.0 network command
R2(config-router-af)# exit-address-family Must match other routers AS for IPv6 AF
R2(config-router)# address-family ipv6 unicast autonomous-system 2
*Sep 7 04:47:46.536: %DUAL-5-NBRCHANGE: EIGRP-IPv6 2: Neighbor FE80::1
IPv6 adjacency with R1 comes up
(Serial0/0/0) is up: new adjacency
immediately because all IPv6 interfaces
R2(config-router-af)# eigrp router-id 2.2.2.2 are enabled automatically
2001:DB8:CAFE:4::/64
Named EIGRP Configuration R3 192.168.4.0/24
2001:DB8:CAFE:1::/64 2001:DB8:CAFE:2::/64 2001:DB8:CAFE:3::/64 G0/0 2001:DB8:77::/64
FE80::1 FE80::2 FE80::3 :1/.1 FE80::77
G0/0 S0/0/0 S0/0/1
S0/0/0 S0/0/1 :2/.2 S0/1/0
:1/.1 :2/.2
R1 :1/.1 R2 :1/.1 R3 :1/.1 ISP
192.168.1.0/24 192.168.2.0/24 192.168.3.0/24 192.168.77.0/24
R3(config)# ipv6 unicast-routing
R3(config)# router eigrp DUAL-STACK
R3(config-router)# address-family ipv4 unicast autonomous-system 1
R3(config-router-af)# eigrp router-id 3.3.3.3
R3(config-router-af)# network 192.168.3.0
*Sep 7 05:06:43.036: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 192.168.3.1
(Serial0/0/1) is up: new adjacency
R3(config-router-af)# network 192.168.4.0
R3(config-router-af)# exit-address-family
R3(config-router)# address-family ipv6 unicast autonomous-system 2
*Sep 7 05:07:22.584: %DUAL-5-NBRCHANGE: EIGRP-IPv6 2: Neighbor FE80::2
(Serial0/0/1) is up: new adjacency
R3(config-router-af)# eigrp router-id 3.3.3.3
2001:DB8:CAFE:4::/64
Default Route 192.168.4.0/24
2001:DB8:CAFE:1::/64 2001:DB8:CAFE:2::/64 2001:DB8:CAFE:3::/64 G0/0 2001:DB8:77::/64
FE80::1 FE80::2 FE80::3 :1/.1 FE80::77
Default
G0/0 S0/0/0 S0/0/1
S0/0/0 S0/0/1 :2/.2 S0/1/0
:1/.1 :2/.2
R1 :1/.1 R2 :1/.1 R3 :1/.1 ISP
192.168.1.0/24 192.168.2.0/24 192.168.3.0/24 192.168.77.0/24

R3(config)# ip route 0.0.0.0 0.0.0.0 192.168.77.2


R3(config)# ipv6 route ::/0 2001:db8:feed:77::2 serial 0/1/0
R3(config)# router eigrp DUAL-STACK
R3(config-router)# address-family ipv4 unicast autonomous-system 1
R3(config-router-af)# topology base
R3(config-router-af-topology)#


R3(config-router-af-topology)# ?
Address Family Topology configuration commands:
auto-summary Enable automatic network number summarization
default Set a command to its defaults
default-information Control distribution of default information
default-metric Set metric of redistributed routes
distance Define an administrative distance
distribute-list Filter entries in eigrp updates
eigrp EIGRP specific commands
exit-af-topology Exit from Address Family Topology configuration mode
maximum-paths Forward packets over multiple paths
metric Modify metrics and parameters for advertisement
no Negate a command or set its defaults
offset-list Add or subtract offset from EIGRP metrics
redistribute Redistribute IPv4 routes from another routing protocol
snmp Modify snmp parameters
summary-metric Specify summary to apply metric/filtering
timers Adjust topology specific timers
traffic-share How to compute traffic share over alternate paths
variance Control load balancing variance
R3(config-router-af-topology)#


2001:DB8:CAFE:4::/64
Default Route 192.168.4.0/24
2001:DB8:CAFE:1::/64 2001:DB8:CAFE:2::/64 2001:DB8:CAFE:3::/64 G0/0 2001:DB8:77::/64
FE80::1 FE80::2 FE80::3 :1/.1 FE80::77
Static (Default) Default
G0/0 S0/0/0 S0/0/1
S0/0/0 S0/0/1 :2/.2 S0/1/0
:1/.1 :2/.2
R1 :1/.1 R2 :1/.1 R3 :1/.1 ISP
192.168.1.0/24 192.168.2.0/24 192.168.3.0/24 192.168.77.0/24
R3(config)# ip route 0.0.0.0 0.0.0.0 192.168.77.2
R3(config)# ipv6 route ::/0 2001:db8:feed:77::2 serial 0/1/0
R3(config)# router eigrp DUAL-STACK
R3(config-router)# address-family ipv4 unicast autonomous-system 1
R3(config-router-af)# topology base
R3(config-router-af-topology)# redistribute static
R3(config-router-af-topology)# exit-af-topology
R3(config-router-af)# exit-address-family
R3(config-router)# address-family ipv6 unicast autonomous-system 2
R3(config-router-af)# topology base
R3(config-router-af-topology)# redistribute static
R3(config-router-af-topology)#

R1s IPv4 Routing Table 2001:DB8:CAFE:4::/64
192.168.4.0/24
2001:DB8:CAFE:1::/64 2001:DB8:CAFE:2::/64 2001:DB8:CAFE:3::/64 G0/0 2001:DB8:77::/64
FE80::1 FE80::2 FE80::3 :1/.1 FE80::77
Static (Default) Default
G0/0 S0/0/0 S0/0/1
S0/0/0 S0/0/1 :2/.2 S0/1/0
:1/.1 :2/.2
R1 :1/.1 R2 :1/.1 R3 :1/.1 ISP
192.168.1.0/24 192.168.2.0/24 192.168.3.0/24 192.168.77.0/24
R1# show ip route eigrp
Gateway of last resort is 192.168.2.2 to network 0.0.0.0
Default route
D*EX 0.0.0.0/0 [170/34036062] via 192.168.2.2, 00:32:38, Serial0/0/0
D 192.168.3.0/24 [90/23796062] via 192.168.2.2, 01:03:35, Serial0/0/0
D 192.168.4.0/24 [90/23847262] via 192.168.2.2, 01:00:00, Serial0/0/0
R1#

192.168.77.0/24 network not advertised by EIGRP for IPv4


because we didnt include it with a network command.

R1s IPv6 Routing Table 2001:DB8:CAFE:4::/64
192.168.4.0/24
2001:DB8:CAFE:1::/64 2001:DB8:CAFE:2::/64 2001:DB8:CAFE:3::/64 G0/0 2001:DB8:77::/64
FE80::1 FE80::2 FE80::3 :1/.1 FE80::77
Static (Default) Default
G0/0 S0/0/0 S0/0/1
S0/0/0 S0/0/1 :2/.2 S0/1/0
:1/.1 :2/.2
R1 :1/.1 R2 :1/.1 R3 :1/.1 ISP
192.168.1.0/24 192.168.2.0/24 192.168.3.0/24 192.168.77.0/24
R1# show ipv6 route eigrp
IPv6 Routing Table - default - 8 entries
<output omitted>
EX ::/0 [170/34036062] Default route
via FE80::2, Serial0/0/0
D

D
2001:DB8:77::/64 [90/34036062]
via FE80::2, Serial0/0/0
2001:DB8:CAFE:3::/64 [90/23796062]
?
All IPv6 interfaces are enabled automatically
via FE80::2, Serial0/0/0
D 2001:DB8:CAFE:4::/64 [90/23847262] How do we remove this IPv6
via FE80::2, Serial0/0/0 prefix from being advertised?
R1#

2001:DB8:CAFE:4::/64
Disabling EIGRP on an Interface 192.168.4.0/24
2001:DB8:CAFE:1::/64 2001:DB8:CAFE:2::/64 2001:DB8:CAFE:3::/64 G0/0 2001:DB8:77::/64
FE80::1 FE80::2 FE80::3 :1/.1 FE80::77
Default
G0/0 S0/0/0 S0/0/1
S0/0/0 S0/0/1 :2/.2 S0/1/0
:1/.1 :2/.2
R1 :1/.1 R2 :1/.1 R3 :1/.1 ISP
192.168.1.0/24 192.168.2.0/24 192.168.3.0/24 192.168.77.0/24
R3(config)# router eigrp DUAL-STACK Make sure you are in the proper AF
R3(config-router)# address-family ipv6 unicast autonomous-system 2
R3(config-router-af)# af-interface serial 0/1/0
R3(config-router-af-interface)# shutdown shutdown af-interface command is
R3(config-router-af-interface)# exit-af-interface used to disable EIGRP for IPv6 on
an interface
R3(config-router-af)# exit-address-family
R3(config-router)# end
R3# show ipv6 interface brief | begin Serial0/1/0
Serial0/1/0 [up/up]
FE80::3 Serial 0/1/0 is still up/up but no longer
By default, ALL IPv6 interfaces are enabled
enabled for EIGRP
for EIGRP for IPv6 for IPv6.
2001:DB8:77::1


R1s Routing Table 2001:DB8:CAFE:4::/64
192.168.4.0/24
2001:DB8:CAFE:1::/64 2001:DB8:CAFE:2::/64 2001:DB8:CAFE:3::/64 G0/0 2001:DB8:77::/64
FE80::1 FE80::2 FE80::3 :1/.1 FE80::77
Static (Default) Default
G0/0 S0/0/0 S0/0/1
S0/0/0 S0/0/1 :2/.2 S0/1/0
:1/.1 :2/.2
R1 :1/.1 R2 :1/.1 R3 :1/.1 ISP
192.168.1.0/24 192.168.2.0/24 192.168.3.0/24 192.168.77.0/24
R1# show ipv6 route eigrp
IPv6 Routing Table - default - 8 entries
<output omitted>
EX ::/0 [170/34036062]
via FE80::2, Serial0/0/0
D 2001:DB8:CAFE:3::/64 [90/23796062] No longer
via FE80::2, Serial0/0/0 advertised by
D 2001:DB8:CAFE:4::/64 [90/23847262] EIGRP for IPv6
via FE80::2, Serial0/0/0
R1#


Address Family Interface Options
R3(config-router-af)# af-interface gigabitethernet 0/1
R3(config-router-af-interface)# ?
Address Family Interfaces configuration commands:
add-paths Advertise add paths
authentication authentication subcommands
bandwidth-percent Set percentage of bandwidth percentage limit
<some output omitted>
default Set a command to its defaults
exit-af-interface Exit from Address Family Interface configuration mode
hello-interval Configures hello interval
hold-time Configures hold time
next-hop-self Configures EIGRP next-hop-self
no Negate a command or set its defaults
passive-interface Suppress address updates on an interface
shutdown Disable Address-Family on interface
split-horizon Perform split horizon
summary-address Perform address summarization

2001:DB8:CAFE:4::/64
Passive Interface for both AFs 192.168.4.0/24
2001:DB8:CAFE:1::/64 2001:DB8:CAFE:2::/64 2001:DB8:CAFE:3::/64 G0/0 2001:DB8:77::/64
FE80::1 FE80::2 FE80::3 :1/.1 FE80::77
Default
G0/0 S0/0/0 S0/0/1
S0/0/0 S0/0/1 :2/.2 S0/1/0
:1/.1 :2/.2
R1 :1/.1 R2 :1/.1 R3 :1/.1 ISP
192.168.1.0/24 192.168.2.0/24 192.168.3.0/24 192.168.77.0/24

R3(config)# router eigrp DUAL-STACK


R3(config-router)# address-family ipv4 unicast autonomous-system 1
R3(config-router-af)# af-interface gigabitethernet 0/0
R3(config-router-af-interface)# passive-interface Suppresses EIGRP messages
R3(config-router-af-interface)# exit-af-interface on the interface
R3(config-router-af)# exit-address-family
R3(config-router)# address-family ipv6 unicast autonomous-system 2
R3(config-router-af)# af-interface gigabitethernet 0/0
R3(config-router-af-interface)# passive-interface
R3(config-router-af-interface)# exit-af-interface
R3(config-router-af)#

2001:DB8:CAFE:4::/64
Passive Interface for both AFs 192.168.4.0/24
2001:DB8:CAFE:1::/64 2001:DB8:CAFE:2::/64 2001:DB8:CAFE:3::/64 G0/0 2001:DB8:77::/64
FE80::1 FE80::2 FE80::3 :1/.1 FE80::77
Default
G0/0 S0/0/0 S0/0/1
S0/0/0 S0/0/1 :2/.2 S0/1/0
:1/.1 :2/.2
R1 :1/.1 R2 :1/.1 R3 :1/.1 ISP
192.168.1.0/24 192.168.2.0/24 192.168.3.0/24 192.168.77.0/24

R1(config)# router eigrp DUAL-STACK


R1(config-router)# address-family ipv4 unicast autonomous-system 1
R1(config-router-af)# af-interface gigabitethernet 0/0
R1(config-router-af-interface)# passive-interface
R1(config-router-af-interface)# exit The abbreviated exit command
R1(config-router-af) #exit can be used for both sub-modes.
R1(config-router)# address-family ipv6 unicast autonomous-system 2
R1(config-router-af)# af-interface gigabitethernet 0/0
R1(config-router-af-interface)# passive-interface
R1(config-router-af-interface)# exit
R1(config-router-af)#

2001:DB8:CAFE:4::/64
Manual Summarization 192.168.4.0/24
2001:DB8:CAFE:2::/64 2001:DB8:CAFE:3::/64 G0/0
FE80::1 FE80::2 FE80::3 :1/.1
S0/0/0 S0/0/1 Summary
G0/0 S0/0/0 S0/0/1
:2/.2 :2/.2 2001:DB8:10::/48
:1/.1 R1 :1/.1 R2 :1/.1 Summary R3 10.0.0.0/8
192.168.1.0/24 192.168.2.0/24 192.168.3.0/24

R3(config)# router eigrp DUAL-STACK


R3(config-router)# address-family ipv4 unicast autonomous-system 1
R3(config-router-af)# af-interface serial 0/0/1
R3(config-router-af-interface)# summary-address 10.0.0.0/8
R3(config-router-af-interface)# exit-af-interface
R3(config-router-af)# exit-address-family
R3(config-router)# address-family ipv6 unicast autonomous-system 2
R3(config-router-af)# af-interface serial 0/0/1
R3(config-router-af-interface)# summary-address 2001:db8:10::/48
R3(config-router-af-interface)#


2001:DB8:CAFE:4::/64
Manual Summarization 192.168.4.0/24
2001:DB8:CAFE:2::/64 2001:DB8:CAFE:3::/64 G0/0
FE80::1 FE80::2 FE80::3 :1/.1
S0/0/0 S0/0/1 Summary
G0/0 S0/0/0 S0/0/1
:2/.2 :2/.2 2001:DB8:10::/48
:1/.1 R1 :1/.1 R2 :1/.1 Summary R3 10.0.0.0/8
192.168.1.0/24 192.168.2.0/24 192.168.3.0/24
R1# show ip route eigrp

D*EX 0.0.0.0/0 [170/34036062] via 192.168.2.2, 00:43:04, Serial0/0/0


D 10.0.0.0/8 [90/23796702] via 192.168.2.2, 00:00:06, Serial0/0/0
D 192.168.3.0/24 [90/23796062] via 192.168.2.2, 01:14:01, Serial0/0/0
D 192.168.4.0/24 [90/23847262] via 192.168.2.2, 01:10:26, Serial0/0/0

R1# show ipv6 route eigrp


EX ::/0 [170/34036062]
via FE80::2, Serial0/0/0
D 2001:DB8:10::/48 [90/23796702]
via FE80::2, Serial0/0/0
<rest of output omitted>

show ip protocols
R3# show ip protocols
<some output omitted>
Routing Protocol is "eigrp 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
Redistributing: static
EIGRP-IPv4 VR(DUAL-STACK) Address-Family Protocol for AS(1)
Metric weight K1=1, K2=0, K3=1, K4=0, K5=0 K6=0
Metric rib-scale 128
Metric version 64bit
NSF-aware route hold timer is 240
Router-ID: 3.3.3.3
Topology : 0 (base)
<continued next slide>


show ip protocols continued
R3# show ip protocols <continued>

Automatic Summarization: disabled


Address Summarization:
10.0.0.0/8 for Se0/0/1
Maximum path: 4
Routing for Networks:
10.0.0.0
192.168.3.0
192.168.4.0
Passive Interface(s):
GigabitEthernet0/0

<output omitted>
R3#


show ipv6 protocols
R3# show ipv6 protocols
<some output omitted>
IPv6 Routing Protocol is "eigrp 2"
EIGRP-IPv6 VR(DUAL-STACK) Address-Family Protocol for AS(2)
Metric weight K1=1, K2=0, K3=1, K4=0, K5=0 K6=0
Metric rib-scale 128
Metric version 64bit
NSF-aware route hold timer is 240
Router-ID: 3.3.3.3
Topology : 0 (base)
Active Timer: 3 min
Distance: internal 90 external 170
Maximum path: 16
Maximum hopcount 100
Maximum metric variance 1
continued next slide>

show ipv6 protocols continued
R3# show ipv6 protocols <continued>

Interfaces:
Serial0/0/1
GigabitEthernet0/0 (passive)
Redistribution:
Redistributing protocol static
Address Summarization:
2001:DB8:10::/48 for Se0/0/1
Summarizing 1 component with metric 163840
R3#


address-family ipv6 unicast
R3s Configuration autonomous-system 2
ipv6 unicast-routing eigrp router-id 3.3.3.3
router eigrp DUAL-STACK !
! af-interface GigabitEthernet0/0
address-family ipv4 unicast passive-interface
autonomous-system 1 !
network 10.0.0.0 af-interface Serial0/0/1
network 192.168.3.0 summary-address 2001:DB8:10::/48
network 192.168.4.0 !
eigrp router-id 3.3.3.3 af-interface Serial0/1/0
! shutdown
af-interface GigabitEthernet0/0 exit-af-interface
passive-interface !
! topology base
af-interface Serial0/0/1 redistribute static
summary-address 10.0.0.0 255.0.0.0
!
topology base
redistribute static
12.4: EIGRP Configurations at a Glance
EIGRP Configurations at a Glance
EIGRP for Classic Named EIGRP
IPv4 EIGRP for
IPv6 IPv4 IPv6

router eigrp 1 ipv6 unicast-routing ipv6 unicast-routing


network 192.168.1.0 router eigrp DUAL-STACK
network 192.168.2.0 ipv6 router eigrp 2 !
eigrp router-id 1.1.1.1 eigrp router-id 1.1.1.1 address-family ipv4 unicast autonomous-
system 1
interface gig0/0 eigrp router-id 1.1.1.1
ipv6 eigrp 2 network 192.168.3.0
network 192.168.4.0
!
address-family ipv6 unicast autonomous-
Separate configurations versus system 2
unified configuration eigrp router-id 1.1.1.1
!
af-interface GigabitEthernet0/1
shutdown

For more information please check out my Cisco Press book and video series:

IPv6 Fundamentals: A Straightforward IPv6 Fundamentals LiveLessons: A


Approach to Understanding IPv6 Straightforward Approach to Understanding IPv6
By Rick Graziani By Rick Graziani
ISBN-10: 1-58714-313-5 ISBN-10: 1-58720-457-6


12: EIGRP for IPv6
Rick Graziani
Cabrillo College

Rick.Graziani@cabrillo.edu