Sunteți pe pagina 1din 11

Algoritmi de baza

PREDA ISABELLA
CLASA A IX-A D
Intreg x, cx, nr
Inceput
citeste x
cx  x nr0
Cat timp (cx>0) executa
nr nr+1
cx cx/10
Scrie nr
Sfarsit
Suma cifrelor unui numar natural

Intreg x, cx, s
Inceput
citeste x
cx  0 s 0
Cat timp(cx>0) executa
s s+cx%10
cx cx/10
Scrie s
sfarsit
Suma cifrelor pare

Intreg x, cx, s
inceput
citeste x
cx  x s 0
Cat timp (cx>0) exectuta
daca (cx%2=0) atunci s s+cx%10
cx cx/10

scrie s
sfarsit
Algoritm de numarare a cifrelor pare si
impare ale unui numar

Intreg x, cx, nrp, nri


inceput
citeste x
cx  x nrp0 nri 0
Cat timp (cx>0) exectuta
daca (cx%2=0) atunci nrp nrp+1
altfel nri nri+1
scrie s
sfarsit
Suma cifrelor impare

intreg
inceput
citeste x
cx  x s 0
Cat timp (cx>0) exectuta
daca (cx%2=!0) atunci s s+cx%10
cx cx/10

scrie s
sfarsit
Algorim pentru cel mai mare divisor
comun

intreg a, b
Inceput
citeste a, b
ca  a cb  b
cat_timp (ca=!cb) and (ca>0) executa
Daca ca>cb atunci ca  ca-cb
altfel cb  cb-ca
scrie ca
sfarsit.
Algoritm pentru determinarea
divizorilor unui numar

intreg a, I
inceput
citeste a
pentru i <- 2,a/2 executa
daca a%i=0 atunci scrie I

sfarsit.
Algoritm de inversare

intreg a, inv;
inceput
citeste a
inv  0
cat_timp x>0 executa
inv  inv * 10 + a% 10;
a  a/ 10
scrie inv
sfarsit.
Algoritm pentru numar prim

intreg a, I, OK
inceput
citeste a
ok<- 1;
pentru i <- 2,a/2 executa
daca a%i=0 atunci ok <- 0

daca ok = 1 atunci scrie "Numarul este prim";


altfel scrie "Numarul nu este prim."
sfarsit.
Algoritm pentru determinare
palindromului

Intreg
Citeste x
Inv 0 cx x
cat_timp x>0 executa
inv  inv * 10 + cx% 10;
cx  cx/ 10
daca inv=x atunci scrie “PALINDROM”
altfel scrie ”NU ESTE PALINDROM”
sfarsit

Evaluare